Repository 32bit  Forum
Repository 64bit  Wiki

Portatile nuovo, slackware in difficolta?

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Portatile nuovo, slackware in difficolta?

Messaggioda miklos » sab apr 10, 2010 19:35

Ciao a tutti,

da poco piu' di una settimana possiedo un Acer Aspire 5542G su cui ho montato 'quasi' subito slackware.
Per poter sfruttare appieno la scheda grafica ho dovuto ricompilare il kernel perche' i driver ati open source nel kernel di default non erano presenti.
Sono stato abbastanza soddisfatto del mio acquisto perche' in pratica pur non essendo un bolide, per quello che mi serve va benissimo, e soprattutto non ho dovuto, per una volta, bisticciare per far funzionare l'hardware. Slackware ha riconosciuto tutto al primo colpo.
Pero' forse mi sono un po' tirato i piedi, perche' il sistema e' diventato abbastanza instabile.
Per me l'abbastanza vuol dire che una volta ogni 2-3 giorni Xorg si pianta, oppure si chiude, insomma per uno che da quando usa slackware non ha mai visto cose del genere e' un po' strano.
Vorrei pero' capire se il problema dipende dal portatile magari difettoso, oppure dal fatto che ho messo un kernel troppo 'recente', o forse dal fatto che uso la versione a 64bit.
Lo so che la mia domanda e' abbastanza generica, pero' volevo sapere se magari qualcuno di voi ha esperienza su questo tipo di problemi e magari se mi consigliate di non essere troppo precipitoso nella scelta del kernel e usare qualche versione precedente.
Comunque il kernel che ho montato ora e' il 2.6.33.2

Grazie in anticipo
ho visto cose che voi astemi non potete immaginare
miklos
Linux 3.x
Linux 3.x
 
Messaggi: 1282
Iscritto il: lun lug 16, 2007 16:39
Località: Roma
Slackware: 14.1 64bit
Kernel: 3.16.3
Desktop: openbox 3.5.2

Re: Portatile nuovo, slackware in difficolta?

Messaggioda freax » sab apr 10, 2010 20:00

non ho mai avuto problemi del genere , più che altro siccome xorg si avvia anche senza lo xorg.conf , ma a volte è proprio il file di configurazione a risolvere tanti problemi , hai provato a scriverne uno ?

non ho mai avuto a che fare con driver ati recenti , ma credo che ci sia qualche utility per aiutarti a scrivere uno xorg.conf adatto :-k
Avatar utente
freax
Linux 2.0
Linux 2.0
 
Messaggi: 177
Iscritto il: lun gen 19, 2009 0:29
Slackware: 13
Desktop: kde4

Re: Portatile nuovo, slackware in difficolta?

Messaggioda SIV » sab apr 10, 2010 20:18

freax ha scritto: ma credo che ci sia qualche utility per aiutarti a scrivere uno xorg.conf adatto :-k


Sì anche io ricordo qualcosa del genere:
Codice: Seleziona tutto
aticonfig --initial ...


Però mi sa che c'è solo nei driver proprietari closed.
Avatar utente
SIV
Linux 2.6
Linux 2.6
 
Messaggi: 918
Iscritto il: mer apr 25, 2007 13:07
Località: Bari (Provincia)

Re: Portatile nuovo, slackware in difficolta?

Messaggioda 414N » sab apr 10, 2010 20:24

X ballerino è un probabile sintomo di qualcosa che non va nei driver e/o nella loro configurazione.
Controlla il log di X per vedere come vengono configurati in automatico e se ci sono errori vari.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2884
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Portatile nuovo, slackware in difficolta?

Messaggioda miklos » dom apr 11, 2010 3:13

freax ha scritto:non ho mai avuto problemi del genere , più che altro siccome xorg si avvia anche senza lo xorg.conf , ma a volte è proprio il file di configurazione a risolvere tanti problemi , hai provato a scriverne uno ?


a questo effettivamente non c'avevo pensato, ma con il nuovo sistema di configurazione ho letto da qualche parte che l'xorg.conf puo' essere usato anche per configurare solo alcune sezioni specifiche (tipo in questo caso solo il driver) e lasciare che al resto ci pensi hal... me lo confermate?
Comunque a sto punto penso che provero' anche ad usare un po' il driver vesa e vedere come va.
ho visto cose che voi astemi non potete immaginare
miklos
Linux 3.x
Linux 3.x
 
Messaggi: 1282
Iscritto il: lun lug 16, 2007 16:39
Località: Roma
Slackware: 14.1 64bit
Kernel: 3.16.3
Desktop: openbox 3.5.2

Re: Portatile nuovo, slackware in difficolta?

Messaggioda Blallo » dom apr 11, 2010 3:20

a questo punto dai prima
X -configure
che ti crea un xorg.conf
lo copi in /etc/X11 (backuppando il preesistente se c'è)
e POI dai aticonfig -i
e prova
Io sono il detective Arsenio Magret, e porto sempre la camicia TATUATA!
Avatar utente
Blallo
Packager
Packager
 
Messaggi: 3244
Iscritto il: ven ott 12, 2007 10:37
Località: Torino / Torremaggiore (FG)
Nome Cognome: Savino Liguori
Slackware: 14.1 / 12.2
Kernel: 3.12.2-ck
Desktop: Openbox

Re: Portatile nuovo, slackware in difficolta?

Messaggioda 414N » dom apr 11, 2010 12:05

jimmy_page_89 ha scritto:a questo punto dai prima
X -configure
che ti crea un xorg.conf
lo copi in /etc/X11 (backuppando il preesistente se c'è)
e POI dai aticonfig -i
e prova

Non può usare aticonfig se non installa i driver proprietari...
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2884
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Portatile nuovo, slackware in difficolta?

Messaggioda Blallo » dom apr 11, 2010 12:18

414N ha scritto:Non può usare aticonfig se non installa i driver proprietari...

ops..non avevo letto bene..
Io sono il detective Arsenio Magret, e porto sempre la camicia TATUATA!
Avatar utente
Blallo
Packager
Packager
 
Messaggi: 3244
Iscritto il: ven ott 12, 2007 10:37
Località: Torino / Torremaggiore (FG)
Nome Cognome: Savino Liguori
Slackware: 14.1 / 12.2
Kernel: 3.12.2-ck
Desktop: Openbox

Re: Portatile nuovo, slackware in difficolta?

Messaggioda Meskalamdug » dom apr 11, 2010 23:35

Non ho un portatile,ma ho scheda ATI.
Praticamente ho cancellato il vecchio /etc/X11/xorg.conf
e fatto partire il pc,problemi 0.
Kernel in uso 2.6.33.1 di Pat.
che include il driver radeon(open sourcE)
Meskalamdug
Iper Master
Iper Master
 
Messaggi: 3593
Iscritto il: gio mag 13, 2004 23:00

Re: Portatile nuovo, slackware in difficolta?

Messaggioda 414N » lun apr 12, 2010 13:32

Per quel che ho visto su Slackware64 13 (ma dubito fortemente che la situazione sarebbe stata diversa con la versione a 32 bit), i driver radeon opensource inclusi nella distro (ho una X800 XT) fanno pena. Addirittura il solo glxgears mi provocava una schermata nera, senza però blocco/riavvio di X.
Seguendo un post su linux-questions mi sono ricompilato libdrm (e quel che ci sta dietro, ovvero dri2proto e glproto), mesa e xf86-video-ati alle ultime versioni su git e la situazione è notevolmente migliorata, col vantaggio che ora posso usare il KMS presente negli ultimi kernel.
Se vuoi provare questa strada posso provare a darti qualche dritta e qualche SlackBuild che ho trovato e ritoccato alla bisogna.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2884
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE


Torna a Slackware64

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite