Repository 32bit  Forum
Repository 64bit  Wiki

[Risolto] SoundBlaster muta

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

[Risolto] SoundBlaster muta

Messaggioda kanzy » gio apr 15, 2010 17:44

Ciao a tutti!..

Ho assemblato un nuovo AMD e ho caricato Salix 13.0.2a 64. Tutto a posto.. tranne l'uscita audio che non dà segni di vita (SoundBlaster Audigy2).

- Diabilitato nel BIOS l'audio integrato;
- user nel gruppo audio e permessi ok sul device audio (ma non va neanche da root);
- moduli caricati (v. lsmod | grep snd):

Codice: Seleziona tutto
snd_seq_dummy           3172  0
snd_seq_oss            33536  0
snd_seq_midi_event      7264  1 snd_seq_oss
snd_seq                56320  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_pcm_oss            42976  0
snd_mixer_oss          16768  2 snd_pcm_oss
snd_emu10k1           150944  2
snd_rawmidi            22784  1 snd_emu10k1
snd_ac97_codec        121496  1 snd_emu10k1
ac97_bus                1920  1 snd_ac97_codec
snd_pcm                80872  3 snd_pcm_oss,snd_emu10k1,snd_ac97_codec
snd_seq_device          7188  5 snd_seq_dummy,snd_seq_oss,snd_seq,snd_emu10k1,snd_rawmidi
snd_timer              22256  3 snd_seq,snd_emu10k1,snd_pcm
snd_page_alloc          9616  2 snd_emu10k1,snd_pcm
snd_util_mem            3968  1 snd_emu10k1
snd_hwdep               8456  1 snd_emu10k1
snd                    65000  13 snd_seq_oss,snd_seq,snd_pcm_oss,snd_mixer_oss,snd_emu10k1,snd_rawmidi,snd_ac97_codec,snd_pcm,snd_seq_device,snd_timer,snd_hwdep
soundcore               7168  2 snd


- scheda riconosciuta (v. lspci);
Codice: Seleziona tutto
...
03:06.0 Multimedia audio controller: Creative Labs SB Audigy (rev 04)
03:06.1 Input device controller: Creative Labs SB Audigy Game Port (rev 04)
03:06.2 FireWire (IEEE 1394): Creative Labs SB Audigy FireWire Port (rev 04)
...


- dmesg | grep Audigy
Codice: Seleziona tutto
...
EMU10K1_Audigy 0000:03:06.0: PCI INT A -> GSI 21 (level, low) -> IRQ 21
Installing spdif_bug patch: SB Audigy 2 Platinum [SB0240P]
...


- hw a posto (ho solo passato i 3 jack da un PC all'altro);

Ho letto qui le discussioni sull'argomento, ma in fondo ho visto che si trattava più che altro di una questione di permessi.
Il che non sembra essere il mio caso. Avete qualche suggerimento?.. grazie 1000!
Ultima modifica di kanzy il sab apr 17, 2010 10:20, modificato 1 volta in totale.
l'uomo ha bisogno di cibo rifugio e storie
Avatar utente
kanzy
Linux 2.4
Linux 2.4
 
Messaggi: 206
Iscritto il: sab mag 10, 2008 14:02
Località: Godiasco PV
Nome Cognome: Franz Fricker
Slackware: 14.0-x86_64
Kernel: 3.2.29
Desktop: kde

Re: SoundBlaster muta

Messaggioda teox99 » gio apr 15, 2010 17:56

logicamente avrai reso UNMUTE tutti i canali tramite alsamixer ed alzato le barre al max, giusto?
Avatar utente
teox99
Linux 2.6
Linux 2.6
 
Messaggi: 732
Iscritto il: ven lug 25, 2008 13:54
Località: Roma[Eur]
Slackware: 13.37
Desktop: KDE - Xfce

Re: SoundBlaster muta

Messaggioda kanzy » gio apr 15, 2010 18:27

@teox99

..of course :D
l'uomo ha bisogno di cibo rifugio e storie
Avatar utente
kanzy
Linux 2.4
Linux 2.4
 
Messaggi: 206
Iscritto il: sab mag 10, 2008 14:02
Località: Godiasco PV
Nome Cognome: Franz Fricker
Slackware: 14.0-x86_64
Kernel: 3.2.29
Desktop: kde

Re: SoundBlaster muta

Messaggioda teox99 » gio apr 15, 2010 22:46

posta
# aplay -L
Avatar utente
teox99
Linux 2.6
Linux 2.6
 
Messaggi: 732
Iscritto il: ven lug 25, 2008 13:54
Località: Roma[Eur]
Slackware: 13.37
Desktop: KDE - Xfce

Re: SoundBlaster muta

Messaggioda aschenaz » ven apr 16, 2010 7:02

Sul sito di Salix c'è questo articolo: http://www.salixos.org/wiki/index.php/H ... _Alsa_card

Ma non dovrebbe essere il tuo caso perché hai disabilitato l'audio integrato.
Fatto sta che quell'accorgimento con Slackware non mi sembra sia stato mai
necessario. Magari con Salix si... Prova...
pensieriemotivi.aschenaz.eu - music-blog
Avatar utente
aschenaz
Staff
Staff
 
Messaggi: 4433
Iscritto il: mar lug 27, 2004 23:00
Località: Reggio Calabria
Nome Cognome: Nino
Slackware: current 64bit
Kernel: 3.14.18
Desktop: KDE 4.10.5

Re: SoundBlaster muta

Messaggioda kanzy » ven apr 16, 2010 15:53

@aschenaz
Ciao Nino!.. l'ho disabilitato proprio perchè sul forum di Salix era stato consigliato così :D

@teox99

Codice: Seleziona tutto
default:CARD=SB
    HDA ATI SB, ALC888 Analog
    Default Audio Device
front:CARD=SB,DEV=0
    HDA ATI SB, ALC888 Analog
    Front speakers
surround40:CARD=SB,DEV=0
    HDA ATI SB, ALC888 Analog
    4.0 Surround output to Front and Rear speakers
surround41:CARD=SB,DEV=0
    HDA ATI SB, ALC888 Analog
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=SB,DEV=0
    HDA ATI SB, ALC888 Analog
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=SB,DEV=0
    HDA ATI SB, ALC888 Analog
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=SB,DEV=0
    HDA ATI SB, ALC888 Analog
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
null
    Discard all samples (playback) or generate zero samples (capture)
default:CARD=Audigy2
    SB Audigy 2 Platinum [SB0240P], ADC Capture/Standard PCM Playback
    Default Audio Device
front:CARD=Audigy2,DEV=0
    SB Audigy 2 Platinum [SB0240P], ADC Capture/Standard PCM Playback
    Front speakers
rear:CARD=Audigy2,DEV=0
    SB Audigy 2 Platinum [SB0240P], ADC Capture/Standard PCM Playback
    Rear speakers
center_lfe:CARD=Audigy2,DEV=0
    SB Audigy 2 Platinum [SB0240P], ADC Capture/Standard PCM Playback
    Center and Subwoofer speakers
side:CARD=Audigy2,DEV=0
    SB Audigy 2 Platinum [SB0240P], ADC Capture/Standard PCM Playback
    Side speakers
surround40:CARD=Audigy2,DEV=0
    SB Audigy 2 Platinum [SB0240P], ADC Capture/Standard PCM Playback
    4.0 Surround output to Front and Rear speakers
surround41:CARD=Audigy2,DEV=0
    SB Audigy 2 Platinum [SB0240P], ADC Capture/Standard PCM Playback
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=Audigy2,DEV=0
    SB Audigy 2 Platinum [SB0240P], ADC Capture/Standard PCM Playback
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=Audigy2,DEV=0
    SB Audigy 2 Platinum [SB0240P], ADC Capture/Standard PCM Playback
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=Audigy2,DEV=0
    SB Audigy 2 Platinum [SB0240P], ADC Capture/Standard PCM Playback
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=Audigy2,DEV=0
    SB Audigy 2 Platinum [SB0240P], ADC Capture/Standard PCM Playback
    IEC958 (S/PDIF) Digital Audio Output
l'uomo ha bisogno di cibo rifugio e storie
Avatar utente
kanzy
Linux 2.4
Linux 2.4
 
Messaggi: 206
Iscritto il: sab mag 10, 2008 14:02
Località: Godiasco PV
Nome Cognome: Franz Fricker
Slackware: 14.0-x86_64
Kernel: 3.2.29
Desktop: kde

Re: SoundBlaster muta

Messaggioda teox99 » ven apr 16, 2010 18:21

Avatar utente
teox99
Linux 2.6
Linux 2.6
 
Messaggi: 732
Iscritto il: ven lug 25, 2008 13:54
Località: Roma[Eur]
Slackware: 13.37
Desktop: KDE - Xfce

Re: SoundBlaster muta

Messaggioda kanzy » ven apr 16, 2010 19:33

scheda bruciata.. mai successo.. non so come sia potuto capitare..
andato anche il subwoofer, l'ampli, uno speaker ed il telecomando a filo con annesso output per la cuffia.
Praticamente tutto l'home theatre. =D> =D>
Grazie per le risposte.
l'uomo ha bisogno di cibo rifugio e storie
Avatar utente
kanzy
Linux 2.4
Linux 2.4
 
Messaggi: 206
Iscritto il: sab mag 10, 2008 14:02
Località: Godiasco PV
Nome Cognome: Franz Fricker
Slackware: 14.0-x86_64
Kernel: 3.2.29
Desktop: kde


Torna a Slackware64

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite