Repository 32bit  Forum
Repository 64bit  Wiki

problema stream audio alsa

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

problema stream audio alsa

Messaggioda akerbabber » gio set 02, 2010 8:00

Ciao a tutti, ho un problema, in pratica la scheda audio è in grado di gestire solo uno stream audio e alsa non ha la gestione virtuale di più stream cosicche funziona l'audio di un solo programma.
Ultima modifica di akerbabber il mer set 22, 2010 6:51, modificato 2 volte in totale.
akerbabber
Linux 1.0
Linux 1.0
 
Messaggi: 82
Iscritto il: gio feb 21, 2008 20:48
Slackware: slackware64-current
Desktop: kde4.5

Re: problema stream audio alsa

Messaggioda akerbabber » mar set 21, 2010 22:40

vabbe alla fine sono arrivato alla conclusione che il problema sta tutto in pulseaudio, infatti quando lo avvia mi dà questo errore
Codice: Seleziona tutto
pulseaudio: error while loading shared libraries: libasyncns.so.0: cannot open shared object file: No such file or directory

il problema sta nel fatto che me lo installa in /usr/lib e non in /usr/lib64 anche se lo compilo da sorgente, qualche suggerimento?
akerbabber
Linux 1.0
Linux 1.0
 
Messaggi: 82
Iscritto il: gio feb 21, 2008 20:48
Slackware: slackware64-current
Desktop: kde4.5

Re: problema stream audio alsa

Messaggioda targzeta » mar set 21, 2010 23:55

Cioè, quella libreria mancante è parte di pulseaudio? E nonostante sia presente non viene trovata perchè viene installata sotto lib invece che sotto lib64?

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6185
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: problema stream audio alsa

Messaggioda targzeta » mer set 22, 2010 0:01

Dai sorgenti di pulseaudio si nota questo:
Codice: Seleziona tutto
$> configure --help
...
--libdir=DIR            object code libraries [EPREFIX/lib]
...
Ciò vuol dire che normalmente ti basta settare quel parametro per dire dove vanno installate le librerie.
Codice: Seleziona tutto
$> configure --libdir=/usr/lib64


Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6185
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: problema stream audio alsa

Messaggioda zoros » mer set 22, 2010 0:24

però potrebbe essere anche un problema al file /etc/ld.so.cache (ricostruito da ldconfig) ... la "stranezza" è che in alcuni sistemini che sviluppo io ho eliminato del tutto quel file, così metto le lib dove voglio ... e i programmi le trovano sempre ;)
vorrei riavere le mie firme ...
Avatar utente
zoros
Linux 3.x
Linux 3.x
 
Messaggi: 1302
Iscritto il: lun mag 28, 2007 21:51
Località: Gorizia
Nome Cognome: Fabio∙Zorba
Slackware: 13.37
Kernel: 3.2.5
Desktop: KDE-3.5.10

Re: problema stream audio alsa

Messaggioda akerbabber » mer set 22, 2010 3:38

mi mancavano anche la libreria libspeexdsp.so.1: ma sono riuscito a trovarla, ora ho installato pulseaudio, ma il problema resta sempre lo stesso, riesco a sentire l'audio di un solo programma.
akerbabber
Linux 1.0
Linux 1.0
 
Messaggi: 82
Iscritto il: gio feb 21, 2008 20:48
Slackware: slackware64-current
Desktop: kde4.5


Torna a Slackware64

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti