Repository 32bit  Forum
Repository 64bit  Wiki

reboot all avvio

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

reboot all avvio

Messaggioda akerbabber » mer ott 06, 2010 14:35

Salve ragazzi ho provato a aggiornare alla current slackware, installando anche kde 4.5.2, ora mentre avvio mi reboota il sistema, ho già eseguito altre volte l'aggiornamento alla current eppure non mi era mai capitata una cosa simile, qualcuno protrebbe aiutarmi genitlmente?

Grazie.
akerbabber
Linux 1.0
Linux 1.0
 
Messaggi: 82
Iscritto il: gio feb 21, 2008 20:48
Slackware: slackware64-current
Desktop: kde4.5

Re: reboot all avvio

Messaggioda matzu » mer ott 06, 2010 19:46

Hai provato a forzare il runlevel a 1, 3 o 4, alla schermata del bootloader?
Avatar utente
matzu
Linux 2.4
Linux 2.4
 
Messaggi: 217
Iscritto il: dom set 20, 2009 1:26
Nome Cognome: Franco
Slackware: 64-13.37 13.1
Kernel: generic
Desktop: kde

Re: reboot all avvio

Messaggioda akerbabber » mer ott 06, 2010 20:23

come faccio con lilo?
ps: se lo avvio da il dvd con il kernel huge.s parte però senza che funzioni il server X
akerbabber
Linux 1.0
Linux 1.0
 
Messaggi: 82
Iscritto il: gio feb 21, 2008 20:48
Slackware: slackware64-current
Desktop: kde4.5

Re: reboot all avvio

Messaggioda matzu » mer ott 06, 2010 20:50

akerbabber ha scritto:come faccio con lilo?

Non lo so: ho sempre usato grub. Se mai ti può servire come traccia, con grub basta editare la stringa del kernel al boot, e aggiungere alla fine 'runlevel 4' o quale altro numero di runlevel vuoi. Forse lilo consente, allo stesso modo, l'aggiunta di parametri "al volo". Prova a vedere il man, magari online.
akerbabber ha scritto:ps: se lo avvio da il dvd con il kernel huge.s parte però senza che funzioni il server X

In questo modo non ci ho mai provato, ma se avvii dal dvd il sistema che hai installato, nel modo indicato nella schermata di avvio dello stesso, aggiungi anche in questo caso alla fine della riga la stessa stringa, in modo che termini con (se non ricordo male) 'rdinit= ro runlevel 4'. Non ho mai aggiunto il runlevel come parametro in questo caso, ma per altri parametri ho sempre usato la sintassi valida per grub e funzionano.

A ogni modo, se riesci ad avviare dal dvd il sistema installato sul computer, ancorché in modalità testuale, è probabile che sia proprio solo impostato male il runlevel. In tal caso, anche in modalità testuale, puoi sempre andare a controllare il runleve di default in /etc/inittab, ed eventualmente cambiarlo con un editor impostandolo a 4 per avviare da lilo in modalità grafica, senza più necessità di aggiungere parametri al boot. Se vuoi usare la modalità grafica per modificare inittab, e sempre a patto che abbia avviato (dal dvd) il sistema installato sul pc, puoi sempre eseguire startx dopo il login come root (se non hai creato un user, cosa che sarebbe meglio fare prima di startx).

EDIT: ti sconsiglierei, comunque, di avviare da runlevel 4 (grafico) se non hai già la comprovata certezza che il tuo hardware grafico funziona correttamente con il sistema che hai installato. In tal caso meglio avviare in modalità testuale ed eseguire startx. E solo dopo impostare il runlevel default a 4.
Avatar utente
matzu
Linux 2.4
Linux 2.4
 
Messaggi: 217
Iscritto il: dom set 20, 2009 1:26
Nome Cognome: Franco
Slackware: 64-13.37 13.1
Kernel: generic
Desktop: kde

Re: reboot all avvio

Messaggioda akerbabber » mer ott 06, 2010 21:06

matzu ha scritto:
akerbabber ha scritto:come faccio con lilo?

Non lo so: ho sempre usato grub. Se mai ti può servire come traccia, con grub basta editare la stringa del kernel al boot, e aggiungere alla fine 'runlevel 4' o quale altro numero di runlevel vuoi. Forse lilo consente, allo stesso modo, l'aggiunta di parametri "al volo". Prova a vedere il man, magari online.
akerbabber ha scritto:ps: se lo avvio da il dvd con il kernel huge.s parte però senza che funzioni il server X

In questo modo non ci ho mai provato, ma se avvii dal dvd il sistema che hai installato, nel modo indicato nella schermata di avvio dello stesso, aggiungi anche in questo caso alla fine della riga la stessa stringa, in modo che termini con (se non ricordo male) 'rdinit= ro runlevel 4'. Non ho mai aggiunto il runlevel come parametro in questo caso, ma per altri parametri ho sempre usato la sintassi valida per grub e funzionano.

A ogni modo, se riesci ad avviare dal dvd il sistema installato sul computer, ancorché in modalità testuale, è probabile che sia proprio solo impostato male il runlevel. In tal caso, anche in modalità testuale, puoi sempre andare a controllare il runleve di default in /etc/inittab, ed eventualmente cambiarlo con un editor impostandolo a 4 per avviare da lilo in modalità grafica, senza più necessità di aggiungere parametri al boot. Se vuoi usare la modalità grafica per modificare inittab, e sempre a patto che abbia avviato (dal dvd) il sistema installato sul pc, puoi sempre eseguire startx dopo il login come root (se non hai creato un user, cosa che sarebbe meglio fare prima di startx).

EDIT: ti sconsiglierei, comunque, di avviare da runlevel 4 (grafico) se non hai già la comprovata certezza che il tuo hardware grafico funziona correttamente con il sistema che hai installato. In tal caso meglio avviare in modalità testuale ed eseguire startx. E solo dopo impostare il runlevel default a 4.

seguirò i tuoi consigli, comunque prima quell'installazione la usavo con kde 4.5.1 felicemente, comunque preferisco evitare di partire con il runlevel 4, per il resto grazie per i consigli domani vi farò sapere
akerbabber
Linux 1.0
Linux 1.0
 
Messaggi: 82
Iscritto il: gio feb 21, 2008 20:48
Slackware: slackware64-current
Desktop: kde4.5

Re: reboot all avvio

Messaggioda 414N » mer ott 06, 2010 21:08

akerbabber ha scritto:come faccio con lilo?

Premi TAB per poter inserire manualmente il nome dell'immagine e poi
Codice: Seleziona tutto
Nome_IMG X

dove X è il numero del runlevel voluto.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: reboot all avvio

Messaggioda akerbabber » mer ott 06, 2010 21:09

akerbabber ha scritto:
matzu ha scritto:
akerbabber ha scritto:come faccio con lilo?

Non lo so: ho sempre usato grub. Se mai ti può servire come traccia, con grub basta editare la stringa del kernel al boot, e aggiungere alla fine 'runlevel 4' o quale altro numero di runlevel vuoi. Forse lilo consente, allo stesso modo, l'aggiunta di parametri "al volo". Prova a vedere il man, magari online.
akerbabber ha scritto:ps: se lo avvio da il dvd con il kernel huge.s parte però senza che funzioni il server X

In questo modo non ci ho mai provato, ma se avvii dal dvd il sistema che hai installato, nel modo indicato nella schermata di avvio dello stesso, aggiungi anche in questo caso alla fine della riga la stessa stringa, in modo che termini con (se non ricordo male) 'rdinit= ro runlevel 4'. Non ho mai aggiunto il runlevel come parametro in questo caso, ma per altri parametri ho sempre usato la sintassi valida per grub e funzionano.

A ogni modo, se riesci ad avviare dal dvd il sistema installato sul computer, ancorché in modalità testuale, è probabile che sia proprio solo impostato male il runlevel. In tal caso, anche in modalità testuale, puoi sempre andare a controllare il runleve di default in /etc/inittab, ed eventualmente cambiarlo con un editor impostandolo a 4 per avviare da lilo in modalità grafica, senza più necessità di aggiungere parametri al boot. Se vuoi usare la modalità grafica per modificare inittab, e sempre a patto che abbia avviato (dal dvd) il sistema installato sul pc, puoi sempre eseguire startx dopo il login come root (se non hai creato un user, cosa che sarebbe meglio fare prima di startx).

EDIT: ti sconsiglierei, comunque, di avviare da runlevel 4 (grafico) se non hai già la comprovata certezza che il tuo hardware grafico funziona correttamente con il sistema che hai installato. In tal caso meglio avviare in modalità testuale ed eseguire startx. E solo dopo impostare il runlevel default a 4.

seguirò i tuoi consigli, comunque prima quell'installazione la usavo con kde 4.5.1 felicemente.
Preferisco evitare di partire con il runlevel 4, per il resto grazie per i consigli domani vi farò sapere
akerbabber
Linux 1.0
Linux 1.0
 
Messaggi: 82
Iscritto il: gio feb 21, 2008 20:48
Slackware: slackware64-current
Desktop: kde4.5

Re: reboot all avvio

Messaggioda akerbabber » gio ott 07, 2010 14:39

Nulla da fare, mettendo il runlevel 4 partendo dal dvd appare uno schermo nero con un cursore rettangolare che non mi concede di fare nullam, invece cambiandolo da lilo mi dà sempre lo stesso problema.
akerbabber
Linux 1.0
Linux 1.0
 
Messaggi: 82
Iscritto il: gio feb 21, 2008 20:48
Slackware: slackware64-current
Desktop: kde4.5

Re: reboot all avvio

Messaggioda 414N » gio ott 07, 2010 16:05

Messaggi di errore prima che si riavvii il tutto?
Log di sistema ed X, ricavati magari tramite ssh?
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: reboot all avvio

Messaggioda akerbabber » gio ott 07, 2010 16:43

nessun messaggio d'errore prima del riavvio.
come faccio a usare ssh?
akerbabber
Linux 1.0
Linux 1.0
 
Messaggi: 82
Iscritto il: gio feb 21, 2008 20:48
Slackware: slackware64-current
Desktop: kde4.5

Re: reboot all avvio

Messaggioda 414N » gio ott 07, 2010 16:57

akerbabber ha scritto:nessun messaggio d'errore prima del riavvio.
come faccio a usare ssh?

Se hai una rete con un altro computer a disposizione, puoi provare di collegarti tramite ssh al computer non resposivo (ovviamente quando questo non si riavvia di continuo...).
Codice: Seleziona tutto
ssh nome_utente@IP_computer
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: reboot all avvio

Messaggioda erio » gio ott 07, 2010 17:38

puoi entrare con un live cd per vedere i log di sistema,magari modifica xconf con i driver vesa,quando cambi kernel devi riinstallare i driver video,per escludere kde dai problemi parti con un'altro wm.se hai nvidia blacklista i nouveau,udev che va per fatti suoi,ma con il kernel di pat credo che l'opzione per usare udev recenti gia' ci sia.
erio
Linux 3.x
Linux 3.x
 
Messaggi: 1086
Iscritto il: ven ott 09, 2009 18:25
Slackware: 13.37
Kernel: 3.0.7
Desktop: kde

Re: reboot all avvio

Messaggioda akerbabber » sab ott 09, 2010 14:31

Codice: Seleziona tutto
X.Org X Server 1.7.7
Release Date: 2010-05-04
X Protocol Version 11, Revision 0
Build Operating System: Slackware 13.1 Slackware Linux Project
Current Operating System: Linux akerbabber 2.6.33.4 #3 SMP Wed May 12 23:13:09 CDT 2010 x86_64
Kernel command line: initrd=initrd.img load_ramdisk=1 prompt_ramdisk=0 rw SLACK_KERNEL=huge.s BOOT_IMAGE=/kernels/huge.s/bzImage root=/dev/sda1 rdinit= ro
Build Date: 20 August 2010  12:39:24PM
 
Current version of pixman: 0.16.6
   Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sat Oct  9 15:21:27 2010
(II) Loader magic: 0x7bff60
(II) Module ABI versions:
   X.Org ANSI C Emulation: 0.4
   X.Org Video Driver: 6.0
   X.Org XInput driver : 7.0
   X.Org Server Extension : 2.0
(--) using VT number 7

(--) PCI:*(0:0:2:0) 8086:29c2:1043:82b0 rev 16, Mem @ 0xfea80000/524288, 0xe0000000/268435456, 0xfe900000/1048576, I/O @ 0x0000dc00/8
(==) Using default built-in configuration (30 lines)
(==) --- Start of built-in configuration ---
   Section "Device"
      Identifier   "Builtin Default intel Device 0"
      Driver   "intel"
   EndSection
   Section "Screen"
      Identifier   "Builtin Default intel Screen 0"
      Device   "Builtin Default intel Device 0"
   EndSection
   Section "Device"
      Identifier   "Builtin Default vesa Device 0"
      Driver   "vesa"
   EndSection
   Section "Screen"
      Identifier   "Builtin Default vesa Screen 0"
      Device   "Builtin Default vesa Device 0"
   EndSection
   Section "Device"
      Identifier   "Builtin Default fbdev Device 0"
      Driver   "fbdev"
   EndSection
   Section "Screen"
      Identifier   "Builtin Default fbdev Screen 0"
      Device   "Builtin Default fbdev Device 0"
   EndSection
   Section "ServerLayout"
      Identifier   "Builtin Default Layout"
      Screen   "Builtin Default intel Screen 0"
      Screen   "Builtin Default vesa Screen 0"
      Screen   "Builtin Default fbdev Screen 0"
   EndSection
(==) --- End of built-in configuration ---
(==) ServerLayout "Builtin Default Layout"
(**) |-->Screen "Builtin Default intel Screen 0" (0)
(**) |   |-->Monitor "<default monitor>"
(**) |   |-->Device "Builtin Default intel Device 0"
(==) No monitor specified for screen "Builtin Default intel Screen 0".
   Using a default monitor configuration.
(**) |-->Screen "Builtin Default vesa Screen 0" (1)
(**) |   |-->Monitor "<default monitor>"
(**) |   |-->Device "Builtin Default vesa Device 0"
(==) No monitor specified for screen "Builtin Default vesa Screen 0".
   Using a default monitor configuration.
(**) |-->Screen "Builtin Default fbdev Screen 0" (2)
(**) |   |-->Monitor "<default monitor>"
(**) |   |-->Device "Builtin Default fbdev Device 0"
(==) No monitor specified for screen "Builtin Default fbdev Screen 0".
   Using a default monitor configuration.
(==) Automatically adding devices
(==) Automatically enabling devices
(WW) The directory "/usr/share/fonts/local" does not exist.
   Entry deleted from font path.
(WW) The directory "/usr/share/fonts/CID" does not exist.
   Entry deleted from font path.
(==) FontPath set to:
   /usr/share/fonts/TTF,
   /usr/share/fonts/OTF,
   /usr/share/fonts/Type1,
   /usr/share/fonts/misc,
   /usr/share/fonts/75dpi/:unscaled,
   /usr/share/fonts/100dpi/:unscaled,
   /usr/share/fonts/75dpi,
   /usr/share/fonts/100dpi,
   /usr/share/fonts/cyrillic
(==) ModulePath set to "/usr/lib64/xorg/modules"
(II) Cannot locate a core pointer device.
(II) Cannot locate a core keyboard device.
(II) The server relies on HAL to provide the list of input devices.
   If no devices become available, reconfigure HAL or disable AutoAddDevices.
(II) Open ACPI successful (/var/run/acpid.socket)
(II) LoadModule: "extmod"
(II) Loading /usr/lib64/xorg/modules/extensions/libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
   compiled for 1.7.7, module version = 1.0.0
   Module class: X.Org Server Extension
   ABI class: X.Org Server Extension, version 2.0
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "dbe"
(II) Loading /usr/lib64/xorg/modules/extensions/libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
   compiled for 1.7.7, module version = 1.0.0
   Module class: X.Org Server Extension
   ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "glx"
(II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
(II) Module glx: vendor="X.Org Foundation"
   compiled for 1.7.7, module version = 1.0.0
   ABI class: X.Org Server Extension, version 2.0
(==) AIGLX enabled
(II) Loading extension GLX
(II) LoadModule: "dri"
(II) Loading /usr/lib64/xorg/modules/extensions/libdri.so
(II) Module dri: vendor="X.Org Foundation"
   compiled for 1.7.7, module version = 1.0.0
   ABI class: X.Org Server Extension, version 2.0
(II) Loading extension XFree86-DRI
(II) LoadModule: "dri2"
(II) Loading /usr/lib64/xorg/modules/extensions/libdri2.so
(II) Module dri2: vendor="X.Org Foundation"
   compiled for 1.7.7, module version = 1.1.0
   ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DRI2
(II) LoadModule: "intel"
(II) Loading /usr/lib64/xorg/modules/drivers/intel_drv.so
(II) Module intel: vendor="X.Org Foundation"
   compiled for 1.7.6, module version = 2.11.0
   Module class: X.Org Video Driver
   ABI class: X.Org Video Driver, version 6.0
(II) LoadModule: "vesa"
(II) Loading /usr/lib64/xorg/modules/drivers/vesa_drv.so
(II) Module vesa: vendor="X.Org Foundation"
   compiled for 1.7.5, module version = 2.3.0
   Module class: X.Org Video Driver
   ABI class: X.Org Video Driver, version 6.0
(II) LoadModule: "fbdev"
(WW) Warning, couldn't open module fbdev
(II) UnloadModule: "fbdev"
(EE) Failed to load module "fbdev" (module does not exist, 0)
(II) intel: Driver for Intel Integrated Graphics Chipsets: i810,
   i810-dc100, i810e, i815, i830M, 845G, 852GM/855GM, 865G, 915G,
   E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM, Pineview G,
   965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33, GM45,
   4 Series, G45/G43, Q45/Q43, G41, B43, Clarkdale, Arrandale
(II) VESA: driver for VESA chipsets: vesa
(II) Primary Device is: PCI 00@00:02:0
(WW) Falling back to old probe method for vesa
(EE) intel(0): No kernel modesetting driver detected.
(II) UnloadModule: "intel"
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.


ecco a voi il log ottenuto avviando da dvd, non c'era verso di utilizzare un altro runlevel per non far riavviare bootando da lilo
akerbabber
Linux 1.0
Linux 1.0
 
Messaggi: 82
Iscritto il: gio feb 21, 2008 20:48
Slackware: slackware64-current
Desktop: kde4.5

Re: reboot all avvio

Messaggioda 414N » sab ott 09, 2010 20:24

akerbabber ha scritto:
Codice: Seleziona tutto
(EE) intel(0): No kernel modesetting driver detected.
(II) UnloadModule: "intel"
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.



Il problema è lì: hai installato i driver intel dal disco di installazione di Slackware?
Oppure hai disabilitato il modesetting al boot?
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: reboot all avvio

Messaggioda akerbabber » dom ott 10, 2010 7:29

io sapevo che i driver intel fossero integrati con il kernel...
comunque non c'è nessun riferimento al mode settings nel mio lilo.conf, cosa posso fare?
akerbabber
Linux 1.0
Linux 1.0
 
Messaggi: 82
Iscritto il: gio feb 21, 2008 20:48
Slackware: slackware64-current
Desktop: kde4.5

Prossimo

Torna a Slackware64

Chi c’è in linea

Visitano il forum: Google [Bot] e 1 ospite