Repository 32bit  Forum
Repository 64bit  Wiki

[RISOLTO]Inaspettato problema dispositivi audio e alsa

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

[RISOLTO]Inaspettato problema dispositivi audio e alsa

Messaggioda shock » dom ott 17, 2010 10:00

Ciao a tutti, mi è successa una cosa un po strana.Ieri ho aggiornato il sistema con slackyd.Il processo non ha mostrato alcun errore ed ho eseguito perfettamente tutte le procedure.Ci tengo a far notare che dopo l'aggiornamento ho ascoltato della musica sul computer.Faccio notare questo perche stamattina quando ho riacceso il computer mi è apparso sullo schermo un messaggio che dice che gli apparati audio sono stati disinseriti e poi quando provo ad aprire un file audio con vlc mi da il seguente errore : "Potential ALSA version problem: VLC failed to initialize your sound output device (if any).Please update alsa-lib to version 1.0.23-2-g8d80d5f or higher to try to fix this issue." Come devo procedere per evitare di fare altri casini?E da terminale non riconosce alcun comando relativo ad alsa.

Ciao e grazie in anticipo
Ultima modifica di shock il dom ott 17, 2010 13:31, modificato 1 volta in totale.
Avatar utente
shock
Linux 2.4
Linux 2.4
 
Messaggi: 359
Iscritto il: mer ott 28, 2009 18:47
Nome Cognome: Ivan
Slackware: 13.1 x86_64
Kernel: 2.6.33.4-huge-smp
Desktop: KDE 4.4.3

Re: Inaspettato problema dispositivi audio e alsa

Messaggioda hashbang » dom ott 17, 2010 10:39

posta l'output di
Codice: Seleziona tutto
ls /var/log/packages | grep alsa
Adoro il pragmatismo della lingua giapponese, è l'unica in cui per dire ad una ragazza che la ami le dici "suki". (cit.)
Avatar utente
hashbang
Packager
Packager
 
Messaggi: 1833
Iscritto il: ven giu 04, 2010 9:27
Località: Lecce
Nome Cognome: Luca De Pandis
Distribuzione: Windows 8.1 Pro

Re: Inaspettato problema dispositivi audio e alsa

Messaggioda shock » dom ott 17, 2010 10:43

Eccolo:
Codice: Seleziona tutto
alsa-lib-1.0.23-x86_64-1
alsa-oss-1.0.17-x86_64-1
alsa-utils-1.0.23-x86_64-1
Avatar utente
shock
Linux 2.4
Linux 2.4
 
Messaggi: 359
Iscritto il: mer ott 28, 2009 18:47
Nome Cognome: Ivan
Slackware: 13.1 x86_64
Kernel: 2.6.33.4-huge-smp
Desktop: KDE 4.4.3

Re: Inaspettato problema dispositivi audio e alsa

Messaggioda hashbang » dom ott 17, 2010 10:49

lo script di INIT rc.alsa è attivo?
se così non fosse dai un
Codice: Seleziona tutto
chmod a+x /etc/rc.d/rc.alsa && sh /etc/rc.d/rc.alsa start
Adoro il pragmatismo della lingua giapponese, è l'unica in cui per dire ad una ragazza che la ami le dici "suki". (cit.)
Avatar utente
hashbang
Packager
Packager
 
Messaggi: 1833
Iscritto il: ven giu 04, 2010 9:27
Località: Lecce
Nome Cognome: Luca De Pandis
Distribuzione: Windows 8.1 Pro

Re: Inaspettato problema dispositivi audio e alsa

Messaggioda shock » dom ott 17, 2010 10:56

Ho dato anche questo comando, ma nulla...questo è l'output di alsamixer:
Codice: Seleziona tutto
cannot open mixer: No such file or directory
, e cosi per tutti i comandi di alsa :-k
Avatar utente
shock
Linux 2.4
Linux 2.4
 
Messaggi: 359
Iscritto il: mer ott 28, 2009 18:47
Nome Cognome: Ivan
Slackware: 13.1 x86_64
Kernel: 2.6.33.4-huge-smp
Desktop: KDE 4.4.3

Re: Inaspettato problema dispositivi audio e alsa

Messaggioda hashbang » dom ott 17, 2010 10:58

ok prova a reinstallare i pacchetti di alsa
Codice: Seleziona tutto
wget -c ftp://ftp.slackware.at/slackware-13.1/slackware/l/alsa*.txz && upgradepkg --reinstall --install-new alsa*.txz


EDIT: ho dimenticato alsa-utlis
Codice: Seleziona tutto
wget -c ftp://ftp.slackware.at/slackware-13.1/slackware/ap/alsa-utils*.txz && upgradepkg --reinstall --install-new alsa-utils*.txz
Adoro il pragmatismo della lingua giapponese, è l'unica in cui per dire ad una ragazza che la ami le dici "suki". (cit.)
Avatar utente
hashbang
Packager
Packager
 
Messaggi: 1833
Iscritto il: ven giu 04, 2010 9:27
Località: Lecce
Nome Cognome: Luca De Pandis
Distribuzione: Windows 8.1 Pro

Re: Inaspettato problema dispositivi audio e alsa

Messaggioda shock » dom ott 17, 2010 11:23

Ma questo procedimento è valido anche per slackware 64?E poi scusa alsa* non dovrebbe installare anche alsa-utilis?E poi posso convogliare tutto in un solo comando? :-k

Ciao e grazie
Avatar utente
shock
Linux 2.4
Linux 2.4
 
Messaggi: 359
Iscritto il: mer ott 28, 2009 18:47
Nome Cognome: Ivan
Slackware: 13.1 x86_64
Kernel: 2.6.33.4-huge-smp
Desktop: KDE 4.4.3

Re: Inaspettato problema dispositivi audio e alsa

Messaggioda Ansa89 » dom ott 17, 2010 11:28

shock ha scritto:Ma questo procedimento è valido anche per slackware 64?

Sì, basta cambiare l'indirizzo con un mirror di slackware 64.


shock ha scritto:E poi scusa alsa* non dovrebbe installare anche alsa-utilis?

No: "alsa-utils" è sotto "ap", mentre "alsa*" è sotto "l".
Avatar utente
Ansa89
Iper Master
Iper Master
 
Messaggi: 2621
Iscritto il: mer ago 29, 2007 16:57
Località: Modena
Nome Cognome: Stefano Ansaloni
Slackware: 13.1
Kernel: 3.16.1-ck1
Desktop: XFCE 4.6.1

Re: Inaspettato problema dispositivi audio e alsa

Messaggioda shock » dom ott 17, 2010 11:36

Ho reinstallato i pacchetti con i due comandi, ho dato :
Codice: Seleziona tutto
chmod a+x /etc/rc.d/rc.alsa && sh /etc/rc.d/rc.alsa start
e poi ho dato "alsaconf"...ho scelto la scheda che è stata auomaticamente riconosciuta...poi ho dato "alsamixer" ma ancora non trova alcuna directory :-k E vlc mi da ancora quell'errore
Avatar utente
shock
Linux 2.4
Linux 2.4
 
Messaggi: 359
Iscritto il: mer ott 28, 2009 18:47
Nome Cognome: Ivan
Slackware: 13.1 x86_64
Kernel: 2.6.33.4-huge-smp
Desktop: KDE 4.4.3

Re: Inaspettato problema dispositivi audio e alsa

Messaggioda hashbang » dom ott 17, 2010 11:48

ops...scusate l'errore dei 64 bit....sono abituato con la 32...
comunque da root dai:
Codice: Seleziona tutto
updatedb && slocate alsamixer
Adoro il pragmatismo della lingua giapponese, è l'unica in cui per dire ad una ragazza che la ami le dici "suki". (cit.)
Avatar utente
hashbang
Packager
Packager
 
Messaggi: 1833
Iscritto il: ven giu 04, 2010 9:27
Località: Lecce
Nome Cognome: Luca De Pandis
Distribuzione: Windows 8.1 Pro

Re: Inaspettato problema dispositivi audio e alsa

Messaggioda shock » dom ott 17, 2010 11:55

Ho dato :
Codice: Seleziona tutto
updatedb && slocate alsamixer

poi ho ridato "alsaconf"
poi :
Codice: Seleziona tutto
chmod a+x /etc/rc.d/rc.alsa && sh /etc/rc.d/rc.alsa start
e questo è il suo (chmod) output :
Codice: Seleziona tutto
WARNING: All config files need .conf: /etc/modprobe.d/sound, it will be ignored in a future release.
Loading ALSA kernel modules.
WARNING: All config files need .conf: /etc/modprobe.d/sound, it will be ignored in a future release.
WARNING: Error inserting snd_timer (/lib/modules/2.6.33.4/kernel/sound/core/snd-timer.ko): Unknown symbol in module, or unknown parameter (see dmesg)
WARNING: Error inserting snd_pcm (/lib/modules/2.6.33.4/kernel/sound/core/snd-pcm.ko): Unknown symbol in module, or unknown parameter (see dmesg)
WARNING: Error inserting snd_hwdep (/lib/modules/2.6.33.4/kernel/sound/core/snd-hwdep.ko): Unknown symbol in module, or unknown parameter (see dmesg)
WARNING: Error inserting snd_hda_codec (/lib/modules/2.6.33.4/kernel/sound/pci/hda/snd-hda-codec.ko): Unknown symbol in module, or unknown parameter (see dmesg)
FATAL: Error inserting snd_hda_intel (/lib/modules/2.6.33.4/kernel/sound/pci/hda/snd-hda-intel.ko): Unknown symbol in module, or unknown parameter (see dmesg)
Avatar utente
shock
Linux 2.4
Linux 2.4
 
Messaggi: 359
Iscritto il: mer ott 28, 2009 18:47
Nome Cognome: Ivan
Slackware: 13.1 x86_64
Kernel: 2.6.33.4-huge-smp
Desktop: KDE 4.4.3

Re: Inaspettato problema dispositivi audio e alsa

Messaggioda hashbang » dom ott 17, 2010 12:00

L'errore sembra essere relativo ad alcuni moduli del kernel. Posta l'output del dmesg e l'output di slocate alsamixer.

Per evitare output che contengono info inutili dai un dmesg | tail che è più specifico
Adoro il pragmatismo della lingua giapponese, è l'unica in cui per dire ad una ragazza che la ami le dici "suki". (cit.)
Avatar utente
hashbang
Packager
Packager
 
Messaggi: 1833
Iscritto il: ven giu 04, 2010 9:27
Località: Lecce
Nome Cognome: Luca De Pandis
Distribuzione: Windows 8.1 Pro

Re: Inaspettato problema dispositivi audio e alsa

Messaggioda targzeta » dom ott 17, 2010 12:04

Prova a fare così (da root):
  • Rinomina il file '/etc/modprobe.d/sound' come '/etc/modprobe.d/sound.conf' così elimini i warning
  • Esegui:
    Codice: Seleziona tutto
    dmesg -c
    depmod
    /etc/rc.d/rc.alsa start
se ci sono ancora degli errori postaci l'output di:
Codice: Seleziona tutto
dmseg


Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6175
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: Inaspettato problema dispositivi audio e alsa

Messaggioda shock » dom ott 17, 2010 12:14

Questo è l'output di "/etc/rc.d/rc.alsa start" :
Codice: Seleziona tutto
Loading ALSA kernel modules.
WARNING: Error inserting snd_timer (/lib/modules/2.6.33.4/kernel/sound/core/snd-timer.ko): Unknown symbol in module, or unknown parameter (see dmesg)
WARNING: Error inserting snd_pcm (/lib/modules/2.6.33.4/kernel/sound/core/snd-pcm.ko): Unknown symbol in module, or unknown parameter (see dmesg)
WARNING: Error inserting snd_hwdep (/lib/modules/2.6.33.4/kernel/sound/core/snd-hwdep.ko): Unknown symbol in module, or unknown parameter (see dmesg)
WARNING: Error inserting snd_hda_codec (/lib/modules/2.6.33.4/kernel/sound/pci/hda/snd-hda-codec.ko): Unknown symbol in module, or unknown parameter (see dmesg)
FATAL: Error inserting snd_hda_intel (/lib/modules/2.6.33.4/kernel/sound/pci/hda/snd-hda-intel.ko): Unknown symbol in module, or unknown parameter (see dmesg)


Adesso nemmeno il comando dmesg va , prima usciva un messaggio che non ho salvato...ora proprio piu nulla, accetta il comando senza output :-k
Avatar utente
shock
Linux 2.4
Linux 2.4
 
Messaggi: 359
Iscritto il: mer ott 28, 2009 18:47
Nome Cognome: Ivan
Slackware: 13.1 x86_64
Kernel: 2.6.33.4-huge-smp
Desktop: KDE 4.4.3

Re: Inaspettato problema dispositivi audio e alsa

Messaggioda targzeta » dom ott 17, 2010 12:20

E' normale, hai eliminato il contenuto con 'dmesg -c'. Dai di nuovo '/etc/rc.d/rc.alsa start' e poi di nuovo dmesg, se c'è qualcosa postalo.

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6175
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Prossimo

Torna a Slackware64

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite