Repository 32bit  Forum
Repository 64bit  Wiki

[RISOLTO] aggiornamento toolchain

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

[RISOLTO] aggiornamento toolchain

Messaggioda zevin » lun ott 18, 2010 11:17

Salve! Dopo l'ulitmo aggiornamento delle toolchain su Slackware64-current non riesco più a compilare. Il sistema lamenta la mancata installazione delle GCC. Altri hanno lo stesso problema o lo hanno risolto?
Grazie!
Ultima modifica di zevin il ven ott 22, 2010 22:31, modificato 1 volta in totale.
zevin
Linux 2.0
Linux 2.0
 
Messaggi: 167
Iscritto il: ven dic 05, 2003 0:00
Località: Bolzano
Nome Cognome: Ezio Vinante
Slackware: current x86_64
Kernel: 3.10.12
Desktop: Kde 4.12.0-alien

Re: aggiornamento toolchain

Messaggioda 414N » lun ott 18, 2010 12:33

Avevi installato i pacchetti di alien di gcc (e compagnia) multilib?
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: aggiornamento toolchain

Messaggioda zevin » lun ott 18, 2010 13:46

SÍ, ho provato ad aggiornare anche quelle, ma il problema rimane. C'è forse qualche file di configurazione che viene sovrascritto o roba del genere?

Grazie!

Ciao
zevin
Linux 2.0
Linux 2.0
 
Messaggi: 167
Iscritto il: ven dic 05, 2003 0:00
Località: Bolzano
Nome Cognome: Ezio Vinante
Slackware: current x86_64
Kernel: 3.10.12
Desktop: Kde 4.12.0-alien

Re: aggiornamento toolchain

Messaggioda 414N » lun ott 18, 2010 14:33

zevin ha scritto:SÍ, ho provato ad aggiornare anche quelle, ma il problema rimane. C'è forse qualche file di configurazione che viene sovrascritto o roba del genere

Aggiornare come? Se hai usato slackpkg, evidentemente non hai seguito la guida di alien bob (qui l'originale in inglese, qui per la versione tradotta da danix), nella quale è scritto chiaramente di escludere i pacchetti gcc/glibc dagli update di slackpkg perché altrimenti vengono sovrascritti dalle versioni pure a 64 bit.
Devi aggiornare quei pacchetti con le nuove versioni messe a disposizioni da alien qua.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: aggiornamento toolchain

Messaggioda zevin » lun ott 18, 2010 14:49

No no, io non uso slackpkg, faccio tutto rigorosamente a manina ed ho seguito pedissequamente le guide di Alien.
zevin
Linux 2.0
Linux 2.0
 
Messaggi: 167
Iscritto il: ven dic 05, 2003 0:00
Località: Bolzano
Nome Cognome: Ezio Vinante
Slackware: current x86_64
Kernel: 3.10.12
Desktop: Kde 4.12.0-alien

Re: aggiornamento toolchain

Messaggioda 414N » lun ott 18, 2010 15:09

zevin ha scritto:No no, io non uso slackpkg, faccio tutto rigorosamente a manina ed ho seguito pedissequamente le guide di Alien.

Quali errori ricevi, di preciso? Roba ripo
Codice: Seleziona tutto
C compiler cannot create executables
?
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: aggiornamento toolchain

Messaggioda zevin » lun ott 18, 2010 16:09

In questo momento ho reinstallato le 4.4.4 e funziona tutto. Non appena posso rifaccio l'upgrade e ti posto l'errore.

Ciao
zevin
Linux 2.0
Linux 2.0
 
Messaggi: 167
Iscritto il: ven dic 05, 2003 0:00
Località: Bolzano
Nome Cognome: Ezio Vinante
Slackware: current x86_64
Kernel: 3.10.12
Desktop: Kde 4.12.0-alien

Re: aggiornamento toolchain

Messaggioda zevin » gio ott 21, 2010 21:21

Questo è l'errore che mi restituisce:

gcc is unable to create an executable file.
If gcc is a cross-compiler, use the --enable-cross-compile option.
Only do this if you know what cross compiling means.
C compiler test failed.
zevin
Linux 2.0
Linux 2.0
 
Messaggi: 167
Iscritto il: ven dic 05, 2003 0:00
Località: Bolzano
Nome Cognome: Ezio Vinante
Slackware: current x86_64
Kernel: 3.10.12
Desktop: Kde 4.12.0-alien

Re: aggiornamento toolchain

Messaggioda 414N » ven ott 22, 2010 10:05

zevin ha scritto:Questo è l'errore che mi restituisce:

gcc is unable to create an executable file.
If gcc is a cross-compiler, use the --enable-cross-compile option.
Only do this if you know what cross compiling means.
C compiler test failed.

Usi uno SlackBuild? Hai impostato ARCH=x86_64 prima di lanciare lo SlackBuild?
In caso contrario, riesci a postare il config.log?
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: aggiornamento toolchain

Messaggioda zevin » ven ott 22, 2010 22:01

Non è un problema di SlackBuild in quanto installando le gcc 4.4.4 compila regolarmente. Credo invece sia dovuto alle ultime versioni di gcc che mi sembra diano problemi diversi un po' a tutti. D'altronde il bello della current è anche questo.

Grazie comunque.

Ciao
zevin
Linux 2.0
Linux 2.0
 
Messaggi: 167
Iscritto il: ven dic 05, 2003 0:00
Località: Bolzano
Nome Cognome: Ezio Vinante
Slackware: current x86_64
Kernel: 3.10.12
Desktop: Kde 4.12.0-alien

Re: aggiornamento toolchain

Messaggioda zevin » ven ott 22, 2010 22:30

Ho risolto. Mi ero perso un aggiornamento e mi mancavano un paio di librerie: libmpc e libelf.

Ciao
zevin
Linux 2.0
Linux 2.0
 
Messaggi: 167
Iscritto il: ven dic 05, 2003 0:00
Località: Bolzano
Nome Cognome: Ezio Vinante
Slackware: current x86_64
Kernel: 3.10.12
Desktop: Kde 4.12.0-alien


Torna a Slackware64

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti