Repository 32bit  Forum
Repository 64bit  Wiki

[RISOLTO] acroread in multilib

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

[RISOLTO] acroread in multilib

Messaggioda sbabaro » mer ott 27, 2010 18:39

sto provando a usare le multilib

ho eseguito quanto indicato da Alien

ho provato ad installare il pacchetto acrobat reader dal repository a 32 bit

se ho compreso bene, non devo convertire il pacchetto prima di installarlo, visto che le lib a 64 sono sotto lib64

installato il pacchetto del reader, il programma parte, ma senza caratteri

in console vedo
Codice: Seleziona tutto
Pango-CRITICAL **: No modules found
PangoFc will not work correctly.
This probably means there was an error in the creation of:
   '/etc/pango/pango.modules

ho provato a creare il file come suggerito, ma non degna di uno sguardo: evidentemente mi mancano delle librerie, o qualche configurazione

In generale è che vorrei capire meglio prima di installare mezzo mondo e ritrovarmi con una installazione troppo incasinata
sbabaro
Packager
Packager
 
Messaggi: 388
Iscritto il: gio set 08, 2005 23:00
Slackware: slack 12.1
Kernel: 2.6.26 ricompilato
Desktop: gslacky

Re: [RISOLTO] acroread in multilib

Messaggioda sbabaro » mer ott 27, 2010 18:56

mi rispondo da solo:
ho trovato un thread che trattava esattamente la stessa cosa: bastava riavviare.......
no comment :oops:

Comunque: è giusto che i pacchetti a 32 che installo non hanno bisogno di essere converititi con lo script di Alien?
sbabaro
Packager
Packager
 
Messaggi: 388
Iscritto il: gio set 08, 2005 23:00
Slackware: slack 12.1
Kernel: 2.6.26 ricompilato
Desktop: gslacky

Re: [RISOLTO] acroread in multilib

Messaggioda 414N » mer ott 27, 2010 19:43

sbabaro ha scritto:Comunque: è giusto che i pacchetti a 32 che installo non hanno bisogno di essere converititi con lo script di Alien?

Lo script di alien (convertpkg-compat32) è utile nei casi in cui devi affiancare ad un programma (più che altro una libreria) già presente sul sistema a 64 bit la sua versione a 32 bit: lo script non fa altro che tenere le librerie a 32 bit, "nascondere" gli eseguibili in modo che non sovrascrivano quelli a 64 bit e cancellare roba ridondante col pacchetto a 64 bit già presente (tipo documentazione, man pages, script di configurazione etc.).
Nel caso di un'applicazione solo a 32 bit (come acrobat reader o skype) non c'è bisogno di preoccuparsi di andare a sovrascrivere qualcosa a 64 bit con una versione a 32 bit: c'è solo quest'ultima disponibile.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2881
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: [RISOLTO] acroread in multilib

Messaggioda sbabaro » ven ott 29, 2010 16:07

grazie
sbabaro
Packager
Packager
 
Messaggi: 388
Iscritto il: gio set 08, 2005 23:00
Slackware: slack 12.1
Kernel: 2.6.26 ricompilato
Desktop: gslacky


Torna a Slackware64

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite