Repository 32bit  Forum
Repository 64bit  Wiki

[Risolto] dhcp mi rallenta l'avvio del pc

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

[Risolto] dhcp mi rallenta l'avvio del pc

Messaggioda lablinux » mer nov 03, 2010 14:59

Come da post:
Slackware 13.1, per gestire la connessione al router wifi uso wicd, il mio wm è xfce.
All'avvio mi esegue operazione di (poolling?) che arrestano per quasi 10 secondi l'avvio del pc. Niente di mortale, ma mi infastidiscono.
Mi sono posto le seguenti domande:
1. non mi connetto tramite cavo, è possibile eliminare il passaggio in cui cerca di connettersi, magari disattivando l'interfaccia eth0?
2. posso evitare che parta il servizio di dhcp all'avvio se uso wicd?
3. è obbligatorio usare wicd per connettersi tramite wifi?

Ciao e grazie.


Michele.
Ultima modifica di lablinux il mer nov 03, 2010 23:00, modificato 1 volta in totale.
Avatar utente
lablinux
Linux 2.6
Linux 2.6
 
Messaggi: 753
Iscritto il: gio nov 27, 2008 12:23
Località: Rho
Slackware: 14 64bit
Desktop: kde4

Re: dhcp mi rallenta l'avvio del pc

Messaggioda targzeta » mer nov 03, 2010 16:25

Puoi tranquillamente evitare l'uso di DHCP. Io per connettermi alla wifi uso wpa_supplicant, poi la configurazione me la faccio a mano. Eccoti un esempio:
Codice: Seleziona tutto
TMP_FILE=/tmp/Alice-XXX;

# Carico la scheda di rete
modprobe iwl3945

# Imposto la scheda di rete
ifconfig wlan0 up 192.168.1.250

# Preparo il file di configurazione per wpa_supplicant
cat > ${TMP_FILE} <<EOF
network={
        ssid="Alice-XXX"
        key_mgmt=NONE
        wep_key0="yyyyyy"
}
EOF

sleep 1

# Mi collego alla rete tramite wpa_supplicant
wpa_supplicant -iwlan0 -Bc ${TMP_FILE};

# Aggiungo il gateway di default
route add default gw 192.168.1.1

Come vedi mi sono dato un IP statico ed ho aggiunto il default gateway a mano, con il resolv.conf in questo modo:
Codice: Seleziona tutto
option rotate
nameserver 151.99.125.1
nameserver 151.99.125.3
altro non dovrebbe servire.

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6185
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: dhcp mi rallenta l'avvio del pc

Messaggioda lablinux » mer nov 03, 2010 16:45

il problema è che io non mi posso assegnare un ip.
Sono un cliente fastweb e per connettermi devo obbligatoriamente usare un ip dinamico.
Avatar utente
lablinux
Linux 2.6
Linux 2.6
 
Messaggi: 753
Iscritto il: gio nov 27, 2008 12:23
Località: Rho
Slackware: 14 64bit
Desktop: kde4

Re: dhcp mi rallenta l'avvio del pc

Messaggioda targzeta » mer nov 03, 2010 16:53

Quindi il router fastweb non ti da la possibilità di crearti una sottorete con il NAT? Ti devi collegare a lui e chiedergli un indirizzo IP? Allora dopo esserti collegato con 'wpa_supplicant' puoi anche lanciare 'dhcpcd'.

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6185
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: dhcp mi rallenta l'avvio del pc

Messaggioda lablinux » mer nov 03, 2010 17:07

mmmhhhh lo sai che mi metti il dubbio...
Avatar utente
lablinux
Linux 2.6
Linux 2.6
 
Messaggi: 753
Iscritto il: gio nov 27, 2008 12:23
Località: Rho
Slackware: 14 64bit
Desktop: kde4

Re: dhcp mi rallenta l'avvio del pc

Messaggioda phobos3576 » mer nov 03, 2010 22:18

spina ha scritto:Quindi il router fastweb non ti da la possibilità di crearti una sottorete con il NAT? Ti devi collegare a lui e chiedergli un indirizzo IP? Allora dopo esserti collegato con 'wpa_supplicant' puoi anche lanciare 'dhcpcd'.

Emanuele

Wpa_supplicant e dhcpcd vengono lanciati automaticamente da Wicd; tra l'altro, io lo sto usando su due PC e non ho alcun rallentamento in avvio del WM.

Nel caso di lablinux il problema potrebbe essere un conflitto tra Wicd e gli script wireless messi da Pat in /etc/rc.d. Quando si usa Wicd bisogna togliere i permessi di esecuzione a /etc/rc.d/rc.wireless e bisogna commentare in /etc/rc.d/rc.inet1.conf eventuali righe del tipo:
Codice: Seleziona tutto
USE_DHCP[4]="yes"
DHCP_TIMEOUT[4]=20
WLAN_WPA[4]="wpa_supplicant"
WLAN_WPAWAIT[4]=10
Avatar utente
phobos3576
Staff
Staff
 
Messaggi: 2980
Iscritto il: sab apr 16, 2005 23:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Re: dhcp mi rallenta l'avvio del pc

Messaggioda lablinux » mer nov 03, 2010 23:00

Perfetto adesso cerco di capire un'altra "perdita di tempo", in caso non risolva mi rifaccio vivo.
Avatar utente
lablinux
Linux 2.6
Linux 2.6
 
Messaggi: 753
Iscritto il: gio nov 27, 2008 12:23
Località: Rho
Slackware: 14 64bit
Desktop: kde4


Torna a Slackware64

Chi c’è in linea

Visitano il forum: Google [Bot] e 2 ospiti

cron