[Risolto] Problemi con il Boot Loader?

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
mrfabiolo
Linux 1.0
Linux 1.0
Messaggi: 11
Iscritto il: mer set 08, 2010 15:56
Nome Cognome: Fabio Vianello
Distribuzione: Slackware 13.1 32bit

[Risolto] Problemi con il Boot Loader?

Messaggioda mrfabiolo » mar nov 23, 2010 20:06

Mi era capitato di installare Slackware a 32 bit (mi pare fosse il 13.0) in un computer di un altro. C'era già dentro Debian e Windows.
Quando installai Lilo però all'avvio del computer potevo scegliere solo tra avviare Windows o Linux. (se cliccavo su linux mi faceva partire Slackware)
Quindi, come dovevo fare per poter far partire anche Debian? La questione il mio amico l'ha risolta da solo grazie ad una live di Ubuntu e installando grub.

Ora vorrei installare sul mio computer Slackware 13.1 a 64 bit. Ho già installato contemporaneamente sua Windows che Debian che Ubuntu e tutte partono alla perfezione con Grub.
Io non ho esperienza di Lilo. Temo che anche questa volta mi faccia avviare solo windows o Slackware, ma qualche volta vorrei poter avviare anche gli altri sistemi operativi.
Come dovrò fare poi per poterle avviare? E' possibile configurando Lilo? E caso mai è possibile da Slackware installare Grub anziché Lilo?

Vi scrivo in anticipo per evitare problemi dopo.

Già che ci siete: installo quella a 64 bit giusto? non ho problemi poi a far partire del software a 32 su slackware a 64?

Grazie.
Ultima modifica di mrfabiolo il mer nov 24, 2010 19:10, modificato 1 volta in totale.

erio
Linux 3.x
Linux 3.x
Messaggi: 1171
Iscritto il: ven ott 09, 2009 19:25
Slackware: 13.37
Kernel: 3.0.7
Desktop: kde

Re: Problemi con il Boot Loader?

Messaggioda erio » mar nov 23, 2010 20:39

penso che tu possa far partire la slackware da grub senza installare lilo.quando ti chiede di installarlo non lo fare poi aggiungi la riga di slackware al tuo grub.io ho fatto cosi..ma aspetta altri consigli..

Avatar utente
hashbang
Packager
Packager
Messaggi: 1951
Iscritto il: ven giu 04, 2010 10:27
Nome Cognome: Luca De Pandis
Slackware: Slackware64-current
Kernel: 4.4.12
Desktop: dwm
Distribuzione: Windows 10 Pro
Località: Lecce
Contatta:

Re: Problemi con il Boot Loader?

Messaggioda hashbang » mar nov 23, 2010 21:37

evita di installare lilo e poi configura grub da debian inserendo le righe relative al kernel della slack e la partizione di root

EDIT: ops, ha già risposto erio. sorry :oops:
There's a certain kind of programmer who'll look at any problem and say, 'I know, I will use XML.' Now he has two problems.

Stack is the new term for "I have no idea what I'm actually using". [Erich Schubert]

mrfabiolo
Linux 1.0
Linux 1.0
Messaggi: 11
Iscritto il: mer set 08, 2010 15:56
Nome Cognome: Fabio Vianello
Distribuzione: Slackware 13.1 32bit

Re: [RISOLTO] Problemi con il Boot Loader?

Messaggioda mrfabiolo » mer nov 24, 2010 19:09

ok. Grazie


Torna a “Slackware64”

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti