Repository 32bit  Forum
Repository 64bit  Wiki

[RISOLTO] Kde4 non parte dopo aggiornamento a current 11/01

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

[RISOLTO] Kde4 non parte dopo aggiornamento a current 11/01

Messaggioda Eberoth » gio gen 13, 2011 11:07

Come da titolo, ho aggiornato la mia current ai due ultimi changelog contemporaneamente e, quindi, ho mi sono ritrovato col il nuovo kde4.5.5. Il problema è che quando cerco di avviarlo mi ritrovo uno schermo completamente bianco con dei pulsantoni rossi con sopra una X. Credo siano errori nel caricamento di qualche "modulo" di kde stesso, ma non so dove mettere le mani. Ho già provato ad eliminare .kde, ma non è cambiato nulla.
Ultima modifica di Eberoth il sab gen 15, 2011 17:08, modificato 1 volta in totale.
Avatar utente
Eberoth
Linux 2.4
Linux 2.4
 
Messaggi: 380
Iscritto il: lun ago 24, 2009 8:22
Slackware: -current
Kernel: 3.13.6
Desktop: KDE4
Distribuzione: Slackel64

Re: Kde4 non parte dopo aggiornamento a current 11/01

Messaggioda Meskalamdug » gio gen 13, 2011 13:40

Io ho quasi abbandonato kde.
Uso il navigatore konqueror e le applicazioni come kmplayer,etc ma l'ambiente desktopo è quasi inutilizzabile,tra configurazioni da cancellare ogni 2 mesi,chiusure improvvise di X.
KDE4 più che una rivoluzione si è trasformato in una delusione cocente,la fretta è cattiva consigliera.
Meskalamdug
Iper Master
Iper Master
 
Messaggi: 3593
Iscritto il: gio mag 13, 2004 23:00

Re: Kde4 non parte dopo aggiornamento a current 11/01

Messaggioda Eberoth » gio gen 13, 2011 15:39

Capisco che non a tutti possa piacere kde4, ma a me non ha mai dato problemi rilevanti. Comunque di topic su kde4 in quanto tale ce ne sono stati a sufficienza, e anche io sono passato ad altro su altre macchine, ma visto che su questa kde4 funziona e a me piace, vorrei una mano a risolvere il problema piuttosto che continuare a discutere sui gusti di ognuno.
Avatar utente
Eberoth
Linux 2.4
Linux 2.4
 
Messaggi: 380
Iscritto il: lun ago 24, 2009 8:22
Slackware: -current
Kernel: 3.13.6
Desktop: KDE4
Distribuzione: Slackel64

Re: Kde4 non parte dopo aggiornamento a current 11/01

Messaggioda ermes » gio gen 13, 2011 15:49

anche io ho problemi simili a Eberoth:

- Portatile nuovo su cui ho installato la 13.1 => tutto ok
- non avendo mai avuto problemi con le current sono passato quasi subito all'aggiornamento e non sono più riuscito a far partire KDE: schermata iniziale con le classiche icone che apppaiono in dissolvenza e poi ritorno alla bash con un errore che più o meno diceva che il server grafico non trovava il video:0 (ma sto andando a memoria).
ho prontamente fatto un downgrade alla 13.1 aspettando tempi migliori (e per questo motivo non posso postare l'errore corretto.

se potesse interessare ho una scheda ATI ma non ho ancora installati i driver della scheda... e soprattutto ho instllato la versione 32 di slackware (non la 64 a cui correttamente fa riferimento il post originale... quindi forse non a vrei douto postare qui ma ho pensato che il problema potrebbe essere lo stesso)

anche a me non è servito a nulla eliminare .kde.

ciao e grazie in anticipo a chi riuscirà a darci una mano con così pochi elementi.
Avatar utente
ermes
Linux 2.4
Linux 2.4
 
Messaggi: 340
Iscritto il: dom feb 20, 2005 0:00
Località: Rho (Mi)
Slackware: current 64
Desktop: kde

Re: Kde4 non parte dopo aggiornamento a current 11/01

Messaggioda Eberoth » gio gen 13, 2011 16:41

Non credo che il mio problema sia lo stesso di ermes in quanto il mio kde sembra avviarsi correttamente fino al punto in cui dovrebbe comparire il desktop, quando invece compaiono le classiche X rosse tipiche dei messaggi di errore di plasma (come se non trovasse alcune componenti). A quel punto lo kde rimane in esecuzione, non torna alla shell, ma è del tutto inutilizzabile in quanto ho solo lo schermo, completamente bianco, i messaggi di errore ed il punatore del mouse: qualunque azione è impossibile.

Tornando sulla shell da cui ho lanciato X (uso runlevel 3 per il login, poi lancio startx), mi trovo con il dump di kde ed ho notato alcuni messaggi di kded che si riferiscono a versioni di librerie non compatibili (il che è strano visto che ho aggiornato tutta la current...).

Il problema di ermes sembra piuttosto dovuto ad una cattiva configurazione del server X...
Avatar utente
Eberoth
Linux 2.4
Linux 2.4
 
Messaggi: 380
Iscritto il: lun ago 24, 2009 8:22
Slackware: -current
Kernel: 3.13.6
Desktop: KDE4
Distribuzione: Slackel64

Re: Kde4 non parte dopo aggiornamento a current 11/01

Messaggioda erio » gio gen 13, 2011 16:47

ci sono delle dipendenze che devono essere soddisfatte prima, guarda un attimo nel sito di alien bob alla directory deps ci sono 12 pacchetti da upgradare,puo essere che l'inghippo sia li.
erio
Linux 3.x
Linux 3.x
 
Messaggi: 1086
Iscritto il: ven ott 09, 2009 18:25
Slackware: 13.37
Kernel: 3.0.7
Desktop: kde

Re: Kde4 non parte dopo aggiornamento a current 11/01

Messaggioda Eberoth » gio gen 13, 2011 16:50

@erio
controllerò... ma la versione di kde4 nel changelog del 10/01 non è la stessa del repo di ktown (che è una rc della 4.6). Inoltre, avendo sempre mantenuto aggiornata la mia current, dovrei essere a posto anche con le dipendenze, non credi?
Avatar utente
Eberoth
Linux 2.4
Linux 2.4
 
Messaggi: 380
Iscritto il: lun ago 24, 2009 8:22
Slackware: -current
Kernel: 3.13.6
Desktop: KDE4
Distribuzione: Slackel64

Re: Kde4 non parte dopo aggiornamento a current 11/01

Messaggioda erio » gio gen 13, 2011 16:54

si credo, di solito i quadrettoni sono un sintomo di inpostazione kde non più valide,ma se l'hai tolta ed è uguale.
erio
Linux 3.x
Linux 3.x
 
Messaggi: 1086
Iscritto il: ven ott 09, 2009 18:25
Slackware: 13.37
Kernel: 3.0.7
Desktop: kde

Re: Kde4 non parte dopo aggiornamento a current 11/01

Messaggioda Eberoth » gio gen 13, 2011 17:09

anche installando le dipendenze della rc di kde4.6 prese dal repo ktown, non cambia nulla.
Gli errori che ho scovato nel dump di kde si riferiscono tutti a kded che non riesce a caricare alcune "librerie" perché la versione non è compatibile. Vi posterei gli errori, ma non so come salvare il dump su un file.
Avatar utente
Eberoth
Linux 2.4
Linux 2.4
 
Messaggi: 380
Iscritto il: lun ago 24, 2009 8:22
Slackware: -current
Kernel: 3.13.6
Desktop: KDE4
Distribuzione: Slackel64

Re: Kde4 non parte dopo aggiornamento a current 11/01

Messaggioda erio » gio gen 13, 2011 17:15

io da dove ti scrivo,la versione della current del 14 dicembre ho installato kde 4.6 di alien bob e la directory deps,a livello di librerie puo essere che ce ne sono di troppo avanzate nella current di gennaio,ma non sono sicuro è un pò che non ho current in tempo reale.
erio
Linux 3.x
Linux 3.x
 
Messaggi: 1086
Iscritto il: ven ott 09, 2009 18:25
Slackware: 13.37
Kernel: 3.0.7
Desktop: kde

Re: Kde4 non parte dopo aggiornamento a current 11/01

Messaggioda erio » gio gen 13, 2011 17:17

se hai una live puoi accedere a /var/log e vedere il problema.
erio
Linux 3.x
Linux 3.x
 
Messaggi: 1086
Iscritto il: ven ott 09, 2009 18:25
Slackware: 13.37
Kernel: 3.0.7
Desktop: kde

Re: Kde4 non parte dopo aggiornamento a current 11/01

Messaggioda Eberoth » gio gen 13, 2011 17:26

@erio
il problema si è presentato subito dopo l'aggiornamento alla current del 10/01 e 11/01, le librerie deps le ho installate dopo il tuo post. Ma il problema e gli errori non cambiano.

Non ho bisogno di una live per accedere a /var/log, ora sto scrivendo dal pc "incriminato" usando lxde come interfaccia di ripiego. Ma in ogni caso, usando il runlevel 3 il mancato funzionamento di kde non compromette la lettura dei log... il problema è: tra tutti file in /var/log, dove accidenti lo trovo il dump di startx?
Avatar utente
Eberoth
Linux 2.4
Linux 2.4
 
Messaggi: 380
Iscritto il: lun ago 24, 2009 8:22
Slackware: -current
Kernel: 3.13.6
Desktop: KDE4
Distribuzione: Slackel64

Re: Kde4 non parte dopo aggiornamento a current 11/01

Messaggioda conraid » gio gen 13, 2011 19:19

Xorg.0.log

avete guardato le informazioni sulle schede video? per ati e intel dovete abilitare il kms. Controllate il file CHANGES_AND_HITS, o l'how-to Current for dummies su slackers.it
Avatar utente
conraid
Staff
Staff
 
Messaggi: 12023
Iscritto il: mer lug 13, 2005 23:00
Località: Livorno
Nome Cognome: Corrado Franco
Slackware: current

Re: Kde4 non parte dopo aggiornamento a current 11/01

Messaggioda erio » gio gen 13, 2011 21:10

ho upgradato a current dell'11 gennaio togliendo la kde di alien ed è tutto a posto,almeno fino ad ora
erio
Linux 3.x
Linux 3.x
 
Messaggi: 1086
Iscritto il: ven ott 09, 2009 18:25
Slackware: 13.37
Kernel: 3.0.7
Desktop: kde

Re: Kde4 non parte dopo aggiornamento a current 11/01

Messaggioda Eberoth » gio gen 13, 2011 22:01

Allora, aggiornando alla rc2 e cancellando .kde, sembra funzionare tutto...

Resta il fatto che usare una beta sul pc con cui lavoro non è il massimo.
Avatar utente
Eberoth
Linux 2.4
Linux 2.4
 
Messaggi: 380
Iscritto il: lun ago 24, 2009 8:22
Slackware: -current
Kernel: 3.13.6
Desktop: KDE4
Distribuzione: Slackel64

Prossimo

Torna a Slackware64

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite