Repository 32bit  Forum
Repository 64bit  Wiki

non riesco a installare gparted

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

non riesco a installare gparted

Messaggioda james2221 » lun feb 07, 2011 7:54

ciao

slackware 64 13.1 xfce4

abbiate pazienza ma ho installato slackware sabato e non riesco a capire alcnue cose.
ho già arch e debian
vorrei installare gparted: ho scaricato da repository, il seguente file
gparted-0.5.2-x86_64-1sl.txz
ho installato con questo comando
bash-4.1# installpkg /home/piero/Downloads/gparted-0.5.2-x86_64-1sl.txz
mi dice
Package gparted-0.5.2-x86_64-1sl.txz installed.
ma poi quando lo voglio far partire mi dice

bash-4.1# gparted
/usr/sbin/gpartedbin: error while loading shared libraries: libgtkmm-2.4.so.1: cannot open shared object file: No such file or directory
bash-4.1# slapt-get --install /home/piero/Downloads/gparted-0.5.2-x86_64-1sl.txz
Reading Package Lists...Done

dove trovo la libreria libgktmm ???

provo con slapt-get ma mi dice che non trova il pacchetto
ho già installato alcuni paccchetti usando lo stesso sitema e sono andati a buon fine
dove ho sbagliato??

altra domanda: volevo gksu ma non trovo il pacchetto nei repositori, mi sembra starno perchè npenso sia un pacchetto utilissimo: sbaglio forse la ricerca ???
grazie
james
james2221
Linux 2.4
Linux 2.4
 
Messaggi: 200
Iscritto il: dom feb 06, 2011 0:28
Località: brescia
Slackware: 14 86_64
Desktop: xfce4.10

Re: non riesco a installare gparted

Messaggioda 414N » lun feb 07, 2011 8:52

Beh, gparted l'hai installato, quindi non è che non riesci ad installarlo, non riesci a farlo andare.
Il motivo è semplice: non hai installato le dipendenze. Quando scarichi un pacchetto da Slacky, nella pagina del download trovi un elenco delle dipendenze richieste per farlo funzionare correttamente. Se non le installi, il fatto che poi il programma che ti interessa non trova delle librerie condivise è normale.
Non so se esistono strumenti automatici per scaricarti anche le dipendenze (forse slackyd, ma non l'ho mai usato), però puoi risolvere consultando manualmente il repository.
Se la tua Slackware è a 32 bit, gtkmm lo trovi qui. Occhio che ha la sua bella lista di dipendenze anche lui...
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2881
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: non riesco a installare gparted

Messaggioda james2221 » lun feb 07, 2011 9:25

ciao
grazie per aver risposto
credo che il problema sia riuscire a capire come funge tutto il discorso per poi essere indipendente.
Forse nello scritto non mi sono espresso bene: ho visto che mancava una libreria ed il mio problema è proprio questo: dove la trovo a 64 bit ???
ho cercato un po' in giro ma, se mi permetti, non tutto è chiarissimo, spesso si segue una traccia ma poi scopri che è relativa ad una versione precedente e non è compatibile, o ci sono dei link molto promettenti ma non funzionanti o cose del genere. Per voi che avete pratica questi problemi non esistono nemmeno, per chi si avvicina a Slack per laprima volta è come trovarsi un muro di gomma. Ho avuto la stessa esperienza con Arch: 2-3 giorni di fuoco e fiamme per capire il giro del discorso poi me la sono cavata egregiamente da solo.
Ripetopertanto la domanda: avendo 64 bit, come risolvo la dipendenza della lib mancante?

grazie
al vostro buon cuore
james

scusa: riapro
ho trovato nei repository la libreria mancante, e vorrei sapere: funziona sempre così? ovvero scarico un programma, vengo informato che ci sono delle dipendenze insoddisfatte, le trovo e le installo, a loro volta queste hanno delle librerie da scaricare, ecc ecc ecc???
non che ci siano problemi a farlo, è solo per sapere se questo è il modo giusto
james2221
Linux 2.4
Linux 2.4
 
Messaggi: 200
Iscritto il: dom feb 06, 2011 0:28
Località: brescia
Slackware: 14 86_64
Desktop: xfce4.10

Re: non riesco a installare gparted

Messaggioda 414N » lun feb 07, 2011 9:44

Ti chiedo scusa, non avevo fatto caso al fatto che sei su una Slackware64.
In tutti i modi, quel pacchetto (gtkmm) è presente anche nel repository a 64 bit di Slacky. Trovi il form per la ricerca nella homepage di Slacky.
Anche le relative dipendenze sono già presenti a 64 bit. Quel che devi fare è scaricare tutti i pacchetti delle dipendenze richieste ed installarli.
Potresti essere un po' più specifico riguardo ai "muri di gomma" che incontri?
Se lo scoglio principale contro il quale ti sei imbattuto è l'installazione dei pacchetti e delle dipendenze su Slackware, permettimi di illustrarti brevemente come funziona: non esiste un gestore di pacchetti automatizzato ed ufficiale che risolva anche le dipendenze (tipo Pacman di Arch). In linea di massima, sei tenuto ad informarti su quello che sei in procinto di installare, tanto da sapere cosa è richiesto come prerequisito per il corretto funzionamento del programma/pacchetto in questione.
Esistono progetti di terze parti che hanno un minimo di gestione automatica delle dipendenze, ma comunque necessitano della supervisione dell'utente. I principali sono swaret (non più sviluppato, credo), slapt-get e slackyd (creato da un utente del forum e di recente "resuscitato"). Se cerchi nel forum, potrai trovare molte informazioni riguardo questi 3 strumenti.
Il problema principale delle dipendenze di pacchetti binari precompilati da terzi è che, a parita di programma che si vuole installare, le dipendenze possono essere diverse.
Metti, per esempio, di voler installare ffmpeg (che ha una miriade di dipendenze se vuoi il supporto a tutti i formati che può gestire), ma di non voler assolutamente installare libdc1394 nel tuo sistema perché allergico ad essa :D oppure perché è stato appena scoperta una vulnerabilità al suo interno e non vuoi correre rischi. Vai sul repository a 64 bit di Slacky, cerchi ffmpeg e lo trovi, però noti che richiede la tanto odiata libreria. Che fare? Installare il pacchetto di Slacky è inutile, perché difficilmente potrà funzionare senza libreria (in questo caso, non funziona proprio). La soluzione sta nel ricompilarselo con le proprie opzioni, e qui vengono in aiuto gli SlackBuild. Gli SlackBuild sono semplici script bash che automatizzano la compilazione di un programma e la creazione del suo pacchetto.
Oltre ai pacchetti, qui su Slacky trovi anche gli SlackBuild utilizzati per crearli. Sempre riferendosi a ffmpeg, lo SlackBuild del pacchetto presente qui su Slacky lo trovi nella subdirectory src. Nessuno ti vieta, una volta installate tutte le altre dipendenze di ffmpeg, di modificare lo SlackBuild in modo da escludere il supporto a libdc1394 e ricompilare il programma, creandoti un pacchetto personalizzato col supporto alle librerie che vuoi te (o nella versione presente sul tuo sistema, nel caso avessi effettuato down/upgrade significativi).
Se vuoi informazioni più esaustive in merito agli SlackBuild, qui trovi un howto (in inglese), mentre qui trovi un'analoga pagina della wiki di Slacky.
Il mio consiglio, se non trovi un pacchetto qui su Slacky (e quindi nemmeno il suo SlackBuild made in Slacky), è di andare su http://www.slackbuilds.org per cercarne uno SlackBuild e compilartelo da te.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2881
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: non riesco a installare gparted

Messaggioda james2221 » lun feb 07, 2011 10:15

ciao
ho capito, ma lo sapevo anche prima, che c'è da sporcarsi le mani, daltronde se non lo volevo fare sarei andato su ubuntu.
i muri di gomma si riferiscono a link mancanti, howto che saltano alcuni passaggi la cui spiegazione è ritenuta superflua ma che spesso superflua non è. imprecisioni dovute a versioni diverse, ecc niente di clamoroso, solo che il novizio ha bisogno anche delle spiegazione su dove trovare l'interruttore del pc (non prendermi alla lettera...)
e poi una cosa che ho notato, mi scuseranno gli amministratori e i guru: premettendo che i confronti sono sempre antipatici: su Arch ho trovato un wiki piu che esauriente, ho dovuto iscrivermi al forum e mandare avanti delle questioni che poi alla fine si sono rivelate alquanto scontate, ma insomma mi è sembrato tutto un po piu ordinato e fruibile. Spero che esprimendo il mio parere non veniate sotto casa con le mazze da base-ball, dico solo la mia impressione da esterno (prima di considerarmi interno al gruppo di Slack avrò bisogno di smanettare sugli SlackBuild e sui .tar.gz

grazie di tutto

credo che ci sentiremo ancora (nota il tono minaccioso...)
ultima domanda: come si traduce "the book is on the table?" vuol dire che il buco è sopra o sotto l tavolo???
...nessuna risposta???....
ho capito, userò il traduttore di google
Ultima modifica di james2221 il lun feb 07, 2011 10:31, modificato 2 volte in totale.
james2221
Linux 2.4
Linux 2.4
 
Messaggi: 200
Iscritto il: dom feb 06, 2011 0:28
Località: brescia
Slackware: 14 86_64
Desktop: xfce4.10

Re: non riesco a installare gparted

Messaggioda Crow » lun feb 07, 2011 10:22

ciao a tutti ho anche io questo problema con gparted, vorrei sapere dove posso prendere il tgz di pangocairo >= 1.23.0.
grazie
Crow
Linux 2.4
Linux 2.4
 
Messaggi: 258
Iscritto il: ven ago 17, 2007 14:37
Slackware: 14.0
Kernel: 3.2.29
Desktop: KDE
Distribuzione: BackTrack

Re: non riesco a installare gparted

Messaggioda 414N » lun feb 07, 2011 10:49

james2221 ha scritto:i muri di gomma si riferiscono a link mancanti, howto che saltano alcuni passaggi la cui spiegazione è ritenuta superflua ma che spesso superflua non è. imprecisioni dovute a versioni diverse, ecc niente di clamoroso, solo che il novizio ha bisogno anche delle spiegazione su dove trovare l'interruttore del pc (non prendermi alla lettera...)

Parli in generale o sempre riferito a gparted?
james2221 ha scritto:e poi una cosa che ho notato, mi scuseranno gli amministratori e i guru: premettendo che i confronti sono sempre antipatici: su Arch ho trovato un wiki piu che esauriente, ho dovuto iscrivermi al forum e mandare avanti delle questioni che poi alla fine si sono rivelate alquanto scontate, ma insomma mi è sembrato tutto un po piu ordinato e fruibile. Spero che esprimendo il mio parere non veniate sotto casa con le mazze da base-ball, dico solo la mia impressione da esterno (prima di considerarmi interno al gruppo di Slack avrò bisogno di smanettare sugli SlackBuild e sui .tar.gz

Nota che la wiki di Archlinux è una wiki ufficiale della distribuzione ed è tradotta in uno "sbrozzo" di lingue, mentre Slacky è una comunità italiana di utenti Slackware e bon. Non sono paragonabili, secondo me.
Al massimo, puoi paragonare la wiki di Archlinux allo Slackbook, alle info su http://www.slackware.com/info/ e al forum ufficiale di Slackware su LinuxQuestions.
Crow ha scritto:ciao a tutti ho anche io questo problema con gparted, vorrei sapere dove posso prendere il tgz di pangocairo >= 1.23.0.
grazie

Non mi sembra che il pacchetto di gparted su Slacky richieda pangocairo...
In tutti i modi, se un pacchetto trovato su Slacky non funziona neanche dopo aver installato tutte le dipendenze indicate, create un thread nella sezione Packages del forum (o aggiungete un post ad un thread al riguardo già esistente), in modo da segnalare a chi di dovere il problema e correggerlo insieme.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2881
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE


Torna a Slackware64

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite