Repository 32bit  Forum
Repository 64bit  Wiki

[Risolto] installazione gksu: non ce la faccio

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Re: installazione gksu: non ce la faccio

Messaggioda james2221 » mar feb 08, 2011 18:51

la mia era una minaccia per smuovere le vostre coscienze (comunque Xp e Seven sono in un angolino ad ammuffire).
NON HO mollato Arch, anzi, se potessi darmi un suggerimento: datosi che su entrambi ho xfce4 come potrei distinguerli? mi capita di doverci pensare per sapere se sono su uno o sull'altro. ho messo ovviamente degli sfondi desktop diversi ma cio non toglie che se non guardo il logo mi confondo.
KDE ed io non ci amiamo, ci siamo fatti degi sgarbi a vicenda, brutte storie dietro, di donne di dubbio affare e di debiti non onorati, preferirei non parlarne.
tornando a noi: non ho ancora messo giu gksu. volevo chiarire la storia delle dipendenze prima, ma se mi confermi che kdesu funge potrei provarci, mi fanno paura lelibrerie che si tira dietro, non è che mi devo installare mezzo kde solo per un file.
qualche alternativa leggera che va bene su xfce4 ???

grazzzzie
james2221
Linux 2.4
Linux 2.4
 
Messaggi: 200
Iscritto il: dom feb 06, 2011 0:28
Località: brescia
Slackware: 14 86_64
Desktop: xfce4.10

Re: installazione gksu: non ce la faccio

Messaggioda Rama » mar feb 08, 2011 19:25

james2221 ha scritto:la mia era una minaccia per smuovere le vostre coscienze (comunque Xp e Seven sono in un angolino ad ammuffire).
NON HO mollato Arch, anzi, se potessi darmi un suggerimento: datosi che su entrambi ho xfce4 come potrei distinguerli?

fai degli sfondi con la scritta SONO SU ARCHLINUX e SONO SU SLACKWARE ;-P
james2221 ha scritto: confermi che kdesu funge potrei provarci, mi fanno paura lelibrerie che si tira dietro, non è che mi devo installare mezzo kde solo per un file.
qualche alternativa leggera che va bene su xfce4 ???

da shell
su
programma
preceduto eventualmente da xhost + ;-P
seriamente, non vedo la necessità di lanciare programmi grafici come root se non una volta al mese e per pigrizia;
se hai necessità di lanciarli spesso dicci quali e penso si trovi una soluzione -forse esiste addirittura un xfecesu?

r
Avatar utente
Rama
Linux 2.4
Linux 2.4
 
Messaggi: 253
Iscritto il: sab mar 29, 2008 12:18
Località: Novara, provincia
Slackware: 14.1 64bit
Kernel: 3.16.3 preemptive
Desktop: KDE 4.10.5
Distribuzione: Debian testing

Re: installazione gksu: non ce la faccio

Messaggioda james2221 » mar feb 08, 2011 19:37

volevo spegnere con un piccolo script che però ha bisogno del comando gksu, certamente potrei spegnerwe da terminale, ma era uno sfizio
effettivamente hai ragione, gksu richiede un bel po di gnome, se ci fosse come dici qualcosa tipo xfce-su non sarebbe male

la considerazione di base è questa: l'utilizzo del mio pc è mooolto tranquillo: qualche fattura da trattare con libreoffice, cosi anche preventivi lettere ecc, poca stampante, scannerizzo le fatture passive, musica di sottofondo, radio, film da file o da dvd
per quel che lo uso andrebbe bene anche winqualchecosa 1975, per intenderci, sono io che vorrei smanettare un po, motivo per cui ho installato Arch, Slack e Debian
ottima idea quella dello sfondo, ci potrei aggiungereSONO SU ASLACKWARE E MI CHIAMO PINCO PALLINO cosi non ho piu dubbi

ciao
e grazie per aver scritto
james2221
Linux 2.4
Linux 2.4
 
Messaggi: 200
Iscritto il: dom feb 06, 2011 0:28
Località: brescia
Slackware: 14 86_64
Desktop: xfce4.10

Re: installazione gksu: non ce la faccio

Messaggioda Rama » mar feb 08, 2011 19:55

james2221 ha scritto:volevo spegnere con un piccolo script

cioè quando non sei presente? ad un certo orario?
penso si possa fare, ma non uso cron, ti diranno altri;
oppure intendi da user senza diventare root?
devi inserirti nel gruppo apposito, solo che non ricordo quale, forse wheel?
chiedo aiuto agli slackers;
james2221 ha scritto: n
ottima idea quella dello sfondo, ci potrei aggiungereSONO SU SLACKWARE E MI CHIAMO PINCO PALLINO cosi non ho piu dubbi

uhm, e se non sei tu lutente? potrebbe avere una crisi d'identità;

r
Avatar utente
Rama
Linux 2.4
Linux 2.4
 
Messaggi: 253
Iscritto il: sab mar 29, 2008 12:18
Località: Novara, provincia
Slackware: 14.1 64bit
Kernel: 3.16.3 preemptive
Desktop: KDE 4.10.5
Distribuzione: Debian testing

Re: installazione gksu: non ce la faccio

Messaggioda 414N » mar feb 08, 2011 20:31

james2221 ha scritto:volevo spegnere con un piccolo script che però ha bisogno del comando gksu, certamente potrei spegnerwe da terminale, ma era uno sfizio
effettivamente hai ragione, gksu richiede un bel po di gnome, se ci fosse come dici qualcosa tipo xfce-su non sarebbe male

Se non ho capito male, ti "serve" gksu per lanciare shutdown da una sessione grafica avviata tramite startx, giusto?
Ma non fai prima a cambiare il runlevel di default a 4, in modo da partire già in grafica all'avvio e, soprattutto, di disporre di un gestore della sessione desktop (sia esso kdm, gdm, xdm, slim ecc.) che ti permette di spegnere/riavviare/sospendere (sia in ram che su disco) da utente (a patto di essere nel gruppo power)?
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: installazione gksu: non ce la faccio

Messaggioda james2221 » mer feb 09, 2011 8:37

ciao people
il primo pensiero del mattino è stato per voi, nel senso che ho sognato tutta notte slapt-get e installpkg, complice peperonata, per cui ve ne ho inviate alcune di poco piacevoli, se il vostro gatto fa pipi sulla tastiera e la stessa puzzerà fino a ferragosto (a me è successo) sappiate che è causa mia.
faccio un po di esperimenti piu tardi adesso devo uscire

resto in attesa in merito al preventivo inviatoVi
ringraziando per l'opportunità
colgo l'occasione per porgere
distinti saluti
pinco palla &C. srl

ciao
grazie
james2221
Linux 2.4
Linux 2.4
 
Messaggi: 200
Iscritto il: dom feb 06, 2011 0:28
Località: brescia
Slackware: 14 86_64
Desktop: xfce4.10

Re: installazione gksu: non ce la faccio

Messaggioda miklos » gio feb 10, 2011 12:16

Ciao,

anche io sono allergico a Kde, e anche a me e' capitato di dover compilare gksu, ma al tempo stesso ho una forma di allergia anche verso Gnome.
Percio' cercando, trovai questo qui' che ricordo faceva bene il suo dovere: Ktsuss.
Come dipendenze ha solo gtk.
Se vuoi il pacchetto gia' fatto lo trovi qui su slacky.
Se invece vuoi compilartelo da solo, lo slackbuild lo trovi qui.

Se invece devi per forza usare gksu... in bocca al lupo :D
ho visto cose che voi astemi non potete immaginare
miklos
Linux 3.x
Linux 3.x
 
Messaggi: 1241
Iscritto il: lun lug 16, 2007 16:39
Località: Roma
Slackware: 14.1 64bit
Kernel: 3.16.3
Desktop: openbox 3.5.2

Re: installazione gksu: non ce la faccio

Messaggioda james2221 » sab feb 12, 2011 9:01

ciao
grazie a tutti per le risposte
probabilmente la fortuna del principiante che mi ha accompagnato fin ad ora mi ha abbandonato: sono riuscito a dare una configurazione minima a Slack, sufficiente per lavorare, con musica film tool d'ufficio ecc, ma da quando mi sono messo intesta di portarle Slack all'efficienza di Arch e di >Debian NON RIESCO a installare piu niente.
Per esempio Ktsuss:
1) la versione che mi hai linkato è a 32bit, la mia macchina è a 64bit (modestamente ce l'ho il doppio di tanti altri...), dal che sorge una domanda spontanea: se installo 32bit mi funge? o sono un somaro e avrei dovuto cercare la versione 64bit? oppure ancora c'è un modo di far andare 32 su 64?
2) ammesso che vada bene a 32bit: tu mi dici che hai solo gtk come dipendenze ma leggo qualcosa tipo 26-27 librerie e altro required. Ammesso anche che quasi tutte queste siano già installate devo controllarle una per una oppure in fase di install il terminale mi dice: guarda ciccio che ti manca 'sta robba qua? e per le lib mancanti le trovo sui repository 32 o 64? e se non c'è la lib su 64 che faccio? mi attacco oppure la 32 va bene?

se riuscissi a risolvere questi dubbi sulle dipendenze probabilmente riusciro a d avere una configurazione ottimale, non mi interessa che mi si dica: devi cercare e installare 36 librerie, non c'è problema, mi sono dato tempo fino a pasqua (2014..), il problema è che il web non è che aiuti tantissimo, come ho scritto in un post precedente spesso ci si imbatte in link non funzionanti (per esempio uno di quelli che hai postato sopra), spiegazioni obsolete relative a versione del 1952, procedure descritte approssimativamente ecc.

grazie
james
james2221
Linux 2.4
Linux 2.4
 
Messaggi: 200
Iscritto il: dom feb 06, 2011 0:28
Località: brescia
Slackware: 14 86_64
Desktop: xfce4.10

Re: installazione gksu: non ce la faccio

Messaggioda 414N » sab feb 12, 2011 11:01

james2221 ha scritto:1) la versione che mi hai linkato è a 32bit, la mia macchina è a 64bit (modestamente ce l'ho il doppio di tanti altri...), dal che sorge una domanda spontanea: se installo 32bit mi funge? o sono un somaro e avrei dovuto cercare la versione 64bit? oppure ancora c'è un modo di far andare 32 su 64?

Devi sapere che Slackware64 è una distribuzione quasi 64 bit pura, perché non include software/librerie a 32 bit. Il quasi è dovuto al fatto che, a livello di kernel, il supporto all'esecuzione di binari a 32 bit è comunque supportata. Questo significa che, se installi un pacchetto a 32 bit, probabilmente non funzionerà (a meno che non abbia tutto quel che richiede compilato staticamente) perché gli mancano tutte le librerie di supporto basilari (per esempio, le libc).
Leggi qui per sapere come ottenere almeno un supporto minimo all'esecuzione di programmi a 32 bit in Slackware64.
james2221 ha scritto:2) ammesso che vada bene a 32bit: tu mi dici che hai solo gtk come dipendenze ma leggo qualcosa tipo 26-27 librerie e altro required. Ammesso anche che quasi tutte queste siano già installate devo controllarle una per una oppure in fase di install il terminale mi dice: guarda ciccio che ti manca 'sta robba qua? e per le lib mancanti le trovo sui repository 32 o 64? e se non c'è la lib su 64 che faccio? mi attacco oppure la 32 va bene?

  • Discorso "vada bene il 32 bit": dipende da te. Se hai messo già in piedi tutta l'infrastruttura necessaria ad eseguire il programma che ti interessa a 32 bit e lo stesso non è disponibile a 64 bit (perché magari closed-source, vedi Skype) allora sì, va bene 32 bit.
  • Se i sorgenti sono disponibili, il mio consiglio è di crearti il pacchetto a 64 bit (se non lo trovi già fatto) ed usare il più possibile software a 64 bit. In questo modo sfrutti appieno le potenzialità della macchina e, soprattutto, non devi starti a preoccupare di installare dipendenze a 32 bit (che magari sono già presenti nel tuo sistema ma sono a 64 bit) per far andare un programma.
  • Se le 26-27 librerie che citi sono quelle elencate nello slack-required, sappi che sono librerie/programmi già inclusi in Slackware. Questo non implica che siano installate nel tuo sistema, perché dipende dal tipo di installazione che hai fatto. Puoi controllare di avere installato i relativi pacchetti tramite pkgtool o un semplice
    Codice: Seleziona tutto
    ls /var/log/packages
  • Il file slack-required è una "cortesia" che il pacchettizzatore fa nei tuoi confronti, nulla di più. Gli strumenti offerti da Slackware nuda e cruda non lo controllano, mentre alcuni tool di terze parti (tipo slapt-get o slackyd) permettono il controllo e la risoluzione delle dipendenze automatica proprio tramite quel file. A te la scelta tra controllare manualmente oppure in modo automatico tramite strumenti non ufficiali. Sappi comunque che, non essendoci un repository centralizzato di tutti i pacchetti Slackware sparsi per il globo, anche quei tool possono fallire la risoluzione delle dipendenze. Dipende tutto dal repository che scegli di usare.
  • Premettendo che codice a 32 bit può richiamare solo altro codice a 32 bit (stesso discorso per i 64 bit), non puoi installare librerie di supporto a 32 bit per un programma a 64 bit; o meglio, lo puoi fare, ma non risolvi il problema (il programma a 64 bit continuerà a lamentarsi dell'assenza della libreria che hai installato in versione a 32 bit). Come già detto poc'anzi, se non trovi il pacchetto già pronto, cercane lo SlackBuild in giro e compilatelo da te. La capacità richiesta è quella di scaricare un tar.gz, l'archivio dei sorgenti e lanciare uno script.
james2221 ha scritto:il problema è che il web non è che aiuti tantissimo, come ho scritto in un post precedente spesso ci si imbatte in link non funzionanti (per esempio uno di quelli che hai postato sopra)

A quel link manca solo uno / finale. Probabilmente miklos ha sbagliato ad incollarlo. Se provi a cercare ktsuss tramite la form di ricerca su http://www.slackbuilds.org vedrai che esiste.
Il fatto che il web non ti aiuti tantissimo è, probabilmente, dovuto al fatto che non sei ancora abbastanza "smaliziato" su Slackware da sapere con precisione cosa cercare e dove. L'importante è non darsi per sconfitti alle prime difficoltà e leggere tutto lo scibile, sia nella documentazione che sul forum.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: installazione gksu: non ce la faccio

Messaggioda james2221 » sab feb 12, 2011 11:34

@414N
come sempre cortese ed esaustivo.
A quel link manca solo uno / finale. Probabilmente miklos ha sbagliato ad incollarlo. Se provi a cercare ktsuss tramite la form di ricerca su http://www.slackbuilds.org vedrai che esiste.
Il fatto che il web non ti aiuti tantissimo è, probabilmente, dovuto al fatto che non sei ancora abbastanza "smaliziato" su Slackware da sapere con precisione cosa cercare e dove. L'importante è non darsi per sconfitti alle prime difficoltà e leggere tutto lo scibile, sia nella documentazione che sul forum.

è questione appunto di essere "scafati" nel cercare le cose, è che tante volte ti perdi, apri 6-7 schede web, non vanno bene, ne chiudi alcune e poi scopri che erano quelle giuste, ti inca22i come una iena con te stesso per la stupidità, spegni tutto e te ne torni su una piu tranquilla Arch o Debian.
Ho installato Slack esattamente una settimana fa a quest'ora e non ho avuto un tempo molto lungo per spippiolarci sopra, per cui, considerando anche che sono un semplicissimo appassionato, avere Slackware funzionante pur con alcune cose da sistemare (stamp e scanner, gparted, gksu, xfce4.8 da installare al posto di xfce4.6, far partire X con la giusta risoluzione, e poco altro credo) per me è un traguardo.
Se qualcuno poi pensa che mi tolga dalle scatole causa scoraggiamento fa un grosso errore: qui sono e qui resto.
Fa comunque piacere sentirsi sostenuti, me ne sono andato da un'altra distro perchè, forse perchè era una di quelle facilissime, ho trovato gente nel forum supponente e maleducata: per la serie: ti sembra una domanda da newbee? finche è postata nella sezione newbee ed è in linea con le altre richieste non incavolarti per la pochezza del quesito, non rispondere e basta.

Per la questione tecnica del 3d devo rinviare almeno a mercoledi-giovedi, mi ci vuole una serata libera dalle 8 fino a mezzanotte, un paio di sigari, la mente libera, una dose massiccia grappa distillata in casa, un disinfettante per le nocche che mi morsicerò certamente , insomma una serie di robe per cui come già detto andrò al 2013-2014 circa, ora piu, ora meno.
Slackware for dummies? voi non conoscete il livello di dummietà della gente, io per primo

ciao e grazie
james
james2221
Linux 2.4
Linux 2.4
 
Messaggi: 200
Iscritto il: dom feb 06, 2011 0:28
Località: brescia
Slackware: 14 86_64
Desktop: xfce4.10

Re: installazione gksu: non ce la faccio

Messaggioda james2221 » ven mar 11, 2011 21:42

dopo un mese finalmente ho affrontato il problema di gksu ed ho deciso di seguire il consiglio di miklos che ringrazio: ho installato ktsuss perchè rispetto a gksu si tira dietro molte meno dipendenze, però devo dire una cosa, piccccolisssima critica da neofita: per avere una situazione delle dipendenze mi sono appoggiato a zenwalk.
Problema di coscienza: sarò ancora "eticamente" puro e casto come un giglio???
grazie
james
james2221
Linux 2.4
Linux 2.4
 
Messaggi: 200
Iscritto il: dom feb 06, 2011 0:28
Località: brescia
Slackware: 14 86_64
Desktop: xfce4.10

Precedente

Torna a Slackware64

Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti