Pagina 2 di 2

Re: [RISOLTO] Configurazione Wireless

Inviato: ven gen 06, 2012 19:15
da daniele50
Al momento non mi interessa preservare nulla, voglio solo riuscire a collegarmi al router per poi navigare.

Come faccio a lanciare dhcpcd wlan0 se il comando #wpa_supplicant -i wlan0 -c /etc/wpa_supplicant.conf non termina?
Mi spiego meglio:
quando lancio #wpa_supplicant -i wlan0 -c /etc/wpa_supplicant.conf il comando non termina, non mi appare il cursore e non ho quindi la possibilità di dare altri comandi.
In alternativa posso aprire due terminali (anche se non penso sia la strada giusto). Per non lasciare in dietro nulla ho provato comunque a farlo:

Primo terninale:

Codice: Seleziona tutto

#wpa_supplicant -i wlan0 -c /etc/wpa_supplicant.conf
Trying to associate with 00:1d:6a:71:5a:d9 (SSID='Alice-75200985' freq=2462 MHz)
Associated with 00:1d:6a:71:5a:d9
WPA: Key negotiation completed with 00:1d:6a:71:5a:d9 [PTK=TKIP GTK=TKIP]
CTRL-EVENT-CONNECTED - Connection to 00:1d:6a:71:5a:d9 completed (auth) [id=0 id_str=] <-- qui ho lanciato dhcpcd dal secondo terminale (vedi sotto) --|
Michael MIC failure detected
WPA: Sending EAPOL-Key Request (error=1 pairwise=1 ptk_set=1 len=99)
CTRL-EVENT-DISCONNECTED bssid=00:1d:6a:71:5a:d9 reason=0
Trying to associate with 00:1d:6a:71:5a:d9 (SSID='Alice-75200985' freq=2462 MHz)
Authentication with 00:1d:6a:71:5a:d9 timed out. <-- rimane fermo senza darmi il cursore, il comando è in esecuzione e non termina --|

Secondo terminale:

Codice: Seleziona tutto

#dhcpcd wlan0
dhcpcd[2544]: version 5.2.12 starting
dhcpcd[2544]: wlan0: broadcasting for a lease
dhcpcd[2544]: wlan0: carrier lost
dhcpcd[2544]: timed out
dhcpcd[2544]: allowing 8 seconds for IPv4LL timeout
dhcpcd[2544]: timed out


Spero di aver illustrato chiaramente la situazione.
Attendo fiducioso (ma prossimo alla disperazione) qualche consiglio...

-- EDIT --
intato ho verificato che se, nelle impostazioni del router, disabilito la criptazione del wifi, dando un /etc/rc.d/rc.inet1 restart funziona tutto:

Codice: Seleziona tutto

root@slacky64 /home/daniele50 #/etc/rc.d/rc.inet1 stop                                                                           
root@slacky64 /home/daniele50 #/etc/rc.d/rc.inet1 start                                                                         
/etc/rc.d/rc.inet1:  wlan0 information: 'Any ESSID'                                                                             
Error for wireless request "Set Nickname" (8B1C) :                                                                               
    SET failed on device wlan0 ; Operation not supported.                                                                       
Polling for DHCP server on interface wlan0:                                                                                     
dhcpcd[3084]: version 5.2.12 starting                                                                                           
dhcpcd[3084]: wlan0: broadcasting for a lease                                                                                   
dhcpcd[3084]: wlan0: offered 192.168.1.5 from 192.168.1.1                                                                       
dhcpcd[3084]: wlan0: acknowledged 192.168.1.5 from 192.168.1.1                                                                   
dhcpcd[3084]: wlan0: checking for 192.168.1.5                                                                                   
dhcpcd[3084]: wlan0: leased 192.168.1.5 for 21600 seconds                                                                       
dhcpcd[3084]: forked to background, child pid 3113                                                                               
root@slacky64 /home/daniele50 #

nonostante l'errore Error for wireless request "Set Nickname" (8B1C) : SET failed on device wlan0 ; Operation not supported. che non ho idea di cosa sia...

E' ovvio che voglio proteggere la rete wifi e quindi devo riuscira a collegarmi anche con la chiave di cifratura...

Re: [RISOLTO] Configurazione Wireless

Inviato: ven gen 06, 2012 19:41
da miklos
hai provato a cercare l'errore su google??!?!!
http://www.google.it/search?q=Michael+MIC+failure+detected&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:official&client=firefox-a
da un rapido sguardo pare un bug con alcune schede wireless con il sistema wpa-tkip. dovresti riuscire a risolvere cambiando la cifratura in wpa-aes(per esempio) dal router.

Re: [RISOLTO] Configurazione Wireless

Inviato: ven gen 06, 2012 20:31
da daniele50
miklos ha scritto:hai provato a cercare l'errore su google??!?!!
http://www.google.it/search?q=Michael+MIC+failure+detected&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:official&client=firefox-a
da un rapido sguardo pare un bug con alcune schede wireless con il sistema wpa-tkip. dovresti riuscire a risolvere cambiando la cifratura in wpa-aes(per esempio) dal router.


Ho cambiato da wpa-tkip a wpa-aes e funziona!
Mi viene da piangere pensando che ho perso 3 giorni per questo bug... ma è bene tutto ciò che finisce bene...

GRAZIE :thumbright:

Re: [RISOLTO] Configurazione Wireless

Inviato: sab gen 07, 2012 2:15
da targzeta
In effetti quell'errore prima non c'era e sembrava funzionare tutto bene. Dai, comunque non è stata una perdita di tempo provare ad usare wpa_supplicant.

Sono contento che hai risolto,
Emanuele