Repository 32bit  Forum
Repository 64bit  Wiki

[RISOLTO] Xorg e risoluzione 16:9

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

[RISOLTO] Xorg e risoluzione 16:9

Messaggioda Nilus » ven mar 04, 2011 22:58

Salve a tutti slackers !

Da un po di tempo mi sto accorgendo che sul mio monitor i cerchi non sono cerchi ed i quadrati non sono quadrati ( !!! ).
Vado a guardare la risoluzione sul pannello di controllo Nvidia e noto solo risoluzioni a 4:3, mentro io ho un monitor 24'', 16:9. Cerco di modificare invano lo xorg.conf; le risoluzioni standard per i 16:9 proprio non le accetta.

Questo è lo xorg.conf :

Codice: Seleziona tutto
Section "ServerLayout"
   Identifier     "X.org Configured"
   Screen      0  "Screen0" 0 0
   InputDevice    "Mouse0" "CorePointer"
   InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
   ModulePath   "/usr/lib64/xorg/modules"
   FontPath     "/usr/share/fonts/local"
   FontPath     "/usr/share/fonts/TTF"
   FontPath     "/usr/share/fonts/OTF"
   FontPath     "/usr/share/fonts/Type1"
   FontPath     "/usr/share/fonts/misc"
   FontPath     "/usr/share/fonts/CID"
   FontPath     "/usr/share/fonts/75dpi/:unscaled"
   FontPath     "/usr/share/fonts/100dpi/:unscaled"
   FontPath     "/usr/share/fonts/75dpi"
   FontPath     "/usr/share/fonts/100dpi"
   FontPath     "/usr/share/fonts/cyrillic"
EndSection

Section "Module"
   Load  "dbe"
   Load  "glx"
   Load  "extmod"
   Load  "dri"
   Load  "dri2"
EndSection

Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "kbd"
EndSection

Section "InputDevice"
   Identifier  "Mouse0"
   Driver      "mouse"
   Option       "Protocol" "auto"
   Option       "Device" "/dev/input/mice"
   Option       "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
   Identifier   "Monitor0"
   VendorName   "Monitor Vendor"
   ModelName    "Monitor Model"
        HorizSync    33-83
   VertRefresh  55-75
   # 1920x1080 @ 75.00 Hz (GTF) hsync: 84.60 kHz; pclk: 220.64 MHz
   Modeline "1920x1080_75.00"  220.64  1920 2056 2264 2608  1080 1081 1084 1128 -HSync +Vsync   
EndSection

Section "Device"
   Identifier  "Card0"
   Driver      "nvidia"
   VendorName  "Unknown Vendor"
   BoardName   "Unknown Board"
   BusID       "PCI:2:0:0"
   #Option "UseEDID" "False"
EndSection

Section "Screen"
   Identifier "Screen0"
   Device     "Card0"
   Monitor    "Monitor0"
   DefaultDepth 24
   SubSection "Display"
      Viewport   0 0
      Depth     24
                Modes     "1920x1080_75.00"
   EndSubSection
EndSection


Come potete vedere ho creato una ModeLine con il comando "gtf 1920 1080 70" ma non funziona( anche senza ModeLine, idem ); ho provato anche a disabilitare l' EDID (siccome non veniva riconosciuto dalla scheda video) ma con scarsi risultati.

Questo invece è lo Xorg.0.log :

Codice: Seleziona tutto
X.Org X Server 1.7.7
Release Date: 2010-05-04
X Protocol Version 11, Revision 0
Build Operating System: Slackware 13.1 Slackware Linux Project
Current Operating System: Linux hostname 2.6.33.4 #3 SMP Wed May 12 23:13:09 CDT 2010 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz root=/dev/sda3 ro vt.default_utf8=0 vga = 773
Build Date: 05 May 2010  01:59:51AM
 
Current version of pixman: 0.16.6
   Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri Mar  4 22:11:25 2011
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "X.org Configured"
(**) |-->Screen "Screen0" (0)
(**) |   |-->Monitor "Monitor0"
(**) |   |-->Device "Card0"
(**) |-->Input Device "Mouse0"
(**) |-->Input Device "Keyboard0"
(==) Automatically adding devices
(==) Automatically enabling devices
(WW) The directory "/usr/share/fonts/local" does not exist.
   Entry deleted from font path.
(WW) The directory "/usr/share/fonts/CID" does not exist.
   Entry deleted from font path.
(WW) The directory "/usr/share/fonts/local" does not exist.
   Entry deleted from font path.
(WW) The directory "/usr/share/fonts/CID" does not exist.
   Entry deleted from font path.
(**) FontPath set to:
   /usr/share/fonts/TTF,
   /usr/share/fonts/OTF,
   /usr/share/fonts/Type1,
   /usr/share/fonts/misc,
   /usr/share/fonts/75dpi/:unscaled,
   /usr/share/fonts/100dpi/:unscaled,
   /usr/share/fonts/75dpi,
   /usr/share/fonts/100dpi,
   /usr/share/fonts/cyrillic,
   /usr/share/fonts/TTF,
   /usr/share/fonts/OTF,
   /usr/share/fonts/Type1,
   /usr/share/fonts/misc,
   /usr/share/fonts/75dpi/:unscaled,
   /usr/share/fonts/100dpi/:unscaled,
   /usr/share/fonts/75dpi,
   /usr/share/fonts/100dpi,
   /usr/share/fonts/cyrillic
(**) ModulePath set to "/usr/lib64/xorg/modules"
(WW) AllowEmptyInput is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
(WW) Disabling Mouse0
(WW) Disabling Keyboard0
(II) Loader magic: 0x7c0040
(II) Module ABI versions:
   X.Org ANSI C Emulation: 0.4
   X.Org Video Driver: 6.0
   X.Org XInput driver : 7.0
   X.Org Server Extension : 2.0
(--) using VT number 8

(--) PCI:*(0:2:0:0) 10de:0422:1acc:0851 rev 161, Mem @ 0xdf000000/16777216, 0xc0000000/268435456, 0xdc000000/33554432, I/O @ 0x0000ec00/128, BIOS @ 0x????????/131072
(II) Open ACPI successful (/var/run/acpid.socket)
(II) "extmod" will be loaded. This was enabled by default and also specified in the config file.
(II) "dbe" will be loaded. This was enabled by default and also specified in the config file.
(II) "glx" will be loaded. This was enabled by default and also specified in the config file.
(II) "dri" will be loaded. This was enabled by default and also specified in the config file.
(II) "dri2" will be loaded. This was enabled by default and also specified in the config file.
(II) LoadModule: "dbe"
(II) Loading /usr/lib64/xorg/modules/extensions/libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
   compiled for 1.7.7, module version = 1.0.0
   Module class: X.Org Server Extension
   ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "glx"
(II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
   compiled for 4.0.2, module version = 1.0.0
   Module class: X.Org Server Extension
(II) NVIDIA GLX Module  260.19.36  Tue Jan 18 17:12:12 PST 2011
(II) Loading extension GLX
(II) LoadModule: "extmod"
(II) Loading /usr/lib64/xorg/modules/extensions/libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
   compiled for 1.7.7, module version = 1.0.0
   Module class: X.Org Server Extension
   ABI class: X.Org Server Extension, version 2.0
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "dri"
(II) Loading /usr/lib64/xorg/modules/extensions/libdri.so
(II) Module dri: vendor="X.Org Foundation"
   compiled for 1.7.7, module version = 1.0.0
   ABI class: X.Org Server Extension, version 2.0
(II) Loading extension XFree86-DRI
(II) LoadModule: "dri2"
(II) Loading /usr/lib64/xorg/modules/extensions/libdri2.so
(II) Module dri2: vendor="X.Org Foundation"
   compiled for 1.7.7, module version = 1.1.0
   ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DRI2
(II) LoadModule: "nvidia"
(II) Loading /usr/lib64/xorg/modules/drivers/nvidia_drv.so
(II) Module nvidia: vendor="NVIDIA Corporation"
   compiled for 4.0.2, module version = 1.0.0
   Module class: X.Org Video Driver
(II) NVIDIA dlloader X Driver  260.19.36  Tue Jan 18 16:57:32 PST 2011
(II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
(II) Primary Device is: PCI 02@00:00:0
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/lib64/xorg/modules/libfb.so
(II) Module fb: vendor="X.Org Foundation"
   compiled for 1.7.7, module version = 1.0.0
   ABI class: X.Org ANSI C Emulation, version 0.4
(II) Loading sub module "wfb"
(II) LoadModule: "wfb"
(II) Loading /usr/lib64/xorg/modules/libwfb.so
(II) Module wfb: vendor="X.Org Foundation"
   compiled for 1.7.7, module version = 1.0.0
   ABI class: X.Org ANSI C Emulation, version 0.4
(II) Loading sub module "ramdac"
(II) LoadModule: "ramdac"
(II) Module "ramdac" already built-in
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) Mar 04 22:11:25 NVIDIA(0): Enabling RENDER acceleration
(II) Mar 04 22:11:25 NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) Mar 04 22:11:25 NVIDIA(0):     enabled.
(WW) Mar 04 22:11:25 NVIDIA(GPU-0): Unable to read EDID for display device CRT-0
(II) Mar 04 22:11:25 NVIDIA(0): NVIDIA GPU GeForce 8400 GS (G86) at PCI:2:0:0 (GPU-0)
(--) Mar 04 22:11:25 NVIDIA(0): Memory: 524288 kBytes
(--) Mar 04 22:11:25 NVIDIA(0): VideoBIOS: 60.86.4a.00.13
(II) Mar 04 22:11:25 NVIDIA(0): Detected PCI Express Link width: 16X
(--) Mar 04 22:11:25 NVIDIA(0): Interlaced video modes are supported on this GPU
(--) Mar 04 22:11:25 NVIDIA(0): Connected display device(s) on GeForce 8400 GS at PCI:2:0:0
(--) Mar 04 22:11:25 NVIDIA(0):     CRT-0
(--) Mar 04 22:11:25 NVIDIA(0): CRT-0: 400.0 MHz maximum pixel clock
(II) Mar 04 22:11:25 NVIDIA(0): Assigned Display Device: CRT-0
(WW) Mar 04 22:11:25 NVIDIA(0): No valid modes for "1920x1080_75.00"; removing.
(WW) Mar 04 22:11:25 NVIDIA(0):
(WW) Mar 04 22:11:25 NVIDIA(0): Unable to validate any modes; falling back to the default mode
(WW) Mar 04 22:11:25 NVIDIA(0):     "nvidia-auto-select".
(WW) Mar 04 22:11:25 NVIDIA(0):
(II) Mar 04 22:11:25 NVIDIA(0): Validated modes:
(II) Mar 04 22:11:25 NVIDIA(0):     "nvidia-auto-select"
(II) Mar 04 22:11:25 NVIDIA(0): Virtual screen size determined to be 1024 x 768
(WW) Mar 04 22:11:25 NVIDIA(0): Unable to get display device CRT-0's EDID; cannot compute DPI
(WW) Mar 04 22:11:25 NVIDIA(0):     from CRT-0's EDID.
(==) Mar 04 22:11:25 NVIDIA(0): DPI set to (75, 75); computed from built-in default
(==) Mar 04 22:11:25 NVIDIA(0): Enabling 32-bit ARGB GLX visuals.
(--) Depth 24 pixmap format is 32 bpp
(II) Mar 04 22:11:25 NVIDIA: Using 768.00 MB of virtual memory for indirect memory access.
(II) Mar 04 22:11:25 NVIDIA(0): Initialized GPU GART.
(II) Mar 04 22:11:25 NVIDIA(0): Setting mode "nvidia-auto-select"
(II) Loading extension NV-GLX
(II) Mar 04 22:11:25 NVIDIA(0): Initialized OpenGL Acceleration
(==) NVIDIA(0): Disabling shared memory pixmaps
(II) Mar 04 22:11:25 NVIDIA(0): Initialized X Rendering Acceleration
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(==) NVIDIA(0): DPMS enabled
(II) Loading extension NV-CONTROL
(II) Loading extension XINERAMA
(==) RandR enabled
(II) Initializing built-in extension Generic Event Extension
(II) Initializing built-in extension SHAPE
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension BIG-REQUESTS
(II) Initializing built-in extension SYNC
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension XC-MISC
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
(II) Initializing extension GLX
(II) config/hal: Adding input device Macintosh mouse button emulation
(II) LoadModule: "evdev"
(II) Loading /usr/lib64/xorg/modules/input/evdev_drv.so
(II) Module evdev: vendor="X.Org Foundation"
   compiled for 1.7.6, module version = 2.3.3
   Module class: X.Org XInput Driver
   ABI class: X.Org XInput driver, version 7.0
(**) Macintosh mouse button emulation: always reports core events
(**) Macintosh mouse button emulation: Device: "/dev/input/event0"
(II) Macintosh mouse button emulation: Found 3 mouse buttons
(II) Macintosh mouse button emulation: Found relative axes
(II) Macintosh mouse button emulation: Found x and y relative axes
(II) Macintosh mouse button emulation: Configuring as mouse
(**) Macintosh mouse button emulation: YAxisMapping: buttons 4 and 5
(**) Macintosh mouse button emulation: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
(II) XINPUT: Adding extended input device "Macintosh mouse button emulation" (type: MOUSE)
(**) Macintosh mouse button emulation: (accel) keeping acceleration scheme 1
(**) Macintosh mouse button emulation: (accel) acceleration profile 0
(II) Macintosh mouse button emulation: initialized for relative axes.
(II) config/hal: Adding input device AT Translated Set 2 keyboard
(**) AT Translated Set 2 keyboard: always reports core events
(**) AT Translated Set 2 keyboard: Device: "/dev/input/event1"
(II) AT Translated Set 2 keyboard: Found keys
(II) AT Translated Set 2 keyboard: Configuring as keyboard
(II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "us"
(**) Option "xkb_options" "terminate:ctrl_alt_bksp"
(II) config/hal: Adding input device Logitech USB-PS/2 Optical Mouse
(**) Logitech USB-PS/2 Optical Mouse: always reports core events
(**) Logitech USB-PS/2 Optical Mouse: Device: "/dev/input/event4"
(II) Logitech USB-PS/2 Optical Mouse: Found 12 mouse buttons
(II) Logitech USB-PS/2 Optical Mouse: Found scroll wheel(s)
(II) Logitech USB-PS/2 Optical Mouse: Found relative axes
(II) Logitech USB-PS/2 Optical Mouse: Found x and y relative axes
(II) Logitech USB-PS/2 Optical Mouse: Configuring as mouse
(**) Logitech USB-PS/2 Optical Mouse: YAxisMapping: buttons 4 and 5
(**) Logitech USB-PS/2 Optical Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
(II) XINPUT: Adding extended input device "Logitech USB-PS/2 Optical Mouse" (type: MOUSE)
(**) Logitech USB-PS/2 Optical Mouse: (accel) keeping acceleration scheme 1
(**) Logitech USB-PS/2 Optical Mouse: (accel) acceleration profile 0
(II) Logitech USB-PS/2 Optical Mouse: initialized for relative axes.
(II) config/hal: Adding input device Power Button
(**) Power Button: always reports core events
(**) Power Button: Device: "/dev/input/event2"
(II) Power Button: Found keys
(II) Power Button: Configuring as keyboard
(II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "us"
(**) Option "xkb_options" "termiate:ctrl_alt_bksp"
(II) config/hal: Adding input device Power Button
(**) Power Button: always reports core events
(**) Power Button: Device: "/dev/input/event3"
(II) Power Button: Found keys
(II) Power Button: Configuring as keyboard
(II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "us"
(**) Option "xkb_options" "terminate:ctrl_alt_bksp"
(II) Mar 04 22:18:49 NVIDIA(0): Setting mode "CRT-0:1280x960@1280x960+0+0"


Uso i driver proprietari Nvida v.260.19.36.

Come secondo sistema operativo uso Debian Squeeze, anche lì l' EDID non viene riconosciuto ma i driver Nvidia v.195.36.31 mi mettono a disposizione anche le risoluzioni tipiche per gli schermi 16:9 ( a sto punto credo che l' EDID si possa quindi ignorare e magari ricostruire a mano le informazioni in esso contenute ).

Vi ringrazio anticipatamente con la speranza che qualcuno possa aiutarmi a far vedere quadrati i quadrati e rotondi i cerchi :D
Ultima modifica di Nilus il dom mar 06, 2011 11:50, modificato 1 volta in totale.
Nilus
Linux 1.0
Linux 1.0
 
Messaggi: 11
Iscritto il: lun feb 21, 2011 14:52
Slackware: 13.1
Desktop: KDE

Re: Xorg e risoluzione 16:9

Messaggioda erio » sab mar 05, 2011 13:45

ciao,se hai installato i driver nvidia e il monitor è riconosciuto non dovresti avere nessun problema,a impostare la risoluzione nativa del monitor ed è questo dato che mi lascia perplesso,hai agganciato il refresh alla risoluzione? "1920x1080_75.00",nvidia x server setting scegli la risoluzione nativa , applica e salva x-configuration file
erio
Linux 3.x
Linux 3.x
 
Messaggi: 1088
Iscritto il: ven ott 09, 2009 18:25
Slackware: 13.37
Kernel: 3.0.7
Desktop: kde

Re: Xorg e risoluzione 16:9

Messaggioda Nilus » sab mar 05, 2011 15:17

Aggiungendo il refresh non cambia nulla.
Comunque mostro anche lo xorg.conf con relativo log del sistema Debian, magari può essere d' aiuto.

xorg.conf :

Codice: Seleziona tutto
Section "ServerLayout"
   Identifier     "X.org Configured"
   Screen      0  "Screen0" 0 0
   InputDevice    "Mouse0" "CorePointer"
   InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
   ModulePath   "/usr/lib/xorg/modules"
   FontPath     "/usr/share/fonts/X11/misc"
   FontPath     "/usr/share/fonts/X11/cyrillic"
   FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
   FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
   FontPath     "/usr/share/fonts/X11/Type1"
   FontPath     "/usr/share/fonts/X11/100dpi"
   FontPath     "/usr/share/fonts/X11/75dpi"
   FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
   FontPath     "built-ins"
EndSection

Section "Module"
   Load  "extmod"
   Load  "record"
   Load  "glx"
   Load  "dri"
   Load  "dri2"
   Load  "dbe"
EndSection

Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "kbd"
EndSection

Section "InputDevice"
   Identifier  "Mouse0"
   Driver      "mouse"
   Option       "Protocol" "auto"
   Option       "Device" "/dev/input/mice"
   Option       "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
   Identifier   "Monitor0"
   VendorName   "Monitor Vendor"
   ModelName    "Monitor Model"
        HorizSync       30-83
        VertRefresh     55-75
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "SWcursor"              # [<bool>]
        #Option     "HWcursor"              # [<bool>]
        #Option     "NoAccel"               # [<bool>]
        #Option     "ShadowFB"              # [<bool>]
        #Option     "VideoKey"              # <i>
   Identifier  "Card0"
   Driver      "nvidia"
   VendorName  "nVidia Corporation"
   BoardName   "G86 [GeForce 8400 GS]"
   BusID       "PCI:2:0:0"
EndSection

Section "Screen"
   Identifier "Screen0"
   Device     "Card0"
   Monitor    "Monitor0"
   DefaultDepth 24
   SubSection "Display"
      Viewport   0 0
      Depth     24
      Modes "1920x1080"
   EndSubSection
EndSection



Xorg.0.log :

Codice: Seleziona tutto
X.Org X Server 1.7.7
Release Date: 2010-05-04
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.37-trunk-amd64 x86_64 Debian
Current Operating System: Linux Danilo-deb 2.6.32-5-amd64 #1 SMP Wed Jan 12 03:40:32 UTC 2011 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-2.6.32-5-amd64 root=UUID=b3bbaec6-9116-4afc-83b7-5b9d8603e80e ro quiet
Build Date: 18 February 2011  08:27:24PM
xorg-server 2:1.7.7-13 (Cyril Brulebois <kibi@debian.org>)
Current version of pixman: 0.16.4
   Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sat Mar  5 15:38:36 2011
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(==) ServerLayout "X.org Configured"
(**) |-->Screen "Screen0" (0)
(**) |   |-->Monitor "Monitor0"
(**) |   |-->Device "Card0"
(**) |-->Input Device "Mouse0"
(**) |-->Input Device "Keyboard0"
(==) Automatically adding devices
(==) Automatically enabling devices
(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
   Entry deleted from font path.
(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
   Entry deleted from font path.
(**) FontPath set to:
   /usr/share/fonts/X11/misc,
   /usr/share/fonts/X11/100dpi/:unscaled,
   /usr/share/fonts/X11/75dpi/:unscaled,
   /usr/share/fonts/X11/Type1,
   /usr/share/fonts/X11/100dpi,
   /usr/share/fonts/X11/75dpi,
   /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,
   built-ins,
   /usr/share/fonts/X11/misc,
   /usr/share/fonts/X11/100dpi/:unscaled,
   /usr/share/fonts/X11/75dpi/:unscaled,
   /usr/share/fonts/X11/Type1,
   /usr/share/fonts/X11/100dpi,
   /usr/share/fonts/X11/75dpi,
   /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,
   built-ins
(**) ModulePath set to "/usr/lib/xorg/modules"
(WW) AllowEmptyInput is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
(WW) Disabling Mouse0
(WW) Disabling Keyboard0
(II) Loader magic: 0x7c8aa0
(II) Module ABI versions:
   X.Org ANSI C Emulation: 0.4
   X.Org Video Driver: 6.0
   X.Org XInput driver : 7.0
   X.Org Server Extension : 2.0
(++) using VT number 7

(--) PCI:*(0:2:0:0) 10de:0422:1acc:0851 nVidia Corporation G86 [GeForce 8400 GS] rev 161, Mem @ 0xdf000000/16777216, 0xc0000000/268435456, 0xdc000000/33554432, I/O @ 0x0000ec00/128, BIOS @ 0x????????/131072
(II) Open ACPI successful (/var/run/acpid.socket)
(II) "extmod" will be loaded. This was enabled by default and also specified in the config file.
(II) "dbe" will be loaded. This was enabled by default and also specified in the config file.
(II) "glx" will be loaded. This was enabled by default and also specified in the config file.
(II) "record" will be loaded. This was enabled by default and also specified in the config file.
(II) "dri" will be loaded. This was enabled by default and also specified in the config file.
(II) "dri2" will be loaded. This was enabled by default and also specified in the config file.
(II) LoadModule: "extmod"
(II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
   compiled for 1.7.7, module version = 1.0.0
   Module class: X.Org Server Extension
   ABI class: X.Org Server Extension, version 2.0
(II) Loading extension SELinux
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "record"
(II) Loading /usr/lib/xorg/modules/extensions/librecord.so
(II) Module record: vendor="X.Org Foundation"
   compiled for 1.7.7, module version = 1.13.0
   Module class: X.Org Server Extension
   ABI class: X.Org Server Extension, version 2.0
(II) Loading extension RECORD
(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions/libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
   compiled for 4.0.2, module version = 1.0.0
   Module class: X.Org Server Extension
(II) NVIDIA GLX Module  195.36.31  Thu Jun  3 08:59:25 PDT 2010
(II) Loading extension GLX
(II) LoadModule: "dri"
(II) Loading /usr/lib/xorg/modules/extensions/libdri.so
(II) Module dri: vendor="X.Org Foundation"
   compiled for 1.7.7, module version = 1.0.0
   ABI class: X.Org Server Extension, version 2.0
(II) Loading extension XFree86-DRI
(II) LoadModule: "dri2"
(II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
(II) Module dri2: vendor="X.Org Foundation"
   compiled for 1.7.7, module version = 1.1.0
   ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DRI2
(II) LoadModule: "dbe"
(II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
   compiled for 1.7.7, module version = 1.0.0
   Module class: X.Org Server Extension
   ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "nvidia"
(II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
(II) Module nvidia: vendor="NVIDIA Corporation"
   compiled for 4.0.2, module version = 1.0.0
   Module class: X.Org Video Driver
(II) NVIDIA dlloader X Driver  195.36.31  Thu Jun  3 08:27:29 PDT 2010
(II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
(II) Primary Device is: PCI 02@00:00:0
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/lib/xorg/modules/libfb.so
(II) Module fb: vendor="X.Org Foundation"
   compiled for 1.7.7, module version = 1.0.0
   ABI class: X.Org ANSI C Emulation, version 0.4
(II) Loading sub module "wfb"
(II) LoadModule: "wfb"
(II) Loading /usr/lib/xorg/modules/libwfb.so
(II) Module wfb: vendor="X.Org Foundation"
   compiled for 1.7.7, module version = 1.0.0
   ABI class: X.Org ANSI C Emulation, version 0.4
(II) Loading sub module "ramdac"
(II) LoadModule: "ramdac"
(II) Module "ramdac" already built-in
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) Mar 05 15:38:37 NVIDIA(0): Enabling RENDER acceleration
(II) Mar 05 15:38:37 NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) Mar 05 15:38:37 NVIDIA(0):     enabled.
(WW) Mar 05 15:38:38 NVIDIA(GPU-0): Unable to read EDID for display device CRT-0
(II) Mar 05 15:38:39 NVIDIA(0): NVIDIA GPU GeForce 8400 GS (G86) at PCI:2:0:0 (GPU-0)
(--) Mar 05 15:38:39 NVIDIA(0): Memory: 524288 kBytes
(--) Mar 05 15:38:39 NVIDIA(0): VideoBIOS: 60.86.4a.00.13
(II) Mar 05 15:38:39 NVIDIA(0): Detected PCI Express Link width: 16X
(--) Mar 05 15:38:39 NVIDIA(0): Interlaced video modes are supported on this GPU
(--) Mar 05 15:38:39 NVIDIA(0): Connected display device(s) on GeForce 8400 GS at PCI:2:0:0:
(--) Mar 05 15:38:39 NVIDIA(0):     CRT-0
(--) Mar 05 15:38:39 NVIDIA(0): CRT-0: 400.0 MHz maximum pixel clock
(II) Mar 05 15:38:39 NVIDIA(0): Assigned Display Device: CRT-0
(II) Mar 05 15:38:39 NVIDIA(0): Validated modes:
(II) Mar 05 15:38:39 NVIDIA(0):     "1920x1080"
(II) Mar 05 15:38:39 NVIDIA(0): Virtual screen size determined to be 1920 x 1080
(WW) Mar 05 15:38:39 NVIDIA(0): Unable to get display device CRT-0's EDID; cannot compute DPI
(WW) Mar 05 15:38:39 NVIDIA(0):     from CRT-0's EDID.
(==) Mar 05 15:38:39 NVIDIA(0): DPI set to (75, 75); computed from built-in default
(==) Mar 05 15:38:39 NVIDIA(0): Enabling 32-bit ARGB GLX visuals.
(--) Depth 24 pixmap format is 32 bpp
(II) Mar 05 15:38:39 NVIDIA: Using 768.00 MB of virtual memory for indirect memory access.
(II) Mar 05 15:38:39 NVIDIA(0): Initialized GPU GART.
(II) Mar 05 15:38:39 NVIDIA(0): Setting mode "1920x1080"
(II) Loading extension NV-GLX
(II) Mar 05 15:38:39 NVIDIA(0): Initialized OpenGL Acceleration
(==) NVIDIA(0): Disabling shared memory pixmaps
(II) Mar 05 15:38:39 NVIDIA(0): Initialized X Rendering Acceleration
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(==) NVIDIA(0): DPMS enabled
(II) Loading extension NV-CONTROL
(II) Loading extension XINERAMA
(==) RandR enabled
(II) Initializing built-in extension Generic Event Extension
(II) Initializing built-in extension SHAPE
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension BIG-REQUESTS
(II) Initializing built-in extension SYNC
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension XC-MISC
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
SELinux: Disabled on system, not enabling in X server
(II) Initializing extension GLX
(II) config/udev: Adding input device Power Button (/dev/input/event4)
(**) Power Button: Applying InputClass "evdev keyboard catchall"
(II) LoadModule: "evdev"
(II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
(II) Module evdev: vendor="X.Org Foundation"
   compiled for 1.7.6.901, module version = 2.3.2
   Module class: X.Org XInput Driver
   ABI class: X.Org XInput driver, version 7.0
(**) Power Button: always reports core events
(**) Power Button: Device: "/dev/input/event4"
(II) Power Button: Found keys
(II) Power Button: Configuring as keyboard
(II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "pc105"
(**) Option "xkb_layout" "it"
(II) config/udev: Adding input device Power Button (/dev/input/event3)
(**) Power Button: Applying InputClass "evdev keyboard catchall"
(**) Power Button: always reports core events
(**) Power Button: Device: "/dev/input/event3"
(II) Power Button: Found keys
(II) Power Button: Configuring as keyboard
(II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "pc105"
(**) Option "xkb_layout" "it"
(II) config/udev: Adding input device Logitech USB-PS/2 Optical Mouse (/dev/input/event2)
(**) Logitech USB-PS/2 Optical Mouse: Applying InputClass "evdev pointer catchall"
(**) Logitech USB-PS/2 Optical Mouse: always reports core events
(**) Logitech USB-PS/2 Optical Mouse: Device: "/dev/input/event2"
(II) Logitech USB-PS/2 Optical Mouse: Found 12 mouse buttons
(II) Logitech USB-PS/2 Optical Mouse: Found scroll wheel(s)
(II) Logitech USB-PS/2 Optical Mouse: Found relative axes
(II) Logitech USB-PS/2 Optical Mouse: Found x and y relative axes
(II) Logitech USB-PS/2 Optical Mouse: Configuring as mouse
(**) Logitech USB-PS/2 Optical Mouse: YAxisMapping: buttons 4 and 5
(**) Logitech USB-PS/2 Optical Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
(II) XINPUT: Adding extended input device "Logitech USB-PS/2 Optical Mouse" (type: MOUSE)
(II) Logitech USB-PS/2 Optical Mouse: initialized for relative axes.
(II) config/udev: Adding input device Logitech USB-PS/2 Optical Mouse (/dev/input/mouse1)
(II) No input driver/identifier specified (ignoring)
(II) config/udev: Adding input device HDA Digital PCBeep (/dev/input/event6)
(II) No input driver/identifier specified (ignoring)
(II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event1)
(**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
(**) AT Translated Set 2 keyboard: always reports core events
(**) AT Translated Set 2 keyboard: Device: "/dev/input/event1"
(II) AT Translated Set 2 keyboard: Found keys
(II) AT Translated Set 2 keyboard: Configuring as keyboard
(II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "pc105"
(**) Option "xkb_layout" "it"
(II) config/udev: Adding input device PC Speaker (/dev/input/event5)
(II) No input driver/identifier specified (ignoring)
(II) config/udev: Adding input device Macintosh mouse button emulation (/dev/input/event0)
(**) Macintosh mouse button emulation: Applying InputClass "evdev pointer catchall"
(**) Macintosh mouse button emulation: always reports core events
(**) Macintosh mouse button emulation: Device: "/dev/input/event0"
(II) Macintosh mouse button emulation: Found 3 mouse buttons
(II) Macintosh mouse button emulation: Found relative axes
(II) Macintosh mouse button emulation: Found x and y relative axes
(II) Macintosh mouse button emulation: Configuring as mouse
(**) Macintosh mouse button emulation: YAxisMapping: buttons 4 and 5
(**) Macintosh mouse button emulation: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
(II) XINPUT: Adding extended input device "Macintosh mouse button emulation" (type: MOUSE)
(II) Macintosh mouse button emulation: initialized for relative axes.
(II) config/udev: Adding input device Macintosh mouse button emulation (/dev/input/mouse0)
(II) No input driver/identifier specified (ignoring)



Ora su entrambi i sistemi oparativi ho gli stessi driver Nvidia ( v.195.36.31 ), quindi a questo punto credo sia solamente un problema di configurazione.
Nilus
Linux 1.0
Linux 1.0
 
Messaggi: 11
Iscritto il: lun feb 21, 2011 14:52
Slackware: 13.1
Desktop: KDE

Re: Xorg e risoluzione 16:9

Messaggioda erio » sab mar 05, 2011 16:33

scusa la domanda,ma i driver supportati dalla tua scheda video sono arrivati a 260.19.36,c'è un motivo particolare per cui non aggiorni la versione,mi ripeto se installi i driver, da nvidia setting fai tutto non serve fare lo script di x,oppure il monitor è un crt e serve un configure particolare?
erio
Linux 3.x
Linux 3.x
 
Messaggi: 1088
Iscritto il: ven ott 09, 2009 18:25
Slackware: 13.37
Kernel: 3.0.7
Desktop: kde

Re: Xorg e risoluzione 16:9

Messaggioda Nilus » dom mar 06, 2011 11:50

erio ho reinstallato i vecchi driver solamente per fare una prova ( siccome su Debian con quella versione di driver la risoluzione si setta correttamente ).

Comunque sia ho risolto; e come molto spesso capita la soluzione è la più banale : impostavo male la frequenza di refresh verticale. Con 1920x1080 l'unica frequenza possibile è 60hz ( l' ho scoperto solo dopo ), mentre per la maggior parte delle altre arriva fino a 75hz, ma essendo un monitor LCD 60hz è più che sufficiente.

Probabilmente nel pannello di controllo Nvidia sono elencate le solite risoluzioni 4:3, e non quelle 16:9, perchè la scheda video non riesce a ricevere l' EDID dal monitor e quindi c'è bisogno di creare una Modeline, per "forzare" la risoluzione, in xorg.conf. Tutto questo però può essere anche non vero, siccome su Debian l' EDID e tutte le varie risoluzioni non vengono lo stesso riconosciuti, ma basta specificare, sempre nel file di configurazione xorg, la risoluzione senza Modeline e senza neanche frequeza di refresh che va comunque tutto va bene.


Ti ringrazio comunque per la tua pazienza :thumbright:
Nilus
Linux 1.0
Linux 1.0
 
Messaggi: 11
Iscritto il: lun feb 21, 2011 14:52
Slackware: 13.1
Desktop: KDE


Torna a Slackware64

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite

cron