Repository 32bit  Forum
Repository 64bit  Wiki

Microfono notebook non funzionante e riproduzione MIDI

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Microfono notebook non funzionante e riproduzione MIDI

Messaggioda Eberoth » mer mar 16, 2011 16:08

Bene,
Dopo non so quanto tempo passato a tentare di risolvere questi due (unici) problemi con l'hardware del mio portatile mi sono arreso. A questo punto non mi resta che rivolgermi alla community, sicuramente ne saprete più di me.

Ho un Fujitsu-Siemens Amilo Pi1515, un portatile vecchiotto ma che funziona ancora bene, la scheda audio è la solita Intel-HDA, questa è la riga di lspci che la riguarda:
Codice: Seleziona tutto
lspci
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 02)


Il sistema è una slackware64-current aggiornata all'ultimo changelog ed il kernel è il 2.6.36-zen2 (ho avuto problemi allo spegnimento con la serie 2.6.37.*). Tutta la sezione del kernel relativa alla scheda audio è compilata staticamente.

Ho lanciato alsaconf, e la scheda audio viene rilevata correttamente. Ho provato a "giocare" con il mixer, ma senza risultato. Ho anche aggiunto delle righe al file /etc/modprobe.d/sound.conf, nella speranza di risolvere il problema (seguendo una guida trovata sul sito di arch mi sembra, ma sono passati mesi).
Codice: Seleziona tutto
less /etc/modprobe.d/sound.conf

# --- ALSACONF version 1.0.23 ---
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
# --- END: Generated by ALSACONF, do not edit. ---
#Qui comincia un tentativo di fix per il microfono:
options snd-hda-intel position_fix=1
# ALSA portion
          alias char-major-116 snd
          alias snd-card-0 snd-hda-intel     
        # OSS/Free portion
          alias char-major-14 soundcore
          alias sound-slot-0 snd-card-0
        # card #1
          alias sound-service-0-0 snd-mixer-oss
          alias sound-service-0-1 snd-seq-oss
          alias sound-service-0-3 snd-pcm-oss
          alias sound-service-0-8 snd-seq-oss
          alias sound-service-0-12 snd-pcm-oss


L'unico effetto di queste righe è stato che prima "rec" registrava solo rumore statico (ad un volume altissimo), mentre ora registra silenzio su tutti i canali. A non funzionare sono sia il microfono interno, frontmic, che quello esterno collegato all'apposita uscita. SInceramente non so più che pesci prendere.

L'altro problema è molto più semplice e breve da esporre: non riesco in nessun modo a riprodurre file MIDI, sebbene abbia installati tutti i moduli ed i pacchetti necessari.
Avatar utente
Eberoth
Linux 2.4
Linux 2.4
 
Messaggi: 376
Iscritto il: lun ago 24, 2009 8:22
Slackware: -current
Kernel: 3.13.6
Desktop: KDE4
Distribuzione: Slackel64

Re: Microfono notebook non funzionante e riproduzione MIDI

Messaggioda Eberoth » mer mar 23, 2011 22:07

Nessuno che chi aiuta?
Avatar utente
Eberoth
Linux 2.4
Linux 2.4
 
Messaggi: 376
Iscritto il: lun ago 24, 2009 8:22
Slackware: -current
Kernel: 3.13.6
Desktop: KDE4
Distribuzione: Slackel64

Re: Microfono notebook non funzionante e riproduzione MIDI

Messaggioda neongen » mer mar 23, 2011 23:50

in sound.conf specifica il modello di scheda: options snd-hda-intel model=....
la lista dei modelli è in /usr/src/linux/Documentation/sound/alsa/HD-Audio-Models.txt
Avatar utente
neongen
Packager
Packager
 
Messaggi: 825
Iscritto il: ven mag 25, 2007 11:37
Nome Cognome: Enrico
Slackware: 14.0_64
Kernel: 3.4.4
Desktop: KDE 4.5.5
Distribuzione: Maemo 5

Re: Microfono notebook non funzionante e riproduzione MIDI

Messaggioda zoros » gio mar 24, 2011 14:55

in un caso di driver hda-intel con scheda muta ho risolto inserendo le configurazioni nel file /etc/modprobe.d/alsa-base.conf simile a /etc/modprobe.d/sound.conf ... cercando con google per /etc/modprobe.d/alsa-base.conf forse trovi la soluzione ;) ...
vorrei riavere le mie firme ...
Avatar utente
zoros
Linux 3.x
Linux 3.x
 
Messaggi: 1302
Iscritto il: lun mag 28, 2007 21:51
Località: Gorizia
Nome Cognome: Fabio∙Zorba
Slackware: 13.37
Kernel: 3.2.5
Desktop: KDE-3.5.10

Re: Microfono notebook non funzionante e riproduzione MIDI

Messaggioda Eberoth » mar mar 29, 2011 17:20

Niente..ho aggiunto l'opzione riguardante il modello della scheda, "fujitsu", ed ho un /etc/modprobe.d/alsa-base.conf che è praticamente identico al sound.conf... ma non è cambiato nulla.
Avatar utente
Eberoth
Linux 2.4
Linux 2.4
 
Messaggi: 376
Iscritto il: lun ago 24, 2009 8:22
Slackware: -current
Kernel: 3.13.6
Desktop: KDE4
Distribuzione: Slackel64

Re: Microfono notebook non funzionante e riproduzione MIDI

Messaggioda zoros » mer mar 30, 2011 20:31

rileggendo i tuoi interventi risulta che hai già apportato varie modifiche ai .conf nel tentativo di risolvere ... a questo punto io cancellerei tutte le configurazioni e ripartirei con dei .conf vuoti ;) ...
vorrei riavere le mie firme ...
Avatar utente
zoros
Linux 3.x
Linux 3.x
 
Messaggi: 1302
Iscritto il: lun mag 28, 2007 21:51
Località: Gorizia
Nome Cognome: Fabio∙Zorba
Slackware: 13.37
Kernel: 3.2.5
Desktop: KDE-3.5.10

Re: Microfono notebook non funzionante e riproduzione MIDI

Messaggioda Eberoth » mar mag 10, 2011 18:11

Scusate se ho lasciato passare tanto tempo, ma poi ho avuto prima problemi con i kernel della serie 2.6.37.* e poi impegni di diversa natura.

Comunque, visto che non sono ancora riuscito a risolvere nessuno dei problemi riguardanti questa discussione mi concedo un piccolo UP, aggiungendo che anche son i .conf vuoti non sono riuscito a risolvere nulla per quanto riguarda il microfono.

Dei MIDI poi non ne parliamo...
Avatar utente
Eberoth
Linux 2.4
Linux 2.4
 
Messaggi: 376
Iscritto il: lun ago 24, 2009 8:22
Slackware: -current
Kernel: 3.13.6
Desktop: KDE4
Distribuzione: Slackel64

Re: Microfono notebook non funzionante e riproduzione MIDI

Messaggioda phobos3576 » mar mag 10, 2011 21:52

Ho notato che tutte le maggiori distribuzioni stanno seguendo la "moda" PulseAudio; dalle prove che ho effettuato su un portatile con vari LiveCD di OpenSuse e Ubuntu, devo dire che questo nuovo modello di interfaccia audio sembra funzionare piuttosto bene.
Su un portatile dotato della solita scheda audio Intel/nVidia HDA, con Slackware non riesco a far riconoscere a VLC (e ad altri programmi) il microfono della webcam; ci sono riuscito solo usando il vecchio supporto OSS, che però è piuttosto inefficiente (infatti, ottengo registrazioni audio/video che vanno a scatti).
Sullo stesso portatile, con OpenSuse o Ubuntu, l'utilizzo di PulseAudio permette un riconoscimento perfetto del microfono da parte di qualunque programma; del resto, bisogna ricordare che Skype, VLC, GoogleChrome, etc, sono ottimizzati per usare eventualmente lo stesso PulseAudio.

Un altro esempio è il riconoscimento vocale su GoogleChrome 11.x. Con Slackware, mi viene visto solo il microfono esterno; il microfono integrato della webcam è come se non esistesse. Con OpenSuse + Pulseaudio, il microfono integrato funziona benissimo.

Sino a qualche tempo fa, PulseAudio era una vera porcheria e se ne sconsigliava pure l'uso; adesso sembra che le cose siano cambiate notevolmente.
In pratica, PulseAudio usa ALSA per riconoscere i vari controlli presenti sulla scheda audio e poi assegna a ciascuno di essi un nome standard di interfaccia; in questo modo, i vari programmi non devono fare i salti mortali per sapere come si chiama un determinato controllo.

Il problema è che Slackware è impostata per usare direttamente ALSA; l'utilizzo di PulseAudio comporta un lavoro di configurazione abbastanza impegnativo soprattutto a causa delle numerose dipendenze.
Magari, per la prossima Slackware Pat potrebbe farci un pensierino.
Avatar utente
phobos3576
Staff
Staff
 
Messaggi: 2980
Iscritto il: sab apr 16, 2005 23:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Re: Microfono notebook non funzionante e riproduzione MIDI

Messaggioda Eberoth » mer mag 11, 2011 11:08

Mi stai forse dicendo che o cambio distribuzione, passando ad una con pulseAudio, o mi tengo i microfoni silenti? Nessuna altra opzione?
Avatar utente
Eberoth
Linux 2.4
Linux 2.4
 
Messaggi: 376
Iscritto il: lun ago 24, 2009 8:22
Slackware: -current
Kernel: 3.13.6
Desktop: KDE4
Distribuzione: Slackel64


Torna a Slackware64

Chi c’è in linea

Visitano il forum: Bing [Bot] e 1 ospite

cron