Repository 32bit  Forum
Repository 64bit  Wiki

[RISOLTO] Problema installazione slackware 13.1.

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Re: Problema installazione slackware 13.1.

Messaggioda yAri » dom lug 24, 2011 19:24

ma è un altra distro di linux?
.. be the change you want to see in the world ..
Avatar utente
yAri
Linux 2.0
Linux 2.0
 
Messaggi: 156
Iscritto il: dom ott 31, 2010 13:16
Nome Cognome: Yari Hembik
Slackware: 14.1
Kernel: 2.6
Desktop: KDE

Re: Problema installazione slackware 13.1.

Messaggioda zoros » dom lug 24, 2011 21:02

invece di cambiare distro potresti provare ad installare Slackware attraverso questi tools ...
vorrei riavere le mie firme ...
Avatar utente
zoros
Linux 3.x
Linux 3.x
 
Messaggi: 1302
Iscritto il: lun mag 28, 2007 21:51
Località: Gorizia
Nome Cognome: Fabio∙Zorba
Slackware: 13.37
Kernel: 3.2.5
Desktop: KDE-3.5.10

Re: Problema installazione slackware 13.1.

Messaggioda slack68 » ven ago 12, 2011 13:34

Ho un problema simile.... non riesco a installare nè la 13.1 nè la 13.37.
Dopo aver scelto huge.s il boot si ferma e non mi vede la tastiera !!!!
Una Trust wireless con chipset sunplus. E' come se mancassero i relativi driver. (cosa che non capitava con la 13.0)

E' possibile aggiungere qualche comando al boot da aggiungere ad huge.s per fargli vedere la tastiera + mouse??
slack68
Linux 1.0
Linux 1.0
 
Messaggi: 55
Iscritto il: gio gen 06, 2005 0:00

Re: Problema installazione slackware 13.1.

Messaggioda 414N » ven ago 12, 2011 14:57

yAri ha scritto:Ho provato a mettere
Codice: Seleziona tutto
huge.s i8042.dumbkbd=1 i8042.nopnp

Prova prima solo con dumbkbd, poi anche con i8042.nopnp=1
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Problema installazione slackware 13.1.

Messaggioda slack68 » sab ago 13, 2011 11:33

Provato ma nulla. Praticamente il comando dumb... mi salta la scelta della lingua della tastiera ma quest'ultima resta inutilizzabile.
Evidentemente è solo un problema di driver non caricato. Aspetterò il prossimo huge.s :( o qualcuno che mi dice come caricare il driver sunplus all'avvio.

Grazie
slack68
Linux 1.0
Linux 1.0
 
Messaggi: 55
Iscritto il: gio gen 06, 2005 0:00

Re: Problema installazione slackware 13.1.

Messaggioda 414N » sab ago 13, 2011 13:14

Ho appena controllato un po' in giro e sembra proprio che il tuo problema sia dovuto ad un mancato caricamento del modulo hid-sunplus all'avvio.
La cosa strana è che nel config huge di Slackware, quel modulo è presente come modulo e non come builtin, come sarebbe logico aspettarsi da uno huge.
Per uscirne, credo tu abbia due alternative:
1) Creare una chiavetta USB avviabile che avvi l'installazione di Slackware con un kernel modificato (più che altro l'initrd);
2) Creare un nuovo disco di installazione di Slackware con la initrd modificata.
Credo che la strada meno impegnativa sia quella della chiavetta, fattibile facilmente solo se il tuo BIOS supporta il boot da USB.
Ti riporto una procedura che dovrebbe portarti alla soluzione del problema (con il disco di installazione non dovrebbe essere molto diversa):
  • Monta in un percorso (per esempio /mnt/tmp) l'immagine per drive USB d'avvio che trovi nel disco di installazione sotto usb-and-pxe-installers/usbboot.img:
    Codice: Seleziona tutto
    mount -o loop /path/del/dvd/usb-and-pxe-installers/usbboot.img /mnt/tmp
  • Estrai il file /mnt/tmp/initrd.img in un'altra directory temporanea (per esempio /tmp/initrd):
    Codice: Seleziona tutto
    mkdir /tmp/initrd && cd /tmp/initrd && gunzip -cd /mnt/tmp/initrd.img  | cpio -i -d -H newc --no-absolute-filenames
  • Installa il bootloader su una chiavetta (che qui suppongo essere /dev/sdb, ma dipende dal tuo pc) --- OCCHIO CHE PERDERAI TUTTO CIÒ CHE CONTIENE ---
    Codice: Seleziona tutto
    dd if=/path/del/dvd/usb-and-pxe-installers/usbboot.img of=/dev/sdb bs=512
  • Se hai a disposizione una Slackware della stessa versione (e bitness, ovviamente) già installata, copia il modulo nel "ramo" della initrd estratta:
    Codice: Seleziona tutto
    cp /lib/modules/2.6.37.6/kernel/drivers/hid/hid-sunplus.ko /tmp/initrd/lib/modules/2.6.37.6/kernel/drivers/hid/

    Se non ce l'hai a disposizione, estrailo dall'archivio dei kernel-modules che trovi sul disco di installazione e copialo nella posizione sopra riportata:
    Codice: Seleziona tutto
    mkdir /tmp/unpack && cd /tmp/unpack && tar xvf /path/del/dvd/slackware{64}/a/kernel-modules-*.txz
    cp lib/modules/2.6.37.6/kernel/drivers/hid/hid-sunplus.ko /tmp/initrd/lib/modules/2.6.37.6/kernel/drivers/hid/

  • Reimpacchettiamo l'initrd:
    Codice: Seleziona tutto
    cd /tmp/initrd && find . | cpio -o -H newc | gzip > /tmp/newinitrd.img

  • Monta la chiavetta in un qualche percorso (per esempio /mnt/disk) e sovrascrivi la initrd.img che troverai al suo interno con quella modificata in /tmp/newinitrd.img:
    Codice: Seleziona tutto
    cp /tmp/newinitrd.img /mnt/disk/initrd.img
Se provi ad avviare l'installazione con la chiavetta, ora la tastiera dovrebbe funzionare. In fase di installazione puoi indicare all'installer di appoggiarsi al DVD per trovare i pacchetti
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Problema installazione slackware 13.1.

Messaggioda slack68 » sab ago 13, 2011 14:16

Grazie per aver trovato una soluzione, anche se la trovo un po articolata.

Io avevo pensato di partire con l'installazione della 13.0 e poi al momento di scegliere i pacchetti inserire il DVD della 13.37.
Resterebbe poi la modifica del file fstab visto che i dischi vengono visti come hda, hda1 e non come sda, sda1 e del relativo file di lilo.conf .

Spero venga corretto l'errore al prossimo huge. Chi lo dice a Pat? :)
slack68
Linux 1.0
Linux 1.0
 
Messaggi: 55
Iscritto il: gio gen 06, 2005 0:00

Re: Problema installazione slackware 13.1.

Messaggioda 414N » sab ago 13, 2011 14:35

slack68 ha scritto:Grazie per aver trovato una soluzione, anche se la trovo un po articolata.

Forse, ma ritengo abbia buone probabilità di funzionare.
slack68 ha scritto:Io avevo pensato di partire con l'installazione della 13.0 e poi al momento di scegliere i pacchetti inserire il DVD della 13.37.

E perché mai? Dalla via che hai la 13.37 (e vorresti installare quella), perché fare il boot con la 13.0?
slack68 ha scritto:Resterebbe poi la modifica del file fstab visto che i dischi vengono visti come hda, hda1 e non come sda, sda1 e del relativo file di lilo.conf .

Questo, al massimo, è un problema del post installazione se effettui un aggiornamento (che è un procedimento manuale, non eseguito in automatico durante un'installazione).
Il problema, pertanto, non si pone se, durante l'installazione, segui il wizard per la popolazione sia di fstab che di lilo.
slack68 ha scritto:Spero venga corretto l'errore al prossimo huge. Chi lo dice a Pat? :)

Posso anche dirglielo io, ma prima è meglio verificare che l'aggiungere quel modulo all'initrd risolve il problema ;)
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Problema installazione slackware 13.1.

Messaggioda zoros » sab ago 13, 2011 20:05

414N ha scritto:...
slack68 ha scritto:Spero venga corretto l'errore al prossimo huge. Chi lo dice a Pat? :)

Posso anche dirglielo io, ma prima è meglio verificare che l'aggiungere quel modulo all'initrd risolve il problema ;)

penso che qualcosa si potrebbe segnalare a Pat ... nel suo huge:
Codice: Seleziona tutto
# cat /boot/config-huge-smp-2.6.37.6-smp | grep USB_HID
CONFIG_USB_HID=m
CONFIG_USB_HIDDEV=y
cioè questo huge non è "nativamente" (intendo: il solo binario vmlinuz) in grado di gestire le tastiere usb, ha bisogno dei moduli di libreria in ramdisk ... e probabilmente l'autorilevamento di alcune tastiere tipo-usb non funziona ...

per questa curiosità suggerivo di provare i miei tools che hanno il modulo nel kernel:
zoros ha scritto:invece di cambiare distro potresti provare ad installare Slackware attraverso questi tools ...
vorrei riavere le mie firme ...
Avatar utente
zoros
Linux 3.x
Linux 3.x
 
Messaggi: 1302
Iscritto il: lun mag 28, 2007 21:51
Località: Gorizia
Nome Cognome: Fabio∙Zorba
Slackware: 13.37
Kernel: 3.2.5
Desktop: KDE-3.5.10

Re: Problema installazione slackware 13.1.

Messaggioda zoros » sab ago 13, 2011 20:23

slack68 ha scritto:Ho un problema simile.... non riesco a installare nè la 13.1 nè la 13.37.
Dopo aver scelto huge.s il boot si ferma e non mi vede la tastiera !!!!
Una Trust wireless con chipset sunplus. E' come se mancassero i relativi driver. (cosa che non capitava con la 13.0)

E' possibile aggiungere qualche comando al boot da aggiungere ad huge.s per fargli vedere la tastiera + mouse??

se è ragionevole l'indicazione del mio precedente post, si potrebbe passare questo append al boot del DVD di Slackware:
Codice: Seleziona tutto
usbhid.mousepoll=2
... per forzare il caricamento del modulo (1=1000Hz, 2=500Hz ...)
vorrei riavere le mie firme ...
Avatar utente
zoros
Linux 3.x
Linux 3.x
 
Messaggi: 1302
Iscritto il: lun mag 28, 2007 21:51
Località: Gorizia
Nome Cognome: Fabio∙Zorba
Slackware: 13.37
Kernel: 3.2.5
Desktop: KDE-3.5.10

Re: Problema installazione slackware 13.1.

Messaggioda 414N » dom ago 14, 2011 9:28

zoros ha scritto:penso che qualcosa si potrebbe segnalare a Pat ... nel suo huge:
Codice: Seleziona tutto
# cat /boot/config-huge-smp-2.6.37.6-smp | grep USB_HID
CONFIG_USB_HID=m
CONFIG_USB_HIDDEV=y
cioè questo huge non è "nativamente" (intendo: il solo binario vmlinuz) in grado di gestire le tastiere usb, ha bisogno dei moduli di libreria in ramdisk ... e probabilmente l'autorilevamento di alcune tastiere tipo-usb non funziona ...

Più che altro, il modulo per le tastiere/device hid sunplus non è proprio presente né come builtin né come modulo nell'initrd.
Se nessuno ne sa il motivo, vedrò di segnalare la faccenda a Pat.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Problema installazione slackware 13.1.

Messaggioda targzeta » dom ago 14, 2011 15:55

Se può essere di aiuto ho appena masterizzato e fatto un boot con il DVD della 13.37. Ho una tastiera+mouse wireless (LG MK250). All'avvio del kernel huge tutto è andato bene, si sono caricati automaticamente i moduli 'hid' e 'usbhid'. Penso che anche il modulo sunplus dovrebbe caricarsi automaticamente al rilevamento di una tale periferica, no?

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6195
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: Problema installazione slackware 13.1.

Messaggioda slack68 » dom ago 14, 2011 16:09

E invece no!!
Con la 13.0 nessun problema ma con la 13.1 e 13.37, 32o 64 bit, la coppia tastiera+mouse Trust chipset sunplus non da segni di vita al momento della scelta lingua !!!
slack68
Linux 1.0
Linux 1.0
 
Messaggi: 55
Iscritto il: gio gen 06, 2005 0:00

Re: Problema installazione slackware 13.1.

Messaggioda 414N » dom ago 14, 2011 16:15

spina ha scritto:Se può essere di aiuto ho appena masterizzato e fatto un boot con il DVD della 13.37. Ho una tastiera+mouse wireless (LG MK250). All'avvio del kernel huge tutto è andato bene, si sono caricati automaticamente i moduli 'hid' e 'usbhid'. Penso che anche il modulo sunplus dovrebbe caricarsi automaticamente al rilevamento di una tale periferica, no?

Dovrebbe, se fosse presente. Come detto sopra, non ce n'è traccia né nella configurazione del kernel né nell'initrd sul DVD d'installazione...
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Problema installazione slackware 13.1.

Messaggioda targzeta » dom ago 14, 2011 16:20

slack68 ha scritto:E invece no!!
Con la 13.0 nessun problema ma con la 13.1 e 13.37, 32o 64 bit, la coppia tastiera+mouse Trust chipset sunplus non da segni di vita al momento della scelta lingua !!!
Scusami slack68, forse mi sono espresso male. Non intendevo mettere in dubbio la tua parola. Volevo solo riportare un'esperienza con periferiche wireless sulla 13.37. Solo perché magari può essere utile sapere che, almeno con qualche chip, il tutto funziona bene.

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6195
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

PrecedenteProssimo

Torna a Slackware64

Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti