Repository 32bit  Forum
Repository 64bit  Wiki

Qemu kvm i/o lento

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Qemu kvm i/o lento

Messaggioda Meskalamdug » gio dic 22, 2011 3:00

Qualcuno sa come mai kvm che un tempo era una scheggia si è trasformato in una ciofeca?
Mi riferisco all i/o lentissimo(disco che frulla come quando swappa).
Sto su ext4 e lvm,ho provato dischi raw(pessimi) e qcow2(pessimi).
Meskalamdug
Iper Master
Iper Master
 
Messaggi: 3586
Iscritto il: gio mag 13, 2004 23:00

Re: Qemu kvm i/o lento

Messaggioda lablinux » gio dic 22, 2011 9:18

Io ho mi sono trovato meglio con virtualbox. Provai qemu, ma era troppo lento.Installando slackware in vm, dopo 15 minuti non aveva ancora finito la 'A'. Cob VB dopo 15 minuti avevo già installato tutto.
Avatar utente
lablinux
Linux 2.6
Linux 2.6
 
Messaggi: 759
Iscritto il: gio nov 27, 2008 12:23
Località: Rho
Slackware: 14 64bit
Desktop: kde4

Re: Qemu kvm i/o lento

Messaggioda miklos » gio dic 22, 2011 11:54

non ho mai avuto problemi di esagerata lentezza.. domanda forse un po' banale ma lo lanci con l'opzione '--enable-kvm'!?!?!?!?
ho visto cose che voi astemi non potete immaginare
miklos
Linux 3.x
Linux 3.x
 
Messaggi: 1261
Iscritto il: lun lug 16, 2007 16:39
Località: Roma
Slackware: 14.1 64bit
Kernel: 3.16.3
Desktop: openbox 3.5.2

Re: Qemu kvm i/o lento

Messaggioda lablinux » gio dic 22, 2011 13:47

miklos ha scritto:non ho mai avuto problemi di esagerata lentezza.. domanda forse un po' banale ma lo lanci con l'opzione '--enable-kvm'!?!?!?!?

:banghead: :banghead: :banghead: :banghead: :banghead: :banghead: :banghead: :banghead: :banghead: :banghead:
Avatar utente
lablinux
Linux 2.6
Linux 2.6
 
Messaggi: 759
Iscritto il: gio nov 27, 2008 12:23
Località: Rho
Slackware: 14 64bit
Desktop: kde4

Re: Qemu kvm i/o lento

Messaggioda Meskalamdug » gio dic 22, 2011 15:14

lablinux ha scritto:Io ho mi sono trovato meglio con virtualbox. Provai qemu, ma era troppo lento.Installando slackware in vm, dopo 15 minuti non aveva ancora finito la 'A'. Cob VB dopo 15 minuti avevo già installato tutto.

Sta li il problema,nell I/O
Pensare che un tempo fino alla versione kvm 0.97 se non ricordo male era un missile,vai e cerca...
Meskalamdug
Iper Master
Iper Master
 
Messaggi: 3586
Iscritto il: gio mag 13, 2004 23:00

Re: Qemu kvm i/o lento

Messaggioda Meskalamdug » gio dic 22, 2011 15:14

miklos ha scritto:non ho mai avuto problemi di esagerata lentezza.. domanda forse un po' banale ma lo lanci con l'opzione '--enable-kvm'!?!?!?!?

Certo.
Meskalamdug
Iper Master
Iper Master
 
Messaggi: 3586
Iscritto il: gio mag 13, 2004 23:00

Re: Qemu kvm i/o lento

Messaggioda NetNightmare » gio dic 22, 2011 18:46

mmmm tutto cio e' strano io invece trovo che qemu-kvm sia meglio addirittura di vmware per certe cose ... sul mio thinkpad con vmware posso far girare una vm alla volta con qemu due girano senza il minimo sforzo e alle volte anche 3 ....

comunque !!! tornando al topic e lentezza dischi .... stai usandi i virtio device ?? lablinux sicuramente no dato che il kernel del setup di slackware ha il supporto virtio come modulo , pertanto in fase di installazione si puo installare solo senza ... i virtio vanno abilitati dopo ... e il suo esempi si riferiva appunto all'installazione
Avatar utente
NetNightmare
Linux 2.0
Linux 2.0
 
Messaggi: 175
Iscritto il: lun ago 18, 2008 10:00
Località: Rome
Nome Cognome: Giuseppe De Nicolo'
Slackware: 13.37 x86_64
Kernel: 2.6.37.6-smp
Desktop: Fluxbox

Re: Qemu kvm i/o lento

Messaggioda Meskalamdug » ven dic 23, 2011 6:23

NetNightmare ha scritto:mmmm tutto cio e' strano io invece trovo che qemu-kvm sia meglio addirittura di vmware per certe cose ... sul mio thinkpad con vmware posso far girare una vm alla volta con qemu due girano senza il minimo sforzo e alle volte anche 3 ....

comunque !!! tornando al topic e lentezza dischi .... stai usandi i virtio device ?? lablinux sicuramente no dato che il kernel del setup di slackware ha il supporto virtio come modulo , pertanto in fase di installazione si puo installare solo senza ... i virtio vanno abilitati dopo ... e il suo esempi si riferiva appunto all'installazione

Vmware WS è un mattone,decisamente meglio Virtualbox
Meskalamdug
Iper Master
Iper Master
 
Messaggi: 3586
Iscritto il: gio mag 13, 2004 23:00

Re: Qemu kvm i/o lento

Messaggioda Meskalamdug » ven dic 23, 2011 13:31

Ho notato un aumento di prestazioni con file=DISCOWIN,cache=writeback
Meskalamdug
Iper Master
Iper Master
 
Messaggi: 3586
Iscritto il: gio mag 13, 2004 23:00

Re: Qemu kvm i/o lento

Messaggioda Meskalamdug » dom dic 25, 2011 10:34

Ho anche notato questo..

EXT4-fs (dm-2): Unaligned AIO/DIO on inode 26083835 by qemu-system-x86; performance will be poor.

:/
Meskalamdug
Iper Master
Iper Master
 
Messaggi: 3586
Iscritto il: gio mag 13, 2004 23:00


Torna a Slackware64

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite