Pagina 1 di 2

[RISOLTO] Problema con startx

Inviato: ven gen 20, 2012 18:44
da darkstar
Ciao a tutti, intanto mi presento, sono nuovo!
Ho iniziato a conoscere GNU/Linux da poco e dopo aver provato Ubuntu e Chakra sto provando a sperimentare Slackware.
Ma veniamo al problema.
Nell'installazione non ho riscontrato grossi problemi. Anche se all'inizio mi ha un po' spiazzato, credo di essere riuscito a installare il sistema correttamente.
Il problema ce l'ho quando riavvio.
Mi connetto con un nuovo utente (anche da root fa uguale) e all'avvio di X con startx subito si avvia KDE, ma poi si blocca e mi appaio pagine di errori:
l'ultima, quella che vedo, è questa:

Re: PROBLEMA CON STARTX

Inviato: ven gen 20, 2012 18:49
da Ansa89
Posta il contenuto di "/var/log/Xorg.0.log" dopo che hai eseguito "startx".

Re: Problema con startx

Inviato: ven gen 20, 2012 19:23
da darkstar
Come faccio a visualizzare le cose che sono scritte prima?
coi comandi

Codice: Seleziona tutto

dmesg | more
e

Codice: Seleziona tutto

dmesg | less
scritti in Slackware for dummies vedo solo i messaggi dell'avvio..

Re: Problema con startx

Inviato: ven gen 20, 2012 20:06
da Meskalamdug
La soluzione è nella foto.
Sembra che manchi qualcosa di kde.
Reinstalla tutto,e seleziona FULL per i pacchetti,quelli inutili eventualmente li potrai rimuovere dopo.

Re: Problema con startx

Inviato: ven gen 20, 2012 20:41
da 414N
Meskalamdug ha scritto:Sembra che manchi qualcosa di kde.
Reinstalla tutto,e seleziona FULL per i pacchetti,quelli inutili eventualmente li potrai rimuovere dopo.

Non credo. I primi messaggi indicano un problema nel connettersi al server X (forse chiuso inaspettatamente prima del tempo).
Scommetto 2 lenticchie di capodanno che si tratta del solito problema col driver nouveau di stock in Slackware.
@darkstar: hai per caso una scheda nvidia nel sistema?
Intanto posta quanto chiesto anche da Ansa89 (tra tag code, mi raccomando). I vari dmesg ti stampano a video i messaggi del kernel, non quelli del server X.
Basta un

Codice: Seleziona tutto

cat /var/log/Xorg.0.log

o

Codice: Seleziona tutto

less /var/log/Xorg.0.log

per vederne il contenuto.

Re: Problema con startx

Inviato: sab gen 21, 2012 13:30
da darkstar
Intanto grazie a tutti per le risposte!
Sì, ho una scheda video Nvidea GeForge GT220.
E il tutto è intallato in un disco virtuale di Virtual Box.
Vi posterei tutto il contenuto, solo che ho un piccolo problemino.. dovuto alla mia incapacità nell'uso della shell (è la prima volta).
Ora che vedo il contenuto, come lo copio?
E come esco? Dopo aver digitato

Codice: Seleziona tutto

less /var/log/Xorg.0.log
posso solo andare su e giù, ma non tornare a dare comandi.
Ok che ho 6 console virtuali su cui eseguirli, però credo che il problema sia mio..
Se va bene posto semplicemente le foto e nel frattempo vedo di studiarmi qualcosa sulla shell così da rompervi il meno possibile sui comandi
(http://it.kioskea.net/faq/412-shell-bas ... e-virtuali può andare come inizio?)

Re: Problema con startx

Inviato: sab gen 21, 2012 13:37
da darkstar
Se invece digito:

Codice: Seleziona tutto

cat /var/log/Xorg.0.log


Mi compaiono altre pagine di errori, quello che vedo alla fine è questo:
Immagine

Uploaded with ImageShack.us

Re: Problema con startx

Inviato: sab gen 21, 2012 14:28
da 414N
Il fatto che sei su una macchina virtuale era la prima cosa da dire! :)
Detto questo, qualche spiegazione:
  • First things first: se non sai usare un programma da shell o ti chiedi a cosa serva, consulta la sua man page tramite il comando

    Codice: Seleziona tutto

    man nomecomando

    All'interno del manuale dovresti trovare tutte le spiegazioni che ti servono.
  • Il programma less ti permette di scorrere agevolmente file di testo, con la possibilità di effettuare anche delle ricerche ecc. I tasti principali sulla tastiera da utilizzare sono le frecce direzionali, PagSu e PagGiù e il tasto 'q' per uscire (quit). La ricerca di testo te la lascio come compito a casa (basta guardare la man page, che tra l'altro consulti proprio con less...).
  • Se devi riportare il contenuto del file, less non è il programma che fa per te. Ti conviene condividere il file verso la macchina host (quella che esegue VirtualBox). Avendolo usato raramente non saprei dirti passo passo come fare, ma so che devi aver prima installato le guest additions (che dovrebbero migliorare anche il supporto alla scheda video nel guest). L'hai fatto?
  • La guida che riporti forse è troppo terra terra per iniziare. Certo, se vuoi farti un background sul funzionamento della shell prima di iniziare a fare esperimenti male non fa, ma forse non è molto immediata per uno a completo digiuno di questi argomenti.
Detto questo, la schermata non mostra l'errore ma solo gli errori che ne conseguono. Se riesci a riportare il file intero è meglio.

Re: Problema con startx

Inviato: sab gen 21, 2012 17:17
da darkstar
Ok.

Codice: Seleziona tutto

man
lo conoscevo, ma non riuscivo ad uscire (il tasto q proprio mi mancava!).
Ora ci pasticcio un po' e vedo di riportarvi tutto! Le guest additions sono installate!
Grazie ancora!

Re: Problema con startx

Inviato: gio mar 01, 2012 21:47
da darkstar
Mi scuso per il ritardo, il sopraggiungere degli esami all'università ha interrotto la mia esplorazione di Slack, e vi ringrazio comunque delle risposte che avete dato.
Non ho risolto il problema, temo che sia sì, la scheda video. Mi sono limitato a non scegliere Kde come interfaccia grafica e senza di lui funziona alla perfezione qualsiasi altra interfaccia scelga e per il momento va bene così.
Prossimamente, non appena prenderò un portatile su cui sperimentare Slack definitivamente, potrei tornare a farmi sentire!
Nel frattempo un po' alla volta mi sto studiando il linguaggio della shell.
Grazie di nuovo e a presto ;)

Re: Problema con startx

Inviato: ven mar 02, 2012 9:23
da 414N
Prova quanto proposto dal buon fgcl2k in questo post, in modo da disattivare forzatamente gli effetti desktop. Ovviamente, il file devi crearlo come root e avrà effetto dal successivo avvio del server X.

Re: Problema con startx

Inviato: ven mar 02, 2012 11:22
da lablinux
ma gli altri de funzionano?

Re: Problema con startx

Inviato: ven mar 02, 2012 11:30
da 414N
lablinux ha scritto:ma gli altri de funzionano?

darkstar ha scritto:Mi sono limitato a non scegliere Kde come interfaccia grafica e senza di lui funziona alla perfezione qualsiasi altra interfaccia scelga e per il momento va bene così.

:-k

Re: Problema con startx

Inviato: ven mar 02, 2012 11:57
da lablinux
az, quel post me lo sono perso... è possibile eliminare il mio inutile intervento?

Re: Problema con startx

Inviato: sab mar 03, 2012 19:59
da darkstar
fgcl2k ha scritto:
fgcl2k ha scritto:Potrebbe essere un problema legato all'accelerazione video non supportata dal tuo sistema, sul quale non dai indicazioni. In questo caso deve essere disabilitata in modo che KDE non cerchi di usarla all'avvio. Se fai qualche ricerca sul Web trovi le indicazioni o magari qualcuno di questo forum te lo sa dire.

Ho ritrovato le vecchie istruzioni: bisogna creare il file /etc/X11/xorg.conf.d/disable-composite.conf contenente:

Codice: Seleziona tutto

Section "Extensions"                                                                                                                                 
     Option "Composite" "Disable"                                                                                                                     
EndSection


Ho provato, ma mi sa che ho sbagliato qualcosa nel tentativo..
Il primo tentativo l'ho fatto dalla dash di Xfce, ho creato le tre directory in /etc e poi ci scritto il file disable-composite.conf
ora ho riprovato dalla shell iniziale, ma anche qui non mi torna qualcosa.

Codice: Seleziona tutto

cd /etc
mkdir X11
cd /X11
mkdir xorg.conf.d

Se provo ad entrare dentro xorg.conf.d mi dice che non è una directory!
Cosa ho sbagliato?