Repository 32bit  Forum
Repository 64bit  Wiki

Installazione drivers NVIDIA proprietari

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Installazione drivers NVIDIA proprietari

Messaggioda aisalord » gio feb 23, 2012 18:41

Salve a tutti, sono nuovo del forum ed ho un problema che vorrei sottoporre alla vostra attenzione.
Ho un AMD64 3000+ e complice un hd sifulo che ho dovuto sostituire, ho deciso il grande passo, una macchina "Linux pure" (tutte le precedenti erano in dual boot con Windows) ed una distro sfidante, slackware64 13.37.
La macchina è semplice, oltre alla CPU è presente una scheda NVIDIA 9600 GT, un hd pata (che avevo in un cassetto e che ha sostituito il SATA andato a donnine) un masterizzatore SATA e 4 Gb ram.
Il problema risiede nell'installazione dei driver proprietari NVIDIA, ho messo in blacklist i nouveau e provato l'installazione sia dei 290 che degli ultimi 295 (dopo aver disinstallato i precedenti) ma nulla da fare, dopo il fatidico startx schermo nero e sistema in freeze. Il bello è che non c'è uno straccio di log, il xorg.0.log è vuoto. Dando un dmesg ¦grep NVIDIA dice che il driver è caricato correttamente. Ho provato sia con l'xorg.conf precotto da NVIDIA, sia con quello minimale (solo con la sezione driver e null'altro), ma senza successo. Schermo nero e freeze.
Qualche anima pia può aiutarmi?
Seconda domanda: posso provare ad installare il kernel 3.2? I programmi funzionerebbero Lo stesso?
Grazie per la vostra attenzione.

Inviato dal mio HTC Wildfire usando Tapatalk
aisalord
Linux 1.0
Linux 1.0
 
Messaggi: 10
Iscritto il: mer feb 22, 2012 17:41
Slackware: 13.37
Kernel: 2.6.37
Desktop: kde

Re: Installazione drivers NVIDIA proprietari

Messaggioda daniele50 » gio feb 23, 2012 18:51

Io ho dovuto ricompilare il kernel togliendo il modulo nouveau.
Mettere in blacklist i nouveau non so se basta, li devi disabilitare nel kernel, almeno così ho fatto io, altrimenti dava schermo nero anche a me.
Il kernel 3.2 l'ho messo 10 giorni fa (sempre compilandolo togliendo i driver nouveau) e sembra di non aver problemi...
Avatar utente
daniele50
Linux 2.6
Linux 2.6
 
Messaggi: 929
Iscritto il: mar apr 10, 2007 12:58
Località: San Zenone al Lambro (MI)
Nome Cognome: Daniele Cinquanta
Slackware: Slackware64 14.0
Kernel: 3.2.29
Desktop: Xfce 4.10

Re: Installazione drivers NVIDIA proprietari

Messaggioda Plaoo » gio feb 23, 2012 18:51

Allora hai provato dopo l'installazione a dare nvidia-xconfig? Per il kernel nessun problema puoi aggiornare benissimo i tuoi programmi non ne risentiranno.

EDIT: per i moduli nouveau ci pensa direttamente il driver nvidia a metterli nella backlist, altrimenti nemmeno l'installazione andrebbe a buon fine. Se posso darti un consiglio io li lascerei cosi, nel caso ne avessi bisogno (i driver nvidia fanno i capricci) li puoi riattivare senza ricompilarti il kernel.
Il canale ufficiale di slacky.eu si trova sui server irc.syrolnet.org canale #slackware
Avatar utente
Plaoo
Linux 2.6
Linux 2.6
 
Messaggi: 809
Iscritto il: gio apr 10, 2008 16:40
Località: Ittiri (SS)
Slackware: 14 64
Kernel: 3.2.9
Desktop: KDE

R: Installazione drivers NVIDIA proprietari

Messaggioda aisalord » gio feb 23, 2012 19:23

@ plaoo: Ho provato sia mettendo manualmente in blacklist i driver nouveau (blacklist nouveau e nouveau modeset =0) sia lasciandoli in chiaro e lasciando fare all'installer di NVIDIA. Stesso risultato.

@ Daniele: proverò a ricompilare il kernel, tanto così come sono per me i nouveau sono inutili :grin:
Inviato dal mio HTC Wildfire usando Tapatalk
aisalord
Linux 1.0
Linux 1.0
 
Messaggi: 10
Iscritto il: mer feb 22, 2012 17:41
Slackware: 13.37
Kernel: 2.6.37
Desktop: kde

Re: R: Installazione drivers NVIDIA proprietari

Messaggioda Plaoo » gio feb 23, 2012 19:33

aisalord ha scritto:@ plaoo: Ho provato sia mettendo manualmente in blacklist i driver nouveau (blacklist nouveau e nouveau modeset =0) sia lasciandoli in chiaro e lasciando fare all'installer di NVIDIA. Stesso risultato.

@ Daniele: proverò a ricompilare il kernel, tanto così come sono per me i nouveau sono inutili :grin:
Inviato dal mio HTC Wildfire usando Tapatalk

Se sei riuscito ad installarli significa che i moduli nouveau sono nella blacklist, altrimenti non parte nemmeno l'installazione. Devi essere a runlevel 3 per installarli quindi senza X avviato.
Il canale ufficiale di slacky.eu si trova sui server irc.syrolnet.org canale #slackware
Avatar utente
Plaoo
Linux 2.6
Linux 2.6
 
Messaggi: 809
Iscritto il: gio apr 10, 2008 16:40
Località: Ittiri (SS)
Slackware: 14 64
Kernel: 3.2.9
Desktop: KDE

Re: Installazione drivers NVIDIA proprietari

Messaggioda nyquist » gio feb 23, 2012 19:38

Scusate un attimo, ma rimuovendo il pacchetto xf86-video-nouveau con removepkg e poi installando i driver proprietari NVIDIA dovrebbe funzionare. Almeno credo...
Avatar utente
nyquist
Linux 2.4
Linux 2.4
 
Messaggi: 217
Iscritto il: sab ago 02, 2008 15:02
Località: Gonars (UD)
Nome Cognome: Cristiano Urban
Slackware: 14.1 x86
Kernel: 3.10.17-smp
Desktop: KDE 4.10.5
Distribuzione: CentOS, Fedora

Re: Installazione drivers NVIDIA proprietari

Messaggioda erio » gio feb 23, 2012 20:02

i driver nvidia mandano i noveau in blacklist automaticamente, sicuro che hai scaricato i driver per la tua versione di slackware:se si da init3 sh NVIDIA-L versione dei driver.run e segui quello che ti dice,ci vuole anche il kernel header di slackware, alla domanda finale del backup della configurazione di xorg rispondi si poi dai startx.
erio
Linux 3.x
Linux 3.x
 
Messaggi: 1076
Iscritto il: ven ott 09, 2009 18:25
Slackware: 13.37
Kernel: 3.0.7
Desktop: kde

Re: Installazione drivers NVIDIA proprietari

Messaggioda Plaoo » ven feb 24, 2012 10:53

erio ha scritto:i driver nvidia mandano i noveau in blacklist automaticamente, sicuro che hai scaricato i driver per la tua versione di slackware:se si da init3 sh NVIDIA-L versione dei driver.run e segui quello che ti dice,ci vuole anche il kernel header di slackware, alla domanda finale del backup della configurazione di xorg rispondi si poi dai startx.

Vero quasi dimenticavo, per il modulo del kernel devi avere i sorgenti del kernel in /usr/src, nel caso ricompilassi l' ultimo stable.
Il canale ufficiale di slacky.eu si trova sui server irc.syrolnet.org canale #slackware
Avatar utente
Plaoo
Linux 2.6
Linux 2.6
 
Messaggi: 809
Iscritto il: gio apr 10, 2008 16:40
Località: Ittiri (SS)
Slackware: 14 64
Kernel: 3.2.9
Desktop: KDE

Re: Installazione drivers NVIDIA proprietari

Messaggioda rik70 » ven feb 24, 2012 11:10

Bisogna stare attenti anche a come si configura xorg.

Mettere in blacklist il modulo nouveau impedisce a udev di caricarlo al boot. Ma se non c'è un 'xorg.conf' con una sezione Device che specifica di caricare il driver proprietario nvidia, il server X tenterà di usare il driver nouveau e caricherà il relativo modulo del kernel.

Quindi occhio. Mi sembra strano che si debba ricompilare il kernel per far funzionare i driver nvidia. A me non è mai successo, nemmneo col kernel 3.1. Col 3.2 non ho mai provato però.

Per andare sul sicuro, oltre a blacklistare il modulo nouveau, si può rimuovere il pacchetto xf86-video-nouveau-*; in questo modo Xorg non tenterà di usare il driver open.
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1217
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: Installazione drivers NVIDIA proprietari

Messaggioda aisalord » ven feb 24, 2012 14:47

X è stato sempre lanciato con il suo file di configurazione, sia la versione compilata dall'installer di nvidia, sia quella "minimale", (con l'indicazione della sola sezione driver di nvidia) sia altre due tre versioni pescate su internet. Il risultato è sempre lo stesso.
Anche a me sinceramente appare molto strano tutto ciò, anche perché prima che il pc iniziasse a dare di matto per colpa dell'hd avevo ubuntu a 32 bit e l'installazione dei drivers di nvidia a 32 bit (ver. 290) filò liscia come l'olio (sempre con gli accorgimenti del caso, ovvio).
Visto che ho una scheda wifi N su usb che dalla versione 3.x del kernel viene riconosciuta automaticamente senza tanti spippolamenti tra driver e firmware proprietari, nel week-end colgo la palla al balzo e provo con la compilazione del 3.2.7 escludendo dal principio l'inclusione dei nuoveau e poi vediamo. Mal che vada, posso sempre riprovare con la versione a 32 bit. :D
aisalord
Linux 1.0
Linux 1.0
 
Messaggi: 10
Iscritto il: mer feb 22, 2012 17:41
Slackware: 13.37
Kernel: 2.6.37
Desktop: kde

Re: Installazione drivers NVIDIA proprietari

Messaggioda erio » ven feb 24, 2012 21:25

scusa la domanda sorge spontanea, marzullo docet, ma che sistema hai 32 o 64 perche' mi pare difficile non scaricare la versione dei driver giusta per la tua architettura visto che ci passano 30 mb di differenza tra 32 e 64 bit, ricapitolo hai installato slackware 32 0 64 bit completa di tutto, sai che se compili qualche programma devi avere slackware full, perche' senza slackware header non compila.scarichi la versione dei nvidia driver,init3, i driver in root,sh NVIDIA-Linux-versione dei driver.run se hai 64 bit ,quando ti dice installa le librerie a 32 bit tu dici si,backup del xorg config tu dici si,bene i driver sono installati, ok, e dai startx,se non hai xorg config e' sicuramente perche' non salvi la configurazione quando te lo chiede.
erio
Linux 3.x
Linux 3.x
 
Messaggi: 1076
Iscritto il: ven ott 09, 2009 18:25
Slackware: 13.37
Kernel: 3.0.7
Desktop: kde

Re: Installazione drivers NVIDIA proprietari

Messaggioda robbybby » sab feb 25, 2012 7:52

rik70 ha scritto:Col 3.2 non ho mai provato però.

Anche col 3.2 i driver nVidia funzionano. Sto usando la serie 3.2 dalla 3.2.0 (adesso ho la 3.2.7). Anche compilando i nouveau e lasciandoli in blacklist.
Io sto usando questo pacchetto nVidia a 64 bit:
NVIDIA-Linux-x86_64-295.20.run
Avatar utente
robbybby
Linux 3.x
Linux 3.x
 
Messaggi: 1175
Iscritto il: sab dic 16, 2006 10:48
Località: Fra Trantor e Terminus
Slackware: 13.1 / 64 bit
Kernel: 3.3.x
Desktop: KDE 4.4.5

Re: Installazione drivers NVIDIA proprietari

Messaggioda brainvision » sab feb 25, 2012 10:54

ma scusa sei proprio sicuro che dipenda dal driver nVidia? Non potrebbe essere altrove l'errore?
Avatar utente
brainvision
Packager
Packager
 
Messaggi: 756
Iscritto il: ven dic 26, 2008 18:23
Località: bologna (bo)
Nome Cognome: Leonardo Totaro
Slackware: x86_64-current
Kernel: 3.7.1
Desktop: xfce 4.10

Re: Installazione drivers NVIDIA proprietari

Messaggioda aisalord » sab feb 25, 2012 11:52

Cerco di rispondere a tutti per fare un pò di chiarezza.
La versione da me installata è slackware 64 13.37, i driver nvidia sono i NVIDIA-Linux-x86_64-295.20.run
Ho installato il kernel 3.2.7 e ricompilatolo escludendo i driver nouveau, ho quindi installato i driver nvidia e dato alla fine nvidia-xconfig
Stesso risultato, schermo nero e freeze, ma almeno stavolta abbiamo un file di log!

Codice: Seleziona tutto
[    41.949] X.Org X Server 1.9.5 Release Date: 2011-03-17
[    41.950] X Protocol Version 11, Revision 0
[    41.950] Build Operating System: Slackware 13.37 Slackware Linux Project
[    41.950] Current Operating System: Linux darkstar 3.2.7 #1 SMP Fri Feb 24 21:33:24 CET 2012 x86_64
[    41.950] Kernel command line: BOOT_IMAGE=Linux_3.2.7 ro root=801 vt.default_utf8=0
[    41.950] Build Date: 17 March 2011  10:50:17PM
[    41.950] 
[    41.951] Current version of pixman: 0.20.2
[    41.951]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[    41.951] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    41.953] (==) Log file: "/var/log/Xorg.0.log", Time: Sat Feb 25 10:13:30 2012
[    42.026] (==) Using config file: "/etc/X11/xorg.conf"
[    42.026] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    42.100] (==) ServerLayout "Layout0"
[    42.100] (**) |-->Screen "Screen0" (0)
[    42.100] (**) |   |-->Monitor "Monitor0"
[    42.100] (**) |   |-->Device "Device0"
[    42.100] (**) |-->Input Device "Keyboard0"
[    42.100] (**) |-->Input Device "Mouse0"
[    42.100] (==) Automatically adding devices
[    42.100] (==) Automatically enabling devices
[    42.147] (WW) The directory "/usr/share/fonts/local" does not exist.
[    42.147]    Entry deleted from font path.
[    42.147] (WW) The directory "/usr/share/fonts/CID" does not exist.
[    42.147]    Entry deleted from font path.
[    42.147] (**) FontPath set to:
   /usr/lib64/X11/fonts/misc/:unscaled,
   /usr/lib64/X11/fonts/100dpi/:unscaled,
   /usr/lib64/X11/fonts/75dpi/:unscaled,
   /usr/lib64/X11/fonts/misc/,
   /usr/lib64/X11/fonts/Type1/,
   /usr/lib64/X11/fonts/Speedo/,
   /usr/lib64/X11/fonts/100dpi/,
   /usr/lib64/X11/fonts/75dpi/,
   /usr/lib64/X11/fonts/cyrillic/,
   /usr/lib64/X11/fonts/TTF/,
   /usr/share/fonts/TTF,
   /usr/share/fonts/OTF,
   /usr/share/fonts/Type1,
   /usr/share/fonts/misc,
   /usr/share/fonts/75dpi/:unscaled,
   /usr/share/fonts/100dpi/:unscaled,
   /usr/share/fonts/75dpi,
   /usr/share/fonts/100dpi,
   /usr/share/fonts/cyrillic
[    42.147] (==) ModulePath set to "/usr/lib64/xorg/modules"
[    42.147] (WW) AllowEmptyInput is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[    42.147] (WW) Disabling Keyboard0
[    42.147] (WW) Disabling Mouse0
[    42.147] (II) Loader magic: 0x7d2500
[    42.147] (II) Module ABI versions:
[    42.147]    X.Org ANSI C Emulation: 0.4
[    42.147]    X.Org Video Driver: 8.0
[    42.147]    X.Org XInput driver : 11.0
[    42.147]    X.Org Server Extension : 4.0
[    42.147] (--) PCI:*(0:2:0:0) 10de:0622:1043:82a1 rev 161, Mem @ 0xfd000000/16777216, 0xd0000000/268435456, 0xfa000000/33554432, I/O @ 0x0000e800/128, BIOS @ 0x????????/524288
[    42.147] (II) Open ACPI successful (/var/run/acpid.socket)
[    42.147] (II) LoadModule: "extmod"
[    42.204] (II) Loading /usr/lib64/xorg/modules/extensions/libextmod.so
[    42.223] (II) Module extmod: vendor="X.Org Foundation"
[    42.223]    compiled for 1.9.5, module version = 1.0.0
[    42.223]    Module class: X.Org Server Extension
[    42.223]    ABI class: X.Org Server Extension, version 4.0
[    42.223] (II) Loading extension MIT-SCREEN-SAVER
[    42.223] (II) Loading extension XFree86-VidModeExtension
[    42.223] (II) Loading extension XFree86-DGA
[    42.223] (II) Loading extension DPMS
[    42.223] (II) Loading extension XVideo
[    42.223] (II) Loading extension XVideo-MotionCompensation
[    42.223] (II) Loading extension X-Resource
[    42.223] (II) LoadModule: "dbe"
[    42.223] (II) Loading /usr/lib64/xorg/modules/extensions/libdbe.so
[    42.224] (II) Module dbe: vendor="X.Org Foundation"
[    42.224]    compiled for 1.9.5, module version = 1.0.0
[    42.224]    Module class: X.Org Server Extension
[    42.224]    ABI class: X.Org Server Extension, version 4.0
[    42.224] (II) Loading extension DOUBLE-BUFFER
[    42.224] (II) LoadModule: "glx"
[    42.224] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[    43.199] (II) Module glx: vendor="NVIDIA Corporation"
[    43.208]    compiled for 4.0.2, module version = 1.0.0
[    43.208]    Module class: X.Org Server Extension
[    43.208] (II) NVIDIA GLX Module  295.20  Mon Feb  6 21:28:16 PST 2012
[    43.208] (II) Loading extension GLX
[    43.208] (II) LoadModule: "record"
[    43.208] (II) Loading /usr/lib64/xorg/modules/extensions/librecord.so
[    43.227] (II) Module record: vendor="X.Org Foundation"
[    43.227]    compiled for 1.9.5, module version = 1.13.0
[    43.227]    Module class: X.Org Server Extension
[    43.227]    ABI class: X.Org Server Extension, version 4.0
[    43.227] (II) Loading extension RECORD
[    43.227] (II) LoadModule: "dri"
[    43.227] (II) Loading /usr/lib64/xorg/modules/extensions/libdri.so
[    43.239] (II) Module dri: vendor="X.Org Foundation"
[    43.239]    compiled for 1.9.5, module version = 1.0.0
[    43.239]    ABI class: X.Org Server Extension, version 4.0
[    43.239] (II) Loading extension XFree86-DRI
[    43.239] (II) LoadModule: "dri2"
[    43.239] (II) Loading /usr/lib64/xorg/modules/extensions/libdri2.so
[    43.253] (II) Module dri2: vendor="X.Org Foundation"
[    43.253]    compiled for 1.9.5, module version = 1.2.0
[    43.253]    ABI class: X.Org Server Extension, version 4.0
[    43.253] (II) Loading extension DRI2
[    43.253] (II) LoadModule: "nvidia"
[    43.253] (II) Loading /usr/lib64/xorg/modules/drivers/nvidia_drv.so
[    43.336] (II) Module nvidia: vendor="NVIDIA Corporation"
[    43.341]    compiled for 4.0.2, module version = 1.0.0
[    43.341]    Module class: X.Org Video Driver
[    43.364] (II) NVIDIA dlloader X Driver  295.20  Mon Feb  6 21:09:10 PST 2012
[    43.364] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[    43.374] (--) using VT number 7

[    43.378] (II) Loading sub module "fb"
[    43.378] (II) LoadModule: "fb"
[    43.379] (II) Loading /usr/lib64/xorg/modules/libfb.so
[    43.391] (II) Module fb: vendor="X.Org Foundation"
[    43.391]    compiled for 1.9.5, module version = 1.0.0
[    43.391]    ABI class: X.Org ANSI C Emulation, version 0.4
[    43.391] (II) Loading sub module "wfb"
[    43.391] (II) LoadModule: "wfb"
[    43.391] (II) Loading /usr/lib64/xorg/modules/libwfb.so
[    43.394] (II) Module wfb: vendor="X.Org Foundation"
[    43.394]    compiled for 1.9.5, module version = 1.0.0
[    43.394]    ABI class: X.Org ANSI C Emulation, version 0.4
[    43.394] (II) Loading sub module "ramdac"
[    43.394] (II) LoadModule: "ramdac"
[    43.394] (II) Module "ramdac" already built-in
[    43.422] (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
[    43.422] (==) NVIDIA(0): RGB weight 888
[    43.422] (==) NVIDIA(0): Default visual is TrueColor
[    43.422] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[    43.422] (**) NVIDIA(0): Option "UseDisplayDevice" "DFP"
[    43.422] (**) NVIDIA(0): Enabling 2D acceleration
[    53.349] (II) NVIDIA(GPU-0): Display (HannStar Display Corp JC198D (DFP-0)) does not
[    53.349] (II) NVIDIA(GPU-0):     support NVIDIA 3D Vision stereo.
[    53.355] (II) NVIDIA(0): NVIDIA GPU GeForce 9600 GT (G94) at PCI:2:0:0 (GPU-0)
[    53.355] (--) NVIDIA(0): Memory: 1048576 kBytes
[    53.355] (--) NVIDIA(0): VideoBIOS: 62.94.4b.00.00
[    53.355] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[    53.355] (--) NVIDIA(0): Interlaced video modes are supported on this GPU
[    53.355] (--) NVIDIA(0): Connected display device(s) on GeForce 9600 GT at PCI:2:0:0
[    53.355] (--) NVIDIA(0):     HannStar Display Corp JC198D (DFP-0)
[    53.355] (--) NVIDIA(0): HannStar Display Corp JC198D (DFP-0): 330.0 MHz maximum pixel
[    53.355] (--) NVIDIA(0):     clock
[    53.355] (--) NVIDIA(0): HannStar Display Corp JC198D (DFP-0): Internal Dual Link TMDS
[    56.357] (II) NVIDIA(0): Option "UseDisplayDevice" "DFP" converted to "DFP-0".
[    56.358] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
[    56.358] (**) NVIDIA(0):     device HannStar Display Corp JC198D (DFP-0) (Using EDID
[    56.358] (**) NVIDIA(0):     frequencies has been enabled on all display devices.)
[    56.376] (II) NVIDIA(0): Assigned Display Device: DFP-0
[    56.376] (==) NVIDIA(0):
[    56.376] (==) NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
[    56.376] (==) NVIDIA(0):     will be used as the requested mode.
[    56.376] (==) NVIDIA(0):
[    56.376] (II) NVIDIA(0): Validated modes:
[    56.376] (II) NVIDIA(0):     "nvidia-auto-select"
[    56.376] (II) NVIDIA(0): Virtual screen size determined to be 1280 x 1024
[    56.402] (--) NVIDIA(0): DPI set to (85, 86); computed from "UseEdidDpi" X config
[    56.402] (--) NVIDIA(0):     option
[    56.403] (--) Depth 24 pixmap format is 32 bpp
[    56.403] (II) NVIDIA: Using 768.00 MB of virtual memory for indirect memory access.


Ecco il contenuto dell'xorg.conf

Codice: Seleziona tutto
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 295.20  (buildmeister@swio-display-x86-rhel47-05.nvidia.com)  Mon Feb  6 22:13:40 PST 2012


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Module"
    Load "glx"
EndSection

Section "Files"
    FontPath        "/usr/lib64/X11/fonts/misc/:unscaled"
    FontPath        "/usr/lib64/X11/fonts/100dpi/:unscaled"
    FontPath        "/usr/lib64/X11/fonts/75dpi/:unscaled"
    FontPath        "/usr/lib64/X11/fonts/misc/"
    FontPath        "/usr/lib64/X11/fonts/Type1/"
    FontPath        "/usr/lib64/X11/fonts/Speedo/"
    FontPath        "/usr/lib64/X11/fonts/100dpi/"
    FontPath        "/usr/lib64/X11/fonts/75dpi/"
    FontPath        "/usr/lib64/X11/fonts/cyrillic/"
    FontPath        "/usr/lib64/X11/fonts/TTF/"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "UseDisplayDevice" "DFP"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection




Aiuto!!!!
aisalord
Linux 1.0
Linux 1.0
 
Messaggi: 10
Iscritto il: mer feb 22, 2012 17:41
Slackware: 13.37
Kernel: 2.6.37
Desktop: kde

Re: Installazione drivers NVIDIA proprietari

Messaggioda Plaoo » sab feb 25, 2012 12:13

Ma ci manca un pezzo del log?
Il canale ufficiale di slacky.eu si trova sui server irc.syrolnet.org canale #slackware
Avatar utente
Plaoo
Linux 2.6
Linux 2.6
 
Messaggi: 809
Iscritto il: gio apr 10, 2008 16:40
Località: Ittiri (SS)
Slackware: 14 64
Kernel: 3.2.9
Desktop: KDE

Prossimo

Torna a Slackware64

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite

cron