Repository 32bit  Forum
Repository 64bit  Wiki

Problema audio Host e Guest con Virtualbox

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Problema audio Host e Guest con Virtualbox

Messaggioda N1cuz » mer mar 14, 2012 19:31

Ho installato l'ultima versione di Virtualbox (4.10.1 mi pare) su Slackware64 13.0, funziona tutto, persino la webcam integrata (si tratta di un portatile), l'unico problema è che il sistema guest "monopolizza" l'audio, ossia con il sistema guest attivo non ho l'audio sul sistema host, terminando il guest l'audio sull'host ritorna a funzionare... Non mi ricordo bene ma mi pareva che con laversione 3.x di virtualbox questo problema non ci fosse.
Avatar utente
N1cuz
Linux 2.4
Linux 2.4
 
Messaggi: 279
Iscritto il: dom ott 05, 2008 23:41
Località: Pieve a Nievole (PT)
Nome Cognome: Nicola Bartolomei
Slackware: 13.0
Kernel: 2.6.29.6
Desktop: kde/lxde

Re: Problema audio Host e Guest con Virtualbox

Messaggioda miklos » gio mar 15, 2012 0:38

capita anche a me, non mi ricordo con versioni vecchie di virtualbox, ma con le ultime quando imposti l'audio hai a disposizione diversi backend (alsa, pulseaudio etc etc etc)
su una slackware regolare pulseaudio non c'e' quindi sei obbligato ad usare il backend alsa che è aime' esclusivo, il primo che lo occupa ne detiene l'accesso.
pulseaudio è invece un server audio che gestisce la concorrenza riguardo l'utilizzo del device audio.. quindi sto problema non ce l'hai.

a me non serve l'audio sulla macchina virtuale quindi ho risolto disabilitando la scheda audio emulata.

p.s: forse le vecchie versioni di virtualbox ti permettevano di usare come backend esd (che è anch'esso un server audio come pulseaudio) e quello è incluso in slackware.
ho visto cose che voi astemi non potete immaginare
miklos
Linux 3.x
Linux 3.x
 
Messaggi: 1200
Iscritto il: lun lug 16, 2007 16:39
Località: Roma
Slackware: 14.1 64bit
Kernel: 3.12.6
Desktop: openbox 3.5.2

Re: Problema audio Host e Guest con Virtualbox

Messaggioda N1cuz » gio mar 15, 2012 10:00

Grazie miklos, speravo che il backend oss potesse risolvere, ma niente.
Avatar utente
N1cuz
Linux 2.4
Linux 2.4
 
Messaggi: 279
Iscritto il: dom ott 05, 2008 23:41
Località: Pieve a Nievole (PT)
Nome Cognome: Nicola Bartolomei
Slackware: 13.0
Kernel: 2.6.29.6
Desktop: kde/lxde

Re: Problema audio Host e Guest con Virtualbox

Messaggioda 414N » gio mar 15, 2012 10:31

Prova a creare un dispositivo dmix in alsa, più o meno come suggerito qui.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2877
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Problema audio Host e Guest con Virtualbox

Messaggioda N1cuz » gio mar 15, 2012 10:58

414N ha scritto:Prova a creare un dispositivo dmix in alsa, più o meno come suggerito qui.


Ok, ma prima dovrò rivedere un pò di cose, non ho idea di cosa sia un dispositivo dmix... Comunque non ho capito una cosa, occore ricompilare SDL con il flag "-esd" o cos'altro? non mi è chiaro cosa s'intende per "rebuild the dependent packages" nel link che mi hai passato.
Ad ogni modo grazie mille.
Avatar utente
N1cuz
Linux 2.4
Linux 2.4
 
Messaggi: 279
Iscritto il: dom ott 05, 2008 23:41
Località: Pieve a Nievole (PT)
Nome Cognome: Nicola Bartolomei
Slackware: 13.0
Kernel: 2.6.29.6
Desktop: kde/lxde

Re: Problema audio Host e Guest con Virtualbox

Messaggioda 414N » gio mar 15, 2012 11:45

Quella è una pagina che si riferisce a gentoo, che fa uso di portage (un sistema per la compilazione da sorgenti di tutti i pacchetti) ed il flag "-esd" è probabilmente usato dall'ebuild (l'equivalente di uno SlackBuild per Slackware) per disabilitare il supporto ad esd durante la compilazione del pacchetto (una sorta di --disable-esd, per intenderci). Ignora la prima parte che riguarda la compilazione di un tot di pacchetti (non solo SDL o virtualbox) senza esd.
Quello che potrebbe darti uno spunto di soluzione lo trovi nella spiegazione del secondo problema e, soprattutto, nel file ~/.asoundrc riportato, che forza l'uso di un mixer software (tramite il plugin dmix) nel dispositivo di output di default di alsa.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2877
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Problema audio Host e Guest con Virtualbox

Messaggioda miklos » gio mar 15, 2012 19:21

414N ha scritto:Prova a creare un dispositivo dmix in alsa, più o meno come suggerito qui.
mi hai dato un bello spunto. non mi capita spesso di incrociare troppi programmi che usano la scheda audio, ma è sempre bene premunirsi per evitare noiose chiusure :)

comunque penso che il primo step sia usare uno slackbuild.
poi seguire il link di 414N.
ho visto cose che voi astemi non potete immaginare
miklos
Linux 3.x
Linux 3.x
 
Messaggi: 1200
Iscritto il: lun lug 16, 2007 16:39
Località: Roma
Slackware: 14.1 64bit
Kernel: 3.12.6
Desktop: openbox 3.5.2


Torna a Slackware64

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite