Pagina 3 di 4

Re: errori dopo ultimo aggiornamento a current

Inviato: mer mag 23, 2012 16:28
da targzeta
Ma quindi posso aggiornare tutto senza paura?

Emanuele

Re: errori dopo ultimo aggiornamento a current

Inviato: mer mag 23, 2012 17:13
da RedSkull92
conraid ha scritto:altra cosa strana, come ho scritto su LQ (non chiedermi di riscrivere, che tra mia scarsa conoscenza dell'inglese e ... lasciamo perdere va), ho provato adesso sul notebook, a 64bit, e non da quell'errore. Sul fisso a 32 sì. Boh... avrò dimenticato qualcosa, poi controllo meglio. Ma sembra tutto di default

UPDATE
sì, con tutto di default (oddio, decommentando la riga che include mod_php) ho questo

Codice: Seleziona tutto

SSH root@asustar:/etc/httpd# apachectl start
[Wed May 23 14:50:07.707395 2012] [:crit] [pid 2282:tid 3070101248] Apache is running a threaded MPM, but your PHP Module is not compiled to be threadsafe.  You need to recompile PHP.
AH00013: Pre-configuration failed

solo nella -current a 32 bit

per la cronaca
64bit:
# grep mpm httpd.conf
LoadModule mpm_event_module lib64/httpd/modules/mod_mpm_event.so
#LoadModule mpm_prefork_module lib64/httpd/modules/mod_mpm_prefork.so
#Include /etc/httpd/extra/httpd-mpm.conf

32bit
# grep mpm httpd.conf
LoadModule mpm_event_module lib/httpd/modules/mod_mpm_event.so
#Include /etc/httpd/extra/httpd-mpm.conf

Anche nella mia 32bit dà questo errore, infatti sono dovuto tornare al pacchetto della stable per far rifunzionare il tutto.

Re: errori dopo ultimo aggiornamento a current

Inviato: mer mag 23, 2012 18:18
da ermes
Amarok continua a darmi problemi.
ora vede le scalette, i file e si collega al Db di Mysql ma non riesce a riprodurre nulla... continua a scorrere la scaletta dei brani e dice che ci sono troppi errori :cry:
ho provato anche a svuotare il Db e fargli ricostruire tutto... ma non funziona proprio [-X

Re: errori dopo ultimo aggiornamento a current

Inviato: mer mag 23, 2012 18:27
da conraid
a me amarok funziona regolarmente. Ma qui sul notebook, dove ho un solo cd indicizzato. Quindi poco utile come test

Re: errori dopo ultimo aggiornamento a current

Inviato: mer mag 23, 2012 21:29
da ponce
se devo dire la verità anch'io ho testato la 64 (e un installazione pulita funziona senza problemi).
Domani mi installo una 32 e provo :)

Re: errori dopo ultimo aggiornamento a current

Inviato: gio mag 24, 2012 13:42
da rfringuello89
Disponibili nuovi pacchetti tra cui php e mysql... Vediamo un po' dopo l'upgrade..

Re: errori dopo ultimo aggiornamento a current

Inviato: gio mag 24, 2012 13:45
da conraid
rfringuello89 ha scritto:Disponibili nuovi pacchetti tra cui php e mysql... Vediamo un po' dopo l'upgrade..


ma dove? o stai ancora parlando di quelli di ieri?

Re: errori dopo ultimo aggiornamento a current

Inviato: gio mag 24, 2012 13:52
da rfringuello89
si credo siano di ieri!! non mi venivano visualizzare le pagine 2 e 3 di questo topic e quindi ho scritto la risposta pensando finisse tutto a pagina 1!

Re: errori dopo ultimo aggiornamento a current

Inviato: gio mag 24, 2012 17:28
da rfringuello89
Funziona tutto alla perfezione, perfino la connessione tramite NetBeans con il server Apache e il framework Hibernate!

Re: errori dopo ultimo aggiornamento a current

Inviato: gio mag 24, 2012 19:39
da targzeta
Quindi aggiorno anche io???

Emanuele

Re: errori dopo ultimo aggiornamento a current

Inviato: gio mag 24, 2012 20:24
da rfringuello89
A me funziona egregiamente.. Altro che mySql Administrator che usavo a scopo didattico e per giunta su windows!

Re: errori dopo ultimo aggiornamento a current

Inviato: ven mag 25, 2012 6:34
da ponce
n/php-5.4.3-x86_64-3.txz: Rebuilt.
Added --enable-maintainer-zts to the ./configure options.
It seems that this option was automatically enabled on the 64-bit side,
but not on 32-bit. I'm still not entirely sure why that happened. I
had a few theories about it, like perhaps httpd was running when one of
the PHP packages was compiled, but testing on 32-bit seemed to engage
ZTS at random. The only reliable way to make things work was to specify
the option explicitly, so that's what has been done. If it has to be
one way or the other, I think we want a thread-safe PHP that will work
with any httpd MPM. Let me know if there are still any issues, but it
should be working properly now.

Pat ha risposto anche su linuxquestions ;)

https://www.linuxquestions.org/question ... ost4686764

Re: errori dopo ultimo aggiornamento a current

Inviato: ven mag 25, 2012 11:09
da conraid
Finalmente qualcuno che ha capito la cosa :-' dovevo scrivere a lui fin dal'inizio :p

Ora scarico e provo, comunque come dicevo qualche post fa e come vorrei scrivere li se sapessi bene l'inglese, non è proprio un "problema", visto che quelli di PHP mettono warning ovunque relativi all'uso di mpm non prefork con mod_php. Però in effetti è strano questo comportamento del configure

Re: errori dopo ultimo aggiornamento a current

Inviato: ven mag 25, 2012 19:08
da ermes
finalmente sono riuscito a capire cosa non andava in amarok: il backend
alcune current fa avevo settato xine perché con gstreamer non funzionava (grazie a Corrado)
ora invece l'unico modo per farlo funzionare è quello di ritornare su gstreamer... vabbè!

continua ad avere problemi invece sul montaggio in kde degli hd esterni. Vengono rilevati, vengono aperti ma solo in lettura... le penne usb invece vanno normalmente.

qualcuno ha un'idea ? [-o<

Re: errori dopo ultimo aggiornamento a current

Inviato: ven mag 25, 2012 19:15
da conraid
ermes ha scritto:finalmente sono riuscito a capire cosa non andava in amarok: il backend
alcune current fa avevo settato xine perché con gstreamer non funzionava (grazie a Corrado)
ora invece l'unico modo per farlo funzionare è quello di ritornare su gstreamer... vabbè!

continua ad avere problemi invece sul montaggio in kde degli hd esterni. Vengono rilevati, vengono aperti ma solo in lettura... le penne usb invece vanno normalmente.

qualcuno ha un'idea ? [-o<


per gstreamer stai attento, che con il kernel 3.4 ha dei problemi con la versione in -current
http://slackblogs.blogspot.it/2012/05/u ... ugins.html

a me gli hd esterni vanno, tra l'altro non c'è differenza tra hd e usbpen, almeno che non abbiano filesystem diversi. Io gli hd esterni li ho solo ext3/4, le usbpen fat