Repository 32bit  Forum
Repository 64bit  Wiki

Domande alla prima installazione di Slackware

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Domande alla prima installazione di Slackware

Messaggioda Rod.M » gio giu 21, 2012 15:02

Ho 15 anni ed è la prima volta che installo Slackware...pensavo di essere molto più ferrato in ambito Linux dato che non ho avuto problemi con altre distro (Debian Sid, Arch...) ed invece dopo aver installato slackware (l'installazione è piuttosto semplice...magari perchè ho fatto la full) mi sono trovato in un mondo nuovo e maledettamente difficile.

il problema principale che ho è che non riesco a configurare la connessione wifi ( Ho blacklistato il modulo rt2870sta e la chiavetta funge, facendo iwlist wlan0 scan rileva la connessione ) ho letto alcuni post ma non riesco a settare la connessione

il secondo problema riguarda invece i pacchetti finora ho installato solo il pacchetto swaret per installare altri pacchetti con annesse dipendenze ma non riesco a trovare nessun pacchetto penso sia un problema di repo ma non riesco proprio a capire come funzionino quelli di slackware.

Grazie a tutti coloro che mi risponderanno
Rod.M
Linux 1.0
Linux 1.0
 
Messaggi: 21
Iscritto il: gio giu 21, 2012 14:47
Nome Cognome: Rodolfo Mariotti
Slackware: 14.0
Kernel: 3.2.29smp/3.6.7
Desktop: Xfce

Re: Domande alla prima installazione di Slackware

Messaggioda tornadomig » gio giu 21, 2012 15:17

ciao!

almeno wicd o networkmanager l'hai installato?
rm -rf / && rm -rf . && rm -rf *
Avatar utente
tornadomig
Linux 2.6
Linux 2.6
 
Messaggi: 507
Iscritto il: gio set 30, 2010 14:17
Nome Cognome: giorgio
Slackware: -curr64 uefi_grub
Kernel: 3.14.17
Desktop: KDE-4.14.0
Distribuzione: gentoo

Re: Domande alla prima installazione di Slackware

Messaggioda tornadomig » gio giu 21, 2012 15:19

e lascia perdere swaret, e' deprecato. e poi su slackware non esiste un vero "pacman" o "portage" o "synaptic", i cosiddetti manager dei pacchetti.

ti consiglio slackpkg per aggiornare il sistema e poi per i pacchetti aggiuntivi alla distribuzione usa gli slackbuilds o i binari di slacky per iniziare. i wiki ci sono :)

per ulteriori info basta chiedere :)

ma cosa hai installato? l'architettura e la versione intendo...grazie!
rm -rf / && rm -rf . && rm -rf *
Avatar utente
tornadomig
Linux 2.6
Linux 2.6
 
Messaggi: 507
Iscritto il: gio set 30, 2010 14:17
Nome Cognome: giorgio
Slackware: -curr64 uefi_grub
Kernel: 3.14.17
Desktop: KDE-4.14.0
Distribuzione: gentoo

Re: Domande alla prima installazione di Slackware

Messaggioda Rod.M » gio giu 21, 2012 16:02

Allora non ho installato nulla il kernel è quello di base a 64bit comunque pensavo che il networkmanager fosse gia incluso in kde
Rod.M
Linux 1.0
Linux 1.0
 
Messaggi: 21
Iscritto il: gio giu 21, 2012 14:47
Nome Cognome: Rodolfo Mariotti
Slackware: 14.0
Kernel: 3.2.29smp/3.6.7
Desktop: Xfce

Re: Domande alla prima installazione di Slackware

Messaggioda Vic Steele » gio giu 21, 2012 16:32

Ciao.

Riguardo alla prima domanda, sul ramo /extra della distribuzione puoi trovare wicd per la gestione grafica delle reti wireless. Se hai correttamente configurato il tuo dispositivo di rete non avrai nessun problema ad utilizzarlo.

Riguardo alla seconda, secondo me prima di puntare a un gestore automatico dei pacchetti dovresti provare ad usare gli SlackBuilds, la vera essenza della semplicità di Slackware. Se stai studiando questa distribuzione è obbligatorio approfondire, potresti anche imparare qualcosa sugli shell scripts e sulle patch.
Una risorsa che mette a disposizione tanti SlackBuilds è http://slackbuilds.org/ .
Tra i repository che ti danno invece dei pacchetti precompilati prova quello di Alien (dove comunque trovi gli SlackBuilds), e ovviamente quello del nostro sito.
Vic Steele
Linux 2.6
Linux 2.6
 
Messaggi: 534
Iscritto il: dom apr 27, 2008 12:46
Località: Potenza
Nome Cognome: Luigi Caiazza
Slackware: current x86_64
Kernel: 3.0.0
Desktop: Fluxbox / KDE 4.7.0
Distribuzione: Fedora 15

Re: Domande alla prima installazione di Slackware

Messaggioda Rod.M » gio giu 21, 2012 16:44

Allora il principale motivo per cui voglio usare questa distro è perchè voglio imparare quindi se ci sono guide da leggere ben venga, il pacchetto wicd che si trova nel dvd nella sezione extra non ha dipendenze?? posso installarlo disrettamente con installpkg???
Rod.M
Linux 1.0
Linux 1.0
 
Messaggi: 21
Iscritto il: gio giu 21, 2012 14:47
Nome Cognome: Rodolfo Mariotti
Slackware: 14.0
Kernel: 3.2.29smp/3.6.7
Desktop: Xfce

Re: Domande alla prima installazione di Slackware

Messaggioda erio » gio giu 21, 2012 17:59

quando hai installato wicd,dai questi comandi in un terminale o console: al riavvio dovresti avere l'icona wicd attiva
chmod +x /etc/rc.d/rc.wicd : con questo rendi eseguibile wicd
/etc/rc.d/rc.wicd start :questo fa partire il demone
erio
Linux 3.x
Linux 3.x
 
Messaggi: 1073
Iscritto il: ven ott 09, 2009 18:25
Slackware: 13.37
Kernel: 3.0.7
Desktop: kde

Re: Domande alla prima installazione di Slackware

Messaggioda tornadomig » gio giu 21, 2012 18:29

un consiglio a meno che tu non l'abbia già fatto: la creazione dell'utente, cioè te.

qundi a terminale da root #, come immagino tu sappia già, digita adduser e lo username che ti pare, per esempio sempre da root

Codice: Seleziona tutto
 # adduser rod


e vai avanti a rispondere al questionario curiosone ;)

per aggiungerti successivamente (cioè se non vuoi inserirti mentre compili il questionario) ai vari gruppi, ti faccio un esempio da root

Codice: Seleziona tutto
 # gpasswd -g rod lp
così ti aggiungi al gruppo delle stampanti, se ci tieni a stampare.


i gruppi li trovi in /etc/group


ciao e buon slack!

chiedi pure, nessuno si offende :thumbright:
rm -rf / && rm -rf . && rm -rf *
Avatar utente
tornadomig
Linux 2.6
Linux 2.6
 
Messaggi: 507
Iscritto il: gio set 30, 2010 14:17
Nome Cognome: giorgio
Slackware: -curr64 uefi_grub
Kernel: 3.14.17
Desktop: KDE-4.14.0
Distribuzione: gentoo

Re: Domande alla prima installazione di Slackware

Messaggioda Vic Steele » gio giu 21, 2012 18:57

Rod.M ha scritto:Allora il principale motivo per cui voglio usare questa distro è perchè voglio imparare quindi se ci sono guide da leggere ben venga, il pacchetto wicd che si trova nel dvd nella sezione extra non ha dipendenze?? posso installarlo disrettamente con installpkg???

Wicd non ha nessuna dipendenza che non sia stata già soddisfatta dall'installazione pulita del sistema operativo, quindi vai tranquillo.
In ogni caso, semmai dovessi installare a mano un pacchetto con qualche dipendenza non soddisfatta, puoi accorgerti delle librerie di cui hai bisogno leggendo l'output da terminale dell'applicazione non funzionante.
Vic Steele
Linux 2.6
Linux 2.6
 
Messaggi: 534
Iscritto il: dom apr 27, 2008 12:46
Località: Potenza
Nome Cognome: Luigi Caiazza
Slackware: current x86_64
Kernel: 3.0.0
Desktop: Fluxbox / KDE 4.7.0
Distribuzione: Fedora 15

Re: Domande alla prima installazione di Slackware

Messaggioda Rod.M » gio giu 21, 2012 19:16

Allora ho installato wicd e funziona solo che quando configuro la rete metto password ip dns ecc e faccio connect restituisce un errore : Bad password...premetto che la password è corretta e ho un altro pc con arch e wicd che riesce a connettersi.
Puo essere che wpa_supplicant non è installato???
Rod.M
Linux 1.0
Linux 1.0
 
Messaggi: 21
Iscritto il: gio giu 21, 2012 14:47
Nome Cognome: Rodolfo Mariotti
Slackware: 14.0
Kernel: 3.2.29smp/3.6.7
Desktop: Xfce

Re: Domande alla prima installazione di Slackware

Messaggioda Plaoo » gio giu 21, 2012 20:35

Rod.M se vuoi usare un pkg manager usa slapt-get, ti aggiusti i mirror (ti consigli di aggiungere anche quelli di salixos) e sei ok. Però non stai usando più una slackware "pura", ma fai tu sei libero di fare ciò che vuoi ;). Ah e benvenuto :D
Il canale ufficiale di slacky.eu si trova sui server irc.syrolnet.org canale #slackware
Avatar utente
Plaoo
Linux 2.6
Linux 2.6
 
Messaggi: 809
Iscritto il: gio apr 10, 2008 16:40
Località: Ittiri (SS)
Slackware: 14 64
Kernel: 3.2.9
Desktop: KDE

Re: Domande alla prima installazione di Slackware

Messaggioda tornadomig » gio giu 21, 2012 20:47

se dai da root

Codice: Seleziona tutto
# ls /var/log/packages|grep wpa_supplicant


dovresti scoprire che e' gia' installato, suppongo io
rm -rf / && rm -rf . && rm -rf *
Avatar utente
tornadomig
Linux 2.6
Linux 2.6
 
Messaggi: 507
Iscritto il: gio set 30, 2010 14:17
Nome Cognome: giorgio
Slackware: -curr64 uefi_grub
Kernel: 3.14.17
Desktop: KDE-4.14.0
Distribuzione: gentoo

Re: Domande alla prima installazione di Slackware

Messaggioda Rod.M » ven giu 22, 2012 8:42

si è installato ma non capisco dove sia l'errore ho settato il network come sull'altro pc l'unica diffrerenza è che sull'altro pc la password è impostata su wpa 1/2 esadecimale ma su questo wicd non me lo fa impostare
EDIT: forse sarebbe meglio mettere da parte wicd e configurare la rete manualmente, magari imparo qualcosa. Potreste linkarmi una bella guida possibilmente sintetica
Rod.M
Linux 1.0
Linux 1.0
 
Messaggi: 21
Iscritto il: gio giu 21, 2012 14:47
Nome Cognome: Rodolfo Mariotti
Slackware: 14.0
Kernel: 3.2.29smp/3.6.7
Desktop: Xfce

Re: Domande alla prima installazione di Slackware

Messaggioda tornadomig » ven giu 22, 2012 11:03

aspetta, non drammatizziamo, magari è una menata

se wicd è installato (e tu me lo hai confermato), l' iconcina è presente quindi in basso a dx, ok? il demone di wicd è attivato allora, lo leggi anche durante i vari logs del bootstrap.

ci posti per cortesia

Codice: Seleziona tutto
# iwlist scan


e postaci anche

Codice: Seleziona tutto
# lspci


e vediamo di conoscere se il sistema la vede. se non fosse pci la tua scheda wifi, digita

Codice: Seleziona tutto
lsusb
rm -rf / && rm -rf . && rm -rf *
Avatar utente
tornadomig
Linux 2.6
Linux 2.6
 
Messaggi: 507
Iscritto il: gio set 30, 2010 14:17
Nome Cognome: giorgio
Slackware: -curr64 uefi_grub
Kernel: 3.14.17
Desktop: KDE-4.14.0
Distribuzione: gentoo

Re: Domande alla prima installazione di Slackware

Messaggioda Rod.M » ven giu 22, 2012 13:41

Allora la chiavetta funge e le reti le trova è un problema di password...Metto IP DNS password e restituisce un errore : Bad password sul wicd di arch sull'alto pc è presente di default la WPA 1/2 esadecimale qui invece no
cos'è un logos del bootstrap
Grazie
Rod.M
Linux 1.0
Linux 1.0
 
Messaggi: 21
Iscritto il: gio giu 21, 2012 14:47
Nome Cognome: Rodolfo Mariotti
Slackware: 14.0
Kernel: 3.2.29smp/3.6.7
Desktop: Xfce

Prossimo

Torna a Slackware64

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti