Pagina 1 di 1

Kwifimanager errore al confiigure

Inviato: mar nov 20, 2012 20:17
da DarkNeo
Salve, stavo installando kwifimanager, al configure mi da questo errore:
checking for Qt... configure: error: Qt (>= Qt 3.0.2) (headers and libraries) not found. Please check your installation!
For more details about this problem, look at the end of config.log.

L'unico problema è che io le ho installate queste Qt e ho sia le 3.3.8 che le 4.5.8.
Sapete perchè?
Grazie

Re: Kwifimanager errore al confiigure

Inviato: mer nov 21, 2012 17:06
da DarkNeo
Grazie a questa guida ho scoperto qualcosa di nuovo http://www.linuxfromscratch.org/blfs/view/6.3/x/qt.html.
Pare riguardi un problema di PATH della libreria qt-mt all'interno della qt3, solo che non ci capisco niente avete qualche idea?

Re: Kwifimanager errore al confiigure

Inviato: mer nov 21, 2012 17:21
da DarkNeo
ho provato dando
./configure --with-qt-libraries=/opt/kde3/lib/libqt-mt.so.3
e da sempre lo stesso errore, allora ho provato
./configure --disable-mt
cambia l'errore e diventa
checking for Qt... configure: error: Qt (>= Qt 3.0.2) (library qt) not found. Please check your installation!
For more details about this problem, look at the end of config.log.

Re: Kwifimanager errore al confiigure

Inviato: lun nov 26, 2012 17:40
da 414N
Su quale versione di Slackware stai provando a compilare kwifimanager?
Controlla quale switch del configure (tramite configure --help) permette di specificare la directory nella quale cercare le QT3.
Nel caso fosse proprio "--with-qt-libraries", allora dovresti indicare solo la directory che contiene le QT3 e non un singolo file di libreria.

Re: Kwifimanager errore al confiigure

Inviato: mer nov 28, 2012 18:48
da DarkNeo
Ciao,
sto lavorando sulla 14.0, adesso provo a fare come mi hai consigliato e posto il risultato.
Grazie

Re: Kwifimanager errore al confiigure

Inviato: mer nov 28, 2012 20:19
da 414N
Ma le qt3 sulla Slackware 14.0 come ce le hai messe?

Re: Kwifimanager errore al confiigure

Inviato: gio nov 29, 2012 1:19
da DarkNeo
Le ho scaricate dal repository del sito

Re: Kwifimanager errore al confiigure

Inviato: gio nov 29, 2012 2:25
da DarkNeo
niente da sempre lo stesso errore.

Re: Kwifimanager errore al confiigure

Inviato: gio nov 29, 2012 9:27
da 414N
Devo dedurre che hai scaricato il pacchetto per Slackware 14.0 a 32 bit (non c'è a 64 bit sul repo di slacky) e tu stai usando Slackware64 14.0 (altrimenti non avresti scelto questo forum per questo thread).
Confermi?

Re: Kwifimanager errore al confiigure

Inviato: gio nov 29, 2012 18:37
da DarkNeo
Confermo

Re: Kwifimanager errore al confiigure

Inviato: gio nov 29, 2012 18:46
da 414N
Beh, allora la vedo un po' dura:
  • Se non hai installato le multilib di alien, qualsiasi roba a 32 bit non funzionerà sul tuo sistema;
  • Anche dopo averle installate, non vedo il motivo di usare le qt-3 a 32 bit su un sistema a 64;
  • kwifimanager era un programma per KDE3, che ovviamente necessiterà di un tot di librerie di kde3 anche solo per compilarsi;
  • anche arrivando in fondo alla compilazione (ne dubito fortemente ma Natale è vicino e non si sa mai) dubito che il programma possa funzionare correttamente
Il che porta alla domanda fatidica da 1 milione di dollari: perché stai cercando di compilartelo da sorgenti su un sistema che difficilmente lo farà girare? Non sei soddisfatto da wicd o networkmanager?

Re: Kwifimanager errore al confiigure

Inviato: ven nov 30, 2012 15:35
da DarkNeo
Allora, ti do perfettamente ragione a pormi questa domanda, ti spiego subito.
Ho installato e pare funzioni wicd, solo che ho scoperto dell'esistenza di questo programma ieri,
NetworkManager non mi funziona non mi rileva la wlan0 e l'eth0 di conseguenza non c'ho perso tanto tempo a capire i perchè.
kwifimanager l'ho scelto perchè mi sembrava il piu chiaro tra tutti per utilizzare un tool grafico wifi.
Comunque per principio installerò queste librerie per i programmi a 32 bit al fine di vedere funzionante kwifimanager

Re: Kwifimanager errore al confiigure

Inviato: ven nov 30, 2012 18:51
da 414N
DarkNeo ha scritto:Allora, ti do perfettamente ragione a pormi questa domanda, ti spiego subito.
Ho installato e pare funzioni wicd, solo che ho scoperto dell'esistenza di questo programma ieri,
NetworkManager non mi funziona non mi rileva la wlan0 e l'eth0 di conseguenza non c'ho perso tanto tempo a capire i perchè.

Probabilmente perché non hai avviato il demone di networkmanager dopo aver disattivato wicd. Assicurati che /etc/rc.d/rc.wicd non abbia permesso di esecuzione e che /etc/rc.d/rc.networkmanager ce l'abbia, invece.
DarkNeo ha scritto:kwifimanager l'ho scelto perchè mi sembrava il piu chiaro tra tutti per utilizzare un tool grafico wifi.

Può darsi, ma rimane un programma per KDE 3.4. Slackware 14.0 "monta" KDE 4.8 di suo, e ti assicuro che tra le versioni 3.x e 4.x di KDE sussistono notevoli differenze architetturali, percui non puoi neanche sperare di compilare kwifimanager su KDE 4.
Se proprio ti sei "fissato" su kwifimanager, potresti provare con Trinity desktop, che mira a tenere in vita KDE 3.x sulle ultime distribuzioni... Se n'è parlato anche in questo thread su slacky.eu, nel quale sono presenti link a pacchetti già precompilati per Slackware64 14.0.
DarkNeo ha scritto:Comunque per principio installerò queste librerie per i programmi a 32 bit al fine di vedere funzionante kwifimanager

Non ti basteranno le librerie a 32 bit, in quanto dovrai ricompilarti mezzo KDE 3.x solo per compilare kwifimanager e, dalla via che lo ricompili, tanto vale compilare a 64 bit tutto a partire dalle qt-3.

Re: Kwifimanager errore al confiigure

Inviato: ven nov 30, 2012 19:45
da DarkNeo
Credo che sia meglio affidarmi alla tua esperienza e non entrare in tunnel dai quali non saprei uscirne vivo. Ora che funziona correttamente Network Manager e wicd non mi vado ad impelagare in situazioni assurde.
Grazie comunque dell'attenzione
Stefano