Repository 32bit  Forum
Repository 64bit  Wiki

[Risolto]: Multilib pacchetto 32bit + problema Java

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

[Risolto]: Multilib pacchetto 32bit + problema Java

Messaggioda james2221 » ven giu 28, 2013 14:41

ciao
Slack 86_64 xfce4.10
Installazione di 15gg fa circa.
Ho installato le multilib e ci ho fatto funzionare Draftsight (programma 32bit autocad 2D) e wine. Quest'ultimo l'ho disinstallato perchè tutto sommato non mi serviva, con draftsight ci ho lavorato, pertanto fino a un paio di giorni fa tutto ok.
Questa mattina draftsight non si apre, vado di terminale e mi dice:
Codice: Seleziona tutto
bash-4.2$ /opt/dassault-systemes/draftsight/bin/draftsight
/opt/dassault-systemes/draftsight/bin/draftsight: line 32: /opt/dassault-systemes/draftsight/bin/draftsight.bin: No such file or directory
bash-4.2$
mentre invece draftsight/bin esiste. Mi pare di ricordare che quel tipo di errore, ovvero file not found, indichi oltetutto che l'architettura non corrisponde. Reinstallato il pacchetto ma l'errore persiste.
Draftsight e wine erano gli ultimi pacchetti installati, però ho provato altri programmi cad (come da thread recente) credo un paio, non di piu, e non ricordo di aver installato dipendenze: tutto sommato draftsight fa al caso mio pertanto alle prime difficoltà ho desistito.
Datosi che non ho altre indicazioni da trminale come potrei cercare altrimenti?
Grazie
Ultima modifica di james2221 il mar lug 30, 2013 16:35, modificato 3 volte in totale.
james2221
Linux 2.4
Linux 2.4
 
Messaggi: 200
Iscritto il: dom feb 06, 2011 0:28
Località: brescia
Slackware: 14 86_64
Desktop: xfce4.10

Re: Multilib: pacchetto 32bit non va più

Messaggioda 414N » dom lug 07, 2013 9:40

Hai altri programmi a 32 bit installati sul sistema, per verificare che funzionino ancora?
Quale pacchetto di wine avevi installato?
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2881
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Multilib: pacchetto 32bit non va più

Messaggioda ZeroUno » dom lug 07, 2013 20:03

ldd /opt/dassault-systemes/draftsight/bin/draftsight.bin
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4345
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: Multilib: pacchetto 32bit non va più

Messaggioda james2221 » lun lug 08, 2013 17:14

ciao
In effetti avevo pensato di installare un qualsiasi altro pacchetto a 32bit ma in questi giorni sono stato fuori e non ne ho avuto l'opportunità.
Wine l' ho preso da AlienBob http://slackware.com/~alien/slackbuilds/wine/pkg64/14.0/ . Prima che installassi le multilib non funzionava, dopo andava benissimo. L'ho rimosso solo perchè non mi serviva un granchè (ovvero: avrei voluto farci funzionare alcuni programmi specifici per il mio lavoro che ho su windows ma al primo riscontro negativo ho desistito).
Con Draftsight ci ho lavorato per qualche giorno. E' pur vero che ho provato altri programmi Cad ma draftsight ho continuato ad usarlo anche successivamente.
In merito a
Codice: Seleziona tutto
bash-4.2$ ldd /opt/dassault-systemes/draftsight/bin/draftsight
   not a dynamic executable
bash-4.2$
ovviamente il file ha la casella spuntata come eseguibile.
Un'altra cosa, che non ho messo nel titolo per non appesantirlo, è che anche java non c'è più (faccio riferimento a questo mio recente post )http://www.slacky.eu/forum/viewtopic.php?f=51&t=37012
Codice: Seleziona tutto
bash-4.2$  . /etc/profile
piero@darkstar:~$ which java
which: no java in (/usr/local/bin:/usr/bin:/bin:/usr/games:/usr/lib64/qt/bin:/usr/share/texmf/bin:.)
piero@darkstar:~$
. Il test nel sito di Oracle invece me lo da per installato e funzionante.
Ricapitolando: di punto in bianco non va piu un programma a 32 bit (draftsifgt) e java scompare.
Cosa mai posso aver combinato ?
grazie

Riedito per completezza di informazione: ci sarebbe stato un guaio anche con virtualbox ma, avendone una certa urgenza, l'ho risolto ancora prima di aprire questo thread. Magari c'entra niente, ma...
james2221
Linux 2.4
Linux 2.4
 
Messaggi: 200
Iscritto il: dom feb 06, 2011 0:28
Località: brescia
Slackware: 14 86_64
Desktop: xfce4.10

Re: Multilib: pacchetto 32bit non va più

Messaggioda 414N » lun lug 08, 2013 21:08

Una cosa alla volta...
ldd l'hai lanciato sullo script che richiamerà, in modo opportuno, il vero binario (che è draftsight.bin come riporta l'errore nel tuo primo post).
Assicurati di avere ancora installate le glibc multilib (l'errore è tipico del non averle installate). Se hai eseguito aggiornamenti con slackpkg senza aver messo in blacklist i pacchetti multliib potresti averli sovrascritti con le versioni a 64 bit puri.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2881
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Multilib: pacchetto 32bit non va più

Messaggioda james2221 » dom lug 14, 2013 16:37

grazie @414N
1) draftsight 32bit per multilib: ora va, ho reinstallato le multilib di AlienBob
Codice: Seleziona tutto
bash-4.2# installpkg /home/piero/Dati/Linuxx/DownLoadSlack/14.0/*.txz

ma vorrei evitare di doverlo rifare al prossimo aggiornamento, qualche dritta sulla blacklist?

2) wuala(programma per cloud) e java: java è scomparso, pertanto wuala non parte. Probabilmente farei più in fretta a reinstallarlo seguendo il link che avevo seguito in precedenza http://docs.slackware.com/howtos:software:java ma mi farebbe piacere riparare il tutto in modo piu scientifico.
Codice: Seleziona tutto
bash-4.2$ which java
which: no java in (/usr/local/bin:/usr/bin:/bin:/usr/games:/usr/lib64/qt/bin:/usr/share/texmf/bin:.)
bash-4.2$  . /etc/profile
piero@darkstar:~$ which java
which: no java in (/usr/local/bin:/usr/bin:/bin:/usr/games:/usr/lib64/qt/bin:/usr/share/texmf/bin:.)
piero@darkstar:~$



ciao
grazie
james2221
Linux 2.4
Linux 2.4
 
Messaggi: 200
Iscritto il: dom feb 06, 2011 0:28
Località: brescia
Slackware: 14 86_64
Desktop: xfce4.10

Re: Multilib: pacchetto 32bit non va più

Messaggioda 414N » dom lug 14, 2013 18:21

james2221 ha scritto:grazie @414N
1) draftsight 32bit per multilib: ora va, ho reinstallato le multilib di AlienBob
Codice: Seleziona tutto
bash-4.2# installpkg /home/piero/Dati/Linuxx/DownLoadSlack/14.0/*.txz

ma vorrei evitare di doverlo rifare al prossimo aggiornamento, qualche dritta sulla blacklist?

Spero tu abbia usato installpkg dopo un removepkg, altrimenti ti troverai dei bei doppioni nella lista dei pacchetti con conseguente "broncio" da parte di slackpkg al prossimo upgrade...
In caso contrario, rimuovi i pacchetti vecchi (tanto i file in comune con quelli nuovi non verranno toccati) con removepkg, prima di proseguire.
Per non sovrascrivere i pacchetti di alien (in generale, non solo i multlib) puoi aggiungere a /etc/slackpkg/blacklist la seguente riga:
Codice: Seleziona tutto
[0-9]+alien

sfruttando il fatto che i suoi pacchetti riportano sempre "alien" nel tag.
james2221 ha scritto:2) wuala(programma per cloud) e java: java è scomparso, pertanto wuala non parte. Probabilmente farei più in fretta a reinstallarlo seguendo il link che avevo seguito in precedenza http://docs.slackware.com/howtos:software:java ma mi farebbe piacere riparare il tutto in modo piu scientifico.
Codice: Seleziona tutto
bash-4.2$ which java
which: no java in (/usr/local/bin:/usr/bin:/bin:/usr/games:/usr/lib64/qt/bin:/usr/share/texmf/bin:.)
bash-4.2$  . /etc/profile
piero@darkstar:~$ which java
which: no java in (/usr/local/bin:/usr/bin:/bin:/usr/games:/usr/lib64/qt/bin:/usr/share/texmf/bin:.)
piero@darkstar:~$


Controlla se hai ancora un qualche pacchetto java (jre o jdk o openjdk) installato facendo un bel
Codice: Seleziona tutto
ls -l /var/log/packages/j*

In caso negativo, procedi pure con la reinstallazione di un pacchetto appropriato alle tue esigenze di java.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2881
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Multilib: pacchetto 32bit non va più

Messaggioda ZeroUno » dom lug 14, 2013 21:49

oppure usare slackpkg+ che supporta l'aggiornamento delle multilib di alienbob e altro.
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4345
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: Multilib: pacchetto 32bit non va più

Messaggioda james2221 » dom lug 21, 2013 7:33

BuonaDomenicaMattina
Il caro leader 414N scrive
Spero tu abbia usato installpkg dopo un removepkg, altrimenti ti troverai dei bei doppioni nella lista dei pacchetti con conseguente "broncio" da parte di slackpkg
ed effettivamente dovrò andar giù pesante con pkgtool, ma non sarà un problema, ho messo i pacchetti di AlienBob nella blacklist come da suggerimento per cui questione N° 01 risolta.
Problema java: mi ritrovo nella stessa identica situazione di un mio recente thread http://www.slacky.eu/forum/viewtopic.php?f=51&t=37012. Se si vuole riapriamo l'altro o proseguiamo qui, fatemi sapere.
La situazione è, brevemente, la seguente:
ho reinstallato java jre come da wiki dando prima un removepkg http://docs.slackware.com/howtos:software:java, la pagina di Oracle mi conferma tutto ok, ma il comando
Codice: Seleziona tutto
piero@darkstar:~$ which java
which: no java in (/usr/local/bin:/usr/bin:/bin:/usr/games:/usr/lib64/kde4/libexec:/usr/lib64/qt/bin:/usr/share/texmf/bin:.)
piero@darkstar:~$
non trova niente. Notare che ho spento e riacceso e dato un
Codice: Seleziona tutto
piero@darkstar:~$ . /etc/profile
, nonostante questo il sito del cloud wuala sta facendo girare a vuoto il pirolino alla ricerca spasmodica di Java. Praticamente tutto come nel thread precedente ma con una diversa conclusione: là avevo risolto, qua nulla.
Per sicurezza ho rimosso e reinstallato ma siamo sempre lì.
Un' altra domanda: ma java funziona solo con firefox o anche con altri browser ? perchè Opera non me lo vede nemmeno di striscio. O devo configurarlo, appunto, anche con Opera ?

grazie


Riedito: essendo sicuro che java esiste ho dato questo comando
Codice: Seleziona tutto
root@darkstar:~# cp /usr/lib64/qt/bin/java/java /usr/bin/
pertanto adesso java me lo trova, solo che non trova questa libreria
Codice: Seleziona tutto
libjli.so
che è in ben 4 posizioni ma evidentemente non in quella giusta, ho provata seguendo alcuni suggerimenti del web a spostarla in varie directory nel filesystem ma ovviamente non posso riempire l'hd con i link a 'sta libreria.
Dove la piazzo ?

grazie
james2221
Linux 2.4
Linux 2.4
 
Messaggi: 200
Iscritto il: dom feb 06, 2011 0:28
Località: brescia
Slackware: 14 86_64
Desktop: xfce4.10

Re: Multilib: pacchetto 32bit non va più

Messaggioda 414N » dom lug 21, 2013 20:12

james2221 ha scritto:BuonaDomenicaMattina
Il caro leader 414N scrive
Spero tu abbia usato installpkg dopo un removepkg, altrimenti ti troverai dei bei doppioni nella lista dei pacchetti con conseguente "broncio" da parte di slackpkg
ed effettivamente dovrò andar giù pesante con pkgtool, ma non sarà un problema, ho messo i pacchetti di AlienBob nella blacklist come da suggerimento per cui questione N° 01 risolta.

Bene, un problema in meno
PS: leader? :?:
james2221 ha scritto:Problema java: mi ritrovo nella stessa identica situazione di un mio recente thread http://www.slacky.eu/forum/viewtopic.php?f=51&t=37012. Se si vuole riapriamo l'altro o proseguiamo qui, fatemi sapere.
La situazione è, brevemente, la seguente:
ho reinstallato java jre come da wiki dando prima un removepkg http://docs.slackware.com/howtos:software:java, la pagina di Oracle mi conferma tutto ok, ma il comando
Codice: Seleziona tutto
piero@darkstar:~$ which java
which: no java in (/usr/local/bin:/usr/bin:/bin:/usr/games:/usr/lib64/kde4/libexec:/usr/lib64/qt/bin:/usr/share/texmf/bin:.)
piero@darkstar:~$
non trova niente. Notare che ho spento e riacceso e dato un
Codice: Seleziona tutto
piero@darkstar:~$ . /etc/profile
, nonostante questo il sito del cloud wuala sta facendo girare a vuoto il pirolino alla ricerca spasmodica di Java. Praticamente tutto come nel thread precedente ma con una diversa conclusione: là avevo risolto, qua nulla.

Cerchiamo di arrivarci in fondo una volta per tutte. Se hai seguito la wiki, allora hai creato un pacchetto di Java (jre o jdk) tramite lo SlackBuild sul disco di installazione di Slackware, fornendogli il percorso su file system del tarball scaricato dal sito della Oracle, giusto?
Riporta, per cortesia, l'output di
Codice: Seleziona tutto
ls -l /etc/profile.d/
così vediamo come è impostato lo script che imposta le variabili d'ambiente per java.
james2221 ha scritto:Un' altra domanda: ma java funziona solo con firefox o anche con altri browser ? perchè Opera non me lo vede nemmeno di striscio. O devo configurarlo, appunto, anche con Opera ?

Non credo che Opera richieda della configurazione extra, ma di più non so dirti dato che non l'ho mai usato.
james2221 ha scritto:Riedito: essendo sicuro che java esiste ho dato questo comando
Codice: Seleziona tutto
root@darkstar:~# cp /usr/lib64/qt/bin/java/java /usr/bin/
pertanto adesso java me lo trova, solo che non trova questa libreria
Codice: Seleziona tutto
libjli.so
che è in ben 4 posizioni ma evidentemente non in quella giusta, ho provata seguendo alcuni suggerimenti del web a spostarla in varie directory nel filesystem ma ovviamente non posso riempire l'hd con i link a 'sta libreria.
Dove la piazzo ?

Qui la faccenda puzza... Che ci fa il binario di java sotto /usr/lib64/qt/bin? Dovrebbe essere solo sotto /usr/lib64/java/bin/.
Io aspetterei prima di provare queste "copie artigianali".
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2881
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Multilib: pacchetto 32bit non va più

Messaggioda james2221 » lun lug 22, 2013 15:53

Ciao
ti allego l'output richiesto
Codice: Seleziona tutto
root@darkstar:~# ls -l /etc/profile.d/
total 104
-rw-r--r-- 1 root root  918 May 22 14:02 32dev.csh
-rw-r--r-- 1 root root 1096 May 22 14:02 32dev.sh
-rwxr-xr-x 1 root root 1551 Sep  4  2012 coreutils-dircolors.csh*
-rwxr-xr-x 1 root root 1822 Sep  4  2012 coreutils-dircolors.sh*
-rwxr-xr-x 1 root root  328 Mar 27  2011 glibc.csh*
-rwxr-xr-x 1 root root  325 Sep 14  2006 glibc.sh*
-rwxr-xr-x 1 root root   32 Dec  9  2010 gtk+.csh*
-rwxr-xr-x 1 root root   44 Dec  9  2010 gtk+.sh*
-rwxr-xr-x 1 root root  276 Aug  7  2012 kde.csh*
-rwxr-xr-x 1 root root  263 Aug  7  2012 kde.sh*
-rwxr-xr-x 1 root root 1199 Feb 16  2004 lang.csh*
-rwxr-xr-x 1 root root 1197 Feb 16  2004 lang.sh*
-rwxr-xr-x 1 root root  999 Mar 27  2011 libglib2.csh*
-rwxr-xr-x 1 root root  982 Mar 18  2008 libglib2.sh*
-rwxr-xr-x 1 root root   51 Nov 29  2008 mc.csh*
-rwxr-xr-x 1 root root   45 Nov 29  2008 mc.sh*
-rwxr-xr-x 1 root root  200 Jul 29  2010 pkgconfig.csh*
-rwxr-xr-x 1 root root  210 Jul 29  2010 pkgconfig.sh*
-rwxr-xr-x 1 root root  667 Aug 30  2012 qt4.csh*
-rwxr-xr-x 1 root root  567 Aug 30  2012 qt4.sh*
-rw-r--r-- 1 root root 1812 Sep 10  2012 scim.csh
-rw-r--r-- 1 root root 1740 Sep 10  2012 scim.sh
-rwxr-xr-x 1 root root   50 Aug 10  2012 t1lib.csh*
-rwxr-xr-x 1 root root   63 Aug 10  2012 t1lib.sh*
-rwxr-xr-x 1 root root  134 Apr 24  2000 tetex.csh*
-rwxr-xr-x 1 root root  118 Apr 24  2000 tetex.sh*
root@darkstar:~#
che per me ha la stessa chiarezza della stele di Rosetta.
Ieri, per non stare con le mani in mano, ho spulciato il web e ho trovato la giusta posizione alla libreria libjli.so aggiungendo il percorso al file /etc/ld-so.conf del quale ti riporto il testo
Codice: Seleziona tutto
/usr/local/lib
/usr/x86_64-slackware-linux/lib
/usr/lib64/qt/bin
/usr/lib

adesso manca quest' altra libreria
Codice: Seleziona tutto
piero@darkstar:~$ /home/piero/wuala/wuala
Running on display :0.0
/usr/bin/java
Error: could not find libjava.so
Error: Could not find Java SE Runtime Environment.
piero@darkstar:~$
e, pur utilizzando il metodo "ficcalo-dentro-una-directory-qualsiasi-che prima-di-sera-ce-la-fai", non ci sono riuscito. Su google, anche relativamente a Slack, trovo dei suggerimenti ma sono chiaramente obsoleti, relativi a percorsi che non esistono ecc, Lo stesso vale tentando di fare dei paralleli tra Arch, Debian e Slack.
Nella mia santa ingenuità pensavo che i percorsi fossero univoci o quanto meno ci fosse uno script che dicesse: la tal libreria la prendi qui, la talaltra là, ecc.
Stante la mia incapacità ce la caveremo per Natale ?

grazie per la pazienza

O.T.: leader arriva da una associazione di idee: Iper Master > Leader

Ciao
un'ultima domanda: le notizie "scorrevoli" che si leggono sui quotidiani on-line necessitano di java? perchè con Firefox tutto funge, con Opera no, motivo della mia domanda di ieri
ma java funziona solo con firefox o anche con altri browser ? perchè Opera non me lo vede nemmeno di striscio.
james2221
Linux 2.4
Linux 2.4
 
Messaggi: 200
Iscritto il: dom feb 06, 2011 0:28
Località: brescia
Slackware: 14 86_64
Desktop: xfce4.10

Re: Multilib: pacchetto 32bit non va più

Messaggioda ZeroUno » mar lug 23, 2013 22:48

non so gli altri, ma io non riesco a capire quale java hai installata (open, oracle, versione, pacchetto, tarball, slackbuild...), dove l'hai scaricata e come l'hai installata.

Dall'output dell'ls che ti é stato richiesto sembra che non hai usato un pacchetto slackware (mancano i file jre o jdk).

E non trovo la risposta all'ls /var/log/packages per cercare 'jdk' o 'jre' o 'openjdk' o 'openjre'.

Confermo quanto detto da 414N riguardo a java che é sotto qt/

darei un 'locate bin/java' (se da errore lanciare prima il comando 'updatedb' che impiegherà qualche minuto per la elaborazione)

la libreria di java dovrà essere linkata poi in /usr/lib64/mozilla/plugins
tutti i browser la cercheranno lì, incluso opera.

Per i testi scorrevoli dipende dal sito. Alcuni usano java, altri flash, altri javascript (che non centra nulla con java) altri solo html avanzato (per non entrare nei dettagli)
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4345
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: Multilib: pacchetto 32bit non va più

Messaggioda james2221 » mer lug 24, 2013 13:27

ciao
in effetti c'è stata una contaminazione di thread, l'originale è questo http://www.slacky.eu/forum/viewtopic.php?f=51&t=37012#p331868 poi c' è stato un problema di lib32-64 e le cose si sono un po' mischiate, era certamente meglio proseguire di là, ma tant'è...
Riassumo: ho seguito questo wiki chè è ufficiale http://docs.slackware.com/howtos:software:java, ho scaricato il seguente pacchetto da Oracle
Codice: Seleziona tutto
jre-7u25-linux-x64.tar.gz
che mi ritrovo in /var/log/packages/e installato il tutto con lo SlackBuild del DVD di Slackware 14, come, appunto, da wiki. Il sito di Oracle mi conferma che java c'è e funziona.
il comando locate mi dà
Codice: Seleziona tutto
root@darkstar:~# locate bin/java
/usr/bin/java
/usr/lib64/libreoffice/sdk/bin/javamaker
/usr/lib64/libreoffice/ure/bin/javaldx
/usr/lib64/qt/bin/java
/usr/lib64/qt/bin/java/libjli.so
/usr/lib64/qt/bin/java/java
/usr/lib64/java/bin/java_vm
/usr/lib64/java/bin/java
/usr/lib64/java/bin/javaws
/usr/lib64/jvm/bin/javah
/usr/lib64/jvm/bin/javac
/usr/lib64/jvm/bin/java
/usr/lib64/jvm/bin/javadoc
/usr/lib64/jvm/jre/bin/java
root@darkstar:~#

Lo script per wuala
Codice: Seleziona tutto
piero@darkstar:~$ /home/piero/wuala/wuala
Running on display :0.0
/usr/bin/java
Error: could not find libjava.so
Error: Could not find Java SE Runtime Environment.
piero@darkstar:~$
non trova libjava.so, inizialmente il comando
Codice: Seleziona tutto
$ which java
non trovava java, l'ho posizionato io in /usr/bin/, poi mancava la libreria libjli.so che son riuscito a sistemare, adesso tocca a libjava.so. Mi pare strano che lo SlackBuild di java piazzi i file in alcune directory e poi li vada a cercare in altre.

Che faccio ? cambio titolo al thread? ed eventualmente come lo chiamo ?

Grazie
james2221
Linux 2.4
Linux 2.4
 
Messaggi: 200
Iscritto il: dom feb 06, 2011 0:28
Località: brescia
Slackware: 14 86_64
Desktop: xfce4.10

Re: Multilib: pacchetto 32bit non va più

Messaggioda ZeroUno » mer lug 24, 2013 14:56

già é più chiaro.

Continua ad essere strano che manca jre.sh in profile.d
quando hai lanciato lo slackbuild suppongo che tu abbia copiato in locale lo slackbuild e _tutti_ gli altri file che si trovano nel cd, giusto?
Verifica il contenuto di /var/log/packages/jre*

il plugin per il browser te lo dovresti ritrovare nel path /usr/lib64/mozilla/plugins

metti l'url 'about:plugins' su firefox e assicurati che la versione di java é quella che hai installata.

Opera é a 64bit?

E' opportuno cominciare a capire cosa hai fatto la scorsa volta per risolvere e cosa hai fatto da allora ad oggi perché a mio parere hai un casino su quella installazione
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4345
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: Multilib: pacchetto 32bit non va più

Messaggioda james2221 » mer lug 24, 2013 16:11

ciao
in /var/log/packages/ mi ritrovo /var/log/packages/jre-7u25-x86_64-1 e basta.
Quando ho fatto la installazione ho seguito pedissequamente il wiki, ovvero ho scaricato la piu recente versione di java in una directory dedicata ~/Downloads/JAVA/ , copiato dal DVD tutti i file nella medesima (da /media/SlackDVD/extra/java/ ho 1 directory e 4 file) e dato:
Codice: Seleziona tutto
root@darkstar:~# cd /home/piero/Downloads/JAVA/
root@darkstar:~# ./java.SlackBuild jre-7u25-linux-x64.tar.gz
root@darkstar:~# upgradepkg --install-new  /tmp/jre-7u25-x86_64-1.txz

La installazione è andata a buon fine ma, come si dice, operazione riuscita ma paziente defunto.
Peraltro sia Opera che Firefox mi confermano, con about:plugins, java installato, verificato anche dall'apposita pagina di Oracle.
libjava.so che è mancante me la ritrovo in
Codice: Seleziona tutto
root@darkstar:~# locate libjava.so
/usr/lib64/java/lib/amd64/jli/libjava.so
/usr/lib64/java/lib/amd64/libjava.so
/usr/lib64/jvm/jre/lib/amd64/client/libjava.so
root@darkstar:~#
ma evidentemente non al posto giusto.

Opera è a 64bit ma, pur rigraziandoti, lo lascerei stare, al momento, mi va meglio di Firefox e le scritte che non scorrono nn soono certo un problema, ho tirato fuori il discorso perchè pensavo ci potesse essere un nesso.

Grazie ciao
james2221
Linux 2.4
Linux 2.4
 
Messaggi: 200
Iscritto il: dom feb 06, 2011 0:28
Località: brescia
Slackware: 14 86_64
Desktop: xfce4.10

Prossimo

Torna a Slackware64

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite