Pagina 1 di 3

Mplayer non legge DVD

Inviato: mar dic 10, 2013 19:13
da varjag
Buona sera
Uso slackware64-14.1 multilib aggiornata.
Installazione full.
Mplayer quello di default presente in installazione ufficiale.
Ho un DVD che contiene vecchi canzoni che si shelgono tramite menu.
Quando lancio gmplayer DVD si apre e suona penso solo primo albom e non c'e menu. Qundi non si puo navigare.Su DVD ci sono 31 albom.
Che si fa?
Ho provato di aggiungere libdvdnav, libdvdcss e mplayer-codecs ma non cambia niente.
Devo aggiungere qualche codec o devo ricompilare mplayer?

Codice: Seleziona tutto

gmplayer
MPlayer 1.1-4.8.2 (C) 2000-2012 MPlayer Team
(gmplayer:2197): Gdk-WARNING **: Attempt to draw a drawable with depth 24 to a drawable with depth 32

Playing dvd://1.
libdvdread: Encrypted DVD support unavailable.
libdvdread: Attempting to use device /dev/loop1 mounted on /home/varjag/iso for CSS authentication
libdvdread: Could not open input: Permission denied
libdvdread: Can't open /dev/loop1 for reading
libdvdread: Device /dev/loop1 inaccessible, CSS authentication not available.
There are 9 titles on this DVD.
There are 1 angles in this DVD title.
audio stream: 0 format: ac3 (stereo) language: en aid: 128.
number of audio channels on disk: 1.
subtitle ( sid ): 0 language: en
number of subtitles on disk: 1

MPEG-PS file format detected.
VIDEO:  MPEG2  720x576  (aspect 2)  25.000 fps  8000.0 kbps (1000.0 kbyte/s)
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
libavcodec version 54.23.100 (internal)
Selected video codec: [ffmpeg2] vfm: ffmpeg (FFmpeg MPEG-2)
==========================================================================
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 48000 Hz, 2 ch, s16le, 192.0 kbit/12.50% (ratio: 24000->192000)
Selected audio codec: [ffac3] afm: ffmpeg (FFmpeg AC-3)
==========================================================================
[AO OSS] audio_setup: Can't open audio device /dev/dsp: No such file or directory
AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO: [xv] 720x576 => 768x576 Planar YV12
[mpeg2video @ 0xe99d40]ac-tex damaged at 25 0
[mpeg2video @ 0xe99d40]Warning MVs not available
[mpeg2video @ 0xe99d40]concealing 1620 DC, 1620 AC, 1620 MV errors
A:   0.5 V:   0.3 A-V:  0.144 ct:  0.012   5/  5 ??% ??% ??,?% 0 0                                                       

Too many audio packets in the buffer: (4096 in 8254176 bytes).
Maybe you are playing a non-interleaved stream/file or the codec failed?
For AVI files, try to force non-interleaved mode with the -ni option.
A:   0.8 V:   0.3 A-V:  0.500 ct:  0.192   5/  5 ??% ??% ??,?% 913 0                                                     


           ************************************************
           **** Your system is too SLOW to play this!  ****
           ************************************************

Possible reasons, problems, workarounds:
- Most common: broken/buggy _audio_ driver
  - Try -ao sdl or use the OSS emulation of ALSA.
  - Experiment with different values for -autosync, 30 is a good start.
- Slow video output
  - Try a different -vo driver (-vo help for a list) or try -framedrop!
- Slow CPU
  - Don't try to play a big DVD/DivX on a slow CPU! Try some of the lavdopts,
    e.g. -vfm ffmpeg -lavdopts lowres=1:fast:skiploopfilter=all.
- Broken file
  - Try various combinations of -nobps -ni -forceidx -mc 0.
- Slow media (NFS/SMB mounts, DVD, VCD etc)
  - Try -cache 8192.
- Are you using -cache to play a non-interleaved AVI file?
  - Try -nocache.
Read DOCS/HTML/en/video.html for tuning/speedup tips.
If none of this helps you, read DOCS/HTML/en/bugreports.html.

A:   5.3 V:   0.3 A-V:  4.996 ct: -0.736   5/  5 ??% ??% ??,?% 17334 0                                                   


Exiting... (Quit)

Poi mi da che il computer è lento.
é un i7.
Grazie in anticipo per aiuto

Re: Mplayer non legge DVD

Inviato: mar dic 10, 2013 21:59
da gyrodeck
Ricompila mplayer dopo che hai installato libdvdnav e libdvdcss ed in fase di compilazione controlla con ./configure --help (mi pare che sia questo il comando oppure prova -h o --h o -help)che tutte le opzioni che ti interessano siano abilitate.Probabilmente questo è un passaggio inutile perche' se non ricordo male ,e' molto tempo che non ricompilo mplayer, le varie opzioni si abilitano automaticamente se trovano la libreria corrispondente installata.

Re: Mplayer non legge DVD

Inviato: mar dic 10, 2013 23:02
da Blallo
Ho caricato MPlayer per slackware 64 bit sul nostro repository con abilitato tutto quello che ti serve.
Scaricalo da li già impacchettato :)

Re: Mplayer non legge DVD

Inviato: mer dic 11, 2013 1:42
da varjag
Infatti chiedevo proprio per questo.
Devo rimuovere mplayer di slackware o semplicemente scarico Mplayer di repository di slacky con tutte dipendenze e installo?
o devo rimuovere qualcosa per non romperele dipendenze o pacchetti?

Re: Mplayer non legge DVD

Inviato: lun dic 23, 2013 12:16
da Rama
anche a me Mplayer non va, e a quanto ricordo ho sempre tribolato per farlo andare, ma con Xine o Kaffeine non c'è problema;
la cosa è abbastanza strana, se non erro Xine si appoggia a Mplayer

r

Re: Mplayer non legge DVD

Inviato: mar dic 24, 2013 12:36
da Trotto@81
Rama ha scritto:anche a me Mplayer non va, e a quanto ricordo ho sempre tribolato per farlo andare, ma con Xine o Kaffeine non c'è problema;
la cosa è abbastanza strana, se non erro Xine si appoggia a Mplayer

r
Non è mai stato così!! Xine va settato nelle impostazioni dopo aver installato le librerie necessaria o non leggerà mai i DVD.

Re: Mplayer non legge DVD

Inviato: ven gen 10, 2014 20:29
da varjag
buona sera
mi scuso per sparizione
sono all'estero e non avevo per un periodo acesso all'internet
Volevo usare MPlayer di slacky perche MPlayer di default non mi legge DVD che ho descritto prima.
Visto numerose dipendenze necessarie ho installato slakyd per scaricare automaticamente le dipendenze necessarie
come repository ho messo : http://repository.slacky.eu/slackware64-14.1/
ho dato

Codice: Seleziona tutto

bash-4.2# slackyd -u

poi

Codice: Seleziona tutto

bash-4.2# slackyd -g MPlayer
Searching MPlayer: found 1 package.

MPlayer-1.1.1-x86_64-1sl.txz [from slacky]

*** MPlayer-1.1.1-x86_64-1sl.txz: already installed (MPlayer-1.1_20130819-x86_64-2).

All packages available are installed.

Ho letto la guida di slackyd ma probabilmente non ho capito tutto.
Prima devo rimuovere MPlayer-1.1_20130819-x86_64-2?
con opzione slacky -g si scaricano anche le dipendenze?
dove sbaglio?
grazie in anticipo

Re: Mplayer non legge DVD

Inviato: ven gen 10, 2014 22:01
da gyrodeck
Mi sembra di capire che Mplayer non ti funziona ancora.Perche' non provi ad installare tutto a mano?Vai su Slacky,repository 14.1, 64 bit,cerchi Mplayer,lo scarichi e scarichi anche tutte le dipendenze che sono elencate,installi prima le dipendenze e poi Mplayer.Magari invece di dare upgradepkg prima cancelli il programma precedentemente installato e cancelli anche la directory con i files di configurazione che sta in root .A me funziona.

Re: Mplayer non legge DVD

Inviato: ven gen 10, 2014 22:09
da varjag
certo che lo posso fare manualmente, ma visto che ci sono tante dipendenze volevo sfruttare topic per studiare qualcosa di nuovo per me come slackyd

Re: Mplayer non legge DVD

Inviato: ven gen 10, 2014 22:11
da Trotto@81
Credo che la tua risposta sia nello slackbuild di MPlayer. Tra l'altro la compilazione non è nemmeno gravosa per un normale PC.

Re: Mplayer non legge DVD

Inviato: ven gen 10, 2014 22:50
da varjag
si certo che non è gravoso ricompilare MPlayer..magari un po gravoso ricompilare tutte dipendenze per questo volevo usare slakyd e MPlayer di slaky..

Re: Mplayer non legge DVD

Inviato: ven gen 10, 2014 23:08
da tornadomig
ok...non sono stato a leggere tutto fin dall'inizio e per questo chiedo umilmente scusa ma nel mio caso per riprodurre un dvd di un film o di un bel concerto mi basta installare libdvdnav e smplayer dal repo di slackbuilds.org, libdvdcss dal repo restricted-slackbuilds di alienbob. tutto cio' sempre e soltanto mantenendo mplayer che e' gia' in slackware. ci installo pure mplayer-plugins dal dvd di installazione dalla directory /extra. per vedere il risultato basta andare nei componenti aggiuntivi - plugins di firefox.
ho detto solo la mia sperando di non aver annoiato alcuno... :)

Re: Mplayer non legge DVD

Inviato: ven gen 17, 2014 16:03
da varjag
Allora vi aggiorno che la mia avventura con MPlayer continua...comunque ho provato in tutti i modi e non riesco leggere Menu di quello DVD che ho scritto prima..Mi apre sempre solo parte del menu , e non dall'inizio, parte direttamente dal menu di terzo o 4 albom.
VLC apre questo DVD senza problemi e legge tutto menu i mi pemette di navigare dentro.
1. Ho scaricato tutti i pachetti del MPlayer e MPlayer stesso dall slacky.eu , installato ma risultatto è lo stesso.
2. Ho compilatto tutti i pachetti neccessari usando slackbuilds di SBo, ho compilato anche MPlayer , pero usando slackbuilds del slacky.eu --- il risultato è lo stesso.
I pachetti libdvdcss, libdvdnav, libdvdread certamente sono installati. Per questi paccheti ho usato slackbuilds di SBo.
Ho dimenticato qualcosa,o non do informazione sufficiente ?
Buon weekend a tutti

Re: Mplayer non legge DVD

Inviato: ven gen 17, 2014 20:00
da brg
Io ho sempre avuto problemi con mplayer ed i menù dei DVD.

Re: Mplayer non legge DVD

Inviato: dom gen 19, 2014 11:31
da varjag
probabilmente il problema è di MPlayer proprio...e non di installazione sbagliata o qualche libreria mancante