Audio a scatti e disturbatissimo

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
sunreal
Master
Master
Messaggi: 1599
Iscritto il: dom apr 10, 2005 0:00
Slackware: 14.1
Desktop: kde
Località: P.P.P.

Audio a scatti e disturbatissimo

Messaggioda sunreal » sab nov 14, 2015 15:40

Ancora io.....
Sarà che erano anni che non cambiavo più hardware e nonostante le numerose reinstallazioni di slack non avevo più avuto problemi.... Ma in questi giorni è un inferno....
Ora mi sono accorto di avere problemi di audio, i video su youtube e su player hanno l'audio che si sente a scatti, se cerco di ascoltare un mp3 sembra di ascoltare una voce aliena.
Ho cercato una soluizone ma o non ne ho trovate o non capito come applicarle.... però ho dato un bel pò di comandi di cui vi posto l' output:
bash-4.2$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC887-VD Analog [ALC887-VD Analog]
Subdevices: 0/1
Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC887-VD Digital [ALC887-VD Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: HDMI 1 [HDMI 1]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 8: HDMI 2 [HDMI 2]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 9: HDMI 3 [HDMI 3]
Subdevices: 1/1
Subdevice #0: subdevice #0


bash-4.2$ alsactl init
bash: alsactl: command not found

bash-4.2$ cat /etc/modprobe.d/alsa.conf
cat: /etc/modprobe.d/alsa.conf: File o directory non esistente

bash-4.2$ cat /proc/asound/modules
0 snd_hda_intel
1 snd_hda_intel

bash-4.2$ cat /proc/asound/card*/codec* | grep Codec
Codec: Realtek ALC887-VD
Codec: Nvidia GPU 40 HDMI/DP

bash-4.2$ cat /proc/asound/cards
0 [Intel ]: HDA-Intel - HDA Intel
HDA Intel at 0xf7210000 irq 44
1 [NVidia ]: HDA-Intel - HDA NVidia
HDA NVidia at 0xf7080000 irq 17
La cosa che mi salta all' occhio è che risulano due schede audio immagino che la nvidia sia integrata alla gtx760, non so se questo può creare problemi.
Grazie

sunreal
Master
Master
Messaggi: 1599
Iscritto il: dom apr 10, 2005 0:00
Slackware: 14.1
Desktop: kde
Località: P.P.P.

Re: Audio a scatti e disturbatissimo

Messaggioda sunreal » dom nov 15, 2015 1:50

In attesa di consigli, ho trovato questo errore
aplay -D plughgw:0,0 test.wav
ALSA lib pcm.c:2239:(snd_pcm_open_noupdate) Unknown PCM plughgw:0,0
aplay: main:722: audio open error: File o directory non esistente
ho provato anche
aplay -D plughgw:0,1 test.wav
aplay -D plughgw:1,0 test.wav
aplay -D plughgw:1,1 test.wav
stesso errore.
Nella guida che stavo seguendo diceva di creare il file /etc/asound.conf e scrivere questo:

defaults.pcm.card 1
defaults.pcm.device 0
defaults.ctl.card 1

Al riavvio kde mi accoglie con:
KDE ha rilevato che uno o più dispositivi interni sono stati rimossi.
Vuoi che KDE ignori in modo permanente questi dispositivi?
Uscita: HDA Intel, ALC887-VD Analog (Default Audio Device)

e tentando di riprodurre un mp3, vlc:
Uscita audio non riuscita:
Il dispositivo audio "default" non può essere utilizzato:
File o directory non esistente.

In asound.conf ho provato anche:
pcm.!default {
type hw
card 1
device 0
}
ctl.!defaulttype hw
card 1
}

Stessi risultati
Ho creato il file /etc/modprobe.d/sound.conf ed anche alsa-base.conf
con la riga
options snd_hda_intel index=1 model=auto

nada de nada.....
Please help
grazie

sunreal
Master
Master
Messaggi: 1599
Iscritto il: dom apr 10, 2005 0:00
Slackware: 14.1
Desktop: kde
Località: P.P.P.

Re: Audio a scatti e disturbatissimo

Messaggioda sunreal » dom nov 15, 2015 9:54

Nonostante credo di aver rimesso tutto a posto, all' avvio kde mi dice:
KDE ha rilevato che uno o più dispositivi interni sono stati rimossi.
Vuoi che KDE ignori in modo permanente questi dispositivi?
Questo è l'elenco dei dispositivi che KDE crede si possano rimuovere:
Acquisizione: HDA Intel (ALC887-VD Analog)
Uscita: HDA Intel (ALC887-VD Analog)

???????????
Sempre audio agghiacciante.....

Avatar utente
brg
Linux 2.x
Linux 2.x
Messaggi: 442
Iscritto il: sab mar 12, 2011 14:20
Slackware: 14.2
Kernel: 4.4.38
Desktop: KDE4
Località: Montecatini
Contatta:

Re: Audio a scatti e disturbatissimo

Messaggioda brg » dom nov 15, 2015 10:29

Se digiti

Codice: Seleziona tutto

aplay -l
che cosa vedi nel terminale?

sunreal
Master
Master
Messaggi: 1599
Iscritto il: dom apr 10, 2005 0:00
Slackware: 14.1
Desktop: kde
Località: P.P.P.

Re: Audio a scatti e disturbatissimo

Messaggioda sunreal » dom nov 15, 2015 10:53

brg ha scritto:Se digiti

Codice: Seleziona tutto

aplay -l
che cosa vedi nel terminale?

bash-4.2$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC887-VD Analog [ALC887-VD Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC887-VD Digital [ALC887-VD Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: HDMI 1 [HDMI 1]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 8: HDMI 2 [HDMI 2]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 9: HDMI 3 [HDMI 3]
Subdevices: 1/1
Subdevice #0: subdevice #0

Avatar utente
brg
Linux 2.x
Linux 2.x
Messaggi: 442
Iscritto il: sab mar 12, 2011 14:20
Slackware: 14.2
Kernel: 4.4.38
Desktop: KDE4
Località: Montecatini
Contatta:

Re: Audio a scatti e disturbatissimo

Messaggioda brg » dom nov 15, 2015 11:11

Lì è tutto ok, usa il comando:

Codice: Seleziona tutto

aplay -D plughw:0,0 test.wav


mi raccomando "plughw" e non "plughwg"...

sunreal
Master
Master
Messaggi: 1599
Iscritto il: dom apr 10, 2005 0:00
Slackware: 14.1
Desktop: kde
Località: P.P.P.

Re: Audio a scatti e disturbatissimo

Messaggioda sunreal » dom nov 15, 2015 14:07

brg ha scritto:Lì è tutto ok, usa il comando:

Codice: Seleziona tutto

aplay -D plughw:0,0 test.wav


mi raccomando "plughw" e non "plughwg"...


bash-4.2$ aplay -D plughw:0,0 test.wav
test.wav: File o directory non esistente

Avatar utente
brg
Linux 2.x
Linux 2.x
Messaggi: 442
Iscritto il: sab mar 12, 2011 14:20
Slackware: 14.2
Kernel: 4.4.38
Desktop: KDE4
Località: Montecatini
Contatta:

Re: Audio a scatti e disturbatissimo

Messaggioda brg » dom nov 15, 2015 14:54

Ovviamente test.wav dev'essere un file wav presente nella directory in cui esegui il comando :-s

Comunque questo dovrebbe andare:

Codice: Seleziona tutto

aplay -D plughw:0,0 /usr/share/sounds/alsa/Front_Center.wav

sunreal
Master
Master
Messaggi: 1599
Iscritto il: dom apr 10, 2005 0:00
Slackware: 14.1
Desktop: kde
Località: P.P.P.

Re: Audio a scatti e disturbatissimo

Messaggioda sunreal » dom nov 15, 2015 19:53

brg ha scritto:Ovviamente test.wav dev'essere un file wav presente nella directory in cui esegui il comando :-s

Comunque questo dovrebbe andare:

Codice: Seleziona tutto

aplay -D plughw:0,0 /usr/share/sounds/alsa/Front_Center.wav

:oops: :oops: :oops: :oops: :oops: :oops: :oops:

bash-4.2$ aplay -D plughw:0,0 /usr/share/sounds/alsa/Front_Center.wav
Playing WAVE '/usr/share/sounds/alsa/Front_Center.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Mono
underrun!!! (at least 0,001 ms long)
underrun!!! (at least 0,001 ms long)

bash-4.2$ aplay -D plughw:0,0 /usr/share/sounds/alsa/africa.wav
Playing WAVE '/usr/share/sounds/alsa/africa.wav' : Unsigned 8 bit, Rate 22050 Hz, Mono

africa.wav è un file che ci ho messo io preso da internet per fare due prove.
Comunque non si sente quasi nulla, in entrambe i casi

Avatar utente
brg
Linux 2.x
Linux 2.x
Messaggi: 442
Iscritto il: sab mar 12, 2011 14:20
Slackware: 14.2
Kernel: 4.4.38
Desktop: KDE4
Località: Montecatini
Contatta:

Re: Audio a scatti e disturbatissimo

Messaggioda brg » dom nov 15, 2015 20:48

Ok, avevo avuto un problema simile sul fisso, ma ora non l'ho qui e non mi ricordo quale fosse la soluzione, né quale chipset ci sia montato.

Ho visto che su un forum di Debian consigliano di creare il file "/etc/modprobe.d/alsa-base.conf" e di includervi la seguente riga:

Codice: Seleziona tutto

options snd-hda-intel model=generic


Ovvero ti basta dare il seguente comando come utente di root:

Codice: Seleziona tutto

echo options snd-hda-intel model=generic >> /etc/modprobe.d/alsa-base.conf

sunreal
Master
Master
Messaggi: 1599
Iscritto il: dom apr 10, 2005 0:00
Slackware: 14.1
Desktop: kde
Località: P.P.P.

Re: Audio a scatti e disturbatissimo

Messaggioda sunreal » dom nov 15, 2015 21:22

brg ha scritto:Ok, avevo avuto un problema simile sul fisso, ma ora non l'ho qui e non mi ricordo quale fosse la soluzione, né quale chipset ci sia montato.

Ho visto che su un forum di Debian consigliano di creare il file "/etc/modprobe.d/alsa-base.conf" e di includervi la seguente riga:

Codice: Seleziona tutto

options snd-hda-intel model=generic


Ovvero ti basta dare il seguente comando come utente di root:

Codice: Seleziona tutto

echo options snd-hda-intel model=generic >> /etc/modprobe.d/alsa-base.conf

Fatto!
Ma nonostante un leggero (edit: leggerissimo quasi assente) miglioramento l' audio rimane pessimo
e kde ha "reagito" così:
KDE ha rilevato che uno o più dispositivi interni sono stati rimossi.
Vuoi che KDE ignori in modo permanente questi dispositivi?
Questo è l'elenco dei dispositivi che KDE crede si possano rimuovere:
Acquisizione: HDA Intel (ALC887-VD Analog)
Acquisizione: HDA Intel, ALC887-VD Analog (Default Audio Device)
Uscita: HDA Intel (ALC887-VD Analog)
Uscita: HDA Intel, ALC887-VD Analog (Default Audio Device)

sunreal
Master
Master
Messaggi: 1599
Iscritto il: dom apr 10, 2005 0:00
Slackware: 14.1
Desktop: kde
Località: P.P.P.

Re: Audio a scatti e disturbatissimo

Messaggioda sunreal » lun nov 16, 2015 1:59

C'è una cosa strana, mi sono accorto che alcuni mp3 quando tento di aprirli con xmms o xine o mplayer sembra che non vengono suonati, ma nel display dell' applicazione appaiono le info del brano. Mentre altri file vengono "letti" nel solito modo orripilante.

rik70
Master
Master
Messaggi: 1943
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.2
Kernel: 4.18
Desktop: Xfce 4.12
Distribuzione: archlinux

Re: Audio a scatti e disturbatissimo

Messaggioda rik70 » lun nov 16, 2015 10:08

Riporta tutto a default - compresi eventuali .asoundrc/asound.conf - e prova questa opzione:

Codice: Seleziona tutto

options snd-hda-intel enable_msi=0

sunreal
Master
Master
Messaggi: 1599
Iscritto il: dom apr 10, 2005 0:00
Slackware: 14.1
Desktop: kde
Località: P.P.P.

Re: Audio a scatti e disturbatissimo

Messaggioda sunreal » lun nov 16, 2015 12:35

rik70 ha scritto:Riporta tutto a default - compresi eventuali .asoundrc/asound.conf - e prova questa opzione:

Codice: Seleziona tutto

options snd-hda-intel enable_msi=0

Ciao
ho eliminato il precedente file che era in /etc/modprobe.d/alsa-base.conf, poi ho dato: alsactl store, ho controllato nella home non c'è alcun file .asoundrc e nessun file trovato con slocate asound.conf.
Ho dato questoi comando: echo options snd-hda-intel enable_msi=0 >> /etc/modprobe.d/alsa-base.conf
Purtroppo nessun cambiamento.
Però mi chiedo perchè ora, nel senso da un paio di giorni, kde all' avvio mi accoglie con:
KDE ha rilevato che uno o più dispositivi interni sono stati rimossi.
Vuoi che KDE ignori in modo permanente questi dispositivi?
Questo è l'elenco dei dispositivi che KDE crede si possano rimuovere:
Acquisizione: HDA Intel (ALC887-VD Analog)
Acquisizione: HDA Intel, ID 887 Analog (Default Audio Device)
Uscita: HDA Intel (ALC887-VD Analog)
Uscita: HDA Intel, ID 887 Analog (Default Audio Device)
Forse qualche prova che ho fatto ha creato "danni" permanenti al sistema audio?

sunreal
Master
Master
Messaggi: 1599
Iscritto il: dom apr 10, 2005 0:00
Slackware: 14.1
Desktop: kde
Località: P.P.P.

Re: Audio a scatti e disturbatissimo

Messaggioda sunreal » lun nov 16, 2015 13:26

Tanto per capire come si sentono gli mp3:
http://dropcanvas.com/XQTYmp1pS0B9Ij
Questa invece è la registrazione dell' audio da youtube, che a parte qualche scatto non si sente malissimo, ma quando metto il filmato in pausa... Fa una specie di eco.
http://dropcanvas.com/#X6T841AX79QyT1