skype_static per slackware64-14.2

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
ZeroUno
Staff
Staff
Messaggi: 5195
Iscritto il: ven giu 02, 2006 14:52
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current
Località: Roma / Castelli
Contatta:

skype_static per slackware64-14.2

Messaggioda ZeroUno » sab lug 16, 2016 0:38

Sto tentando di aggiornare il pacchettone skype_static che dalla 14.1 ad oggi ha visto molte vicissitudini, tra cui l'aggiunta del supporto pulse (sia le librerie a 32 bit sia il pacchetto inside a 64bit) che non era ancora in current, poi la rimozione a favore di apulse, ed ora l'aggiornamento di tutte le librerie per slackware 14.2

tante librerie sono state aggiornate tra la 14.1 e la 14.2, ma tra queste finora una sola mi sta dando rogne.
Le librerie aggiornate si stanno portando appresso anche altre dipendenze, che però non sono molte-
Ma skype dipende anche da libQtWebKit.so.4 che - se gli fai un ldd - ora richiede libGL.so.1 che prima non voleva!!!!
questo a sua volta richiede il mondo. ma soprattutto se uno ha i driver proprietari nvidia il libGL necessario non è più quello di slackware.
Non ho ben capito che succede se non metto la libreria (non ho ancora finito quindi non posso provare)
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg

Codice: Seleziona tutto

1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111

Avatar utente
conraid
Staff
Staff
Messaggi: 13305
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Desktop: kde
Località: Livorno
Contatta:

Re: skype_static per slackware64-14.2

Messaggioda conraid » sab lug 16, 2016 12:55

A me Skype funziona normalmente con il tuo vecchio pacchetto, semplicemente togliendo pulse.

Avatar utente
ZeroUno
Staff
Staff
Messaggi: 5195
Iscritto il: ven giu 02, 2006 14:52
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current
Località: Roma / Castelli
Contatta:

Re: skype_static per slackware64-14.2

Messaggioda ZeroUno » sab lug 16, 2016 13:07

Perchè aveva le qt vecchie.

ce ne sono due di pacchetti miei, uno che funziona con apulse e uno con pulseaudio dentro (il primo ha lib32 e l'altro ha sia lib/ che lib64). Quale hai tu?

Che modifiche gli hai fatto? Perchè le librerie a 32bit di pulseaudio comunque vanno messe no?
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg

Codice: Seleziona tutto

1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111

Avatar utente
conraid
Staff
Staff
Messaggi: 13305
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Desktop: kde
Località: Livorno
Contatta:

Re: skype_static per slackware64-14.2

Messaggioda conraid » sab lug 16, 2016 13:16

Ti ho mandato un messaggio privato, il pacchetto l'ho creato dal tuo slackbuild.

Avatar utente
conraid
Staff
Staff
Messaggi: 13305
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Desktop: kde
Località: Livorno
Contatta:

Re: skype_static per slackware64-14.2

Messaggioda conraid » sab lug 16, 2016 13:17

ZeroUno ha scritto:Che modifiche gli hai fatto? Perchè le librerie a 32bit di pulseaudio comunque vanno messe no?


No, le ho semplicemente tolte, usa quelle di sistema.

Avatar utente
conraid
Staff
Staff
Messaggi: 13305
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Desktop: kde
Località: Livorno
Contatta:

Re: skype_static per slackware64-14.2

Messaggioda conraid » dom lug 17, 2016 22:02

Ho visto che c'è la nuova versione in alfa da scaricare

https://community.skype.com/t5/Linux/Sk ... -p/4434299

Son senza pc e non ho potuto ancora provare

hashbang
Packager
Packager
Messaggi: 1975
Iscritto il: ven giu 04, 2010 10:27
Nome Cognome: Luca De Pandis
Distribuzione: macOS Catalina
Località: Lecce / Bergamo / Milano
Contatta:

Re: skype_static per slackware64-14.2

Messaggioda hashbang » lun lug 18, 2016 0:28

Skype for Linux Alpha è un client basato su Electron (niente più Qt, ma Node.js+Chromium) che chiama Skype for Web. Attualmente comunque è solo a 64-bit, ed è in grado giusto di fare chiamate audio.
Lo sto usando dal giorno del rilascio e ho mandato alcuni feedback. Vedremo cosa faranno...


EDIT: Se state in vecchie chat (p2p) è probabile che Skype for Linux Alpha non le veda, perché Skype for Web supporta solo le nuove chat basate sul cloud.
Microsoft ha detto che nelle prossime settimane vedranno di completare la migrazione, quindi a breve dovrebbero essere accessibili anche dal nuovo client.

Avatar utente
ZeroUno
Staff
Staff
Messaggi: 5195
Iscritto il: ven giu 02, 2006 14:52
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current
Località: Roma / Castelli
Contatta:

Re: skype_static per slackware64-14.2

Messaggioda ZeroUno » lun lug 18, 2016 0:49

L'ho provato anche io, ma giusto al volo. la testcall funziona, ma non sono riuscito a fare chiamate vocali, ma come detto ho fatto poche prove.

Riguardo skype_static invece ho fatto una versione in cui ci sono le librerie di pulseaudio. Non è completamente terminato perchè sto approfittando per ripulirlo, ma già dovrebbe essere funzionante, e visto che non so se domani posso lavorarci lo pubblico quì:
http://slakfinder.org/skype/ skype_static-14.2-tmp/
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg

Codice: Seleziona tutto

1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111

Avatar utente
Paoletta
Staff
Staff
Messaggi: 3974
Iscritto il: lun apr 25, 2005 0:00
Slackware: 14.2 - 64 bit
Desktop: fluxbox
Località: Varese

Re: skype_static per slackware64-14.2

Messaggioda Paoletta » mer lug 20, 2016 21:14

ciao, da quel che ho potuto testare funziona bene..bravo zerouno!

Avatar utente
ZeroUno
Staff
Staff
Messaggi: 5195
Iscritto il: ven giu 02, 2006 14:52
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current
Località: Roma / Castelli
Contatta:

Re: skype_static per slackware64-14.2

Messaggioda ZeroUno » gio lug 21, 2016 0:08

Già, e visto che lo so che mancano diverse librerie mi chiedo cosa non funziona
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg

Codice: Seleziona tutto

1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111

_gda
Linux 0.x
Linux 0.x
Messaggi: 2
Iscritto il: gio lug 21, 2016 17:04

Re: skype_static per slackware64-14.2

Messaggioda _gda » gio lug 21, 2016 17:47

ZeroUno ha scritto:Già, e visto che lo so che mancano diverse librerie mi chiedo cosa non funziona


Probabilmente le libGL sono utilizzate da libQtWebKit in funzioni non realmente utilizzate da skype. Nel mio caso ho una scheda Nvida (e pertanto ho dovuto installare i driver proprietari) tuttativa skype funziona anche utilizzando le libGL standard a 32 bit...

OT: Abbiamo avuto uno scambio di post sullo stesso argomento anche su LQ. E' un vero piacere scoprire che sei italiano! :D

Avatar utente
ZeroUno
Staff
Staff
Messaggi: 5195
Iscritto il: ven giu 02, 2006 14:52
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current
Località: Roma / Castelli
Contatta:

Re: skype_static per slackware64-14.2

Messaggioda ZeroUno » gio lug 21, 2016 19:02

Dal momento che skype dipende direttamente da libQtWebKit e questo da libGL, senza di queste skype non parte, quindi devono esserci, anche se non sono quelle corrispondenti alla scheda video corrente (al massimo non usa l'accelerazione hw, che non è il più grande dei problemi).

Credo che il mio nick e il mio nome (nonché gli strafalcioni di traduzione ;) ) e il fatto che il pacchetto ufficiale va su slacky.eu fa ben capire la mia nazionalità :). Più di un utente slacky è su LQ e viceversa (incluso Eric ;)) .
Comunque benvenuto tra noi.
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg

Codice: Seleziona tutto

1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111

_gda
Linux 0.x
Linux 0.x
Messaggi: 2
Iscritto il: gio lug 21, 2016 17:04

Re: skype_static per slackware64-14.2

Messaggioda _gda » gio lug 21, 2016 21:36

Ho fatto un po' di ricerche in giro sulle dipendenze del modulo qtwebkit da opengl... Mi sembra di capire che qtwebkit usa le opengl per questioni legate principalmente all'accelerazione grafica... quindi probabilmente in skype non è cruciale (o forse lo è solo per le videocon cosa che io non ho mai testato).

Ho trovato questa patch in cui sono riportate tutte le calls che qtwebkit fa alle lib opengl. Magari può essere utile.

Avatar utente
ZeroUno
Staff
Staff
Messaggi: 5195
Iscritto il: ven giu 02, 2006 14:52
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current
Località: Roma / Castelli
Contatta:

Re: skype_static per slackware64-14.2

Messaggioda ZeroUno » ven lug 22, 2016 0:58

Ho appena caricato una nuova versione temporanea, da testare, ma credo si approssimi abbastanza alla definitiva.

Ho fatto una videocall poco fa, e funziona. L'unica cosa ottengo l'errore a console
"$ libv4l2: error dequeuing buf: Device or resource busy
libv4l2: error dequeuing buf: Invalid argument
libv4l2: error dequeuing buf: Invalid argument
libv4l2: error dequeuing buf: Device or resource busy"
ma non ho approfondito. funziona. ci penso poi.

Dal trace sembra che non riesca a fare LD_PRELOAD
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg

Codice: Seleziona tutto

1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111

Avatar utente
Trotto@81
Iper Master
Iper Master
Messaggi: 3557
Iscritto il: sab giu 26, 2004 0:00
Nome Cognome: Andrea
Slackware: Slackware64 14.2 bet
Kernel: default
Desktop: KDE 4.14.14
Località: Monasterace M. (RC)
Contatta:

Re: skype_static per slackware64-14.2

Messaggioda Trotto@81 » ven lug 29, 2016 17:45

Uscita una nuova versione di Skype per Linux, per ora in versione alpha. Dovrebbe essere nativa a 64 bit.
https://community.skype.com/t5/Linux/Sk ... -p/4434299
Ultima modifica di Trotto@81 il ven lug 29, 2016 17:50, modificato 1 volta in totale.