Xfce Terminal non applica .profile

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
hal9000
Linux 1.x
Linux 1.x
Messaggi: 171
Iscritto il: dom gen 07, 2007 21:24
Nome Cognome: Alessandro Zamori
Slackware: 64 14.2
Kernel: huge-4.4.75
Desktop: xfce
Località: Roma

Xfce Terminal non applica .profile

Messaggioda hal9000 » mar ago 30, 2016 12:18

Salve, dopo aver installato la Slackware64 14.2 con Xfce, mi sono acccorto che lanciando l' emulatore di terminale, e normale, cioè non applica le istruzioni inserite nel .profile della mia home (directory colorate e le varie scorciatoie per i comandi bash che ho creato). Però se mi riloggo nel terminale il .profile funziona a dovere. Come posso ovviare al doppio login per avere il terminale con la bash personalizzata? Grazie e saluti,

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2636
Iscritto il: mer mar 05, 2008 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 5.3.2
Desktop: lxde
Località: Pisa
Contatta:

Re: Xfce Terminal non applica .profile

Messaggioda ponce » mar ago 30, 2016 12:54

http://docs.xfce.org/apps/terminal/preferences#command

personalmente, comunque, metto tutte le mie personalizzazioni dentro ~/.bashrc e, per averle a disposizione anche nelle shell di login, ho questo blocco dentro ~/.bash_profile (non lo uso proprio ~/.profile)

Codice: Seleziona tutto

if [ -f ~/.bashrc ]; then
    source ~/.bashrc
fi


le uniche cose che tengo specificatamente solo in ~/.bash_profile sono

Codice: Seleziona tutto

export LESSCHARSET='utf-8'
export GROFF_ENCODING='utf8'
export LANG=en_US.UTF-8
export LC_CTYPE=en_US.UTF-8
export LC_COLLATE=C
export LC_MONETARY=it_IT.UTF-8
export LC_NUMERIC=it_IT.UTF-8
export LC_TIME=it_IT.UTF-8
export PATH=$PATH:~/bin

Avatar utente
hal9000
Linux 1.x
Linux 1.x
Messaggi: 171
Iscritto il: dom gen 07, 2007 21:24
Nome Cognome: Alessandro Zamori
Slackware: 64 14.2
Kernel: huge-4.4.75
Desktop: xfce
Località: Roma

[Risolto] Xfce Terminal non applica .profile

Messaggioda hal9000 » mar ago 30, 2016 13:30

Grazie, mi è bastato rinominare il file .profile in .bashrc e ho risolto. Saluti

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2636
Iscritto il: mer mar 05, 2008 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 5.3.2
Desktop: lxde
Località: Pisa
Contatta:

Re: Xfce Terminal non applica .profile

Messaggioda ponce » mar ago 30, 2016 13:52

se hai solo ~/.bashrc le shell di login non lo caricheranno proprio, quelle leggono ~/.bash_profile.
come scrivevo sopra per fare in modo che le shell di login abbiano anche loro le tue personalizzazioni avrai bisogno di un file ~/.bash_profile col primo blocco del post sopra.