Installazione e punto della situazione

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
ChriD
Linux 2.4
Linux 2.4
Messaggi: 362
Iscritto il: dom ott 30, 2005 16:43

Installazione e punto della situazione

Messaggioda ChriD » ven set 16, 2016 1:21

Salve a tutti,
vi scrivo in quanto volevo chiedervi alcune cose e volevo confrontarmi con voi circa alcuni passaggi relativi all'installazione di Slackware64...

Premetto che attualmente mi trovo a doverlo installare in VM in quanto sono in attesa di assemblare un mini pc (apu amd quad e 4gb di ram con 250gb di ssd) che ho voluto dedicare a Slackware ed in generale a linux per imparare e sperimentare! In ogni caso ho deciso di voler imparare linux per bene e credo che non ci possa miglior distribuzione che Slacware in questo senso.

Circa quindi l'installazione con Virtualbox devo dire che non e' stata un impresa facilissima... Ho impostato la macchina virtuale con bios uefi in modo da complicarmi la vita e sempre seguendo la linea del voler imparare non limitandomi al bios classico!

Ho letto parecchie guide a riguardo ma non ho trovato niente di particolarmente preciso in merito al voler installare Slackware direttamente con un boot manager quale GRUB2 in grado di gestire il boot efi.
Innanzi tutto ho partizionato il disco virtuale con tabella delle partizioni GPT con gdisk, quindi una partizione di boot da 100MB ef00, una di swap da 2GB 8200 ed il resto root ext4 8300.

Fin qui sembrerebbe tutto ok... ho pensato tuttavia che magari avrei dovuto effettuare io le formattazioni ed attivare la partizione di swap ma poi dalle guide ho capito che bisognava lanciare il setup in quanto era tutto guidato. Terminato il setup guidato, ho deciso di non voler installare ELILO in quanto ho visto che non e' piu' supportato e di affidarmi quindi a GRUB2 e qui sono incominciati i dolori... Grub2 stranamente risultava gia' installato, insieme ad efibootmgr

Il primo e' relativo al fatto che ho dovuto effettuare un

Codice: Seleziona tutto

 chroot /mnt
sulla base della mia breve esperienza... successivamente ho montato la partizione di boot in /boot/efi e qui ho dovuto cercare un bel po' sulla rete... Successivamente ho lanciato prima un

Codice: Seleziona tutto

grub-mkconfig -o /boot/grub/grub.cfg
e successivamente

Codice: Seleziona tutto

grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=Slackware

quest'ultimo comando ha fallito in quanto ho scoperto che prima di effettuare il chroot avrei dovuto effettuare il

Codice: Seleziona tutto

 mount -t sysfs sys /mnt/sys
e

Codice: Seleziona tutto

mount -t bind /dev /mnt/dev
.
Successivamente sono riuscito ad installare grub... (L'ordine e' corretto, prima grub-mkconfig e poi grub-install?)

Dopo di cio' i dolori per avviare X che in macchina virtuale non ne voleva sapere in quanto il log mi dava un errore relativo allo schermo non trovato che ho poi scoperto essere collegato ad un problema di driver mancanti per la macchina virtuale. Ho trovato alla fine la soluzione nell'installare le extension per la macchina virtuale, prima scaricando tramite wget i sorgenti e poi lo Slackbuild tramite il quale ho creato e installato il pacchetto che al successivo riavvio ha dato i suoi frutti.

Ho ancora pero' molti problemi, sia relativi allo spegnimento, che alla risoluzione... Inoltre io sono rimasto ai tempi dello Xorg -config che mi consentiva la generazione di un bel xorg.conf.new Esiste ancora? Inoltre ci sono due directory xorg.conf.d, una in /etc e l'altra in /usr/share/X11, dove si piazza il file di configurazione?

Ho scaricato la slacky for dummies e la sto macinando a tutta forza ma e' tanta roba.... e comunque mancano tutte le guide relative all'installazione di un boot loader alternativo ad ELILO e ad i sistemi UEFI...