Pagina 1 di 3

Scheda wireless Atheros

Inviato: lun ott 15, 2018 14:11
da Black bart
Salve a tutti,ho installato sul mio nuovo portatile slackware 14.2 (come del resto sul vecchio...)questa volta però non mi funziona la rete wireless.
Ho scoperto che si tratta di una scheda Atheros

Codice: Seleziona tutto

01:00.0 Network controller: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter (rev 31


Sapete quali driver devo installare per favore?

Grazie!

Re: Scheda wireless Atheros

Inviato: lun ott 15, 2018 15:11
da ponce
non dovresti avere bisogno di driver aggiuntivi, dovrebbero gia' essere inclusi nel kernel 4.4.157.

Re: Scheda wireless Atheros

Inviato: lun ott 15, 2018 15:22
da rik70
Potrebbe essere un problema di firmware.

Ce la fai a incollare qui l'output di

Codice: Seleziona tutto

tree /lib/firmware/ath10k/QCA9377/
?

Re: Scheda wireless Atheros

Inviato: mar ott 16, 2018 10:36
da Black bart
Mi da questo:

Codice: Seleziona tutto

/lib/firmware/ath10k/QCA9377/
└── hw1.0
    ├── board-2.bin
    ├── board.bin
    ├── firmware-5.bin
    └── notice_ath10k_firmware-5.txt

Re: Scheda wireless Atheros

Inviato: mar ott 16, 2018 13:26
da erio
https://forum.manjaro.org/t/solved-qca9 ... ng/51196/4 ho un acer che ha lo stesso chipset,e avevo preso un dongle wifi per far funzionare il wireless, dai un occhio al link sembra che funzioni.....

Re: Scheda wireless Atheros

Inviato: mar ott 16, 2018 15:19
da rik70
I firmware dovrebbero essere a posto. Se hai installato le ultime patch della distro, dovresti ritrovarti con questi, che dovrebbero essere gli ultimi:
ath10k: QCA9377 hw1.0: update firmware-5.bin to WLAN.TF.1.0-00002-QCATFSWPZ-5

Prova a incollare

Codice: Seleziona tutto

dmesg | grep ath10k

Re: Scheda wireless Atheros

Inviato: mer ott 17, 2018 12:32
da erio
usa lo slackbuild del firmware di current,e fai upgradepkg, ho risolto si connette, io uso wicd.

Re: Scheda wireless Atheros

Inviato: lun ott 22, 2018 10:43
da Black bart
Grazie...proverò.

Re: Scheda wireless Atheros

Inviato: ven feb 08, 2019 11:33
da Black bart
erio ha scritto:usa lo slackbuild del firmware di current,e fai upgradepkg, ho risolto si connette, io uso wicd.


Non trovo lo slackbuild di nm,in quale gruppo si trova?

Grazie

Re: Scheda wireless Atheros

Inviato: ven feb 08, 2019 12:09
da ponce
Black bart ha scritto:Non trovo lo slackbuild di nm,in quale gruppo si trova?

se cerchi NetworkManager e' gia' incluso nella distribuzione insieme alle sue dipendenze, dovresti averlo disponibile se hai fatto un'installazione completa.

Re: Scheda wireless Atheros

Inviato: ven feb 08, 2019 21:22
da joe
Ma perché network manager?
Erio consigliava lo slackbuild del firmware.
La roba di cui si vede il "tree" qualche messaggio sopra si trova nella current qui:
https://ba.mirror.garr.it/mirrors/Slack ... arch-1.txt

Il contenuto è simile al tree postato prima ma contiene roba in più e più recente sicuramente:
https://git.kernel.org/pub/scm/linux/che ... 9377/hw1.0

In pratica è il pacchetto fa parte della seria "a" che trovi in "slackware/a"
https://ba.mirror.garr.it/mirrors/Slack ... ackware/a/

Anzi quello è il pacchetto precompilato per current, lo slackbuild (e corrispondente slack-desc) si trova nel corrispondente ramo sources ovviamente:
https://ba.mirror.garr.it/mirrors/Slack ... -firmware/

Il soldoni devi considerare il pacchetto "kernel-firmware" non network manager.
Ciao!

Re: Scheda wireless Atheros

Inviato: lun feb 11, 2019 11:17
da Black bart
Vero,ho sbagliato io...
In ogni caso dopo l'installazione funzionava,ora però dopo l'aggiornamento della 14.2 non parte più il server X,come ho scritto in altra discussione.

Re: Scheda wireless Atheros

Inviato: lun feb 11, 2019 13:28
da joe
Non ricordo la discussione sul server X che non parte.
Ad ogni modo per esperienza dopo un aggiornamento che coinvolge ad esempio il kernel può capitare che se tu avevi driver video proprietari (ad esempio nvidia) e li avevi installati compilandoli contro il kernel vecchio, quando aggiorni e viene installato un kernel diverso accade che i driver video non funzionano più e quando fai partire X, questo risponde picche.
La soluzione, nel mio caso è stat banalmente la ricompilazione del pacchetto dei drivers proprietari, nel mio caso uso un pacchetto creato con la ricetta di SBo... che sputa fuori sta roba qui:

Codice: Seleziona tutto

$ ls /var/log/packages/|grep nvid
nvidia-legacy340-driver-340.104-x86_64-1_SBo
nvidia-legacy340-kernel-340.104_4.4.132-x86_64-1_SBo


Ovvio che la versione del driver dipende dal modello della tua scheda video.
La domanda quindi che ti farei per capire cosa non funziona è: come gestisci la scheda video?
Usi drivers proprietari?
Come li avevi installati?

Re: Scheda wireless Atheros

Inviato: mar feb 26, 2019 9:10
da Black bart
Ho provato a compilare kernel-firmware preso da current e poi sostituito quello della 14.2 ma non funziona lo stesso...

per quanto riguarda il server X non uso driver proprietari ma solo ciò che installa il dvd di slackware,in ogni caso enon so perchè,poi è ripartito ad un successivo riavvio...

Re: Scheda wireless Atheros

Inviato: mar feb 26, 2019 11:14
da joe
Al primo post dici che non ti funziona il wireless.
Ci siamo buttati sul discorso driver e firmware con un po' troppa fretta secondo me.

Cosa vuol dire esattamente "non mi funziona il wireless"?
Scrivi "questa volta", quindi la scorsa volta funzionava?
In che modo ti colleghi alla rete wireless?
Con quali tool: networkmanager, wicd o cos'altro?
Spiega terra terra come facevi a collegarti l'ultima volta che eri riuscito.