startx fallisce

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
cerfu
Linux 0.x
Linux 0.x
Messaggi: 8
Iscritto il: ven ott 19, 2018 10:44

startx fallisce

Messaggioda cerfu » ven ott 19, 2018 15:13

Ciao a tutti,

come da titolo startx fallisce con Fatal server error: no screens found.
Ho la Slackware current con kernel 4.14.76. L'ultima insomma
installata da pochissimo al'inizio se facevo partire startx attendeva all'infinito una risposta dal server grafico e sui processi si vedeva Xorg.wrap che consumava il 100% della CPU, tant'è che poco dopo la ventola impazziva :( .
Sono riuscito a risolvere questo problema inserendo l'opzione nouveau.modeset=0 all'avvio del kernel.
Ora però mi da l'errore come da titolo sia se installo i driver Nvidia oppure no.La macchina in questione è un laptop Clevo con sia la grafica integrata della cpu intel che la gpu nvidia.
Ho provato tantissime altre cose ma ora non so più cosa fare... :cry: :cry:
Spero che qualcuno mi possa aiutare
Grazie mille in anticipo

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2497
Iscritto il: mer mar 05, 2008 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 4.19.0-rc8
Desktop: lxde
Località: Pisa
Contatta:

Re: startx fallisce

Messaggioda ponce » ven ott 19, 2018 15:30

ciao cerfu, benvenuto su slacky.eu!

secondo me stai usando un laptop con tecnologia optimus, in questi casi:

- o (il metodo principale che ti consiglio) usi solamente la grafica integrata intel, creando un file /etc/X11/xorg.conf.d/20-intel.conf con questo contenuto

Codice: Seleziona tutto

Section "Device"
  Identifier  "Intel Graphics"
  Driver      "intel"
EndSection

e mettendo in blacklist nouveau (c'e' questo pacchetto all'uopo)

- oppure installi bumblebee: c'e' una guida al riguardo su docs.slackware.com, ti consiglio di seguire la procedura "the manual way"

http://docs.slackware.com/howtos:hardwa ... ia_optimus

cerfu
Linux 0.x
Linux 0.x
Messaggi: 8
Iscritto il: ven ott 19, 2018 10:44

Re: startx fallisce

Messaggioda cerfu » ven ott 19, 2018 16:01

Intanto grazie mille della celerissima risposta.
Ti volevo chiedere nella guida di bumblebee quando arrivo all'installazione delle builds bbswitch, libbsd e bumblebee quando do il comando upgradepkg --install-new etc etc su tutti e tre mi dice impossibile file not found. È normale?
Inoltre devo proseguire con la guida dove c'è primus virtualGL o mi devo fermare prima?
Scusa la mia ignoranza ma non sono un utente linux espertissimo :roll: :roll:

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2497
Iscritto il: mer mar 05, 2008 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 4.19.0-rc8
Desktop: lxde
Località: Pisa
Contatta:

Re: startx fallisce

Messaggioda ponce » ven ott 19, 2018 16:27

premetto che io non ho hardware optimus e non ho mai provato la guida, la mia era solo un'indicazione
cerfu ha scritto:Intanto grazie mille della celerissima risposta.
Ti volevo chiedere nella guida di bumblebee quando arrivo all'installazione delle builds bbswitch, libbsd e bumblebee quando do il comando upgradepkg --install-new etc etc su tutti e tre mi dice impossibile file not found. È normale?

forse i pacchetti vengono creati in /tmp/, quindi e' probabile che tu li debba installare di li' (aggiungi il prefisso "/tmp/" prima del nome del pacchetto).
Inoltre devo proseguire con la guida dove c'è primus virtualGL o mi devo fermare prima?

secondo me, leggendo quello che e' scritto nella guida, puoi fermarti prima.
Scusa la mia ignoranza ma non sono un utente linux espertissimo :roll: :roll:

allora forse dovresti evitare di usare slackware current (che e' la versione per gli sviluppatori di Slackware) e limitarti alla versione stabile.

cerfu
Linux 0.x
Linux 0.x
Messaggi: 8
Iscritto il: ven ott 19, 2018 10:44

Re: startx fallisce

Messaggioda cerfu » ven ott 19, 2018 22:10

niente da fare ho provato sia la guida per bumblebee che il conf per la sola integrata intel.
Si è vero che non sono espertissimo ma nemmeno alle prime armi e poter far funzionare la current a dovere lo vedo come un traguardo da raggiungere :D
E poi sono troppo ostinato per arrendermi subito :lol: :lol: :lol:
Cercherò di capire e vedere in giro altre soluzioni sperando di riuscire a farlo funzionare, altrimenti me lo tengo in linea di comando senza X :lol: oppure vedrò di andare sulla 14.2 anche se pure con quella avevo fatto varie prove e niente pure lì.
Grazie mille comunque per l'aiuto
Speriamo in bene

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2497
Iscritto il: mer mar 05, 2008 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 4.19.0-rc8
Desktop: lxde
Località: Pisa
Contatta:

Re: startx fallisce

Messaggioda ponce » ven ott 19, 2018 22:20

cerfu ha scritto:niente da fare ho provato sia la guida per bumblebee che il conf per la sola integrata intel.

oltre alla configurazione per la sola integrata intel ti ci vuole anche il blacklist di nouveau.

magari posta anche il modello esatto del laptop e l'output del comando "lspci -v"
lo puoi salvare in un file e poi postarlo, o usare un servizio online, tipo

Codice: Seleziona tutto

lspci -v | nc r0t.uk 9999

cerfu
Linux 0.x
Linux 0.x
Messaggi: 8
Iscritto il: ven ott 19, 2018 10:44

Re: startx fallisce

Messaggioda cerfu » sab ott 20, 2018 0:11

Si l'ho omesso ma avevo fatto pure la blacklist.
Il laptop è un clevo p950 con CPU i7 8750h
Qui viene invece la cosa strana eseguendo lspci va sotto come se inizia a elaborare ma si blocca.
Andando su un altra tty con top si vede il processo di lspci che consuma il 100% della cpu, ovviamente non facendo nulla.... Non saprei come darti l'output...

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2497
Iscritto il: mer mar 05, 2008 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 4.19.0-rc8
Desktop: lxde
Località: Pisa
Contatta:

Re: startx fallisce

Messaggioda ponce » sab ott 20, 2018 7:54

ce ne sono moltissimi che si chiamano p950, bisognerebbe che tu guardassi il modello esatto nello sticker sotto.
dovresti poterlo vedere anche con questo comando

Codice: Seleziona tutto

dmidecode | grep -A 8 "System Information"


ho trovato un altro report di persone a cui si blocca lspci

https://bbs.archlinux.org/viewtopic.php?id=183185

hanno risolto mettendo in blacklist il modulo nouveau, come ti avevo consigliato sopra: sei sicuro di averlo fatto? che ti dice il comando "lsmod | grep nouveau"?

cerfu
Linux 0.x
Linux 0.x
Messaggi: 8
Iscritto il: ven ott 19, 2018 10:44

Re: startx fallisce

Messaggioda cerfu » sab ott 20, 2018 12:44

Ciao
per quanto riguarda il modello mi devi scusare ma cambiando solamente per qualche porta usb in più o meno gli uni dagli altri pensavo fosse irrilevante la cosa, comunque il modello è un p950ep6 il comando

Codice: Seleziona tutto

dmidecode | grep -A 8 "System Information"
riporta P95xER (anche lo sticker sotto riporta p950ep).
Per quanto riguarda lspci è proprio per quello il motivo, purtroppo avevo tolto il blacklist per poter fare altre prove e me ne ero dimenticato #-o , allego l'output.
Grazie mille ancora per l'aiuto
lspci.txt
(12.17 KiB) Scaricato 21 volte

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2497
Iscritto il: mer mar 05, 2008 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 4.19.0-rc8
Desktop: lxde
Località: Pisa
Contatta:

Re: startx fallisce

Messaggioda ponce » sab ott 20, 2018 13:23

cercando su internet ho trovato questo topic

http://forum.notebookreview.com/threads ... 100/page-2

dove consigliano di usare la modalita' "FULL DISCRETE" (e quindi non usando optimus per niente) da bios: se imposti quella poi, installando i due pacchetti nvidia-kernel e nvidia-driver da SlackBuilds.org (e sempre tenendo nouveau in blacklist) dovresti essere a posto.

cerfu
Linux 0.x
Linux 0.x
Messaggi: 8
Iscritto il: ven ott 19, 2018 10:44

Re: startx fallisce

Messaggioda cerfu » sab ott 20, 2018 14:03

Il problema è che nel BIOS non ho quella opzione anzi non ho quasi nulla( è il BIOS più scarno che abbia mai visto in vita mia). Credo proprio che sia da aggiornare. Ho mandato una richiesta al venditore chiedendo se hanno un aggiornamento del BIOS dato che dal sito della clevo non sembrano esserci.
Speriamo che mi rispondano nel frattempo proverò a fare altre prove.
Vi faccio sapere presto

cerfu
Linux 0.x
Linux 0.x
Messaggi: 8
Iscritto il: ven ott 19, 2018 10:44

Re: startx fallisce

Messaggioda cerfu » gio ott 25, 2018 10:43

Niente da fare il produttore mi ha detto che il BIOS che ho è già aggiornato quindi niente modifiche sull'utilizzo della modalità full discrete o altro. Per ora terrò la slackware così facendo delle prove ogni tanto. Comunque anche averla così a linea di comando e basta non è male :thumbright:
Grazie a tutti per la disponibilità a presto
Ciao