Repository 32bit  Forum
Repository 64bit  Wiki

help per mount disco esterno USB...

Usate questo forum per richieste di aiuto e consigli sull'hardware montato nelle vostre macchine con GNU/Linux Slackware.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata e la versione del Kernel. Questi dati aiutano le persone che possono rispondere.
2) Citare il tipo di hardware coinvolto in modo dettagliato.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT. Non usare termini gergali come procio, mobo e simili per identificare i componenti hardware.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

help per mount disco esterno USB...

Messaggioda hosdo » ven gen 13, 2006 23:05

Ciao raga! E' da un paio di anni che non usavo The Penguin... e ora sono arrugginito...

Dunque ho una nuova necessità da affrontare su una frontiera per me inesplorata: devo collegare un disco esterno tramite USB to IDE adapter...

diciamo subito che ho navigato il sito ma non ho trovato niente che mi aiuti ad aggirare il problema attuale!

In pratica facendo "dmesg" posso notare che il dispositivo viene rilevato ma poi l'emulazione scsi non lo riconosce e non gli assegna nessun identificativo...

analizzando con kinfo center sotto le voci USB il dispositivo IDE to USB viene riconosciuto quindi credo che il problema sia solo relativo alla parte emulazione scsi. Ho già provato ad attivare nel kernel tutte le voci relativi a dischi scsi, etc. ma senza successo...

A questo punto cosa posso tentare???
hosdo
Linux 1.0
Linux 1.0
 
Messaggi: 29
Iscritto il: ven gen 13, 2006 19:22
Località: Udine

Messaggioda vanescar » sab gen 14, 2006 0:46

questa discusione e' stata di grande aiuto....lo spero anche per te
http://www.slacky.it/forum/viewtopic.ph ... ght=#71127


ciao
vanescar
Linux 2.4
Linux 2.4
 
Messaggi: 334
Iscritto il: mar mag 10, 2005 23:00
Slackware: 12.1

mmh temo il mio problema sia a monte

Messaggioda hosdo » sab gen 14, 2006 8:59

perchè comunque non mi riconosce il disco e non so niente di lui...
hosdo
Linux 1.0
Linux 1.0
 
Messaggi: 29
Iscritto il: ven gen 13, 2006 19:22
Località: Udine

Messaggioda hosdo » sab gen 14, 2006 9:04

ecco c'è stata una variazione!

Adesso dmesg mi scrive così:

hub.c: new USB device 00:1d.3-1, assigned address 6
usb.c: unable to get descriptor
usb.c: unable to get device 6 configuration (error=-110)
hub.c: new USB device 00:1d.3-1, assigned address 7
hosdo
Linux 1.0
Linux 1.0
 
Messaggi: 29
Iscritto il: ven gen 13, 2006 19:22
Località: Udine

Messaggioda Paoletta » sab gen 14, 2006 14:28

ciao, i moduli usb_storage, ehci e (a seconda del tuo hw) uhci oppure ohci
sono stati inseriti nel kernel?
Avatar utente
Paoletta
Staff
Staff
 
Messaggi: 3907
Iscritto il: dom apr 24, 2005 23:00
Località: Varese
Slackware: 13.1
Desktop: fluxbox

Messaggioda hosdo » sab gen 14, 2006 14:47

Paoletta ha scritto:ciao, i moduli usb_storage, ehci e (a seconda del tuo hw) uhci oppure ohci
sono stati inseriti nel kernel?



Beh... come dire... mi piacerebbe saperlo...

In parole povere: come faccio a vederlo???
hosdo
Linux 1.0
Linux 1.0
 
Messaggi: 29
Iscritto il: ven gen 13, 2006 19:22
Località: Udine

Messaggioda hosdo » sab gen 14, 2006 15:58

dunque: nel kernel li ho attivati... almeno insomma ho "spuntato" le voci EHCI UHCI e OHCI... però forse non è sufficiente...
hosdo
Linux 1.0
Linux 1.0
 
Messaggi: 29
Iscritto il: ven gen 13, 2006 19:22
Località: Udine

Messaggioda l1q1d » sab gen 21, 2006 10:05

si ma l'hai ricompilato?
Per vedere i moduli che sono caricati usa
Codice: Seleziona tutto
lsmod
Avatar utente
l1q1d
Master
Master
 
Messaggi: 1862
Iscritto il: lun feb 21, 2005 0:00
Località: In uno spazio n-dimesionale

Messaggioda hosdo » sab gen 21, 2006 17:25

si ovvio che l'ho ricompilato! comunque ho indagato un po il mio problema è legato al kernel... dovrò montare il 2.6...
hosdo
Linux 1.0
Linux 1.0
 
Messaggi: 29
Iscritto il: ven gen 13, 2006 19:22
Località: Udine

Messaggioda l1q1d » sab gen 21, 2006 17:47

sei sicuro di avere messo anche l'emulazione scsi se usi il 2.4?
Avatar utente
l1q1d
Master
Master
 
Messaggi: 1862
Iscritto il: lun feb 21, 2005 0:00
Località: In uno spazio n-dimesionale

Messaggioda Luci0 » sab gen 21, 2006 18:36

Ciao... prova a dare questi comandi da root...

Codice: Seleziona tutto
cat /etc/slackware-version
uname -a
lspci
lsusb
lsmod
dmesg | grep sd


posta tutto ... almeno abbiamo un pò di info precise....

il passo successivo é dare
Codice: Seleziona tutto
modprobe usb-storage
dmesg | grep sd
Avatar utente
Luci0
Staff
Staff
 
Messaggi: 3591
Iscritto il: dom giu 26, 2005 23:00
Località: Forte dei Marmi
Nome Cognome: Gabriele Santanché
Slackware: 12.2 14.0
Kernel: 2.6.27.46- gen 3.2.29
Desktop: KDE 3.5.10 Xfce

Messaggioda hosdo » sab gen 21, 2006 23:36

root@hosdo:~# cat /etc/slackware-version
Slackware 10.2.0

root@hosdo:~# uname -a
Linux hosdo 2.4.31 #21 Sun Jun 5 19:19:51 PDT 2005 i686 unknown unknown GNU/Linux

root@hosdo:~# lspci
00:00.0 Host bridge: Intel Corporation 82875P/E7210 Memory Controller Hub (rev 02)
00:01.0 PCI bridge: Intel Corporation 82875P Processor to AGP Controller (rev 02)
00:03.0 PCI bridge: Intel Corporation 82875P/E7210 Processor to PCI to CSA Bridge (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev c2)
00:1f.0 ISA bridge: Intel Corporation 82801EB/ER (ICH5/ICH5R) LPC Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801EB/ER (ICH5/ICH5R) IDE Controller (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801EB (ICH5) SATA Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801EB/ER (ICH5/ICH5R) SMBus Controller (rev 02)
00:1f.5 Multimedia audio controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation NV43 [GeForce 6200] (rev a2)
02:01.0 Ethernet controller: Intel Corporation 82547EI Gigabit Ethernet Controller (LOM)
03:03.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller (rev 80)
03:0b.0 Communication controller: Rockwell International HCF 56k Data/Fax/Voice/Spkp (w/Handset) Modem (rev 01)

root@hosdo:~# lsusb
Bus 005 Device 001: ID 0000:0000
Bus 005 Device 002: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)
Bus 004 Device 001: ID 0000:0000
Bus 004 Device 002: ID 046d:c505 Logitech, Inc. Cordless Mouse+Keyboard Receiver
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000
Bus 002 Device 002: ID 043e:8888 LG Electronics USA, Inc.
Bus 002 Device 003: ID 03f0:0212 Hewlett-Packard
Bus 001 Device 001: ID 0000:0000
Bus 001 Device 002: ID 05e3:0702 Genesys Logic, Inc. USB 2.0 IDE Adapter

root@hosdo:~# lsmod
Module Size Used by Not tainted
snd-pcm-oss 36736 0
snd-mixer-oss 12376 0 [snd-pcm-oss]
hci_usb 8376 0 (unused)
bluez 27940 1 [hci_usb]
usbkbd 2936 0 (unused)
uhci 24284 0 (unused)
ehci-hcd 17516 0 (unused)
hw_random 2712 0 (unused)
i810_rng 2528 0 (unused)
snd-intel8x0 18304 1
snd-ac97-codec 58556 0 [snd-intel8x0]
snd-pcm 54344 0 [snd-pcm-oss snd-intel8x0 snd-ac97-codec]
snd-timer 13764 0 [snd-pcm]
snd 32772 1 [snd-pcm-oss snd-mixer-oss snd-intel8x0 snd-ac97-codec snd-pcm snd-timer]
soundcore 3396 4 [snd]
snd-page-alloc 4712 0 [snd-mixer-oss snd-intel8x0 snd-pcm snd-timer snd]
e1000 70188 1
ohci1394 23888 0 (unused)
ieee1394 41636 0 [ohci1394]
pcmcia_core 39172 0
ntfs 51232 1 (autoclean)
parport_pc 15044 1 (autoclean)
ppa 9718 0 (unused)
parport 22824 1 [parport_pc ppa]
ide-scsi 9392 0
joydev 5568 0 (unused)
usb-storage 62432 0 (unused)
printer 7648 0
usbmouse 1880 0 (unused)
keybdev 1892 0 (unused)
mousedev 4020 1
hid 20868 0 (unused)
input 3200 0 [usbkbd joydev usbmouse keybdev mousedev hid]
usbcore 59148 1 [hci_usb usbkbd uhci ehci-hcd usb-storage printer usbmouse hid]

*** Il comando "dmseg | grep sd non mi da risposte e nemmeno modprobe usb-storage ***

L'emulazione scsi l'ho abilitata ma mi risponde che nessun driver può essere associato alla periferica...
hosdo
Linux 1.0
Linux 1.0
 
Messaggi: 29
Iscritto il: ven gen 13, 2006 19:22
Località: Udine

Messaggioda Luci0 » dom gen 22, 2006 23:51

Sembra che il disco per qualche motivo non parte ... lo senti girare ( ... dico con l' orecchio ) .... :wink:
... verificane il buon funzionamento prima di impazzire...
se sembra ok allora servono più info..

Che tipo di cassettino é ???
Alcuni cassettini per hdd da 2,5" alimentati direttamente da USB a volte fanno pasticci perché piantano la presa USB a causa della esosa richiesta di corrente ... questo dipende anche dal tipo di hdd se richiede più o meno corrente...
in tal caso io utilzzo un cassettino da 3.5 e adattatore per hdd da 2.5 ... se hai un HUB USB alimentato puoi provare ad utilizzarlo per poter fornire più corrente al disco.
Se invece hai un cassettino da 3.5 prova ad accenderlo alcuni minuti prima di collegarlo all' USB in genere l' inizializzazione del controller non é mai instantanea e può succedere che il kernel riconosca il controller ma non il disco che non é stato ancora inizializzato ... dal momento che questo vale anche per gli hdd da 2.5 va da se che se il cassettino é alimentato é più facile farlo riconoscere al kernel...


... ad ogni modo buon divertimento ... :)
Avatar utente
Luci0
Staff
Staff
 
Messaggi: 3591
Iscritto il: dom giu 26, 2005 23:00
Località: Forte dei Marmi
Nome Cognome: Gabriele Santanché
Slackware: 12.2 14.0
Kernel: 2.6.27.46- gen 3.2.29
Desktop: KDE 3.5.10 Xfce

Messaggioda hosdo » lun gen 23, 2006 7:53

Il disco funziona perfettamente perchè con la KNOPPIX su live cd ci ho lavorato sopra...

Inoltre il cassettino è acceso da almeno tre settimane non l'ho ancora mai spento ed è dotato di alimentazione esterna... E inoltre è sempre collegato alla stessa porta USB!
hosdo
Linux 1.0
Linux 1.0
 
Messaggi: 29
Iscritto il: ven gen 13, 2006 19:22
Località: Udine

Messaggioda Luci0 » lun gen 23, 2006 22:45

... boh !!! :-(
hai provato con una SLAX...??
Avatar utente
Luci0
Staff
Staff
 
Messaggi: 3591
Iscritto il: dom giu 26, 2005 23:00
Località: Forte dei Marmi
Nome Cognome: Gabriele Santanché
Slackware: 12.2 14.0
Kernel: 2.6.27.46- gen 3.2.29
Desktop: KDE 3.5.10 Xfce

Prossimo

Torna a Hardware

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti