ATI - Nuovi driver 8.22.5

Usate questo forum per richieste di aiuto e consigli sull'hardware montato nelle vostre macchine con GNU/Linux Slackware.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata e la versione del Kernel. Questi dati aiutano le persone che possono rispondere.
2) Citare il tipo di hardware coinvolto in modo dettagliato.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT. Non usare termini gergali come procio, mobo e simili per identificare i componenti hardware.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
pedro
Linux 1.0
Linux 1.0
Messaggi: 31
Iscritto il: mer mag 11, 2005 0:00
Slackware: 12.0

ATI - Nuovi driver 8.22.5

Messaggioda pedro » ven feb 10, 2006 2:08

Ciao a tutti.
Sto cercando di far funzionare i nuovi driver ati usciti ieri su una Slack 10.2 con kernel 2.15.3. In questi driver sostanzialmente hanno corretto l'errore nel file firegl_public.c dove non si menzionava il kernel 2.6.15.

Ho provato con l'installer ma mi da un errore alla fine dell'installazione.

Ho provato allora con l'rpm trasformandolo prima in tgz con rpm2tgz e facendo poi installpkg fglrx...... e fin qui tutto ok.
Quando faccio sh ./make.sh da /lib/modules/fglrx/build_mod compila ma mi esce questo warning :

*** Warning: "verify_area" [/lib/modules/fglrx/build_mod/firegl_agpgart/fglrx_agp.ko] undefined!

Se poi faccio sh ./make_install da /lib/modules/fglrx mi esce questo errore:

- creating symlink
- recreating module dependency list
- trying a sample load of the kernel modules
FATAL: Error inserting fglrx (/lib/modules/2.6.15.3/kernel/drivers/char/drm/fglrx.ko): Operation not permitted

Tutto ciò l'ho fatto come root. Inutile dire che modprobe fglrx mi da un altro errore.

Ma a voi danno gli stessi problemi?Ho letto di persone che li hanno fatti funzionare. La patch che gira è inutile x questa versione di driver. Non so se ho qualche residuo dei tentativi di installazione dei driver precedenti a questi.Avete qualche idea?
Grazie mille.

Avatar utente
5m0k3r
Linux 2.4
Linux 2.4
Messaggi: 306
Iscritto il: mer ott 06, 2004 0:00
Località: Augusta
Contatta:

Messaggioda 5m0k3r » ven feb 10, 2006 2:35

È incredibile come ancora i driver ATI siano scadenti. Oltretutto ancora non sono disponibili per l'Xorg >= 6.9

pedro
Linux 1.0
Linux 1.0
Messaggi: 31
Iscritto il: mer mag 11, 2005 0:00
Slackware: 12.0

Messaggioda pedro » ven feb 10, 2006 2:40

io sono fiducioso...del resto è nel loro interesse farli funzionare

Avatar utente
5m0k3r
Linux 2.4
Linux 2.4
Messaggi: 306
Iscritto il: mer ott 06, 2004 0:00
Località: Augusta
Contatta:

Messaggioda 5m0k3r » ven feb 10, 2006 2:59

Si ma non è stato MAI loro interesse farli funzionare su Linux

Simone_R
Linux 2.4
Linux 2.4
Messaggi: 218
Iscritto il: mar apr 12, 2005 0:00
Contatta:

Re: ATI - Nuovi driver 8.22.5

Messaggioda Simone_R » ven feb 10, 2006 9:02

pedro ha scritto:Ciao a tutti.
Sto cercando di far funzionare i nuovi driver ati usciti ieri su una Slack 10.2 con kernel 2.15.3. In questi driver sostanzialmente hanno corretto l'errore nel file firegl_public.c dove non si menzionava il kernel 2.6.15.

Ho provato con l'installer ma mi da un errore alla fine dell'installazione.

Ho provato allora con l'rpm trasformandolo prima in tgz con rpm2tgz e facendo poi installpkg fglrx...... e fin qui tutto ok.
Quando faccio sh ./make.sh da /lib/modules/fglrx/build_mod compila ma mi esce questo warning :

*** Warning: "verify_area" [/lib/modules/fglrx/build_mod/firegl_agpgart/fglrx_agp.ko] undefined!

Se poi faccio sh ./make_install da /lib/modules/fglrx mi esce questo errore:

- creating symlink
- recreating module dependency list
- trying a sample load of the kernel modules
FATAL: Error inserting fglrx (/lib/modules/2.6.15.3/kernel/drivers/char/drm/fglrx.ko): Operation not permitted

Tutto ciò l'ho fatto come root. Inutile dire che modprobe fglrx mi da un altro errore.

Ma a voi danno gli stessi problemi?Ho letto di persone che li hanno fatti funzionare. La patch che gira è inutile x questa versione di driver. Non so se ho qualche residuo dei tentativi di installazione dei driver precedenti a questi.Avete qualche idea?
Grazie mille.


I driver Ati sono sempre stati sull'instabile
mal'installer mi e' sempre funzionato.

Comunque non preoccupatevi il problema dei driver ATI e' generalizzato visto che anche su windows mi stanno dando problemi di aggiornamento.

Comicio a pentimi di aver abbandonato la Nvidia che non mi ha mai dato problemi.
E i driver sono stabili.

Avatar utente
Vlainur
Linux 2.4
Linux 2.4
Messaggi: 202
Iscritto il: lun nov 15, 2004 0:00
Località: Catania
Contatta:

Messaggioda Vlainur » ven feb 10, 2006 10:59

quei driver non supportano i kernel 2.6.15.x

Zapata
Linux 1.0
Linux 1.0
Messaggi: 22
Iscritto il: dom nov 14, 2004 0:00

Messaggioda Zapata » ven feb 10, 2006 19:27

Vlainur ha scritto:quei driver non supportano i kernel 2.6.15.x


Sì credo anch'io, li ho provato con kernel 2.6.14.6 e funzionano anche se non vedo grandi differenze sulla mia radeon 9200

Avatar utente
Vlainur
Linux 2.4
Linux 2.4
Messaggi: 202
Iscritto il: lun nov 15, 2004 0:00
Località: Catania
Contatta:

Messaggioda Vlainur » ven feb 10, 2006 20:36

confermo non ci sono differenze sostanziali continuano a farmi crashare il kernel.... :cry:

Vyracocha
Linux 1.0
Linux 1.0
Messaggi: 12
Iscritto il: mer mar 15, 2006 10:45

Re: ATI - Nuovi driver 8.22.5

Messaggioda Vyracocha » mer mar 15, 2006 15:09

pedro ha scritto:Ciao a tutti.
Sto cercando di far funzionare i nuovi driver ati usciti ieri su una Slack 10.2 con kernel 2.15.3. In questi driver sostanzialmente hanno corretto l'errore nel file firegl_public.c dove non si menzionava il kernel 2.6.15.

Ho provato con l'installer ma mi da un errore alla fine dell'installazione.

Ho provato allora con l'rpm trasformandolo prima in tgz con rpm2tgz e facendo poi installpkg fglrx...... e fin qui tutto ok.
Quando faccio sh ./make.sh da /lib/modules/fglrx/build_mod compila ma mi esce questo warning :

*** Warning: "verify_area" [/lib/modules/fglrx/build_mod/firegl_agpgart/fglrx_agp.ko] undefined!

Se poi faccio sh ./make_install da /lib/modules/fglrx mi esce questo errore:

- creating symlink
- recreating module dependency list
- trying a sample load of the kernel modules
FATAL: Error inserting fglrx (/lib/modules/2.6.15.3/kernel/drivers/char/drm/fglrx.ko): Operation not permitted

Tutto ciò l'ho fatto come root. Inutile dire che modprobe fglrx mi da un altro errore.

Ma a voi danno gli stessi problemi?Ho letto di persone che li hanno fatti funzionare. La patch che gira è inutile x questa versione di driver. Non so se ho qualche residuo dei tentativi di installazione dei driver precedenti a questi.Avete qualche idea?
Grazie mille.


Per caso, hai compilato agpgart e intel-agp come moduli nel kernel?.I drivers li hai "patchati" prima di compilarli?.
I drivers dalla versione 8.22.5 in poi,non hanno bisogno di essere "patchati",compilali normalmente.
Per il warning,capita anche a me ignoralo,funzionano.

Carica poi i moduli in quest'ordine:
agpgart
intel-agp
fglrx


Poi in xorg.conf controlla che sia:

UseInternalAGPGart "yes"

Infine controlla se il rendering funziona:

glxinfo | grep "direct rendering" se funziona compare yes

Ah per un miglior "risultato",disinstalla i driver che avevi prima,reinstallali col pacchetto tgz e ricompilali.
Oppure trasforma in tgz i nuovi drivers 8.23.7,la procedura che ho scritto sopra è uguale.
Ciao.


Torna a “Hardware”

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite