driiver ati configurare xorg.conf

Usate questo forum per richieste di aiuto e consigli sull'hardware montato nelle vostre macchine con GNU/Linux Slackware.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata e la versione del Kernel. Questi dati aiutano le persone che possono rispondere.
2) Citare il tipo di hardware coinvolto in modo dettagliato.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT. Non usare termini gergali come procio, mobo e simili per identificare i componenti hardware.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
kanenas
Linux 2.x
Linux 2.x
Messaggi: 211
Iscritto il: lun dic 29, 2003 0:00

driiver ati configurare xorg.conf

Messaggioda kanenas » dom lug 22, 2007 0:22

Salve, ho seguito questo link:

http://www.slacky.eu/forum/viewtopic.ph ... 173#144173

tutto bene fino alla configurazione di xorg.conf in

# This loads the GLX module
Load "glx"

metto

Section "Module"
....
Load "dri"
Load "glx"
....
EndSection


in


# **********************************************************************
# Graphics device section
# **********************************************************************

# Any number of graphics device sections may be present

Section "Device"
Identifier "VESA Framebuffer"
Driver "vesa"
#VideoRam 4096




# Insert Clocks lines here if appropriate
EndSection


inserisco

Section "Device"
....
Driver "fglrx"
....
EndSection


SOLO CHE non capisco dove collocare



Section "DRI"
Group 0
Mode 0666
EndSection




:( potete darmi una mano ?

Avatar utente
phobos3576
Staff
Staff
Messaggi: 2980
Iscritto il: dom apr 17, 2005 0:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Messaggioda phobos3576 » dom lug 22, 2007 1:16

La puoi mettere dove vuoi.
Generalmente viene messa subito dopo la Section "Module".

P.S. Per curiosità sono andato a vedere nel mio xorg.conf ed ho scoperto che non c'è la Section "DRI" (scheda video nVidia GeForce 7600GS + driver proprietari nVidia); eppure tutto funziona perfettamente, per qualunque utente!

Come è possibile una cosa del genere?

Avatar utente
kanenas
Linux 2.x
Linux 2.x
Messaggi: 211
Iscritto il: lun dic 29, 2003 0:00

Messaggioda kanenas » dom lug 22, 2007 9:28

Ho fatto quanto mi hai detto, ma non và.
Neanche in Section Module và collocato.
:(

Avatar utente
gnubit
Linux 3.x
Linux 3.x
Messaggi: 751
Iscritto il: lun apr 17, 2006 0:16
Località: Verona
Contatta:

Messaggioda gnubit » dom lug 22, 2007 23:41

Non IN Section Module ma DOPO

Section DRI e una Section come tutte le altre, mettila in testa o in coda a xorg.conf

Avatar utente
ekxius
Linux 3.x
Linux 3.x
Messaggi: 831
Iscritto il: sab mar 18, 2006 11:01
Slackware: 12.0
Kernel: 2.6.23.12
Desktop: KDE 3.5.9
Località: Casa <-> Torino <-> Aosta
Contatta:

Messaggioda ekxius » dom lug 22, 2007 23:53

phobos3576 ha scritto:La puoi mettere dove vuoi.
Generalmente viene messa subito dopo la Section "Module".

P.S. Per curiosità sono andato a vedere nel mio xorg.conf ed ho scoperto che non c'è la Section "DRI" (scheda video nVidia GeForce 7600GS + driver proprietari nVidia); eppure tutto funziona perfettamente, per qualunque utente!

Come è possibile una cosa del genere?


Il DRI per le schede nvidia non serve a niente

Avatar utente
ekxius
Linux 3.x
Linux 3.x
Messaggi: 831
Iscritto il: sab mar 18, 2006 11:01
Slackware: 12.0
Kernel: 2.6.23.12
Desktop: KDE 3.5.9
Località: Casa <-> Torino <-> Aosta
Contatta:

Messaggioda ekxius » lun lug 23, 2007 0:07

Poi non puoi usare due opzioni Driver insieme.
O usi il driver vesa oppure il fglrx ;)

Avatar utente
phobos3576
Staff
Staff
Messaggi: 2980
Iscritto il: dom apr 17, 2005 0:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Messaggioda phobos3576 » lun lug 23, 2007 0:15

ekxius ha scritto:Il DRI per le schede nvidia non serve a niente


Il bello è che lo sapevo benissimo che con i driver proprietari nVidia il DRI non serve; il fatto è che ho installato la Slack 11 e il driver nVidia circa 7 mesi fa su un nuovo PC e tutto sta funzionando talmente bene che ormai sto diventando una specie di utonto.

Non ho più messo mano a xorg.conf, non guardo più i file di log, non ho più modificato gli script di avvio .....

..... un vero scandalo ....

Avatar utente
targzeta
Iper Master
Iper Master
Messaggi: 6541
Iscritto il: gio nov 03, 2005 14:05
Nome Cognome: Emanuele Tomasi
Slackware: 64-current
Kernel: latest stable
Desktop: IceWM
Località: Carpignano Sal. (LE) <-> Pisa

Messaggioda targzeta » lun lug 23, 2007 4:31

@kanenas,
ti ho risposto all'e-mail che mi hai mandato. Se hai ancora bisogno....

Spina