Repository 32bit  Forum
Repository 64bit  Wiki

HD 300 gb USB non riconosciuto in /dev

Usate questo forum per richieste di aiuto e consigli sull'hardware montato nelle vostre macchine con GNU/Linux Slackware.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata e la versione del Kernel. Questi dati aiutano le persone che possono rispondere.
2) Citare il tipo di hardware coinvolto in modo dettagliato.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT. Non usare termini gergali come procio, mobo e simili per identificare i componenti hardware.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

HD 300 gb USB non riconosciuto in /dev

Messaggioda lostratega » mar nov 04, 2008 0:36

Salva ragazzi

e da qualche tempo che non riesco a montare più il mio HD da 300 gb USB. Monto il cavo USB il sistema fa finta di leggerlo ma in realtà non succede nulla, la lucina del box dell'HD lampeggia.
Ho dato dmesg dopo averlo montato e ci sono degli errori che non so interpretare, vi posto qui le riche significative che ottentgo:

[ 560.007371] sd 3:0:0:0: [sdb] Add. Sense: No additional sense information
[ 560.018126] sd 3:0:0:0: [sdb] Sense Key : No Sense [current]
[ 560.018133] sd 3:0:0:0: [sdb] Add. Sense: No additional sense information
[ 560.019241] sd 3:0:0:0: [sdb] Sense Key : No Sense [current]
[ 560.019246] sd 3:0:0:0: [sdb] Add. Sense: No additional sense information
[ 560.020258] sd 3:0:0:0: [sdb] Sense Key : No Sense [current]
[ 560.020262] sd 3:0:0:0: [sdb] Add. Sense: No additional sense information
[ 560.021239] sd 3:0:0:0: [sdb] Sense Key : No Sense [current]
[ 560.021243] sd 3:0:0:0: [sdb] Add. Sense: No additional sense information
[ 560.022261] sd 3:0:0:0: [sdb] Sense Key : No Sense [current]
[ 560.022266] sd 3:0:0:0: [sdb] Add. Sense: No additional sense information
[ 560.023239] sd 3:0:0:0: [sdb] Sense Key : No Sense [current]
[ 560.023243] sd 3:0:0:0: [sdb] Add. Sense: No additional sense information
[ 560.084254] usb 5-2: USB disconnect, address 6
[ 560.086573] scsi 3:0:0:0: [sdb] Result: hostbyte=DID_NO_CONNECT driverbyte=DRIVER_OK,SUGGEST_OK
[ 560.086580] end_request: I/O error, dev sdb, sector 586114704
[ 560.086585] __ratelimit: 61 callbacks suppressed
[ 560.086589] Buffer I/O error on device sdb, logical block 586114704
[ 560.086628] Buffer I/O error on device sdb, logical block 586114704
[ 560.086665] Buffer I/O error on device sdb, logical block 586114696
[ 560.086673] Buffer I/O error on device sdb, logical block 586114697
[ 560.086679] Buffer I/O error on device sdb, logical block 586114698
[ 560.086686] Buffer I/O error on device sdb, logical block 586114699
[ 560.086692] Buffer I/O error on device sdb, logical block 586114700
[ 560.086698] Buffer I/O error on device sdb, logical block 586114701
[ 560.086705] Buffer I/O error on device sdb, logical block 586114702
[ 560.086711] Buffer I/O error on device sdb, logical block 586114703
[ 583.556064] usb 5-2: new high speed USB device using ehci_hcd and address 7
[ 583.853481] usb 5-2: configuration #1 chosen from 1 choice
[ 583.886810] scsi4 : SCSI emulation for USB Mass Storage devices
[ 583.898234] usb-storage: device found at 7
[ 583.898247] usb-storage: waiting for device to settle before scanning

premetto che nella live di ubuntu 8.04 tutto funziona bene, quindi escludo un problema hardware.

che suggerimenti mi date in merito?

Grazie

L.S.
Ultima modifica di lostratega il mar nov 04, 2008 18:20, modificato 1 volta in totale.
Avatar utente
lostratega
Linux 2.0
Linux 2.0
 
Messaggi: 148
Iscritto il: mer mar 05, 2008 19:32
Località: Salamanca (Spain)
Nome Cognome: LoStratega
Slackware: 13.0
Kernel: 2.6.29.2
Desktop: KDE 4.2.4

Re: HD 300 gb USB non riconosciuto in /dev

Messaggioda lostratega » mar nov 04, 2008 18:19

Nessuno nessuno nessuno mi può suggerire qualcosa?
Avatar utente
lostratega
Linux 2.0
Linux 2.0
 
Messaggi: 148
Iscritto il: mer mar 05, 2008 19:32
Località: Salamanca (Spain)
Nome Cognome: LoStratega
Slackware: 13.0
Kernel: 2.6.29.2
Desktop: KDE 4.2.4

Re: HD 300 gb USB non riconosciuto in /dev

Messaggioda phobos3576 » mar nov 04, 2008 18:43

Che kernel stai usando?

Alcuni kernel della famiglia 2.6.25.x e 2.6.26.x hanno creato problemi con qualche periferica USB; nel passaggio dal 2.6.24 al 2.6.25, tutto il supporto USB è stato completamente riscritto.
Nel mio caso, ad esempio, non funzionava più il card reader sulla stampante HP Photosmart; con il kernel 2.6.27 si è risolto tutto.
Avatar utente
phobos3576
Staff
Staff
 
Messaggi: 2980
Iscritto il: sab apr 16, 2005 23:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Re: HD 300 gb USB non riconosciuto in /dev

Messaggioda lostratega » lun apr 27, 2009 19:55

Ragazzi riprendo la discussione perchè non ho mai risolto questo problema, Ho un HD esterno che collego via USB è un Maxtror 300gb, sto usando slackware 12.2 con kernel 2.6.27.7, un'altro problema che riscontro è il mal funzionamento della wireless del portatile, che è una intel 2200, il mio è un asus A6vc; la scheda wireless viene vista come eth1, ma non categorizzata come wireless, credo come ethernet e poi ha un MAC diverso sballato, ad ogni modo non vado su internet con quella. Premetto che con slackware 12.1 questi due problemi non li ho mai avuti, sono sicuro che è un problema di kernel perchè anche ubuntu e derivate 8.10 con questo kernel dava problemi, ma poi loro hanno aggiornato e tutto è andato bene. Siccome tengo a slackware vorrei quanto meno capire dove mettere mano, mi date delle indicazioni dettagliate con il cucchiaino che di ricompilazione kernel proprio non ci sto :)

Grazie ancora

ls
Avatar utente
lostratega
Linux 2.0
Linux 2.0
 
Messaggi: 148
Iscritto il: mer mar 05, 2008 19:32
Località: Salamanca (Spain)
Nome Cognome: LoStratega
Slackware: 13.0
Kernel: 2.6.29.2
Desktop: KDE 4.2.4

Re: HD 300 gb USB non riconosciuto in /dev

Messaggioda Luci0 » lun apr 27, 2009 22:24

Prova a postare i gli output dei vari lspci poi lsusb e lsmod prima e dopo l' inserimento della periferica..
Avatar utente
Luci0
Staff
Staff
 
Messaggi: 3591
Iscritto il: dom giu 26, 2005 23:00
Località: Forte dei Marmi
Nome Cognome: Gabriele Santanché
Slackware: 12.2 14.0
Kernel: 2.6.27.46- gen 3.2.29
Desktop: KDE 3.5.10 Xfce

Re: HD 300 gb USB non riconosciuto in /dev

Messaggioda zoros » lun apr 27, 2009 23:27

Ritengo che la questione versione kernel sia proprio "la Questione" ... la 2.6.27.7 ha evidenziato dei seri problemi con i filesystem ... installa una diversa versione al più presto ... già la 2.6.28 è diversa, io sono ritornato addirittura indietro ...
vorrei riavere le mie firme ...
Avatar utente
zoros
Linux 3.x
Linux 3.x
 
Messaggi: 1302
Iscritto il: lun mag 28, 2007 21:51
Località: Gorizia
Nome Cognome: Fabio∙Zorba
Slackware: 13.37
Kernel: 3.2.5
Desktop: KDE-3.5.10

Re: HD 300 gb USB non riconosciuto in /dev

Messaggioda Luci0 » mar apr 28, 2009 8:11

Da quello che ho capito" googlando" dovrebbe essere un bug di udev e kernel 2.6.27.x ho trovato un bug analogo su Ubuntu ...
https://bugs.launchpad.net/ubuntu/+sour ... bug/264789
che hanno risolto modificando le in /etc/udev/rules.d/60-storage-persistent.rules... ma su slackware 12.2 non c' é niente di simile, almeno su mio eeePC.

Domanda ... non é per caso che hai upgradato una 12.1 ? Questo perché noto una significativa differenza tra quello che c'é in /etc/udev/rules.d/ della 12.1 e quello che c'é nella 12.2 installata di fresco ...
ecco quello che ho nella 12.1
Codice: Seleziona tutto
ls /etc/udev/rules.d/
05-udev-early.rules               65-permissions.rules
10-vboxdrv.rules                  70-persistent-cd.rules
40-alsa.rules                     70-persistent-net.rules
40-slackware.rules                70-persistent-net.rules.old
40-video.rules                    75-cd-aliases-generator.rules
50-udev-default.rules             75-persistent-net-generator.rules
55-hpmud.rules                    80-drivers.rules
60-bluetooth.rules                80-libnjb.rules
60-cdrom_id.rules                 80-libpisock.rules
60-pcmcia.rules                   80-libsane.rules
60-persistent-input.rules         90-hal.rules
60-persistent-storage.rules       90-libmtp.rules
60-persistent-storage-tape.rules  90-network.rules.old
61-persistent-storage-edd.rules   95-udev-late.rules
64-device-mapper.rules            99-fuse.rules


e quello che c' é nella 12.2
Codice: Seleziona tutto
/etc/udev/rules.d/
70-persistent-net.rules  96-lirc.rules


praticamente non c' é niente ...

EDIT : Quello che ho scritto sotto é un copia incolla post che ho effettuato in questo thread ...
Come aggiornare dalla 12.1 alla 12.2


----------------------------------------
Ho notato che in una 12.2 installata di fresco la directory /etc/udev/rules.d in genere rimane quasi vuota, due file sull' eeepc, mentre sulla 12.1 sulla quale sto scrivendo adesso ci saranno almeno una quindicina di file ... insomma é normale o no ?

Mi rispondo da solo RTFM

Codice: Seleziona tutto
As usual, there are changes in udev packaging that need mentioning...
  First, be sure to move the /etc/rc.d/rc.udev.new over - the old
  /etc/rc.d/rc.udev will not work with the new udev package (and the new
  one won't work with the old udev package).
  The system udev rules now reside in /lib/udev/rules.d/ instead of
  /etc/udev/rules.d/ in older versions.  There should never be a reason
  to edit anything in /lib/udev/rules.d/, so if you think you have a case
  where this is required, either you're wrong or it needs to be addressed
  in the upstream source.  However, you can override default rules by
  placing one with an identical name inside /etc/udev/rules.d/ 
  The rules files in /etc/udev/rules.d/ are still intended to (maybe) be
  edited as needed by local system administrators, and as such, the rules
  for optical and network devices will still be placed there.


le regole le hanno spostate ... ( ma non vale cambiare regole mentre si sta giocando :-( )

Da quello che ho capito però le regole nella directory /etc/udev/rules.d/ continuano a valere creando forse qualche problema in caso di upgrade ...

Insomma nella 12.2 esistono due directory con le regole per udev /lib/udev/rules.d e /etc/udev/rules.d se con l' upgrade dalla 12.1 alla 12.2 avete qualche problema con le periferiche date un occhiata per vedere che non esistano doppioni ... ( almeno credo che sia cosi ! )
-------------------------------------
;-)
Avatar utente
Luci0
Staff
Staff
 
Messaggi: 3591
Iscritto il: dom giu 26, 2005 23:00
Località: Forte dei Marmi
Nome Cognome: Gabriele Santanché
Slackware: 12.2 14.0
Kernel: 2.6.27.46- gen 3.2.29
Desktop: KDE 3.5.10 Xfce

Re: HD 300 gb USB non riconosciuto in /dev

Messaggioda conraid » mar apr 28, 2009 10:01

Non è proprio come è stato spiegato.
Udev ora mette le regole in /lib/udev, ma quelle personali vanno in /etc/udev (logicamente anche storage e schede di rete vengono create qui), proprio per evitare problemi in caso di upgrade
Più che stare attenti ad avere files non nomi uguali (udev non è hal) bisogna stare attenti a non mettere regole contraddittorie, anche se in file di nome diverso
Avatar utente
conraid
Staff
Staff
 
Messaggi: 11987
Iscritto il: mer lug 13, 2005 23:00
Località: Livorno
Nome Cognome: Corrado Franco
Slackware: current

Re: HD 300 gb USB non riconosciuto in /dev

Messaggioda lostratega » mar apr 28, 2009 14:05

Allora ragazzi in ordine, i comandi lspci prima di inserire l'HD (perchè il wireless è integrata)

0:00.0 Host bridge: Intel Corporation Mobile 915GM/PM/GMS/910GML Express Processor to DRAM Controller (rev 04)
00:01.0 PCI bridge: Intel Corporation Mobile 915GM/PM Express PCI Express Root Port (rev 04)
00:1b.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 04)
00:1d.0 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1 (rev 04)
00:1d.1 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2 (rev 04)
00:1d.2 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3 (rev 04)
00:1d.3 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4 (rev 04)
00:1d.7 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller (rev 04)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev d4)
00:1f.0 ISA bridge: Intel Corporation 82801FBM (ICH6M) LPC Interface Bridge (rev 04)
00:1f.1 IDE interface: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) IDE Controller (rev 04)
00:1f.3 SMBus: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) SMBus Controller (rev 04)
01:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8001 Gigabit Ethernet Controller (rev 13)
01:01.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev b3)
01:01.1 FireWire (IEEE 1394): Ricoh Co Ltd R5C552 IEEE 1394 Controller (rev 08)
01:01.2 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 17)
01:01.3 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 08)
01:03.0 Network controller: Intel Corporation PRO/Wireless 2200BG [Calexico2] Network Connection (rev 05)
03:00.0 VGA compatible controller: nVidia Corporation NV43 [GeForce Go 6200/6400] (rev a1)

lsusb

Bus 002 Device 002: ID 13ee:0003
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 004: ID 148f:2573 Ralink Technology, Corp. RT2501USB Wireless Adapter
Bus 001 Device 003: ID 0402:5602 ALi Corp. Video Camera Controller
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

lsmod

Module Size Used by
rt2500usb 19200 0
rt73usb 21760 0
rt2x00usb 8832 2 rt2500usb,rt73usb
rt2x00lib 24704 3 rt2500usb,rt73usb,rt2x00usb
rfkill 8216 1 rt2x00lib
mac80211 150680 2 rt2x00usb,rt2x00lib
cfg80211 23048 2 rt2x00lib,mac80211
snd_seq_dummy 2820 0
snd_seq_oss 28544 0
snd_seq_midi_event 6144 1 snd_seq_oss
snd_seq 43216 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device 6412 3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss 36384 0
snd_mixer_oss 13952 1 snd_pcm_oss
ipv6 229140 24
lp 9508 0
fuse 48924 5
mmc_block 8964 0
pcmcia 31652 0
ppdev 7300 0
snd_hda_intel 363276 3
snd_pcm 63880 3 snd_pcm_oss,snd_hda_intel
snd_timer 18308 3 snd_seq,snd_pcm
parport_pc 23972 1
sdhci_pci 7168 0
asus_laptop 15736 0
yenta_socket 22924 1
rsrc_nonstatic 10496 1 yenta_socket
snd_page_alloc 7432 2 snd_hda_intel,snd_pcm
parport 30024 3 lp,ppdev,parport_pc
sdhci 14212 1 sdhci_pci
skge 37264 0
pcmcia_core 31376 3 pcmcia,yenta_socket,rsrc_nonstatic
ipw2200 137928 0
snd_hwdep 6788 1 snd_hda_intel
snd 46756 13 snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_hda_intel,snd_pcm,snd_timer,snd_hwdep
soundcore 5728 1 snd
i2c_i801 8720 0
mmc_core 45332 2 mmc_block,sdhci
video 16656 0
output 2688 1 video
led_class 3716 2 rt2x00lib,asus_laptop
fan 4356 0
evdev 8992 6
thermal 15516 0
psmouse 36368 0
serio_raw 5124 0
processor 27696 1 thermal
thermal_sys 11168 4 video,fan,thermal,processor
button 6160 0
ieee80211 27592 1 ipw2200
ieee80211_crypt 4352 1 ieee80211
battery 10372 0
intel_agp 25148 0
agpgart 28080 1 intel_agp
ac 4228 0
hwmon 2196 1 thermal_sys


dopo l'inserimento dell'HD

00:00.0 Host bridge: Intel Corporation Mobile 915GM/PM/GMS/910GML Express Processor to DRAM Controller (rev 04)
00:01.0 PCI bridge: Intel Corporation Mobile 915GM/PM Express PCI Express Root Port (rev 04)
00:1b.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 04)
00:1d.0 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1 (rev 04)
00:1d.1 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2 (rev 04)
00:1d.2 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3 (rev 04)
00:1d.3 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4 (rev 04)
00:1d.7 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller (rev 04)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev d4)
00:1f.0 ISA bridge: Intel Corporation 82801FBM (ICH6M) LPC Interface Bridge (rev 04)
00:1f.1 IDE interface: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) IDE Controller (rev 04)
00:1f.3 SMBus: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) SMBus Controller (rev 04)
01:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8001 Gigabit Ethernet Controller (rev 13)
01:01.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev b3)
01:01.1 FireWire (IEEE 1394): Ricoh Co Ltd R5C552 IEEE 1394 Controller (rev 08)
01:01.2 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 17)
01:01.3 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 08)
01:03.0 Network controller: Intel Corporation PRO/Wireless 2200BG [Calexico2] Network Connection (rev 05)
03:00.0 VGA compatible controller: nVidia Corporation NV43 [GeForce Go 6200/6400] (rev a1)

lsusb

Bus 002 Device 002: ID 13ee:0003
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 005: ID 2164:2507
Bus 001 Device 004: ID 148f:2573 Ralink Technology, Corp. RT2501USB Wireless Adapter
Bus 001 Device 003: ID 0402:5602 ALi Corp. Video Camera Controller
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

lsmod

Module Size Used by
sg 25776 0
rt2500usb 19200 0
rt73usb 21760 0
rt2x00usb 8832 2 rt2500usb,rt73usb
rt2x00lib 24704 3 rt2500usb,rt73usb,rt2x00usb
rfkill 8216 1 rt2x00lib
mac80211 150680 2 rt2x00usb,rt2x00lib
cfg80211 23048 2 rt2x00lib,mac80211
snd_seq_dummy 2820 0
snd_seq_oss 28544 0
snd_seq_midi_event 6144 1 snd_seq_oss
snd_seq 43216 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device 6412 3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss 36384 0
snd_mixer_oss 13952 1 snd_pcm_oss
ipv6 229140 24
lp 9508 0
fuse 48924 5
mmc_block 8964 0
pcmcia 31652 0
ppdev 7300 0
snd_hda_intel 363276 3
snd_pcm 63880 3 snd_pcm_oss,snd_hda_intel
snd_timer 18308 3 snd_seq,snd_pcm
parport_pc 23972 1
sdhci_pci 7168 0
asus_laptop 15736 0
yenta_socket 22924 1
rsrc_nonstatic 10496 1 yenta_socket
snd_page_alloc 7432 2 snd_hda_intel,snd_pcm
parport 30024 3 lp,ppdev,parport_pc
sdhci 14212 1 sdhci_pci
skge 37264 0
pcmcia_core 31376 3 pcmcia,yenta_socket,rsrc_nonstatic
ipw2200 137928 0
snd_hwdep 6788 1 snd_hda_intel
snd 46756 13 snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_hda_intel,snd_pcm,snd_timer,snd_hwdep
soundcore 5728 1 snd
i2c_i801 8720 0
mmc_core 45332 2 mmc_block,sdhci
video 16656 0
output 2688 1 video
led_class 3716 2 rt2x00lib,asus_laptop
fan 4356 0
evdev 8992 6
thermal 15516 0
psmouse 36368 0
serio_raw 5124 0
processor 27696 1 thermal
thermal_sys 11168 4 video,fan,thermal,processor
button 6160 0
ieee80211 27592 1 ipw2200
ieee80211_crypt 4352 1 ieee80211
battery 10372 0
intel_agp 25148 0
agpgart 28080 1 intel_agp
ac 4228 0
hwmon 2196 1 thermal_sys


in fine faccio la premessa che ieri ho provato ad installare i driver per la scheda NVIDIA ma l'installazione si è interrotta dicendo che c'erano problemi al kernel

La distribuzione è fresca fresca, cioè installata direttamente dalla ISO senza upgrade.
Quindi in pratica dovrei sostituire il kernel?
Mi suggerite, qualora ci sia solo questa soluzione, una procedura semplicissima?

Grazie

ls
Avatar utente
lostratega
Linux 2.0
Linux 2.0
 
Messaggi: 148
Iscritto il: mer mar 05, 2008 19:32
Località: Salamanca (Spain)
Nome Cognome: LoStratega
Slackware: 13.0
Kernel: 2.6.29.2
Desktop: KDE 4.2.4

Re: HD 300 gb USB non riconosciuto in /dev

Messaggioda zoros » mar apr 28, 2009 22:12

lostratega ha scritto:...
in fine faccio la premessa che ieri ho provato ad installare i driver per la scheda NVIDIA ma l'installazione si è interrotta dicendo che c'erano problemi al kernel

La distribuzione è fresca fresca, cioè installata direttamente dalla ISO senza upgrade.
Quindi in pratica dovrei sostituire il kernel?
Mi suggerite, qualora ci sia solo questa soluzione, una procedura semplicissima?

Grazie

ls


premesso che i problemi di compatibilità kernel<->driver-nVidia ci potrebbero essere ugualmente, io dico "a pelle" senza pretendere che sia una verità assoluta che il 2.6.27.7 ha dei problemi con i filesystem ... la cosa più semplice da fare è scaricare un'altro kernel precompilato completo di sorgenti ... metto le indicazioni sotto forma di script:
Codice: Seleziona tutto
#!/bin/sh
mkdir kernel-download
cd kernel-download
wget -c ftp://ftp.slackware.no/linux/slackware/slackware-current/slackware/a/kernel-huge-2.6.29.1-i486-2.tgz
wget -c ftp://ftp.slackware.no/linux/slackware/slackware-current/slackware/a/kernel-modules-smp-2.6.29.1_smp-i686-2.tgz
wget -c ftp://ftp.slackware.no/linux/slackware/slackware-current/slackware/k/kernel-source-2.6.29.1_smp-noarch-2.tgz
su
installpkg *.tgz
lilo

non provato del tutto ma i doinst.sh dicono che funziona su una 12.2 appena installata
vorrei riavere le mie firme ...
Avatar utente
zoros
Linux 3.x
Linux 3.x
 
Messaggi: 1302
Iscritto il: lun mag 28, 2007 21:51
Località: Gorizia
Nome Cognome: Fabio∙Zorba
Slackware: 13.37
Kernel: 3.2.5
Desktop: KDE-3.5.10

Re: HD 300 gb USB non riconosciuto in /dev

Messaggioda lostratega » mer apr 29, 2009 14:15

OK ho applicato la procedura consigliata e installato i tre file, al momento il problema di montaggio dell'HD è risolto con la sola eccezione che non mi monta la partizione NTFS perchè dice che ci sono problemi ai moduli, nemmeno le schede wireless, ethernet quella sonora vengono rilevate, come mai? devo mettere mano alla ricompilazione del kernel....? cioè attivare le rispettive voci? Quanto è meglio ritornare alla 12.1, il fatto è che volevo provade kde 4.2.2 che nel forum è commentato come essere stabile.

l.s.
Avatar utente
lostratega
Linux 2.0
Linux 2.0
 
Messaggi: 148
Iscritto il: mer mar 05, 2008 19:32
Località: Salamanca (Spain)
Nome Cognome: LoStratega
Slackware: 13.0
Kernel: 2.6.29.2
Desktop: KDE 4.2.4

Re: HD 300 gb USB non riconosciuto in /dev

Messaggioda zoros » mer apr 29, 2009 15:03

Acc ... è cambiato tutto, c'é una nuova versione 2.6.29.2 sul sito ftp ... accidenti proprio ... qui le cose corrono ...
Codice: Seleziona tutto
#!/bin/sh
mkdir kernel-download-2
cd kernel-download-2
wget -c ftp://ftp.slackware.no/linux/slackware/slackware-current/slackware/a/kernel-huge-smp-2.6.29.2_smp-i686-1.tgz
wget -c ftp://ftp.slackware.no/linux/slackware/slackware-current/slackware/a/kernel-modules-smp-2.6.29.2_smp-i686-1.tgz
wget -c ftp://ftp.slackware.no/linux/slackware/slackware-current/slackware/a/kernel-firmware-2.6.29.2-noarch-1.tgz
wget -c ftp://ftp.slackware.no/linux/slackware/slackware-current/slackware/k/kernel-source-2.6.29.2_smp-noarch-1.tgz
su
installpkg *.tgz
lilo

ho aggiunto il tgz del firmware ...

per rimuovere il kernel recedente 2.6.29.1, se hai ancora i tgz ti basta:
Codice: Seleziona tutto
cd kernel-download
removepkg *.tgz


EDIT: adesso che ho scritto "qui le cose corrono ..." capisco finalmente perché la chiamano -current :D ... non capisco perché la data dei files in questione riporta "27/04/2009 20:37:00", lo script precedente non poteva funzionare oggi ... e neanche ieri ...
vorrei riavere le mie firme ...
Avatar utente
zoros
Linux 3.x
Linux 3.x
 
Messaggi: 1302
Iscritto il: lun mag 28, 2007 21:51
Località: Gorizia
Nome Cognome: Fabio∙Zorba
Slackware: 13.37
Kernel: 3.2.5
Desktop: KDE-3.5.10

Re: HD 300 gb USB non riconosciuto in /dev

Messaggioda lostratega » mer apr 29, 2009 19:10

su questo non ci sono problemi ho scaricato proprio l'ultimo arrivato, ma i problemi di cui sopra sono oggettivi e rimangono, sfortunatamente non disponendo della connessione perchè le schede ri rete non mi vengono riconosciute, non riesco a lavorare dalla slackware:(
Quello che vorrei sapere è se alla fine è normale quello che ho, ovvero l'azzeramento del riconoscimento delle periferiche o il mio è un caso "eccezionale".

ls
Avatar utente
lostratega
Linux 2.0
Linux 2.0
 
Messaggi: 148
Iscritto il: mer mar 05, 2008 19:32
Località: Salamanca (Spain)
Nome Cognome: LoStratega
Slackware: 13.0
Kernel: 2.6.29.2
Desktop: KDE 4.2.4

Re: HD 300 gb USB non riconosciuto in /dev

Messaggioda zoros » mer apr 29, 2009 21:27

Non avevo neanche compreso, leggendo frettolosamente ... hai tirato su un post del 4 novembre 2008 ... per come era posta la questione pareva che il tuo fosse un bisogno impellente ... sicuramente non è normale che tutte le periferiche non siano riconosciute ... valutato il tutto io direi che puoi tranquillamente avventurarti nella compilazione del kernel (divertente e formativo) ... non mi sembra che tu abbia bisogno di aiuto ...

in merito al kernel, se il kernel della 12.1 riconosceva tutto ti basta ricopiarlo sulla 12.2 ...
vorrei riavere le mie firme ...
Avatar utente
zoros
Linux 3.x
Linux 3.x
 
Messaggi: 1302
Iscritto il: lun mag 28, 2007 21:51
Località: Gorizia
Nome Cognome: Fabio∙Zorba
Slackware: 13.37
Kernel: 3.2.5
Desktop: KDE-3.5.10

Re: HD 300 gb USB non riconosciuto in /dev

Messaggioda lostratega » mer apr 29, 2009 21:33

si mi sono limitato ad usare la slackware 12.1, per questo mi sono stato quieto ma poi ho sviluppato il desiderio di usare kde 4.2.2 perchè contiene okular di cui ho bisogno per lavorare e come ripeto sembra che vada bene sulla 12.2 :(
comunque grazie per tutte le delucidazioni che mi avete dato perchè già ho appreso molto...

l.s.
Ultima modifica di lostratega il gio apr 30, 2009 0:11, modificato 1 volta in totale.
Avatar utente
lostratega
Linux 2.0
Linux 2.0
 
Messaggi: 148
Iscritto il: mer mar 05, 2008 19:32
Località: Salamanca (Spain)
Nome Cognome: LoStratega
Slackware: 13.0
Kernel: 2.6.29.2
Desktop: KDE 4.2.4

Prossimo

Torna a Hardware

Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti