Repository 32bit  Forum
Repository 64bit  Wiki

nuovo hd sata

Usate questo forum per richieste di aiuto e consigli sull'hardware montato nelle vostre macchine con GNU/Linux Slackware.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata e la versione del Kernel. Questi dati aiutano le persone che possono rispondere.
2) Citare il tipo di hardware coinvolto in modo dettagliato.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT. Non usare termini gergali come procio, mobo e simili per identificare i componenti hardware.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

nuovo hd sata

Messaggioda tarini » sab feb 14, 2009 2:22

salve ragazzi,
oggi mi sono comprato un nuovo HD sata (da 1 tb) sperando di poterlo attaccare con facilità alla mia macchina già dotata di un hd sata con 3 partizioni (/dev/sda1, /dev/sda2 e /dev/sda3)

una volta attaccato l'harddisk sia alla scheda madre col cavetto sata sia all'alimentatore tramite il cavo apposta mi accingo ad accendere la macchina sperando di poterlo trovare in /dev/sdb

invece non compare niente di nuovo e tutti tool di gestione dischi (fdisk chdisk ecc) non funzionano in quanto il drive non viene proprio visto dal sistema operativo...
non è un problema di kernel in quanto il primo hd sata viene visto correttamente ed è proprio grazie a questo che riesco a scrivervi

l'hd è un seagate da 1 tera

Codice: Seleziona tutto
bash-3.1# dmesg | grep sata
sata_via 0000:00:0f.0: version 2.1
sata_via 0000:00:0f.0: routed to hard irq line 11
scsi2 : sata_via
scsi3 : sata_via


questi due scsi possono significare qualcosa?
Avatar utente
tarini
Linux 1.0
Linux 1.0
 
Messaggi: 38
Iscritto il: dom mar 23, 2008 20:32
Kernel: 12
Desktop: KDE 3.x

Re: nuovo hd sata

Messaggioda tarini » sab feb 14, 2009 2:24

aggiungo questa informazione:

Codice: Seleziona tutto
SCSI device sda: 320173056 512-byte hdwr sectors (163929 MB)
sda: Write Protect is off
sda: Mode Sense: 00 3a 00 00
SCSI device sda: write cache: enabled, read cache: enabled, doesn't support DPO or FUA
SCSI device sda: 320173056 512-byte hdwr sectors (163929 MB)
sda: Write Protect is off
sda: Mode Sense: 00 3a 00 00
SCSI device sda: write cache: enabled, read cache: enabled, doesn't support DPO or FUA
 sda: sda1 sda2 sda3
sd 3:0:0:0: Attached scsi disk sda
sd 3:0:0:0: Attached scsi generic sg0 type 0
Adding 1871564k swap on /dev/sda3.  Priority:-1 extents:1 across:1871564k
EXT3 FS on sda1, internal journal
EXT3 FS on sda2, internal journal
bash-3.1# dmesg | grep sd
SCSI device sda: 320173056 512-byte hdwr sectors (163929 MB)
sda: Write Protect is off
sda: Mode Sense: 00 3a 00 00
SCSI device sda: write cache: enabled, read cache: enabled, doesn't support DPO or FUA
SCSI device sda: 320173056 512-byte hdwr sectors (163929 MB)
sda: Write Protect is off
sda: Mode Sense: 00 3a 00 00
SCSI device sda: write cache: enabled, read cache: enabled, doesn't support DPO or FUA
 sda: sda1 sda2 sda3
sd 3:0:0:0: Attached scsi disk sda
sd 3:0:0:0: Attached scsi generic sg0 type 0
Adding 1871564k swap on /dev/sda3.  Priority:-1 extents:1 across:1871564k
EXT3 FS on sda1, internal journal
EXT3 FS on sda2, internal journal


mi pare faccia però riferimento solo al primo hd
Avatar utente
tarini
Linux 1.0
Linux 1.0
 
Messaggi: 38
Iscritto il: dom mar 23, 2008 20:32
Kernel: 12
Desktop: KDE 3.x

Re: nuovo hd sata

Messaggioda onceiateachild » sab feb 14, 2009 2:26

ma scusa fdisk -l da root non ti segna nulla?
onceiateachild
Linux 1.0
Linux 1.0
 
Messaggi: 30
Iscritto il: mer feb 11, 2009 19:10
Località: Torino
Slackware: 12.2
Kernel: 2.6.27.7
Desktop: 3.5

Re: nuovo hd sata

Messaggioda tarini » sab feb 14, 2009 2:33

mi vede solo le partizioni del primo hd

Codice: Seleziona tutto
   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1        7295    58597056   83  Linux
/dev/sda2            7296       19696    99611032+  83  Linux
/dev/sda3           19697       19929     1871572+  82  Linux swap
Avatar utente
tarini
Linux 1.0
Linux 1.0
 
Messaggi: 38
Iscritto il: dom mar 23, 2008 20:32
Kernel: 12
Desktop: KDE 3.x

Re: nuovo hd sata

Messaggioda waka_jawaka » sab feb 14, 2009 3:21

In primis: il bios della scheda madre lo vede? Tanto per cominciare a togliere di mezzo qualche sospetto...
Ciao
Avatar utente
waka_jawaka
Linux 2.6
Linux 2.6
 
Messaggi: 769
Iscritto il: mar ago 09, 2005 23:00
Nome Cognome: Alberto Palillo
Kernel: 2.6.35
Desktop: KDE 4.5
Distribuzione: Archlinux

Re: nuovo hd sata

Messaggioda tarini » sab feb 14, 2009 18:11

effettivamente hai ragione... nemmeno la scheda madre lo vede :((
il problema e' ancora prima!

chiudete pure
Avatar utente
tarini
Linux 1.0
Linux 1.0
 
Messaggi: 38
Iscritto il: dom mar 23, 2008 20:32
Kernel: 12
Desktop: KDE 3.x

Re: nuovo hd sata

Messaggioda tarini » mar feb 17, 2009 22:54

ma secondo voi un dmesg cosi significa qualcosa??

Codice: Seleziona tutto
RocketRAID 3xxx SATA Controller driver v1.0 (060426)
st: Version 20070203, fixed bufsize 32768, s/g segs 256
sata_via 0000:00:0f.0: version 2.1
ACPI: PCI Interrupt 0000:00:0f.0[B] -> Link [ALKA] -> GSI 20 (level, low) -> IRQ 17
sata_via 0000:00:0f.0: routed to hard irq line 11
ata1: SATA max UDMA/133 cmd 0x0001dc00 ctl 0x0001dd02 bmdma 0x0001e000 irq 17
ata2: SATA max UDMA/133 cmd 0x0001de00 ctl 0x0001df02 bmdma 0x0001e008 irq 17
scsi2 : sata_via
ata1: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
ATA: abnormal status 0x7F on port 0x0001dc07
ATA: abnormal status 0x7F on port 0x0001dc07
ata1.00: ATA-7: Maxtor 6Y160M0, YAR51EW0, max UDMA/133
ata1.00: 320173056 sectors, multi 16: LBA48
ata1.00: configured for UDMA/133
scsi3 : sata_via
ata2: SATA link down 1.5 Gbps (SStatus 1 SControl 300)
ATA: abnormal status 0x80 on port 0x0001de07
scsi 2:0:0:0: Direct-Access     ATA      Maxtor 6Y160M0   YAR5 PQ: 0 ANSI: 5
SCSI device sda: 320173056 512-byte hdwr sectors (163929 MB)
sda: Write Protect is off
sda: Mode Sense: 00 3a 00 00
SCSI device sda: write cache: enabled, read cache: enabled, doesn't support DPO or FUA
SCSI device sda: 320173056 512-byte hdwr sectors (163929 MB)
sda: Write Protect is off
sda: Mode Sense: 00 3a 00 00
SCSI device sda: write cache: enabled, read cache: enabled, doesn't support DPO or FUA
 sda: sda1 sda2 sda3
sd 2:0:0:0: Attached scsi disk sda


sda è l'hd collegato alla seconda porta sata della mobo e viene correttamente montato
Avatar utente
tarini
Linux 1.0
Linux 1.0
 
Messaggi: 38
Iscritto il: dom mar 23, 2008 20:32
Kernel: 12
Desktop: KDE 3.x

Re: nuovo hd sata

Messaggioda Luci0 » mer feb 18, 2009 0:48

Potrebbe essere un problema di controller che é SATA1 (150Mb/s) mentre il disco é SATA2 (300Mb/s).
Oppure il cavetto é di vecchio tipo ... provane uno più moderno.
Alcuni hard disk hanno un ponticello per cambiare la modalità di funzionamento ... mentre gli Hitachi/IBM no !
Posta un output completo di dmesg e lspci ... Ciao :-)
Avatar utente
Luci0
Staff
Staff
 
Messaggi: 3591
Iscritto il: dom giu 26, 2005 23:00
Località: Forte dei Marmi
Nome Cognome: Gabriele Santanché
Slackware: 12.2 14.0
Kernel: 2.6.27.46- gen 3.2.29
Desktop: KDE 3.5.10 Xfce

Re: nuovo hd sata

Messaggioda conraid » mer feb 18, 2009 13:02

Luci0 ha scritto:Potrebbe essere un problema di controller che é SATA1 (150Mb/s) mentre il disco é SATA2 (300Mb/s).


Non sono retrocompatibili?
Avatar utente
conraid
Staff
Staff
 
Messaggi: 12022
Iscritto il: mer lug 13, 2005 23:00
Località: Livorno
Nome Cognome: Corrado Franco
Slackware: current

Re: nuovo hd sata

Messaggioda Luci0 » mer feb 18, 2009 14:52

conraid ha scritto:
Luci0 ha scritto:Potrebbe essere un problema di controller che é SATA1 (150Mb/s) mentre il disco é SATA2 (300Mb/s).


Non sono retrocompatibili?

A volte no ! Per certo i Maxtor hanno un ponticello e credo anche i Seagate mentre alcuni Hitachi vanno riprogrammati da software ... con una procedura molto discutibile si aggancia l' hard disk ad un controller SATA2 e si esegue il downgrade a quel punto si può collegare l' hard disk ad un controller SATA1 .

In pratica chi ha solo un controller un SATA1 non può farlo.

Mi domando certe volte cosa fumano e bevono :geek: i progettisti dell' hardware.

EDIT: Sembra che questi problemi siamo causati dai controller SATA Viatech ..
Avatar utente
Luci0
Staff
Staff
 
Messaggi: 3591
Iscritto il: dom giu 26, 2005 23:00
Località: Forte dei Marmi
Nome Cognome: Gabriele Santanché
Slackware: 12.2 14.0
Kernel: 2.6.27.46- gen 3.2.29
Desktop: KDE 3.5.10 Xfce


Torna a Hardware

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti