Repository 32bit  Forum
Repository 64bit  Wiki

HDD SATA con adattatore IDE: Lento!!!

Usate questo forum per richieste di aiuto e consigli sull'hardware montato nelle vostre macchine con GNU/Linux Slackware.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata e la versione del Kernel. Questi dati aiutano le persone che possono rispondere.
2) Citare il tipo di hardware coinvolto in modo dettagliato.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT. Non usare termini gergali come procio, mobo e simili per identificare i componenti hardware.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

HDD SATA con adattatore IDE: Lento!!!

Messaggioda kens » dom feb 15, 2009 0:47

Ho recentemente acquistato un HDD Samsung da 500GB (SATA, 16M Buffer); l'ho dotato di un adattatore IDE e ci ho clonato su la mia Slack. La scheda madre è una vecchia e gloriosa Abit "KT7A-Raid". Tutto bene, sino a che non mi sono voluto togliere lo sfizio di controllarne le prestazioni.
Dramma!!! :cry: :cry: ecco l'output di "hdparm" del disco incriminato (hda), paragonato ad un vecchio Maxtor IDE (hdg) che funziona nello stesso pc:

Codice: Seleziona tutto
root@k6_400:/home/Nicola# hdparm -t /dev/hda
/dev/hda:
Timing buffered disk reads:    8 MB in  3.40 seconds = 2.35 MB/sec

root@k6_400:/home/Nicola# hdparm -t /dev/hdg
/dev/hdg:
Timing buffered disk reads:  122 MB in  3.04 seconds = 40.08 MB/sec


Ho agito in questo modo per poter conservare il disco quando mi troverò ad aggiornare il pc con una mobo più recente (ormai sono tutte SATA).

Secondo voi è normale e debbo rinunciare (così com'è va peggio di una penna USB :( )? Oppure si può risolvere (ad esempio passando qualche parametro a lilo)? Qualcuno ha esperienza su architetture del genere?

Grazie infinite!

--
Avatar utente
kens
Linux 2.4
Linux 2.4
 
Messaggi: 208
Iscritto il: sab giu 05, 2004 23:00
Slackware: 12.2
Kernel: 2.6.27.7-smp
Desktop: KDE

Re: HDD SATA con adattatore IDE: Lento!!!

Messaggioda algol » dom feb 15, 2009 15:10

Il DMA è attivo per il device?
Provato coi nuovi driver pata?
Avatar utente
algol
Linux 2.6
Linux 2.6
 
Messaggi: 969
Iscritto il: gio set 07, 2006 0:19
Slackware: 12.1
Kernel: 2.6.26.1
Desktop: xfce4.4.2

Re: HDD SATA con adattatore IDE: Lento!!!

Messaggioda kens » dom feb 15, 2009 15:27

algol ha scritto:Il DMA è attivo per il device?
Provato coi nuovi driver pata?


Scusa, Algol, dirò una scemata, ma...
I settaggi che citi, non dovrebbero avere impatto anche per l'HDD IDE nativo (il Maxtor)?
No, comunque, non ho provato.
Dove guardo se il DMA è attivo?

Grazie 1000, comunque ;)

--
Avatar utente
kens
Linux 2.4
Linux 2.4
 
Messaggi: 208
Iscritto il: sab giu 05, 2004 23:00
Slackware: 12.2
Kernel: 2.6.27.7-smp
Desktop: KDE

Re: HDD SATA con adattatore IDE: Lento!!!

Messaggioda syaochan » dom feb 15, 2009 16:23

Le impostazioni sono diverse per ogni disco, per controllarle/cambiarle usi hdparm (in particolare opzione d per il DMA). Fai sapere per favore perché anch'io vorrei acquistare un nuovo disco ma la mia mobo non ha controller sata, e pensavo di prendere uno di questi adattatori.
Avatar utente
syaochan
Linux 2.6
Linux 2.6
 
Messaggi: 659
Iscritto il: sab mag 08, 2004 23:00
Nome Cognome: Christian
Slackware: current 64
Kernel: 2.6.38.7
Desktop: KDE 4.5.5

Re: HDD SATA con adattatore IDE: Lento!!!

Messaggioda kens » mer feb 18, 2009 1:18

syaochan ha scritto:Fai sapere per favore perché anch'io vorrei acquistare un nuovo disco ma la mia mobo non ha controller sata, e pensavo di prendere uno di questi adattatori.


Dunque, sarò breve... :D

Sono giunto alla conclusione che i miei problemi derivavano dall'insana accoppiata adattatore SATA1 <-> HDD SATA2.
Il SAMSUNG 500GB che avevo in prova è solo SATA2, di qui l'irregolare funzionamento che, a volte, in fase di boot, induceva il kernel a disabilitare il DMA rendendo il drive di una lentezza pachidermica. Non so se si trovano in giro adattatori SATA2 <-> IDE, quasi certamente no, non ancora o con difficoltà.

In ogni caso fare attenzione all'uniformità di standard tra adattatore e disco, altrimenti le rogne sono assai probabili :(

Ho anche eseguito dei test con un 500GB SATA1 Maxtor e l'adattatore ma, pur essendo come previsto spariti gli inconvenienti, non ho riscontrato vantaggi sostanziali in termini di velocità rispetto ai ben più vecchi dischi PATA che equipaggiano il mio PC da diversi anni (un IBM 60GB ed un Maxtor 40 GB).

Ho optato per un Maxtor PATA da 250GB (per il mio glorioso ferrovecchio bastano ed avanzano). Clonate ed estese le partizioni con "dd" e Gparted, reinstallato LILO, è partito senza battere ciglio =D> Tra l'altro è anche un buon 15% più veloce, sia dei dischi originari sia delle soluzioni con adattatore :)

Servo vostro ;)

--
Avatar utente
kens
Linux 2.4
Linux 2.4
 
Messaggi: 208
Iscritto il: sab giu 05, 2004 23:00
Slackware: 12.2
Kernel: 2.6.27.7-smp
Desktop: KDE

Re: HDD SATA con adattatore IDE: Lento!!!

Messaggioda syaochan » mer feb 18, 2009 8:18

kens ha scritto:Il SAMSUNG 500GB che avevo in prova è solo SATA2, di qui l'irregolare funzionamento che, a volte, in fase di boot, induceva il kernel a disabilitare il DMA rendendo il drive di una lentezza pachidermica.
Hai provato a riabilitare il DMA con hdparm?
Avatar utente
syaochan
Linux 2.6
Linux 2.6
 
Messaggi: 659
Iscritto il: sab mag 08, 2004 23:00
Nome Cognome: Christian
Slackware: current 64
Kernel: 2.6.38.7
Desktop: KDE 4.5.5

Re: HDD SATA con adattatore IDE: Lento!!!

Messaggioda kens » mer feb 18, 2009 14:36

Ovviamente sì e parrebbe pure tenerlo per un po', ma...
Ma assolutamente non mi fido: è un fatto che accade in modo talmente random che suona quasi come avvertimento :!:
Per il momento viva il PATA ;)
Avatar utente
kens
Linux 2.4
Linux 2.4
 
Messaggi: 208
Iscritto il: sab giu 05, 2004 23:00
Slackware: 12.2
Kernel: 2.6.27.7-smp
Desktop: KDE

Re: HDD SATA con adattatore IDE: Lento!!!

Messaggioda syaochan » mer feb 18, 2009 14:41

Però i pata costano di più adesso a parità di capacità, inoltre il 2TB pata non c'è. :-k
Avatar utente
syaochan
Linux 2.6
Linux 2.6
 
Messaggi: 659
Iscritto il: sab mag 08, 2004 23:00
Nome Cognome: Christian
Slackware: current 64
Kernel: 2.6.38.7
Desktop: KDE 4.5.5

Re: HDD SATA con adattatore IDE: Lento!!!

Messaggioda kens » mer feb 18, 2009 14:45

syaochan ha scritto:Però i pata costano di più adesso a parità di capacità, inoltre il 2TB pata non c'è. :-k

Ok, ok, ma per la mia "vecchietta" (la KT7A Raid) basta ed avanza :)
Ci penserò quando sarò costretto a metter su una macchina nuova (questa non l'aggiorno, va troppo bene).
Avatar utente
kens
Linux 2.4
Linux 2.4
 
Messaggi: 208
Iscritto il: sab giu 05, 2004 23:00
Slackware: 12.2
Kernel: 2.6.27.7-smp
Desktop: KDE

Re: HDD SATA con adattatore IDE: Lento!!!

Messaggioda syaochan » mer feb 18, 2009 14:50

Dicevo per me, mica per te! :p
:D
Avatar utente
syaochan
Linux 2.6
Linux 2.6
 
Messaggi: 659
Iscritto il: sab mag 08, 2004 23:00
Nome Cognome: Christian
Slackware: current 64
Kernel: 2.6.38.7
Desktop: KDE 4.5.5

Re: HDD SATA con adattatore IDE: Lento!!!

Messaggioda submax82 » lun ago 17, 2009 0:55

sto pensando di prendere l'adattatore per un laptop ma a sto punto ci penso bene...
Avatar utente
submax82
Staff
Staff
 
Messaggi: 3202
Iscritto il: mar ago 30, 2005 23:00
Desktop: xfce
Distribuzione: SalixOS


Torna a Hardware

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite