Installazione driver Creative SoundBlaster X-Fi XtremeMusic

Usate questo forum per richieste di aiuto e consigli sull'hardware montato nelle vostre macchine con GNU/Linux Slackware.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata e la versione del Kernel. Questi dati aiutano le persone che possono rispondere.
2) Citare il tipo di hardware coinvolto in modo dettagliato.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT. Non usare termini gergali come procio, mobo e simili per identificare i componenti hardware.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Linuxofilo
Linux 2.0
Linux 2.0
Messaggi: 113
Iscritto il: sab feb 14, 2009 15:08
Nome Cognome: Gianluigi Bianchi
Slackware: 14

Installazione driver Creative SoundBlaster X-Fi XtremeMusic

Messaggioda Linuxofilo » sab feb 21, 2009 14:42

salve a tutti,
ho un problema con l'installazione dei driver della scheda audio Creative SoundBlaster X-Fi XtremeMusic Platinum Edition...praticamente ho scaricato il file .gz del driver, selezionando prima il tipo di sistema operativo, quindi l'ho prima scompattato con

Codice: Seleziona tutto

gunzip  nome_file.gz

quindi mi sono ritrovato con un file .tar che ho scompattato a sua volta con

Codice: Seleziona tutto

tar -xvf nome_archivio.tar

dopodichè mi sono ritrovato con la directory contenente tutti i file...l'ho inserita in un file .tgz con

Codice: Seleziona tutto

tar czvf nuovo_nome.tgz cartella_originale

e quindi con

Codice: Seleziona tutto

installpkg nuovo_nome.tgz

ho cercato di installare il tutto...però nn noto alcun segno dell'installazione, neanche quando vado alla configurazione dell'audio mi trova la scheda...sbaglio io ad installarlo in questa maniera??
grazie mille in anticipo

MelmothX
Linux 1.0
Linux 1.0
Messaggi: 89
Iscritto il: sab nov 25, 2006 20:40

Re: Installazione driver Creative SoundBlaster X-Fi XtremeMusic

Messaggioda MelmothX » sab feb 21, 2009 15:06

Se lo rinominavi in .tgz facevi la stessa cosa, e ovviamente non serve a nulla. Leggiti S4D

Avatar utente
414N
Iper Master
Iper Master
Messaggi: 2893
Iscritto il: mer feb 13, 2008 16:19
Slackware: 14.2
Kernel: 4.4.19
Desktop: KDE4
Località: Bulagna
Contatta:

Re: Installazione driver Creative SoundBlaster X-Fi XtremeMusic

Messaggioda 414N » sab feb 21, 2009 15:39

Linuxofilo ha scritto:salve a tutti,
ho un problema con l'installazione dei driver della scheda audio Creative SoundBlaster X-Fi XtremeMusic Platinum Edition...praticamente ho scaricato il file .gz del driver, selezionando prima il tipo di sistema operativo...

Che pacchetto hai scaricato? Un pacchetto di binari o di sorgenti?

Linuxofilo
Linux 2.0
Linux 2.0
Messaggi: 113
Iscritto il: sab feb 14, 2009 15:08
Nome Cognome: Gianluigi Bianchi
Slackware: 14

Re: Installazione driver Creative SoundBlaster X-Fi XtremeMusic

Messaggioda Linuxofilo » sab feb 21, 2009 15:51

414N ha scritto:
Linuxofilo ha scritto:salve a tutti,
ho un problema con l'installazione dei driver della scheda audio Creative SoundBlaster X-Fi XtremeMusic Platinum Edition...praticamente ho scaricato il file .gz del driver, selezionando prima il tipo di sistema operativo...

Che pacchetto hai scaricato? Un pacchetto di binari o di sorgenti?

c'era scritto Driver Source Release...tralaltro era l'unico disponibile

Linuxofilo
Linux 2.0
Linux 2.0
Messaggi: 113
Iscritto il: sab feb 14, 2009 15:08
Nome Cognome: Gianluigi Bianchi
Slackware: 14

Re: Installazione driver Creative SoundBlaster X-Fi XtremeMusic

Messaggioda Linuxofilo » sab feb 21, 2009 15:58

MelmothX ha scritto:Se lo rinominavi in .tgz facevi la stessa cosa, e ovviamente non serve a nulla. Leggiti S4D

l'ho letto il S4D però dice che devo procedere come ho fatto fino ad ora con

Codice: Seleziona tutto

installpkg nome_pacchetto.tgz

infatti con aMSN è andato tutto liscio...nn capisco perchè con questo cambi la faccenda

Avatar utente
navajo
Staff
Staff
Messaggi: 3884
Iscritto il: gio gen 08, 2004 0:00
Nome Cognome: Massimiliano
Slackware: 13.37 (x86_64)
Kernel: 2.6.37.6
Desktop: KDE 4.7.0 (Alien)
Località: Roma

Re: Installazione driver Creative SoundBlaster X-Fi XtremeMusic

Messaggioda navajo » sab feb 21, 2009 16:34

Allora. I pacchetti di slackware, finiscono in tgz, ma NON sono dei semplici file compressi. I programmi per linux sono in genere, sorgenti, o binari.
Partiamo dai secondi. I binari non sono altro che programmi compilati per le varie distro . In questo caso, per slackware, saranno alla fine della compilazione chiamati: nomepacchetto.tgz. per debian invece, nomepacchetto.deb
Il programma che tu hai installato, amsn, se lo hai preso da slacky, è un binario compilato appositamente. Per questo lo hai potuto installare con installpkg.
Da quello che ho capito, tu hai scaricato i sorgenti, infatti : Driver Source Release che dovrebbe suonare come: rilascio dei sorgenti come sorgenti.
Se entri nella directory, ci deve essere un file read.me o qualcosa del genere, contenente le istruzioni per caricare i driver.
Cerca bene.

Avatar utente
umaga
Packager
Packager
Messaggi: 180
Iscritto il: lun gen 30, 2006 10:19
Slackware: 13.37
Kernel: 2.6.38.4-smp
Desktop: KDE 4.7
Località: Cagliari
Contatta:

Re: Installazione driver Creative SoundBlaster X-Fi XtremeMusic

Messaggioda umaga » sab feb 21, 2009 18:46

Mi inserisco per chiedere se nessuno nel forum ha questa scheda audio e si è mai cimentato nella compilazione dei driver. Poiche io ci ho provato e la compilazione dopo alcune modifiche ai file sorgenti è andata a buon fine, ma quando cerco di caricare il modulo il processo resta in stallo...
Fatemi sapere cosi magari ci scambiamo qualche informazione a riguardo.

ciao

ps. per linuxofilo, penso non abbia l'esperienza per affrontare questo problema. Penso che dovrai restare senza audio, cosa non bella, sinche non escono dei driver facilmente installabili.

Linuxofilo
Linux 2.0
Linux 2.0
Messaggi: 113
Iscritto il: sab feb 14, 2009 15:08
Nome Cognome: Gianluigi Bianchi
Slackware: 14

Re: Installazione driver Creative SoundBlaster X-Fi XtremeMusic

Messaggioda Linuxofilo » dom feb 22, 2009 2:23

umaga ha scritto:Mi inserisco per chiedere se nessuno nel forum ha questa scheda audio e si è mai cimentato nella compilazione dei driver. Poiche io ci ho provato e la compilazione dopo alcune modifiche ai file sorgenti è andata a buon fine, ma quando cerco di caricare il modulo il processo resta in stallo...
Fatemi sapere cosi magari ci scambiamo qualche informazione a riguardo.

ciao

ps. per linuxofilo, penso non abbia l'esperienza per affrontare questo problema. Penso che dovrai restare senza audio, cosa non bella, sinche non escono dei driver facilmente installabili.

grazie della fiducia

Avatar utente
navajo
Staff
Staff
Messaggi: 3884
Iscritto il: gio gen 08, 2004 0:00
Nome Cognome: Massimiliano
Slackware: 13.37 (x86_64)
Kernel: 2.6.37.6
Desktop: KDE 4.7.0 (Alien)
Località: Roma

Re: Installazione driver Creative SoundBlaster X-Fi XtremeMusic

Messaggioda navajo » dom feb 22, 2009 10:42

:D :D :D :D :D
Hai ragione. datti da fare e vedrai che ci riesci.. sarebbe utile almeno leggere le istruzioni che sono comprese nel sorgente.

Linuxofilo
Linux 2.0
Linux 2.0
Messaggi: 113
Iscritto il: sab feb 14, 2009 15:08
Nome Cognome: Gianluigi Bianchi
Slackware: 14

Re: Installazione driver Creative SoundBlaster X-Fi XtremeMusic

Messaggioda Linuxofilo » dom feb 22, 2009 11:46

dunque vi pasto il readme che vi ho trovato all'interno:

Codice: Seleziona tutto

Quick install

=============
In terminal,

1) Goto source directory
2) Execute make command as root
   make
   make install

Uninstall
=========
In terminal,
1) Goto source directory
2) Execute make command as root
   make uninstall

prima di tutto, go to source directory significa che mi devo posizionare nella directory dove si trova il file? e poi, il comando make lo devo scrivere così a caso o con una opzione particolare (tipo -f nome_pacchetto.tar, -d nome_pacchetto.tar) perchè se lo scrivo da solo mi dice make: *** No targets specified and no makefile found. Stop....che mi dite?

Avatar utente
navajo
Staff
Staff
Messaggi: 3884
Iscritto il: gio gen 08, 2004 0:00
Nome Cognome: Massimiliano
Slackware: 13.37 (x86_64)
Kernel: 2.6.37.6
Desktop: KDE 4.7.0 (Alien)
Località: Roma

Re: Installazione driver Creative SoundBlaster X-Fi XtremeMusic

Messaggioda navajo » dom feb 22, 2009 12:20

allora. ti conviene tenere il tar scaricato e cancellare tutto il resto, per fare una cosa pulita.
i comandi sono, una volta scompattata la directory:

Codice: Seleziona tutto

 
su
password di root
# cd /directory
# make
# make install


Questo è tutto, dovrebbe andare, poi se non succede nulla, puoi provare con i canonici comandi di alsa, per configurare la scheda ( non so se quei comandi installano solo il modulo )

Codice: Seleziona tutto

# alsaconf
# alsamixer ( togli il mute da tutti i canali che ti interssano (con m) )
# alsactl store


Aggiungi il tuo utente al gruppo audio.

Avatar utente
414N
Iper Master
Iper Master
Messaggi: 2893
Iscritto il: mer feb 13, 2008 16:19
Slackware: 14.2
Kernel: 4.4.19
Desktop: KDE4
Località: Bulagna
Contatta:

Re: Installazione driver Creative SoundBlaster X-Fi XtremeMusic

Messaggioda 414N » dom feb 22, 2009 12:34

Ho scaricato il pacchetto dei sorgenti che indiche e me lo ha compilato subito al primo colpo...
Ti riporto i passi esatti (da utente normale) che ho seguito:
  • Ho scaricato il pacchetto dei driver per Linux da questa pagina, e li ho piazzati in una directory temporanea sul disco (~/temp/creative);
  • Ho aperto una shell ed eseguito:

    Codice: Seleziona tutto

    cd ~/temp/creative
    tar xf XFiDrv_Linux_Public_US_1.00.tar.gz
    cd XFiDrv_Linux_Public_US_1.00
    make
    Ricordati che la shell ti aiuta con l'autocompletamento dei nomi dei file premendo il tasto TAB.
  • Se make termina senza segnalare errori (probabilmente vedrai alcuni warning, ma ignorali), digita:

    Codice: Seleziona tutto

    su
    <Inserisci la password di root>
    make install && make clean && exit

    per installare il driver. Il make clean serve ad eliminare i file intermedi prodotti dalla compilazione ormai inutili e exit ti fa tornare alla shell da utente normale.

Linuxofilo
Linux 2.0
Linux 2.0
Messaggi: 113
Iscritto il: sab feb 14, 2009 15:08
Nome Cognome: Gianluigi Bianchi
Slackware: 14

Re: Installazione driver Creative SoundBlaster X-Fi XtremeMusic

Messaggioda Linuxofilo » dom feb 22, 2009 13:57

navajo ha scritto:allora. ti conviene tenere il tar scaricato e cancellare tutto il resto, per fare una cosa pulita.
i comandi sono, una volta scompattata la directory:

Codice: Seleziona tutto

 
su
password di root
# cd /directory
# make
# make install


Questo è tutto, dovrebbe andare, poi se non succede nulla, puoi provare con i canonici comandi di alsa, per configurare la scheda ( non so se quei comandi installano solo il modulo )

Codice: Seleziona tutto

# alsaconf
# alsamixer ( togli il mute da tutti i canali che ti interssano (con m) )
# alsactl store


Aggiungi il tuo utente al gruppo audio.

dunque...facendo make nella directory del pacchetto esegue un sacco di processi, poi si ferma e io ho immesso make install e mi esce:
[CODE]Copy module files...
Update module dependency relationships...
[CODE]
sempre nella stessa directory...sono andato su Impostazioni-->suono e multimedia ma nn noto cambiamenti...ma dove devo aggiungere quelle stringhe che mi hai postato sopra tipo #alsaconf??

Avatar utente
navajo
Staff
Staff
Messaggi: 3884
Iscritto il: gio gen 08, 2004 0:00
Nome Cognome: Massimiliano
Slackware: 13.37 (x86_64)
Kernel: 2.6.37.6
Desktop: KDE 4.7.0 (Alien)
Località: Roma

Re: Installazione driver Creative SoundBlaster X-Fi XtremeMusic

Messaggioda navajo » dom feb 22, 2009 14:04

da consolle.

Avatar utente
414N
Iper Master
Iper Master
Messaggi: 2893
Iscritto il: mer feb 13, 2008 16:19
Slackware: 14.2
Kernel: 4.4.19
Desktop: KDE4
Località: Bulagna
Contatta:

Re: Installazione driver Creative SoundBlaster X-Fi XtremeMusic

Messaggioda 414N » dom feb 22, 2009 14:06

Linuxofilo ha scritto:dunque...facendo make nella directory del pacchetto esegue un sacco di processi, poi si ferma e io ho immesso make install e mi esce:

Codice: Seleziona tutto

Copy module files...
Update module dependency relationships...

sempre nella stessa directory...sono andato su Impostazioni-->suono e multimedia ma nn noto cambiamenti...ma dove devo aggiungere quelle stringhe che mi hai postato sopra tipo #alsaconf??

Facendo make install hai installato il modulo nel sistema.
Per vedere se funziona, devi innanzitutto caricarlo tramite il comando (eseguito da root)

Codice: Seleziona tutto

modprobe ctxfi
.
Se tutto va bene, non dovrebbe comparire alcun messaggio.
Per essere certi dell'effettivo caricamento del modulo, tramite il comando

Codice: Seleziona tutto

lsmod | grep ctxfi

puoi vedere se il modulo è stato caricato e se è in uso (il numero sulla destra sarebbe diverso da 0 in questo caso).
Caricato il modulo, puoi procedere con la configurazione di alsa tramite il comando alsaconf (naturalmente sempre come root).
Il # che navajo ha anteposto ad alcuni comandi indica solo il fatto che devi eseguire quei comandi come root.

EDIT:
Riguardando il Makefile, ho notato che il caricamento del modulo avviene già quando si lancia make install, percui non è necessario caricarlo manualmente con modprobe come ho riportato poco sopra.


Torna a “Hardware”

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti