Installazione driver Creative SoundBlaster X-Fi XtremeMusic

Usate questo forum per richieste di aiuto e consigli sull'hardware montato nelle vostre macchine con GNU/Linux Slackware.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata e la versione del Kernel. Questi dati aiutano le persone che possono rispondere.
2) Citare il tipo di hardware coinvolto in modo dettagliato.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT. Non usare termini gergali come procio, mobo e simili per identificare i componenti hardware.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Linuxofilo
Linux 2.0
Linux 2.0
Messaggi: 113
Iscritto il: sab feb 14, 2009 15:08
Nome Cognome: Gianluigi Bianchi
Slackware: 14

Re: Installazione driver Creative SoundBlaster X-Fi XtremeMusic

Messaggioda Linuxofilo » dom feb 22, 2009 14:57

niente nn me la trova...mi da solo quella integrata della mobo...naturalmente anche nella schermata di alsaconf nn c'è...

Avatar utente
navajo
Staff
Staff
Messaggi: 3884
Iscritto il: gio gen 08, 2004 0:00
Nome Cognome: Massimiliano
Slackware: 13.37 (x86_64)
Kernel: 2.6.37.6
Desktop: KDE 4.7.0 (Alien)
Località: Roma

Re: Installazione driver Creative SoundBlaster X-Fi XtremeMusic

Messaggioda navajo » dom feb 22, 2009 14:59

Hai settato il bios, in modo che veda come principale la scheda pci ?

Linuxofilo
Linux 2.0
Linux 2.0
Messaggi: 113
Iscritto il: sab feb 14, 2009 15:08
Nome Cognome: Gianluigi Bianchi
Slackware: 14

Re: Installazione driver Creative SoundBlaster X-Fi XtremeMusic

Messaggioda Linuxofilo » dom feb 22, 2009 15:08

bhè su Winzozzz funziona quindi penso sia impostata correttamente...

Avatar utente
navajo
Staff
Staff
Messaggi: 3884
Iscritto il: gio gen 08, 2004 0:00
Nome Cognome: Massimiliano
Slackware: 13.37 (x86_64)
Kernel: 2.6.37.6
Desktop: KDE 4.7.0 (Alien)
Località: Roma

Re: Installazione driver Creative SoundBlaster X-Fi XtremeMusic

Messaggioda navajo » dom feb 22, 2009 15:16

é da un bel po che non setto un pc con due schede in windows. Però mi sembra di ricordare che xp possa scegliere quale scheda audio far andare.
Te dai un occhiata al bios, male non fa.

Linuxofilo
Linux 2.0
Linux 2.0
Messaggi: 113
Iscritto il: sab feb 14, 2009 15:08
Nome Cognome: Gianluigi Bianchi
Slackware: 14

Re: Installazione driver Creative SoundBlaster X-Fi XtremeMusic

Messaggioda Linuxofilo » dom feb 22, 2009 16:45

navajo ha scritto:é da un bel po che non setto un pc con due schede in windows. Però mi sembra di ricordare che xp possa scegliere quale scheda audio far andare.
Te dai un occhiata al bios, male non fa.

nel BIOS nn c'è niente che mi permetta di settare l'ordine delle schede audio...

Avatar utente
navajo
Staff
Staff
Messaggi: 3884
Iscritto il: gio gen 08, 2004 0:00
Nome Cognome: Massimiliano
Slackware: 13.37 (x86_64)
Kernel: 2.6.37.6
Desktop: KDE 4.7.0 (Alien)
Località: Roma

Re: Installazione driver Creative SoundBlaster X-Fi XtremeMusic

Messaggioda navajo » dom feb 22, 2009 16:48

Se non ti chiede quale sia la primaria, dovrebbe chiederti se vuoi abilitare o meno le schede integrate.

Linuxofilo
Linux 2.0
Linux 2.0
Messaggi: 113
Iscritto il: sab feb 14, 2009 15:08
Nome Cognome: Gianluigi Bianchi
Slackware: 14

Re: Installazione driver Creative SoundBlaster X-Fi XtremeMusic

Messaggioda Linuxofilo » dom feb 22, 2009 17:08

navajo ha scritto:Se non ti chiede quale sia la primaria, dovrebbe chiederti se vuoi abilitare o meno le schede integrate.

niente di niente...nel bios nn trovo traccia delle schede audio...

Avatar utente
navajo
Staff
Staff
Messaggi: 3884
Iscritto il: gio gen 08, 2004 0:00
Nome Cognome: Massimiliano
Slackware: 13.37 (x86_64)
Kernel: 2.6.37.6
Desktop: KDE 4.7.0 (Alien)
Località: Roma

Re: Installazione driver Creative SoundBlaster X-Fi XtremeMusic

Messaggioda navajo » dom feb 22, 2009 17:23

mi sembra strano, devi cercare qualcosa che riguardi PnP

Linuxofilo
Linux 2.0
Linux 2.0
Messaggi: 113
Iscritto il: sab feb 14, 2009 15:08
Nome Cognome: Gianluigi Bianchi
Slackware: 14

Re: Installazione driver Creative SoundBlaster X-Fi XtremeMusic

Messaggioda Linuxofilo » dom feb 22, 2009 17:58

l'ho attivato un Plug and Play, ma nn sò se è quello giusto...quindi ora dovrei provare a configurare le schede?

Avatar utente
navajo
Staff
Staff
Messaggi: 3884
Iscritto il: gio gen 08, 2004 0:00
Nome Cognome: Massimiliano
Slackware: 13.37 (x86_64)
Kernel: 2.6.37.6
Desktop: KDE 4.7.0 (Alien)
Località: Roma

Re: Installazione driver Creative SoundBlaster X-Fi XtremeMusic

Messaggioda navajo » dom feb 22, 2009 17:58

si prova. che scheda madre hai ?

Avatar utente
Naitso
Linux 2.4
Linux 2.4
Messaggi: 208
Iscritto il: lun nov 10, 2008 15:09

Re: Installazione driver Creative SoundBlaster X-Fi XtremeMusic

Messaggioda Naitso » dom feb 22, 2009 17:59

Ciao Linuxofilo, se dal BIOS non riesci a disattivare la scheda audio interna puoi provare nel seguente modo: (riporto i moduli del mio pc come esempio)
1.

Codice: Seleziona tutto

cat /proc/asound/modules
 0 snd_intel8x0 <-- scheda audio interna
 1 snd_usb_audio <-- microfono usb

2.
per impostare la scheda audio interna come predefinita ho fatto la seguente operazione (da root)

Codice: Seleziona tutto

echo "options snd-usb-audio index=1" >> /etc/modprobe.d/snd-usb-audio


3. rimosso e reinseriti i moduli (tu qui puoi fare un reboot del pc)
4. e poi

Codice: Seleziona tutto

alsaconf
alsamixer


come ti hanno suggerito

P.S. devi sostituire snd-usb-audio (al punto 2) con il modulo della tua scheda intena se hai dubbi posta l'output del comando cat al punto 1
ciao

Linuxofilo
Linux 2.0
Linux 2.0
Messaggi: 113
Iscritto il: sab feb 14, 2009 15:08
Nome Cognome: Gianluigi Bianchi
Slackware: 14

Re: Installazione driver Creative SoundBlaster X-Fi XtremeMusic

Messaggioda Linuxofilo » dom feb 22, 2009 18:25

Naitso ha scritto:Ciao Linuxofilo, se dal BIOS non riesci a disattivare la scheda audio interna puoi provare nel seguente modo: (riporto i moduli del mio pc come esempio)
1.

Codice: Seleziona tutto

cat /proc/asound/modules
 0 snd_intel8x0 <-- scheda audio interna
 1 snd_usb_audio <-- microfono usb

2.
per impostare la scheda audio interna come predefinita ho fatto la seguente operazione (da root)

Codice: Seleziona tutto

echo "options snd-usb-audio index=1" >> /etc/modprobe.d/snd-usb-audio


3. rimosso e reinseriti i moduli (tu qui puoi fare un reboot del pc)
4. e poi

Codice: Seleziona tutto

alsaconf
alsamixer


come ti hanno suggerito

P.S. devi sostituire snd-usb-audio (al punto 2) con il modulo della tua scheda intena se hai dubbi posta l'output del comando cat al punto 1
ciao

ma per scheda audio interna di riferisci alla soundblaster o alla intel integrata nella mobo? ecco il punto 1:

Codice: Seleziona tutto

@localhost:~# cat /proc/asound/modules
 0 snd_hda_intel
 1 ctxfi

Linuxofilo
Linux 2.0
Linux 2.0
Messaggi: 113
Iscritto il: sab feb 14, 2009 15:08
Nome Cognome: Gianluigi Bianchi
Slackware: 14

Re: Installazione driver Creative SoundBlaster X-Fi XtremeMusic

Messaggioda Linuxofilo » dom feb 22, 2009 18:26

comunque di mobo ho una Asus p5kc

Avatar utente
Naitso
Linux 2.4
Linux 2.4
Messaggi: 208
Iscritto il: lun nov 10, 2008 15:09

Re: Installazione driver Creative SoundBlaster X-Fi XtremeMusic

Messaggioda Naitso » dom feb 22, 2009 18:34

Si mi riferivo all'integrata...
ora la tua integrata è

Codice: Seleziona tutto

0 snd_hda_intel

dunque puoi fare

Codice: Seleziona tutto

echo "options snd_hda_intel index=1" >> /etc/modprobe.d/snd_hda_intel


e poi riavvi e ci fai sapere

Linuxofilo
Linux 2.0
Linux 2.0
Messaggi: 113
Iscritto il: sab feb 14, 2009 15:08
Nome Cognome: Gianluigi Bianchi
Slackware: 14

Re: Installazione driver Creative SoundBlaster X-Fi XtremeMusic

Messaggioda Linuxofilo » dom feb 22, 2009 18:48

yuhuuu! sento la canzoncina di avvio di slack!! praticamente nel BIOS c'era una funzione che disabilitava l'audio integrato...nn sò se abbiano funzionato le stringhe di Naitso oppure bastava solo disabilitare l'intel high definition audio...comunque nn sò ancora se il driver creative sia stato installato correttamente...


Torna a “Hardware”

Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti