[RISOLTO]i video bloccano slackware 13.0

Usate questo forum per richieste di aiuto e consigli sull'hardware montato nelle vostre macchine con GNU/Linux Slackware.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata e la versione del Kernel. Questi dati aiutano le persone che possono rispondere.
2) Citare il tipo di hardware coinvolto in modo dettagliato.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT. Non usare termini gergali come procio, mobo e simili per identificare i componenti hardware.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
odiusseus
Linux 2.4
Linux 2.4
Messaggi: 352
Iscritto il: sab giu 30, 2007 14:09
Slackware: 13.0
Kernel: 2.6.32.2
Desktop: kde
Località: roma/vibo valentia
Contatta:

[RISOLTO]i video bloccano slackware 13.0

Messaggioda odiusseus » dom set 13, 2009 12:39

Salve ragazzi mia madre ha un serio quanto strano problema con slackware 13.0. L'installazione è standard 32 bit:
kernel 2.6.29.6-huge-smp. La amcchina ha un AMD Athlon(tm) 64 X2 Dual Core Processor 3800+, 2GB di RAM 667MHz e una scheda video Nvidia 9500GT.I drivers Nvidia sono

Codice: Seleziona tutto

NVIDIA-Linux-x86-185.18.14-pkg1.run

Se in /etc/profile metto la riga

Codice: Seleziona tutto

export LD_PRELOAD=/usr/lib/libGL.so.1

Kde4 non parte e mi restitusce un errore relativo a DBUS

Codice: Seleziona tutto

"Could not start D-Bus. Check your installation" and "startkde"

e non si avvia (nè da utente nè se tento il login da root).
Quindi per avviare kde non metto questa stringa in /etc/profile e Kde parte. Però quando faccio partire un video (avi,mpeg) con Mplaye,Xine, Dragon player ecc ecc si blocca X, il mouse non si muove, non riesco ad accedere nemmeno alla concole locale ma solo in remoto tramite ssh e sono costretto a riavviare la macchina.Però non ho nessun messaggio d'errore se guardo il log di X e dmesg non mi dice nulla che mi faccia pensare a qualche problema.
Per il resto funziona tutto e bene ....che ne pensate?
Ultima modifica di odiusseus il lun set 14, 2009 20:35, modificato 2 volte in totale.

Avatar utente
teox99
Linux 2.6
Linux 2.6
Messaggi: 737
Iscritto il: ven lug 25, 2008 14:54
Slackware: 13.37
Desktop: KDE - Xfce
Località: Roma[Eur]
Contatta:

Re: i video bloccano slackware 13.0

Messaggioda teox99 » dom set 13, 2009 13:44

non ti serve caricare libGL.so.1

hai li effetti attivi in kde?
potresti provare una versione meno recente dei drv nvidia
ftp://download.nvidia.com/XFree86/

odiusseus
Linux 2.4
Linux 2.4
Messaggi: 352
Iscritto il: sab giu 30, 2007 14:09
Slackware: 13.0
Kernel: 2.6.32.2
Desktop: kde
Località: roma/vibo valentia
Contatta:

Re: i video bloccano slackware 13.0

Messaggioda odiusseus » dom set 13, 2009 18:34

no non ho effetti attivi..ci ho pensato che i drivers meno recenti potrebbero risolvere ma meno recenti quanto? non è che ci sono prblemi d'incompatibilità con il kernel troppo nuovo?
Ciao e grazie

Avatar utente
phobos3576
Staff
Staff
Messaggi: 2980
Iscritto il: dom apr 17, 2005 0:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Re: i video bloccano slackware 13.0

Messaggioda phobos3576 » dom set 13, 2009 19:04

odiusseus ha scritto:non è che ci sono prblemi d'incompatibilità con il kernel troppo nuovo?
Ciao e grazie

Può essere. Infatti, in realtà stai usando dei driver vecchi; la versione stabile più recente è la 185.18.36.

Se poi vuoi fare anche esperimenti, puoi provare la recentissima beta 190.32.

http://www.nvnews.net/vbulletin/showthr ... ?p=2079643

odiusseus
Linux 2.4
Linux 2.4
Messaggi: 352
Iscritto il: sab giu 30, 2007 14:09
Slackware: 13.0
Kernel: 2.6.32.2
Desktop: kde
Località: roma/vibo valentia
Contatta:

Re: i video bloccano slackware 13.0

Messaggioda odiusseus » dom set 13, 2009 19:22

Ah...allora ci devo provare con drivers nuovi....grazie

odiusseus
Linux 2.4
Linux 2.4
Messaggi: 352
Iscritto il: sab giu 30, 2007 14:09
Slackware: 13.0
Kernel: 2.6.32.2
Desktop: kde
Località: roma/vibo valentia
Contatta:

Re: i video bloccano slackware 13.0

Messaggioda odiusseus » lun set 14, 2009 19:45

no niente da fare..ho aggiornato i drivers ma non cambia nulla...che disdetta...funziona così bene tutto il resto!!!!
dbus mi restituisce questo errore

Codice: Seleziona tutto

dbus-daemon[3366]: segfault at 70062128 ip b7f9045b sp bfea2790 error 4 in libGL.so.185.18.36[b7f69000+80000]

Codice: Seleziona tutto

dbus-daemon[3371]: segfault at 6ff54128 ip b7f0945b sp bf8a0070 error 4 in libGL.so.185.18.36[b7ee2000+80000]

Avatar utente
phobos3576
Staff
Staff
Messaggi: 2980
Iscritto il: dom apr 17, 2005 0:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Re: i video bloccano slackware 13.0

Messaggioda phobos3576 » lun set 14, 2009 20:00

Può anche darsi che il problema derivi dal fatto che il nuovo Xorg di default non usa il file /etc/X11/xorg.conf.

Prova a crearne uno personalizzato. rimuovi i driver nVidia e reinstallali; quando ti viene chiesto se vuoi modificare xorg.conf, rispondi YES.

odiusseus
Linux 2.4
Linux 2.4
Messaggi: 352
Iscritto il: sab giu 30, 2007 14:09
Slackware: 13.0
Kernel: 2.6.32.2
Desktop: kde
Località: roma/vibo valentia
Contatta:

Re: i video bloccano slackware 13.0

Messaggioda odiusseus » lun set 14, 2009 20:31

RISOLTO!!!! e vai!!! era uno stupido inutile deficiente problema di mplayer!!! bastava cambiare il drivers video usato da mplayer:

Codice: Seleziona tutto

mplayer -vo gl2 file.avi

e tutto va per il meglio...l'ho impostato su gmplayer con la sua GUI e dopo il clik sul file..tatannn il film..
grazie ragazzi siete stati veramente tanto gentili...grazie!!!


Torna a “Hardware”

Chi c’è in linea

Visitano il forum: Nessuno e 5 ospiti