Repository 32bit  Forum
Repository 64bit  Wiki

[RISOLTO] touchpad,non funziona

Usate questo forum per richieste di aiuto e consigli sull'hardware montato nelle vostre macchine con GNU/Linux Slackware.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata e la versione del Kernel. Questi dati aiutano le persone che possono rispondere.
2) Citare il tipo di hardware coinvolto in modo dettagliato.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT. Non usare termini gergali come procio, mobo e simili per identificare i componenti hardware.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

[RISOLTO] touchpad,non funziona

Messaggioda deadcandance » lun ago 30, 2010 1:46

salve...
ho da poco installato slack sul mio pc,ed ancora ho problemi con la confifgurazione del mio touchpad...
ho provato già a configurare xorg.conf facendolo generare al sistema stesso,col comando X -configure,ma continua a non funzionare...ho inoltre installato i driver synaptics ed ho cercato di modificare xorg.conf seguendo una discussione trovata su questo forum,ma continua a non funzionare...
e quello che vorrei che facesse,è che sia possibile il tapping,e scorrere le finestre...
posto qui di seguito xorg.conf:

Codice: Seleziona tutto
Section "ServerLayout"
   Identifier     "X.org Configured"
   Screen      0  "Screen0" 0 0
   InputDevice    "Mouse0" "CorePointer"
   InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
   ModulePath   "/usr/lib/xorg/modules"
   FontPath     "/usr/share/fonts/local"
   FontPath     "/usr/share/fonts/TTF"
   FontPath     "/usr/share/fonts/OTF"
   FontPath     "/usr/share/fonts/Type1"
   FontPath     "/usr/share/fonts/misc"
   FontPath     "/usr/share/fonts/CID"
   FontPath     "/usr/share/fonts/75dpi/:unscaled"
   FontPath     "/usr/share/fonts/100dpi/:unscaled"
   FontPath     "/usr/share/fonts/75dpi"
   FontPath     "/usr/share/fonts/100dpi"
   FontPath     "/usr/share/fonts/cyrillic"
EndSection

Section "Module"
   Load  "glx"
   Load  "extmod"
   Load  "dbe"
   Load  "dri2"
   Load  "dri"
EndSection

Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "kbd"
EndSection

Section "InputDevice"
   Identifier  "Mouse0"
   Driver      "mouse"
   Option       "Protocol" "auto"
   Option       "Device" "/dev/input/mice"
   Option       "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
   Identifier   "Monitor0"
   VendorName   "Monitor Vendor"
   ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "NoAccel"               # [<bool>]
        #Option     "SWcursor"              # [<bool>]
        #Option     "ColorKey"              # <i>
        #Option     "CacheLines"            # <i>
        #Option     "Dac6Bit"               # [<bool>]
        #Option     "DRI"                   # [<bool>]
        #Option     "NoDDC"                 # [<bool>]
        #Option     "ShowCache"             # [<bool>]
        #Option     "XvMCSurfaces"          # <i>
        #Option     "PageFlip"              # [<bool>]
   Identifier  "Card0"
   Driver      "intel"
   VendorName  "Unknown Vendor"
   BoardName   "Unknown Board"
   BusID       "PCI:0:2:0"
EndSection

Section "Screen"
   Identifier "Screen0"
   Device     "Card0"
   Monitor    "Monitor0"
   SubSection "Display"
      Viewport   0 0
      Depth     1
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     4
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     8
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     15
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     16
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     24
   EndSubSection
EndSection



spero in un vostro aiuto..
grazie
ciao
Ultima modifica di deadcandance il lun ago 30, 2010 14:03, modificato 1 volta in totale.
deadcandance
Linux 2.0
Linux 2.0
 
Messaggi: 118
Iscritto il: ven ago 20, 2010 12:23
Slackware: 13
Desktop: xfce4
Distribuzione: debian

Re: touchpad,non funziona

Messaggioda joseph » lun ago 30, 2010 12:51

Scusa ma non si muove proprio oppure il tap non funziona? comunque prova a caricare manualmente questi moduli

evdev
psmouse

A volte è il server hal che da problemi. Facci sapere ciao
Avatar utente
joseph
Linux 2.4
Linux 2.4
 
Messaggi: 205
Iscritto il: lun giu 14, 2010 22:50
Località: Salerno
Slackware: 13.37
Kernel: 3.2.9
Desktop: xfce

Re: touchpad,non funziona

Messaggioda deadcandance » lun ago 30, 2010 13:11

ciao..
scusa se non ho specificato bene...
il tapping non funziona,mentre posso muovere il puntatore senza alcun problema,ma ovviamente non posso nemmeno scorrere le finestre...
ho caricato quei moduli manualmente,ma continuo a essere sempre nella stessa situazione...

grazie per la risposta
ciao
deadcandance
Linux 2.0
Linux 2.0
 
Messaggi: 118
Iscritto il: ven ago 20, 2010 12:23
Slackware: 13
Desktop: xfce4
Distribuzione: debian

Re: touchpad,non funziona

Messaggioda Blallo » lun ago 30, 2010 13:24

da root, crea un file in
/etc/hal/fdi/policy/11-x11-synaptics.fdi
e ci scrivi dentro
Codice: Seleziona tutto
<?xml version="1.0" encoding="ISO-8859-1"?>
<deviceinfo version="0.2">
  <device>
    <match key="info.capabilities" contains="input.touchpad">
        <merge key="input.x11_driver" type="string">synaptics</merge>
        <merge key="input.x11_options.SHMConfig" type="string">true</merge>
        <merge key="input.x11_options.VertEdgeScroll" type="string">true</merge>
        <merge key="input.x11_options.MaxTapTime" type="string">180</merge>
        <merge key="input.x11_options.FingerLow" type="string">25</merge>
        <merge key="input.x11_options.FingerHigh" type="string">30</merge>
        <merge key="input.x11_options.TapButton1" type="string">1</merge>
        <merge key="input.x11_options.TapButton2" type="string">3</merge>
        <merge key="input.x11_options.TapButton3" type="string">2</merge>
        <merge key="input.x11_options.RTCornerButton" type="string">3</merge>
        <merge key="input.x11_options.RBCornerButton" type="string">2</merge>
    </match>
  </device>
</deviceinfo>


poi riavvia il computer e vedi
Io sono il detective Arsenio Magret, e porto sempre la camicia TATUATA!
Avatar utente
Blallo
Packager
Packager
 
Messaggi: 3212
Iscritto il: ven ott 12, 2007 10:37
Località: Torino / Torremaggiore (FG)
Nome Cognome: Savino Liguori
Slackware: 14.1 / 12.2
Kernel: 3.12.2-ck
Desktop: Openbox

Re: touchpad,non funziona

Messaggioda deadcandance » lun ago 30, 2010 14:03

funziona!!!grazie per la soluzione proposta...ora funziona tutto alla perfezione...
grazie tante...
ciao
deadcandance
Linux 2.0
Linux 2.0
 
Messaggi: 118
Iscritto il: ven ago 20, 2010 12:23
Slackware: 13
Desktop: xfce4
Distribuzione: debian

Re: [RISOLTO] touchpad,non funziona

Messaggioda joseph » lun ago 30, 2010 16:21

prova a caricare manualmente questi moduli

evdev
psmouse

A volte è il server hal che da problemi. Facci sapere ciao


Questa era per un eventuale non riconoscimento della periferica. Ho frainteso io, pensavo che il mouse non veniva riconosciuto
e di conseguenza non si muoveva. Per il tap non funzionava perchè hal non sapeva dove leggere le caratteristiche del mouse.
Ciao :D
Avatar utente
joseph
Linux 2.4
Linux 2.4
 
Messaggi: 205
Iscritto il: lun giu 14, 2010 22:50
Località: Salerno
Slackware: 13.37
Kernel: 3.2.9
Desktop: xfce


Torna a Hardware

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite

cron