Repository 32bit  Forum
Repository 64bit  Wiki

ATI M9000 Kernel 2.6.35.6 instabile

Usate questo forum per richieste di aiuto e consigli sull'hardware montato nelle vostre macchine con GNU/Linux Slackware.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata e la versione del Kernel. Questi dati aiutano le persone che possono rispondere.
2) Citare il tipo di hardware coinvolto in modo dettagliato.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT. Non usare termini gergali come procio, mobo e simili per identificare i componenti hardware.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

ATI M9000 Kernel 2.6.35.6 instabile

Messaggioda Calzo » mer set 29, 2010 21:25

Ciao a tutti.
Ho un ACER Aspire 1601 LC con una ATI 9000M e ho aggiornato da pochissimo il kernel da un 2.6.32.7 a un 2.6.35.6 su Slackware 13, server X 1.6.3 e il driver grafico in xorg.conf è settato con "radeon".

Ora ho gravissimi problemi di stabilità: qualsiasi programma che sfrutti l'accelerazione 3D crea o il crash totale del sistema (posso solo spegnerlo tramite il pulsante di power-on, e spesso forzatamente). Ho avviato glxgears, mplayer -vo gl2 ... sotto fluxbox e anche il KDE con gli effetti grafici abilitati. Il risulatato è sempre lo steso. In particolare in fluxbox devo "toccare" i programmi perchè diano problemi (per esempio spostarli col mouse o mettendoli in secondo piano con alt-tab o ancora selezionando altre finestre).

Forse è un problema gia noto, ma a parte questo link non ho visto altro e il problema sembra legato a X in questa segnalazione (o sbaglio?).

Questo succede anche a voi? e/o avete risolto in qualche modo?

grazie.

PS: con gli altri kernel non ci sono problemi.
Avatar utente
Calzo
Linux 2.0
Linux 2.0
 
Messaggi: 112
Iscritto il: sab ott 06, 2007 21:21
Località: MN
Slackware: 10.2 | 13
Desktop: Fluxbox | KDE

Re: ATI M9000 Kernel 2.6.35.6 instabile

Messaggioda hashbang » gio set 30, 2010 12:40

Lì dice che il server X va in crash quando viene caricato il KMS al boot. Se hai lo stesso problema prova a fare il boot mettendo l'opzione
Codice: Seleziona tutto
-nomodeset
e vedi se la situazione cambia.
Adoro il pragmatismo della lingua giapponese, è l'unica in cui per dire ad una ragazza che la ami le dici "suki". (cit.)
Avatar utente
hashbang
Packager
Packager
 
Messaggi: 1829
Iscritto il: ven giu 04, 2010 9:27
Località: Lecce
Nome Cognome: Luca De Pandis
Distribuzione: Windows 8.1 Pro

Re: ATI M9000 Kernel 2.6.35.6 instabile

Messaggioda Calzo » gio set 30, 2010 18:20

atomix600 ha scritto:Se hai lo stesso problema prova a fare il boot mettendo l'opzione -nomodeset e vedi se la situazione cambia.

No non mi da problemi al boot, ma solo dopo che si è avviato X.
Infatti ho provato a torgliere il modeset caricando il driver così
Codice: Seleziona tutto
modprobe radeon modeset=0
Ok funziona, ma mi toglie l'accelerazione 3D :(
Avatar utente
Calzo
Linux 2.0
Linux 2.0
 
Messaggi: 112
Iscritto il: sab ott 06, 2007 21:21
Località: MN
Slackware: 10.2 | 13
Desktop: Fluxbox | KDE


Torna a Hardware

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti