Repository 32bit  Forum
Repository 64bit  Wiki

ATI open e sleep del PC

Usate questo forum per richieste di aiuto e consigli sull'hardware montato nelle vostre macchine con GNU/Linux Slackware.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata e la versione del Kernel. Questi dati aiutano le persone che possono rispondere.
2) Citare il tipo di hardware coinvolto in modo dettagliato.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT. Non usare termini gergali come procio, mobo e simili per identificare i componenti hardware.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

ATI open e sleep del PC

Messaggioda targzeta » sab feb 12, 2011 16:38

Mi ha contattato un ragazzo dicendo che la sua scheda video non è supportata dai driver ATI proprietari. Ora stiamo cercando di far compilare i 9.3 con il kernel della 13.1.

Gli ho detto di passare agli open e dice che ha dei problemini quando ritorna dalla modalità sleep perché i driver open non sono capaci di riattivare la scheda video (o qualcosa del genere). Qualcuno di voi ha riscontrato questi problemi e li ha risolti?

Ha una ATI Radeon X300 Mobility.

Grazie mille,
Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6186
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: ATI open e sleep del PC

Messaggioda 414N » sab feb 12, 2011 16:56

Io ho una X800 e con gli open mi trovo piuttosto bene.
I problemi che ho riscontrato (e non ho ancora risolto) sono i seguenti:
  • Mettere il pc in standby e farlo riprendere dallo stesso funziona 8 volte su 10. Alcune volte, il video rimane nero (il monitor si accende, però) e il sistema non risponde nemmeno tramite ssh da un altro pc. Direi quindi un bel hard-freeze. Ho notato, però, che questi blocchi sono frequenti quando lascio il pc in standby per molto tempo (un'ora o più).
  • L'ibernazione si rifiuta di funzionare, sia con le pm-utils sia con gli echo diretti. Sembra che il modulo radeon non voglia saperne di "staccare la spina" e, quindi, faccia fallire tutto il processo, riportandomi al desktop come se nulla fosse successo.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: ATI open e sleep del PC

Messaggioda targzeta » sab feb 12, 2011 17:05

Ok, quindi sostanzialmente confermi i problemi. Per chiarirmi le idee, quando si dice standby è come se si dicesse sleep che è come se si dicesse suspend to RAM giusto? Mentre l'ibernazione è il suspend to disk, corretto?

Anche lui dice che dopo lo sleep a volte la scheda va, altre volte no. Mentre con i proprietary, quando compilavano (quindi vecchi kernel della Slackware) non aveva di questi problemi.

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6186
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: ATI open e sleep del PC

Messaggioda 414N » sab feb 12, 2011 17:43

spina ha scritto:Ok, quindi sostanzialmente confermi i problemi. Per chiarirmi le idee, quando si dice standby è come se si dicesse sleep che è come se si dicesse suspend to RAM giusto? Mentre l'ibernazione è il suspend to disk, corretto?

Esatto.
Dubito fortemente che sia possibile far funzionare i vecchi fglrx 9.3 sulle distribuzioni recenti, visti i cambiamenti avvenuti a livello kernel ed X da allora.
Inoltre, aveveno i loro bei problemi anche loro...
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: ATI open e sleep del PC

Messaggioda targzeta » sab feb 12, 2011 17:59

Hai ragione. Infatti stiamo facendo i salti mortali, ho anche cambiato la licenza del driver ATI in modo da poter sfruttare le S.C. del kernel, alcune sono solo GPL e non si possono usare sui driver proprietari. Comunque se riusciamo a farli compilare vi aggiorno.

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6186
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: ATI open e sleep del PC

Messaggioda 414N » sab feb 12, 2011 18:05

Anche se compilano temo non basti.
Comunque vedremo.
In bocca al lupo! ;)
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: ATI open e sleep del PC

Messaggioda ocman » mar feb 15, 2011 11:33

kernel 2.6.36.3 statico
framebuffer attivo = solo quello ati
DRM attivo = solo quello ati + MODESETTING ATTIVO
slackware current 64 con gli ultimi pacchetti della radeon
2 problemi:
- dallo sleep non si ripristina mai. schermo nero. hardfreeze sempre. il supporto nel kernel è stato attivato correttamente.
- all'avvio della macchina quando deve caricare il firmware della mia scheda (rv730) si blocca 30 secondi e poi tutto procede correttamente fino ad init4. (cosa mai vista)
ocman
Linux 2.4
Linux 2.4
 
Messaggi: 239
Iscritto il: gio lug 31, 2008 17:18
Slackware: ArchLinux
Desktop: xfce
Distribuzione: OpenIndiana

Re: ATI open e sleep del PC

Messaggioda targzeta » mar feb 15, 2011 18:31

ocman ha scritto:...
- all'avvio della macchina quando deve caricare il firmware della mia scheda (rv730) si blocca 30 secondi e poi tutto procede correttamente fino ad init4. (cosa mai vista)
E' un po' offtopic, comunque, visto che il kernel te lo sei compilato da solo, ti sei assicurato di inserire il firmware nel kernel? Se il firmware è fornito con il kernel devi abilitare l'opzione:
Codice: Seleziona tutto
CONFIG_FIRMWARE_IN_KERNEL=y
se invece il firmware è esterno dovresti inserire il path nel config del kernel alla voce:
Codice: Seleziona tutto
CONFIG_EXTRA_FIRMWARE=
entrambe le voci si trovano sotto:
Codice: Seleziona tutto
Device Drivers  ---> Generic Driver Options  ---> Userspace firmware loading support

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6186
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: ATI open e sleep del PC

Messaggioda ocman » mar feb 15, 2011 19:00

certo
Codice: Seleziona tutto
       bash-4.1$ grep FIRMWARE /boot/config
# CONFIG_PREVENT_FIRMWARE_BUILD is not set
CONFIG_FIRMWARE_IN_KERNEL=y
CONFIG_EXTRA_FIRMWARE=""
CONFIG_FIRMWARE_EDID=y
CONFIG_FIRMWARE_MEMMAP=y
 


dopo il make per sicurezza faccio anche un make firmware_install

con il 2.6.37 succede la stessa cosa.
ocman
Linux 2.4
Linux 2.4
 
Messaggi: 239
Iscritto il: gio lug 31, 2008 17:18
Slackware: ArchLinux
Desktop: xfce
Distribuzione: OpenIndiana

Re: ATI open e sleep del PC

Messaggioda targzeta » mar feb 15, 2011 19:11

Ma il firmware viene distribuito con il kernel o te lo scarichi da qualche parte? Io ho i tuoi stessi settaggi e non ho nessun problema. Prima di inserire il firmware nel kernel però ce l'avevo anche io.

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6186
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: ATI open e sleep del PC

Messaggioda targzeta » lun feb 21, 2011 8:32

ocman ha scritto:...
- all'avvio della macchina quando deve caricare il firmware della mia scheda (rv730) si blocca 30 secondi e poi tutto procede correttamente fino ad init4. (cosa mai vista)

Alla voce " Device Drivers ---> Graphics support ---> Support for frame buffer devices ---> Enable firmware EDID" dice:
CONFIG_FIRMWARE_EDID:

This enables access to the EDID transferred from the firmware.
On the i386, this is from the Video BIOS. Enable this if DDC/I2C
transfers do not work for your driver and if you are using
nvidiafb, i810fb or savagefb.

In general, choosing Y for this option is safe. If you
experience extremely long delays while booting before you get
something on your display, try setting this to N. Matrox cards in
combination with certain motherboards and monitors are known to
suffer from this problem.
Non penso sia questa la causa, però, non si sa mai :)

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6186
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: ATI open e sleep del PC

Messaggioda ocman » mar feb 22, 2011 4:16

dopo aver letto la descrizione ero convinto fosse quella.
purtroppo dopo aver compilato la 27.1 fa sempre la stessa cosa.
grazie lo stesso.
ocman
Linux 2.4
Linux 2.4
 
Messaggi: 239
Iscritto il: gio lug 31, 2008 17:18
Slackware: ArchLinux
Desktop: xfce
Distribuzione: OpenIndiana

Re: ATI open e sleep del PC

Messaggioda targzeta » mar feb 22, 2011 12:21

Ci abbiamo provato :). Comunque tu citi un firmware. Io nella directory /lib/firmware ho solo il file del firmware per la wireless. Quelli della scheda video non li vedo più, sono tutti nel kernel. Se il tuo firmware è esterno al kernel, dovresti indicargli dove si trova, in modo che lo possa includere nel binario. Ti posto quello che ho settato io per il DRM, FB e FIRMWARE:
Codice: Seleziona tutto
CONFIG_DRM=y
CONFIG_DRM_KMS_HELPER=y
CONFIG_DRM_TTM=y
CONFIG_DRM_RADEON=y
CONFIG_DRM_RADEON_KMS=y
Codice: Seleziona tutto
CONFIG_FB=y
CONFIG_FB_CFB_FILLRECT=y
CONFIG_FB_CFB_COPYAREA=y
CONFIG_FB_CFB_IMAGEBLIT=y
Codice: Seleziona tutto
CONFIG_PREVENT_FIRMWARE_BUILD=y
CONFIG_FIRMWARE_IN_KERNEL=y
CONFIG_EXTRA_FIRMWARE=""
CONFIG_FIRMWARE_MEMMAP=y

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6186
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: ATI open e sleep del PC

Messaggioda ocman » mer feb 23, 2011 8:14

scusami ma vado di fretta. ecco l'output

Codice: Seleziona tutto
bash-4.1$ (grep FIRMWARE config ; grep FB config; grep DRM config;) | grep -v \#
CONFIG_FIRMWARE_IN_KERNEL=y
CONFIG_EXTRA_FIRMWARE=""
CONFIG_FIRMWARE_MEMMAP=y
CONFIG_FB=y
CONFIG_FB_DDC=y
CONFIG_FB_CFB_FILLRECT=y
CONFIG_FB_CFB_COPYAREA=y
CONFIG_FB_CFB_IMAGEBLIT=y
CONFIG_FB_BACKLIGHT=y
CONFIG_FB_MODE_HELPERS=y
CONFIG_FB_TILEBLITTING=y
CONFIG_FB_RADEON=y
CONFIG_FB_RADEON_I2C=y
CONFIG_FB_RADEON_BACKLIGHT=y
CONFIG_DRM=y
CONFIG_DRM_KMS_HELPER=y
CONFIG_DRM_TTM=y
CONFIG_DRM_RADEON=y
CONFIG_DRM_RADEON_KMS=y
bash-4.1$
ocman
Linux 2.4
Linux 2.4
 
Messaggi: 239
Iscritto il: gio lug 31, 2008 17:18
Slackware: ArchLinux
Desktop: xfce
Distribuzione: OpenIndiana

Re: ATI open e sleep del PC

Messaggioda targzeta » mer feb 23, 2011 9:51

C'è una cosa che non capisco, perché usi il frame buffer radeon? Tanto hai il KMS abilitato. Diciamo che come DRM e FIRMWARE siamo simili, con il FB invece mi sembra che hai qualcosina di troppo. Se puoi fare delle prove, disabilita il frame buffer radeon, magari è quello che crea casino.

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6186
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Prossimo

Torna a Hardware

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti