Repository 32bit  Forum
Repository 64bit  Wiki

LXDE...problemini...

Usate questo forum per richieste di aiuto e consigli sull'hardware montato nelle vostre macchine con GNU/Linux Slackware.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata e la versione del Kernel. Questi dati aiutano le persone che possono rispondere.
2) Citare il tipo di hardware coinvolto in modo dettagliato.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT. Non usare termini gergali come procio, mobo e simili per identificare i componenti hardware.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

LXDE...problemini...

Messaggioda Black bart » ven mag 24, 2013 21:46

Salve a tutti,ho installato il mio DE preferito (LXDE) seguendo le indicazioni di "ponce" e tutto fila liscio,anche l'installazione di LXDM poi però' non mi funzionano i tasti per il controllo del volume da tastiera,sapete come fare?
Inoltre non riesco a settare la tastiera in italiano...avete suggerimenti?

Grazie mille!
Black bart
Linux 1.0
Linux 1.0
 
Messaggi: 93
Iscritto il: sab apr 20, 2013 22:10
Località: Bergamo
Nome Cognome: Omar Zanetti
Slackware: 14
Desktop: XFCE

Re: LXDE...problemini...

Messaggioda ponce » sab mag 25, 2013 6:16

in realta' questi due problemini non dipendono da LXDE ;)

per la tastiera in italiano, dai un'occhiata al file /usr/share/X11/xorg.conf.d/90-keyboard-layout.conf: te ne quoto un pezzo
Codice: Seleziona tutto
# READ THIS FOR CUSTOM KEYBOARD INFORMATION
#
#  If you want to add a custom model/layout/variant to X, you will need to COPY
#  this file to /etc/X11/xorg.conf.d/ and edit that copy.  After editing it to
#  suit, you will need to restart X.

seguendo le indicazioni di Pat, devi copiare quel file dentro /etc/X11/xorg.conf.d/ e modificare le linee
Codice: Seleziona tutto
       Option "XkbLayout" "us"
       Option "XkbVariant" "intl"

cosi'
Codice: Seleziona tutto
       Option "XkbLayout" "it"
       Option "XkbVariant" ""


riguardo i tasti per il controllo del volume puoi usare xbindkeys (puoi installarlo anche usando sbopkg) seguendo questa guida, che ho appena testato con due piccole modifiche/aggiunte:

- il file con la mappatura da tastiera personalizzata invece di ~/.xmodmaprc e' ~/.Xmodmap : se puo' esserti utile come esempio (ma e' molto probabile che i keycode nel tuo caso siano diversi, trovali con xev come spiegato nella guida) questo e' il mio file
Codice: Seleziona tutto
keycode 122 = F24
keycode 123 = F25

- ho aggiunto la riga
Codice: Seleziona tutto
/usr/bin/xbindkeys &

al mio ~/.xinitrc perche' avvio in runlevel 3 (login testuale), ma se avvii in runlevel 4 (login grafico) con lxdm (che non legge il tuo ~/.xinitrc) devi aggiungerlo invece dentro al file /etc/lxdm/PostLogin

sempre come esempio, questo e' il mio file ~/.xbindkeysrc
Codice: Seleziona tutto
# Volume GIU’
"amixer set Master 1-"
m:0x10 + c:122
Mod2 + F24
# Volume SU’
"amixer set Master 1+"
m:0x10 + c:123
Mod2 + F25
Avatar utente
ponce
Linux 3.x
Linux 3.x
 
Messaggi: 1485
Iscritto il: mer mar 05, 2008 16:45
Località: limbo
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 3.17-rc3
Desktop: lxde


Torna a Hardware

Chi c’è in linea

Visitano il forum: Bing [Bot] e 3 ospiti