Repository 32bit  Forum
Repository 64bit  Wiki

Frequenza Monitor in X

Usate questo forum per richieste di aiuto e consigli sull'hardware montato nelle vostre macchine con GNU/Linux Slackware.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata e la versione del Kernel. Questi dati aiutano le persone che possono rispondere.
2) Citare il tipo di hardware coinvolto in modo dettagliato.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT. Non usare termini gergali come procio, mobo e simili per identificare i componenti hardware.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Messaggioda pumax » lun set 12, 2005 11:20

Ragazzi, ho scoperto quale è il problema: IL DRIVER!!!
Mi spiego meglio... se nell'xorg.conf carico il driver vesa allora mi prende le impostazioni della frequenza, mentre se carico il driver "fglrx" per l'accelerazione grafica mi va automaticamente a 75hz. Ora mi chiedo, possibile non ci sia un modo per modificare questa impostazione di "default"?
Ciauz
Avatar utente
pumax
Linux 2.0
Linux 2.0
 
Messaggi: 153
Iscritto il: mar mar 15, 2005 0:00

Messaggioda pumax » mer set 14, 2005 13:40

Nessuna idea??? :(
Avatar utente
pumax
Linux 2.0
Linux 2.0
 
Messaggi: 153
Iscritto il: mar mar 15, 2005 0:00

Messaggioda mib85 » gio set 15, 2005 23:27

Ciao pumax
Ciò che stabilisce la frequenza del monitor in xorg.conf sono il "VertRefresh" e l'"HorizSync". In genere si "dovrebbe" poterli trovare nel manuale del monitor. Dico si dovrebbe perchè io c'ho perso la testa x almeno un anno (il manuale del mio notebook HP non riporta nulla del genere) ed i risultati sono qui: http://www.mibware.altervista.org/
Se recuperi VertRefresh ed HorizSync il gioco è fatto! In giro x il web ci sono molte utility che calcolano stringhe particolari da inserire in xorg.conf semplicemente inserendo questi due dati.
Spero riuscirai a risolvere il tuo problema
Avatar utente
mib85
Linux 1.0
Linux 1.0
 
Messaggi: 11
Iscritto il: lun gen 31, 2005 0:00
Località: Grumento Nova (PZ) / Salerno

Messaggioda pumax » dom set 18, 2005 11:48

Ciao mib. Ti ringrazio moltissimo per la risposta. Ho provato già molte volte con le frequenze riportate dal manuale (che tra l'altro non era incluso nella confezione e ho dovuto farmelo spedire dalla Samsung tramite formato PDF). Le frequenze originali sono:
HorizSync 30-81
VertRefresh 56-75

Ma non mi permette comunque di cambiare frequenza. Io a 1280x1024 vorrei avere una frequenza di 60hz, non di 75hz. Questo però non me lo permette di fare se carico il fglrx.
Ciauz
Avatar utente
pumax
Linux 2.0
Linux 2.0
 
Messaggi: 153
Iscritto il: mar mar 15, 2005 0:00

Messaggioda Flinco » mer set 28, 2005 18:05

Non vorrei dire bestialità ma prova inserendo Option "IgnoreEDID"
Ho postato una parte del mio xorg.conf come esempio.

Codice: Seleziona tutto
**********************************************************************
# Graphics device section
# **********************************************************************

Section "Device"

    Identifier  "nVidia GeForce2 Ti"
    Driver      "nvidia"
    Vendorname  "nVidia"
    Boardname   "Riva GeForce2 Ti"
    Option      "NvAGP" "2"
    Option      "ConnectedMonitor" "CRT"
    Option      "IgnoreEDID"

EndSection



L. B.
Avatar utente
Flinco
Linux 1.0
Linux 1.0
 
Messaggi: 45
Iscritto il: mer apr 13, 2005 23:00
Località: Pontebba (UD)

Messaggioda pumax » mer ott 05, 2005 23:41

Ciao Flinco, ti ringrazio per la risposta, molto gentile ;), non era tuttavia quello il problema. Dopo moltissimo tempo sono riuscito a risolvere. Bastava decommentare la stringa del PnP disabilitando dunque il Plug&Play dei monitor:
Option "NoDDC".
Ciauz :)
Avatar utente
pumax
Linux 2.0
Linux 2.0
 
Messaggi: 153
Iscritto il: mar mar 15, 2005 0:00

Precedente

Torna a Hardware

Chi c’è in linea

Visitano il forum: Exabot [Bot] e 2 ospiti