Pagina 1 di 1

Configurare 6600gt AGP

Inviato: dom ago 14, 2005 12:49
da Guevara
Ciao a tutti...allora come da oggetto la mia scheda video non riesce ad andare con idriver NVidia.

Allora nel xorg.conf se uso i driver "nv" l'errore di X è:

No device detected
No Screen Found

Provando a installare i driver dal sito, configurando xorg e caricando i driver con

modprobe nvidia

X sembra avviarsi e poi si inchioda con schermo nero e tutto bloccato (mouse e tastiera)

Qualcuno può aiutarmi? Grazie

Re: Configurare 6600gt AGP

Inviato: dom ago 14, 2005 12:58
da gastone90
Guevara ha scritto:...Allora nel xorg.conf se uso i driver "nv"...

Anch'io ho un nvidia, ma configurando con nv mi dava anche a me lo stesso errore; devi lasciare quella di default che adesso non mi ricordo se è vesa o altro :roll:

Inviato: dom ago 14, 2005 13:31
da Guevara
quindi niente accellerazione 3d o setting della scheda?? :(

Inviato: dom ago 14, 2005 13:54
da Tochiro
per ottenere l'accelerazione 3d puoi provare ad installare i driver proprietari disponibili in http://www.nvidia.it
leggi bene il readme perchè dovrai anche modificare xorg.conf a mano.

Inviato: dom ago 14, 2005 14:12
da clodo
Potrebbe essere un problema di agp: il driver nvdia è composto di 2 grossi oggetti[a parte le librerie]:
1- il modulo del kernel nvidia.ko, che viene in realtà costruito dall'installer.
2- il driver della scheda nvidia che si chiama nvidia.
Se fai modprobe nvidia carichi il modulo del kernel; per il driver devi editare xorg.conf scrivendo nvidia al posto di nv o vesa.
Per l'agp hai due scelte: puoi usare l'agpgart del kernel, consigliato un 2.6.x, oppure l'agpgart "interno" del driver nvidia, soluzione questa a cui certe volte bisogna ricorrere in caso di problemi. Questi due moduli non possono coesistere, e se hai un kernel compilato con l'agpgart staticamente non potrai mai usare l'agpgart del driver se no crash e blocco.
E' anche utile dire a udev di dare i giusti permessi ad agpgart, tipicamente mode 0660 group:video.
La scelta dell'agp di linux o di nvidia si fa in xorg.conf con :
Option "NvAGP" "2" # agp di linux
Option "NvAGP" "1" # agp di nvidia

Inviato: dom ago 14, 2005 14:16
da Guevara
Provando a installare i driver dal sito, configurando xorg e caricando i driver con

modprobe nvidia


Già fatto. Con i driver proprietari mi da schermo nero all'avvio di X

Inviato: dom ago 14, 2005 15:36
da Trotto@81
Non ci hai detto che kernel usi, e se il tuo chipeset è supportato.
Se il chipset della tua mobo non è supportato al 100% puoi scordarti l'accellerazione grafica.
Se il kernel è quello di default della slack, il modulo agpgart è inserito come modulo nel kernel, su questo non ci piove.
Il problema principale risiede nel chipset se nn si era capito :P
La questione dell'agpgart interno o esterno è un'altra questione.
Quello interno è leggermente più performante rispetto a quello dei driver closed.
Io non faccio nemmeno #modprobe nvidia, configuro x11 e lo lancio direttamente, ci pensa lui a tirarlo su.

Potrebbe essere un problema di agp: il driver nvdia è composto di 2 grossi oggetti[a parte le librerie]:
1- il modulo del kernel nvidia.ko, che viene in realtà costruito dall'installer.
2- il driver della scheda nvidia che si chiama nvidia.


@clodo: nvida.ko e nvidia sono la stessa cosa. le due cose a cui ti riferisci sono nvidia e agpgart.

Ritornado la problema, dacci tutte le info e vedremo se possiamo esserti di maggiore aiuto.

Inviato: dom ago 14, 2005 15:49
da Guevara
Non so come ringraziarvi!!!
Spettacolare!

Il problema era tutto nel settaggio dell'AGP

Kernel 2.4.6. Ho inserito
Option "NvAGP" "2"

Grazie grazie grazie... :P :D

Inviato: dom ago 14, 2005 16:32
da clodo
@clodo: nvida.ko e nvidia sono la stessa cosa. le due cose a cui ti riferisci sono nvidia e agpgart.

/lib/modules/2.6.10-5-386/kernel/drivers/video/nvidia.ko :modulo del kernel

/usr/X11R6/lib/modules/drivers/nvidia_drv.o : driver per xorg

Inviato: dom ago 14, 2005 17:02
da clodo
Guevara ha scritto:Non so come ringraziarvi!!!
Spettacolare!

Il problema era tutto nel settaggio dell'AGP

Kernel 2.4.6. Ho inserito
Option "NvAGP" "2"

Grazie grazie grazie... :P :D

in effetti:

There are several choices for configuring the NVIDIA kernel module's use of
AGP: you can choose to either use NVIDIA's AGP module (NVAGP), or the AGP
module that comes with the linux kernel (AGPGART). This is controlled through
the "NvAGP" option in your X config file:

Option "NvAgp" "0" ... disables AGP support
Option "NvAgp" "1" ... use NVAGP, if possible
Option "NvAgp" "2" ... use AGPGART, if possible
Option "NvAGP" "3" ... try AGPGART; if that fails, try NVAGP

The default is 3 (the default was 1 until after 1.0-1251).

You should use the AGP module that works best with your AGP chip set. If you
are experiencing problems with stability, you may want to start by disabling
AGP and observing if that solves the problems. Then you can experiment with
either of the other AGP modules.

You can query the current AGP status at any time via the /proc filesystem
interface (see Appendix M).

To use the Linux AGPGART module, it will need to be compiled with your kernel,
either statically linked in, or built as a module. NVIDIA AGP support cannot
be used if AGPGART is loaded in the kernel. It is recommended that you compile
AGPGART as a module and make sure that it is not loaded when trying to use
NVIDIA AGP. Please also note that changing AGP drivers generally requires a
reboot before the changes actually take effect.

Inviato: dom ago 14, 2005 17:06
da clodo
A proposito, è uscito il driver nuovo il 9 agosto. Buona installazione! :D

Inviato: lun ago 15, 2005 0:28
da Trotto@81
clodo ha scritto:A proposito, è uscito il driver nuovo il 9 agosto. Buona installazione! :D


ah ail changelog più lungo che abbia mai visto: 1 riga! :lol:

Inviato: lun ago 15, 2005 11:21
da clodo
Meglio, vuol dire che il driver è sulla strada della stabilità!