Repository 32bit  Forum
Repository 64bit  Wiki

Problema con la rete Wifi

Usate questo forum per richieste di aiuto e consigli sull'hardware montato nelle vostre macchine con GNU/Linux Slackware.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata e la versione del Kernel. Questi dati aiutano le persone che possono rispondere.
2) Citare il tipo di hardware coinvolto in modo dettagliato.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT. Non usare termini gergali come procio, mobo e simili per identificare i componenti hardware.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Problema con la rete Wifi

Messaggioda Falko » ven set 16, 2005 4:58

Salve a tutti,
Avrei bisogno di un aiuto riguardo alla scheda di rete wifi usb freelan, che da tempo cerco di utilizzare sul mio portatile.
I passi che ho seguito sono stati i seguenti:

- Installazione dei pacchetti extras per la gestione della rete wifi (linux-wlan-ng e via dicendo)
- Installazione di ndiswrapper, caricamento dei driver della scheda e montaggio tramite modprobe
- creazione del dispositivo wlan0

a questo punto il sistema dovrebbe funzionare ma alla fine la scheda di rete wireless resta completamente inutilizzabile.
ho controllato i logs di sistema e pare che non ci siano problemi riguardo alla connessione della chiavetta usb.

PS: Utilizzo la slackware current con kernel 2.4.31
Falko
Linux 1.0
Linux 1.0
 
Messaggi: 16
Iscritto il: dom mag 22, 2005 23:00
Slackware: Current

Messaggioda l1q1d » ven set 16, 2005 8:50

allora per prima cosa o usi wlan-ng o usi ndiswrapper.
I due assieme non servono.
con ndiswrapper se fai:
Codice: Seleziona tutto
ndiswrapper -l

ti dice che hardware present, driver present?

posta il dmesg che ti da quando fai il modprobe di ndiwrapper.
Dimenticavo posta anche l'ifconfig -a, e l'iwconfig
Avatar utente
l1q1d
Master
Master
 
Messaggi: 1862
Iscritto il: lun feb 21, 2005 0:00
Località: In uno spazio n-dimesionale

Problema con la rete Wifi

Messaggioda Falko » ven set 16, 2005 16:54

Ecco riportati i vari messaggi che ho ricevuto con i vari comandi suggeriti:

# ndiswrapper -l
Installed ndis drivers:
wlanuig driver present, hardware present


# dmesg | grep ndiswrapper
ndiswrapper version 1.3rc1 loaded (preempt=no,smp=no)
usb.c: registered new driver ndiswrapper
ndiswrapper: driver wlanuig (Roper,10/31/2003, 1.0.3) loaded
ndiswrapper (wrap_alloc_urb:110): couldn't allocate dma buf
ndiswrapper (wrap_alloc_urb:110): couldn't allocate dma buf
ndiswrapper (wrap_alloc_urb:110): couldn't allocate dma buf
ndiswrapper (wrap_alloc_urb:110): couldn't allocate dma buf
ndiswrapper (wrap_alloc_urb:110): couldn't allocate dma buf
ndiswrapper (NdisWriteErrorLogEntry:328): log: C000138A, count: 3, return_address: cce0e96d
ndiswrapper (NdisWriteErrorLogEntry:331): code: 259
ndiswrapper (NdisWriteErrorLogEntry:331): code: 942813774
ndiswrapper (NdisWriteErrorLogEntry:331): code: 4335
ndiswrapper (NdisWriteErrorLogEntry:328): log: C000138A, count: 3, return_address: cce0aacf
ndiswrapper (NdisWriteErrorLogEntry:331): code: 3221225473
ndiswrapper (NdisWriteErrorLogEntry:331): code: 1835619394
ndiswrapper (NdisWriteErrorLogEntry:331): code: 55
ndiswrapper (ndiswrapper_add_usb_device:343): Windows driver couldn't initialize the device (C0010006)


# tail -f /var/log/messages
Sep 16 17:37:09 PortatiLinux kernel: ndiswrapper version 1.3rc1 loaded (preempt=no,smp=no)
Sep 16 17:37:10 PortatiLinux kernel: usb.c: registered new driver ndiswrapper
Sep 16 17:37:10 PortatiLinux kernel: ndiswrapper: driver wlanuig (Roper,10/31/2003, 1.0.3) loaded


# iwconfig
lo no wireless extensions.
eth0 no wireless extensions.


# ifconfig -a
eth0 Link encap:Ethernet HWaddr XX:XX:XX:XX:XX:XX
inet addr:192.168.XXX.XXX Bcast:192.168.XXX.XXX Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:2808 errors:0 dropped:0 overruns:0 frame:0
TX packets:2608 errors:0 dropped:0 overruns:0 carrier:0
collisions:0
RX bytes:1553926 (1.4 Mb) TX bytes:326337 (318.6 Kb)

lo Link encap:Local Loopback


(i dati della loopback li ho troncati)

Per quanto riguarda wlan-ng ho provveduto a rimuoverlo dal sistema in quanto la scheda in uso (secondo la documentazione di alcuni siti) funziona solamente con ndiswrapper.

A questo punto ritorno al problema sopraccitato, ovvero l'hardware rilevato ma nessuna interfaccia sulla quale farlo lavorare.

Grazie a tutti coloro vorranno aiutarmi nella risoluzione di questo problema :)
Falko
Linux 1.0
Linux 1.0
 
Messaggi: 16
Iscritto il: dom mag 22, 2005 23:00
Slackware: Current


Torna a Hardware

Chi c’è in linea

Visitano il forum: Bing [Bot] e 2 ospiti