Repository 32bit  Forum
Repository 64bit  Wiki

ipod nano impossibile da montare (usb 1.1)

Usate questo forum per richieste di aiuto e consigli sull'hardware montato nelle vostre macchine con GNU/Linux Slackware.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata e la versione del Kernel. Questi dati aiutano le persone che possono rispondere.
2) Citare il tipo di hardware coinvolto in modo dettagliato.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT. Non usare termini gergali come procio, mobo e simili per identificare i componenti hardware.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

ipod nano impossibile da montare (usb 1.1)

Messaggioda sberla54 » ven nov 11, 2005 2:51

Ciao.
Ho letto su una rivista che per utilizzare l'ipod sotto linux è sufficiente montarlo come una qualsiasi partizione e poi utilizzare un programma come gtkpod.

La guida che ho letto io parlava di avere hotplug ed il modulo usb-storage al loro posto, inserire l'ipod, dare un dmesg per capire su quale device fosse rilevato e montarlo in questa maniera:
df -Th /dev/sda3
oppure tramite il classico:
mount -t hfsplus /dev/sda3 /mnt/ipod
o
mount -t vfat /dev/sda3 /mnt/ipod
se e' formattato in fat32 (ma quando si formatta in fat32?).

Quando vado a dare quei 2 comandi ricevo soltanto:
df: `/dev/sda3': No such file or directory
mount: il device speciale /dev/sda3 non esiste.

Se vado a controllare dmesg ci trovo degli errori relativi all'ipod....nn vorrei che fossero collegati al fatto che nn possiedo un'interfaccia usb 2.0 ma soltanto una vecchia usb 1.1:
Codice: Seleziona tutto
usb 1-4: new high speed USB device using ehci_hcd and address 2
usb 1-4: device descriptor read/64, error -71
usb 1-4: device descriptor read/64, error -71
usb 1-4: new high speed USB device using ehci_hcd and address 3
usb 1-4: device descriptor read/64, error -71
usb 1-4: device descriptor read/64, error -71
usb 1-4: new high speed USB device using ehci_hcd and address 4
usb 1-4: device not accepting address 4, error -71
usb 1-4: new high speed USB device using ehci_hcd and address 5
usb 1-4: device not accepting address 5, error -71
usb 1-4: new high speed USB device using ehci_hcd and address 6
usb 1-4: device descriptor read/64, error -71
usb 1-4: device descriptor read/64, error -71
usb 1-4: new high speed USB device using ehci_hcd and address 7
usb 1-4: device descriptor read/64, error -71
usb 1-4: device descriptor read/64, error -71
usb 1-4: new high speed USB device using ehci_hcd and address 8
usb 1-4: device not accepting address 8, error -71
usb 1-4: new high speed USB device using ehci_hcd and address 9
usb 1-4: device not accepting address 9, error -71
scsi: unknown opcode 0x01
usb 1-4: new high speed USB device using ehci_hcd and address 10
usb 1-4: device descriptor read/64, error -71
usb 1-4: device descriptor read/64, error -71
usb 1-4: new high speed USB device using ehci_hcd and address 12
usb 1-4: device descriptor read/64, error -71
usb 1-4: device descriptor read/64, error -71
usb 1-4: new high speed USB device using ehci_hcd and address 14
usb 1-4: new high speed USB device using ehci_hcd and address 15
usb 1-4: device descriptor read/64, error -71
usb 1-4: device descriptor read/64, error -71
usb 1-4: new high speed USB device using ehci_hcd and address 16
usb 1-4: device descriptor read/64, error -71
usb 1-4: device descriptor read/64, error -71
usb 1-4: new high speed USB device using ehci_hcd and address 17
usb 1-4: device not accepting address 17, error -71
usb 1-4: new high speed USB device using ehci_hcd and address 18
usb 1-4: device not accepting address 18, error -71
usb 1-4: new high speed USB device using ehci_hcd and address 19
usb 1-4: device descriptor read/64, error -71
usb 1-4: device descriptor read/64, error -71
usb 1-4: new high speed USB device using ehci_hcd and address 20
usb 1-4: device descriptor read/64, error -71
usb 1-4: device descriptor read/64, error -71
usb 1-4: new high speed USB device using ehci_hcd and address 21
usb 1-4: device not accepting address 21, error -71
usb 1-4: new high speed USB device using ehci_hcd and address 23
usb 1-4: device descriptor read/64, error -71
usb 1-4: new high speed USB device using ehci_hcd and address 25
usb 1-4: new high speed USB device using ehci_hcd and address 26
usb 1-4: device descriptor read/64, error -71
usb 1-4: device descriptor read/64, error -71
usb 1-4: new high speed USB device using ehci_hcd and address 27
usb 1-4: device descriptor read/64, error -71
usb 1-4: device descriptor read/64, error -71
usb 1-4: new high speed USB device using ehci_hcd and address 28
usb 1-4: device not accepting address 28, error -71
usb 1-4: new high speed USB device using ehci_hcd and address 29
usb 1-4: device not accepting address 29, error -71
ReiserFS: hda3: warning: vs-8115: get_num_ver: not directory or indirect item
ReiserFS: hda3: warning: vs-8115: get_num_ver: not directory or indirect item
usb 1-4: new high speed USB device using ehci_hcd and address 30
usb 1-4: new high speed USB device using ehci_hcd and address 31
usb 1-4: device descriptor read/64, error -71
usb 1-4: device descriptor read/64, error -71
usb 1-4: new high speed USB device using ehci_hcd and address 32
usb 1-4: device descriptor read/64, error -71
usb 1-4: new high speed USB device using ehci_hcd and address 33
usb 1-4: device descriptor read/64, error -71
usb 1-4: new high speed USB device using ehci_hcd and address 35
usb 1-4: device descriptor read/64, error -71
usb 1-4: device descriptor read/64, error -71
usb 1-4: new high speed USB device using ehci_hcd and address 36
usb 1-4: device descriptor read/64, error -71
usb 1-4: device descriptor read/64, error -71
usb 1-4: new high speed USB device using ehci_hcd and address 37
usb 1-4: device not accepting address 37, error -71
usb 1-4: new high speed USB device using ehci_hcd and address 38
usb 1-4: device not accepting address 38, error -71
usb 1-4: new high speed USB device using ehci_hcd and address 39
usb 1-4: device descriptor read/64, error -71
usb 1-4: new high speed USB device using ehci_hcd and address 41
usb 1-4: new high speed USB device using ehci_hcd and address 42
usb 1-4: device descriptor read/64, error -71
usb 1-4: device descriptor read/64, error -71
usb 1-4: new high speed USB device using ehci_hcd and address 43
usb 1-4: device descriptor read/64, error -71
usb 1-4: device descriptor read/64, error -71
usb 1-4: new high speed USB device using ehci_hcd and address 44
usb 1-4: device not accepting address 44, error -71
usb 1-4: new high speed USB device using ehci_hcd and address 45
usb 1-4: device not accepting address 45, error -71


ed una cosa simile viene fuori anche da tail -f /var/log/syslog:

Codice: Seleziona tutto
Nov 11 02:39:05 skoria kernel: usb 1-4: device descriptor read/64, error -71
Nov 11 02:39:08 skoria last message repeated 7 times
Nov 11 02:39:08 skoria kernel: usb 1-4: device not accepting address 37, error -71
Nov 11 02:39:09 skoria kernel: usb 1-4: device not accepting address 38, error -71
Nov 11 02:44:45 skoria kernel: usb 1-4: device descriptor read/64, error -71
Nov 11 02:44:46 skoria last message repeated 4 times
Nov 11 02:44:47 skoria kernel: usb 1-4: device not accepting address 44, error -71
Nov 11 02:44:48 skoria kernel: usb 1-4: device not accepting address 45, error -71
Nov 11 02:48:38 skoria kernel: usb 1-4: device descriptor read/64, error -71
Nov 11 02:48:42 skoria last message repeated 5 times


E' colpa dell'usb 1.1?

Un'altra cosa collegata:
quando attacco l'ipod al pc questo si accende normalmente, come se avessi pigiato un tasto, ma nn accenna a ricaricarsi....nn mi tocchera ricaricarlo sempre da win$$ vero?

Spero sappiate aiutarmi perche' ora sono ridotto a masterizzare su dvd-rw la musica, switchiare ad un mini win$$ che ho installato e sincronizzare con itunes da dvd :)
Avatar utente
sberla54
Master
Master
 
Messaggi: 1500
Iscritto il: mer giu 23, 2004 23:00
Località: Bologna
Slackware: 13.0
Desktop: Gnome (o Fluxbox)
Distribuzione: Ubuntu

Messaggioda sberla54 » ven nov 11, 2005 4:03

Credi di aver risolto.
Era semplicemente l'hub frontale che a quanto pare nn andava bene per qualche strano motivo....ho collegato l'ipod alle usb della motherboard e sono riuscito a montarlo.

Ora sto lavorandoci con gtkpod ma mi da vari problemi anche se riesco comunque ad aggiungere e togliere le tracce.

Sto cercando di sincronizzare il calendario copiando il file .ics esportato da korganizer nella directory /mnt/ipod/Calendars...spero funzioni.

Se avete qualche consiglio sulla gestione dell'ipod fatevi vivi :)
Avatar utente
sberla54
Master
Master
 
Messaggi: 1500
Iscritto il: mer giu 23, 2004 23:00
Località: Bologna
Slackware: 13.0
Desktop: Gnome (o Fluxbox)
Distribuzione: Ubuntu

Messaggioda napoleone1981 » ven nov 11, 2005 10:30

Da quello che so gtkpod ancora non supporta il nano (che ho anch'io...). Comunque per passargli le canzoni c'è amarok... che usa libgpod come gtkpod
Avatar utente
napoleone1981
Linux 2.4
Linux 2.4
 
Messaggi: 380
Iscritto il: mer ago 25, 2004 23:00
Località: Sant'Elena

Messaggioda sberla54 » ven nov 11, 2005 14:38

Bhe ieri notte ho smanettato ed ho notato che mi da' qualche errore strano, e nn riesco ad inserire canzoni nuove....forse pero' e' dovuto al fatto che l'ipod e' gia pieno....provero' di nuovo poi ti diro :)

Per il resto il database lo legge senza problemi....

Vero che c'è amarok! Me n'ero scordato :)
Provo anche quello.

Te sai come fare per copiare il calendario, impegni e cose da fare da korganizer all'ipod?
Con quella procedura che dicevo nel post precedente nn ho ottenuto niente...anzi...ora mi ritrovo con 1 solo impegno (dei tanti segnati in korg) all'interno dell'agenda dell'ipod O_O
Avatar utente
sberla54
Master
Master
 
Messaggi: 1500
Iscritto il: mer giu 23, 2004 23:00
Località: Bologna
Slackware: 13.0
Desktop: Gnome (o Fluxbox)
Distribuzione: Ubuntu

Messaggioda napoleone1981 » ven nov 11, 2005 14:41

Purtroppo non uso korganizer... e l'ipod lo uso solamente per ascolatere musica, vedere foto e giocare a solitario. Per il resto c'è il mio bel sonyericsson p800...
Avatar utente
napoleone1981
Linux 2.4
Linux 2.4
 
Messaggi: 380
Iscritto il: mer ago 25, 2004 23:00
Località: Sant'Elena

Messaggioda sberla54 » ven nov 11, 2005 19:51

Ho provato amarok....è un po' troppo semplice e mi ha fatto immediatamente dei casini al database...ho aggiunto delle canzoni e me ne sono trovate altre orfane, ovvero pronte sul disco ma non raggiungibili dai menu.

Ho sistemato con gtkpod che invece s'è dimostrato un buon programma...funziona perfettamente...a parte che devo montare e smontare l'ipod a mano, il quale poi continua sempre a dirmi "non scollegare" e me ne devo sbattere...preparo le modifiche che voglio fare al contenuto dell'ipod e quando ho finito do "sincronizza" ed ho fatto.

Non capisco ancora come armeggiare i contatti....magari daro' un'occhiata al forum ufficiale.

Inoltre, non so se per colpa di amarok o di gtkpod o per quale altro motivo, la sveglia mi da come suono soltanto il beep...adesso vedro' se mi tocchera ripristinare il firmware originale per sistemarlo...forse e' stato perche ho dato il comando "crea directory ipod" da gtkpod...

A proposito...come si fa a far funzionare la sveglia?
Io vado in extra > orologio > quello di default con cupertino > sveglia
e poi setto avviso si, l'orario ed il suono (che pero prima mi faceva arrivare solo alla scelta della playlist).
Aspetto l'ora che ho settato e nn succede niente di niente.
Ma che dovrebbe succedere poi? Si sente senza cuffie e senza casse?
Avatar utente
sberla54
Master
Master
 
Messaggi: 1500
Iscritto il: mer giu 23, 2004 23:00
Località: Bologna
Slackware: 13.0
Desktop: Gnome (o Fluxbox)
Distribuzione: Ubuntu

Messaggioda napoleone1981 » sab nov 12, 2005 12:55

A me la sveglia funziona... non si sente molto alta, però fa bip bip bip all'ora giusta...
Boh, non so che dirti
Avatar utente
napoleone1981
Linux 2.4
Linux 2.4
 
Messaggi: 380
Iscritto il: mer ago 25, 2004 23:00
Località: Sant'Elena


Torna a Hardware

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti