Repository 32bit  Forum
Repository 64bit  Wiki

Vecchissimo scanner: come lo installo?

Usate questo forum per richieste di aiuto e consigli sull'hardware montato nelle vostre macchine con GNU/Linux Slackware.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata e la versione del Kernel. Questi dati aiutano le persone che possono rispondere.
2) Citare il tipo di hardware coinvolto in modo dettagliato.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT. Non usare termini gergali come procio, mobo e simili per identificare i componenti hardware.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Vecchissimo scanner: come lo installo?

Messaggioda Felis » dom nov 20, 2005 17:24

Ho collegato al pc uno scanner vecchissimo (Plug & Scan 96 P). Per essere precisi, l'ho collegato alla porta seriale viola che sarebbe per le stampanti (ma intanto è l'unica a cui si può collegare il mio scanner). sane-find-scanner non lo rileva, come posso fare?
Felis
Linux 2.4
Linux 2.4
 
Messaggi: 254
Iscritto il: lun nov 08, 2004 0:00
Slackware: 12

Messaggioda percoco2000 » dom nov 20, 2005 23:47

Per intanto la porta e' la parallela, non la seriale.
Lo scanner e' supportato da SANE mediante il driver mustek_pp,
http://www.sane-project.org/man/sane-mustek_pp.5.html

sane-find-scanner won't find most parallel port scanners, or scanners
connected to proprietary ports. Some parallel port scanners may be
detected by sane-find-scanner -p. At the time of writing this will
only detect Mustek parallel port scanners.

leggi bene la documentazione di sane e tienici informati.
Avatar utente
percoco2000
Linux 2.6
Linux 2.6
 
Messaggi: 617
Iscritto il: mer lug 14, 2004 23:00
Località: Salerno
Slackware: 12.2
Kernel: 2.6.27
Desktop: mate - fluxbox
Distribuzione: mint 13 / slackware

Messaggioda Felis » lun nov 21, 2005 18:07

con sane-find-scanner -p lui vede lo scanner e mi consiglia di leggere una man page che però non ho idea dove sia

root@darkstar:/home/felis# sane-find-scanner -p

# No SCSI scanners found. If you expected something different, make sure that
# you have loaded a SCSI driver for your SCSI adapter.
# Also you need support for SCSI Generic (sg) in your operating system.
# If using Linux, try "modprobe sg".

# No USB scanners found. If you expected something different, make sure that
# you have loaded a driver for your USB host controller and have installed a
# kernel scanner module.
found possible Mustek parallel port scanner at "0x378"

# Your Mustek parallel port scanner was detected. It may or
# may not be supported by SANE. Please read the sane-mustek_pp
# man-page for setup instructions.

# Most Scanners connected to the parallel port or other proprietary ports
# can't be detected by this program.


il fatto è che lo scanner non è Mustek.
Felis
Linux 2.4
Linux 2.4
 
Messaggi: 254
Iscritto il: lun nov 08, 2004 0:00
Slackware: 12

Messaggioda Felis » lun nov 21, 2005 18:14

nella pagina del link non compare nessun plug&scan. Anche questo è un problema: sullo scanner c'è scritto solo "Plug & Scan 96P", e io non capisco che modello è.
Felis
Linux 2.4
Linux 2.4
 
Messaggi: 254
Iscritto il: lun nov 08, 2004 0:00
Slackware: 12

Messaggioda percoco2000 » lun nov 21, 2005 18:32

da quel che ho visto su net il tuo scanner e' un mustek P&S 96cp, ma lo stesso sane ti tice
found possible Mustek parallel port scanner at "0x378

quindi procedi come se fosse.
Per leggere le man pages basta che usi il comando man
Avatar utente
percoco2000
Linux 2.6
Linux 2.6
 
Messaggi: 617
Iscritto il: mer lug 14, 2004 23:00
Località: Salerno
Slackware: 12.2
Kernel: 2.6.27
Desktop: mate - fluxbox
Distribuzione: mint 13 / slackware

Messaggioda Felis » mar nov 22, 2005 19:27

Ho modificato il file
/etc/sane.d/mustek_pp.conf
aggiungendo la linea
scanner Mustek-Plug&Scan96P 0x378 cis600
però scanimage -L risponde sempre che non ci sono scanner
Felis
Linux 2.4
Linux 2.4
 
Messaggi: 254
Iscritto il: lun nov 08, 2004 0:00
Slackware: 12

Messaggioda percoco2000 » mer nov 23, 2005 10:39

Controlla che nel file /etc/sane.d/dll.conf sia non commentata la linea
mustek_pp che di default e' ignorata

cancella la # da #mustek_pp

se, una volta verificato il funzionamento, vuoi accelerare il riconoscimento della periferica, puoi commentare tutte le altre voci
Avatar utente
percoco2000
Linux 2.6
Linux 2.6
 
Messaggi: 617
Iscritto il: mer lug 14, 2004 23:00
Località: Salerno
Slackware: 12.2
Kernel: 2.6.27
Desktop: mate - fluxbox
Distribuzione: mint 13 / slackware

Messaggioda percoco2000 » lun nov 28, 2005 20:50

Ma hai risolto??
Avatar utente
percoco2000
Linux 2.6
Linux 2.6
 
Messaggi: 617
Iscritto il: mer lug 14, 2004 23:00
Località: Salerno
Slackware: 12.2
Kernel: 2.6.27
Desktop: mate - fluxbox
Distribuzione: mint 13 / slackware

Messaggioda Luci0 » mar nov 29, 2005 16:31

Ma hai risolto??


Non é il primo caso di chi chiede aiuto e poi sparisce ... un pò di educazione non guasterebbe. :?
Avatar utente
Luci0
Staff
Staff
 
Messaggi: 3591
Iscritto il: dom giu 26, 2005 23:00
Località: Forte dei Marmi
Nome Cognome: Gabriele Santanché
Slackware: 12.2 14.0
Kernel: 2.6.27.46- gen 3.2.29
Desktop: KDE 3.5.10 Xfce

Messaggioda percoco2000 » gio dic 01, 2005 9:36

Well, si vede che non comprendono lo spirito di un forum, che e' la condivisione del sapere, non un centro informazioni :( , anche sa a giudicare dal Num. di post Felis non mi pare uno che 'sparisce' ;)
Avatar utente
percoco2000
Linux 2.6
Linux 2.6
 
Messaggi: 617
Iscritto il: mer lug 14, 2004 23:00
Località: Salerno
Slackware: 12.2
Kernel: 2.6.27
Desktop: mate - fluxbox
Distribuzione: mint 13 / slackware

Messaggioda Luci0 » dom dic 04, 2005 0:21

sembra proprio svanito nel nulla.. :?:
Avatar utente
Luci0
Staff
Staff
 
Messaggi: 3591
Iscritto il: dom giu 26, 2005 23:00
Località: Forte dei Marmi
Nome Cognome: Gabriele Santanché
Slackware: 12.2 14.0
Kernel: 2.6.27.46- gen 3.2.29
Desktop: KDE 3.5.10 Xfce

Messaggioda Felis » mar dic 06, 2005 23:43

"Sparito nel nulla", esattamente come la possibilità di connettersi a Internet per gli abitanti della mia zona. Scusate, ma abito fuori dal mondo: niente ISDN o ADSL, e fino a ieri nemeno più 56k. A quanto pare, era un guasto ai modem della centralina Telecom, sta di fatto che ci sono voluti giorni e innumerevoli telefonate al 187 solo perchè telecom si ponesse il problema (dopo che un tecnico al telefono ha avuto anche il coraggio di sostenere che il problema dovesse essere del mio provider -ne uso più di uno- o del mio computer -ripeto che la cosa riguardava TUTTO il quartiere!-).

Sono riuscito a connettermi solo adesso e non ho la possibilità di provare a risolvere come mi suggerite, ma domani dovrei postare una risposta.

Scusate l'off topic ma volevo farvi sapere cosa è veramente il digital divide
Felis
Linux 2.4
Linux 2.4
 
Messaggi: 254
Iscritto il: lun nov 08, 2004 0:00
Slackware: 12

Messaggioda Luci0 » mer dic 07, 2005 10:34

.. scusa Felis :(

per la telecom ... NO COMMENT :(
Avatar utente
Luci0
Staff
Staff
 
Messaggi: 3591
Iscritto il: dom giu 26, 2005 23:00
Località: Forte dei Marmi
Nome Cognome: Gabriele Santanché
Slackware: 12.2 14.0
Kernel: 2.6.27.46- gen 3.2.29
Desktop: KDE 3.5.10 Xfce

Messaggioda Felis » gio dic 08, 2005 18:36

Ho decommentato #mustek.pp e adesso succede una cosa che mi sembra positiva:

root@darkstar:~# scanimage -L
device `mustek_pp:Mustek-Plug&Scan96P' is a Mustek 600CP flatbed scanner

Solo ancora non so che device è
Felis
Linux 2.4
Linux 2.4
 
Messaggi: 254
Iscritto il: lun nov 08, 2004 0:00
Slackware: 12

Messaggioda Felis » dom feb 19, 2006 16:54

Ehi!
Ho scoperto che xsane, da root, FUNZIONA!
Quindi ora il mio unico problema è trovare il dev giusto a cui cambiare i permessi.
Anche perchè se avvii xsane da root, ti minaccia apertamente di morte (provateci, è divertente...)
Felis
Linux 2.4
Linux 2.4
 
Messaggi: 254
Iscritto il: lun nov 08, 2004 0:00
Slackware: 12

Prossimo

Torna a Hardware

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite

cron