Repository 32bit  Forum
Repository 64bit  Wiki

driver NVidia

Usate questo forum per richieste di aiuto e consigli sull'hardware montato nelle vostre macchine con GNU/Linux Slackware.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata e la versione del Kernel. Questi dati aiutano le persone che possono rispondere.
2) Citare il tipo di hardware coinvolto in modo dettagliato.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT. Non usare termini gergali come procio, mobo e simili per identificare i componenti hardware.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

driver NVidia

Messaggioda darkside04 » mar nov 22, 2005 22:15

Ciao a tutti,
ho installato il driver NVidia sul mio sistema ma terminata l'installazione mi ha restituito il seguente warning:
WARNING: Your kernel was configured to include rivafb support as
a loadable kernel module.

The rivafb driver conflicts with the NVIDIA driver; the
NVIDIA kernel module will still be built and installed,
but be aware that the NVIDIA driver will not be able to
function properly if the rivafb module is loaded!

e praticamente quando do startx mi appare uno schermo nero con alcuni puntini.... come faccio a disabilitare il supporto a rivafb ho provato a dare lsmod per vedere se fosse caricato come modulo ma nell'output non c'è!! da dove lo disabilito?? Il mio xorg.conf alla voce Graphics device section è cosi configurato
ection "Device"
Identifier "VESA Framebuffer"
Driver "vesa"
#VideoRam 4096
# Insert Clocks lines here if appropriate
ma quando sostituisco vesa con nvidia mi va in crash
Grazie
Avatar utente
darkside04
Linux 2.4
Linux 2.4
 
Messaggi: 432
Iscritto il: mar nov 23, 2004 0:00
Località: roma

Messaggioda lupurone » mar nov 22, 2005 22:43

Mi spiace dirtelo ma temo si debba disabilitare direttamente dal kernel.
Non so se esistono altri modi, io ho risolto così...
Avatar utente
lupurone
Linux 1.0
Linux 1.0
 
Messaggi: 28
Iscritto il: ven lug 29, 2005 23:00

Messaggioda darkside04 » mar nov 22, 2005 23:02

lupurone ha scritto:Mi spiace dirtelo ma temo si debba disabilitare direttamente dal kernel.
Non so se esistono altri modi, io ho risolto così...


grazie.... ma probabilmente era un bug del driver installato infatti ho scaricato una versione superiore e sembra che il problema non lo dia.....(non si vede ma sto' facendo le corna :lol: :lol: :lol: :lol: )

Thanks again!!
Avatar utente
darkside04
Linux 2.4
Linux 2.4
 
Messaggi: 432
Iscritto il: mar nov 23, 2004 0:00
Località: roma

Messaggioda DarkNeo » mar nov 22, 2005 23:04

Comunque si dovresti togliere nvidiariva nel kernel
DarkNeo
Linux 3.x
Linux 3.x
 
Messaggi: 1071
Iscritto il: ven giu 03, 2005 23:00
Località: Matrix
Nome Cognome: Stefano Arbitrio
Slackware: Slackware64 14
Kernel: 3.2.X
Desktop: KDE

Messaggioda prometeo79 » mer nov 23, 2005 9:29

Ciao
In effetti non funzionano i driver nvidia se c'è attivo il modulo rivafb. Mi pare di essere riuscito a toglierlo una volta con un semplice modprobe -r
Avatar utente
prometeo79
Linux 3.x
Linux 3.x
 
Messaggi: 1278
Iscritto il: gio mar 17, 2005 0:00
Località: Torino
Slackware: 12

Messaggioda clodo » gio nov 24, 2005 20:52

L'importante è che il comando lsmod non restituisca il modulo rivafb caricato.
clodo
Linux 2.6
Linux 2.6
 
Messaggi: 511
Iscritto il: dom gen 23, 2005 0:00
Distribuzione: debian

Messaggioda darkside04 » ven nov 25, 2005 0:40

vi sto scrivendo e come avrete già capito le corna non sono servite a niente!

clodo ha scritto:L'importante è che il comando lsmod non restituisca il modulo rivafb caricato.

In effetti dando lsmod il modulo rivafb non è caricato tuttavia dopo un paio di accessi "funzionanti" fatti con il driver NVidia abilitato lo schermo nero con i puntini colorati è tornato e ho dovuto riconfigurare xorg.conf con il driver "vesa" per farlo funziona. Nel Kernel dove trovo questo modulo rivafb perchè ho provato a dare un'occhiata ma non mi sembra ci sia.

prometeo ha scritto:Ciao
In effetti non funzionano i driver nvidia se c'è attivo il modulo rivafb. Mi pare di essere riuscito a toglierlo una volta con un semplice modprobe -r


devo dare modprobe -r + il nome del modulo oppure è sufficiente dare il comando cosi come l'hai scritto?
Avatar utente
darkside04
Linux 2.4
Linux 2.4
 
Messaggi: 432
Iscritto il: mar nov 23, 2004 0:00
Località: roma

Messaggioda prometeo79 » ven nov 25, 2005 8:56

Modprobe -r nomemodulo, ma se non lo vedi da lsmod probabilmente l'hai attivato staticamente e dovresti ricompilare.
Avatar utente
prometeo79
Linux 3.x
Linux 3.x
 
Messaggi: 1278
Iscritto il: gio mar 17, 2005 0:00
Località: Torino
Slackware: 12

Messaggioda clodo » dom nov 27, 2005 21:07

La faccenda potrebbe essere più complessa, ed il modulo rivafb se non è caricato non dà problemi, te l'assicuro; potrebbe trattarsi di ciò che sul readme di invidia viene identificato come "agp-related", nel senso che potrebbe trattarsi di una questione riguardante la porta grafica (agp). questa è la mia semplice sezione di xorg:
Section "Device"
Identifier "Scheda video generica"
Option "NvAGP" "2"
Driver "nvidia"

Da Xorg.0.log:
(**) NVIDIA(0): Option "NvAGP" "2"
(**) NVIDIA(0): Use of AGPGART requested

Scelgo di usare , col 2, il modulo agpgart del kernel (2.6.12-1-686-smp): se metto 1 viene usato l'agp interno al driver nvidia, con 3 viene tentato l'agp del kernel e nel caso di fallimento l'agp interno. Il device agpgart presente in /dev deve essere proprietà di root, ed appartenere al gruppo video.
teto@debian:/dev$ ls -l agp*
crw-rw---- 1 root video 10, 175 2005-11-27 19:53 agpgart
E' bene che gli utenti appartengano al gruppo video. Il chipset della tua scheda madre deve essere supportato dal driver nvidia. Tieni conto che agpgart viene creato al volo da udev...........per cui udev deve essere in perfetta forma.
Inoltre devi disabilitare in xorg.conf il caricamento di dri e gl-core:
Section "Module"
Load "bitmap"
Load "dbe"
#Load "ddc"
#Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "record"
Load "type1"
Load "v4l"
Load "vbe"
EndSection
Posta eventualmente il file /var/log/nvidia.installer.log
clodo
Linux 2.6
Linux 2.6
 
Messaggi: 511
Iscritto il: dom gen 23, 2005 0:00
Distribuzione: debian

Messaggioda clodo » lun nov 28, 2005 22:15

Ancora una cosa:
teto@ubuntu:/lib/modules/2.6.12-9-386/kernel/drivers/char/agp$ ls -l
totale 188
-rw-r--r-- 1 root root 38844 2005-10-10 15:16 agpgart.ko
-rw-r--r-- 1 root root 9240 2005-10-10 15:16 ali-agp.ko
-rw-r--r-- 1 root root 15192 2005-10-10 15:16 amd64-agp.ko
-rw-r--r-- 1 root root 11100 2005-10-10 15:16 amd-k7-agp.ko
-rw-r--r-- 1 root root 11331 2005-10-10 15:16 ati-agp.ko
-rw-r--r-- 1 root root 9863 2005-10-10 15:16 efficeon-agp.ko
-rw-r--r-- 1 root root 29787 2005-10-10 15:16 intel-agp.ko
-rw-r--r-- 1 root root 10456 2005-10-10 15:16 nvidia-agp.ko
-rw-r--r-- 1 root root 11248 2005-10-10 15:16 sis-agp.ko
-rw-r--r-- 1 root root 11569 2005-10-10 15:16 sworks-agp.ko
-rw-r--r-- 1 root root 13599 2005-10-10 15:16 via-agp.ko

In grassetto vedi i due moduli agp, uno è proprio del kernel (agpgart.ko), l'altro viene compilato ed installato unitamente al driver nvidia (nvidia-agp.ko) ed utilizzato se in xorg.conf dai "1" al posto di "2"; può essere un buon tentativo usare "1".
clodo
Linux 2.6
Linux 2.6
 
Messaggi: 511
Iscritto il: dom gen 23, 2005 0:00
Distribuzione: debian


Torna a Hardware

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite

cron